View Full Version : [ubuntu] Downgrading GCC

July 13th, 2009, 08:46 PM
I have the latest version of Ubuntu and GCC but I trying to compile a program that I am pretty sure it needs an older version of GCC. How could I get and install say GCC 3.4.6 (I compiled this program just fine at work on a redhat machine using GCC 3.4.6)

July 14th, 2009, 04:46 AM
gcc-3.4 is available in jaunty, just install it (and leave your default gcc alone.

if your source uses a ./configure then something like this should do, otherwise edit appropiate file in source

CC=gcc-3.4 ./configure <configure options if any>

edit Forgot to mention you'd need to install cpp-3.4 also

July 21st, 2009, 06:30 PM