View Full Version : [ubuntu] Problem with VirtualBox after installing updates

Ibrahim Mohammed Abdu
July 13th, 2009, 04:53 PM
Pls. Somebody should help me. My virtualbox-2.1_2.1.4-42893_Ubuntu_intrepid_i386 has freezy. Program crash showed on the notification bar. There4 i run sudo apt-get install -f @ the terminal in order to fix the problem. it shows that some programs would be removed others would be upgrade and i press yes to continue. after the installation the virtualbox was removed and i try reinstalling it but all in vain. it keep showing libqt4-network dependencies.
I tried install libqt4-network using synaptic manager bt came up with the following message:

Could not mark all packages for installation or upgrade
the following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences.

Depends: libqtcore4 (=4.4.3-Obuntu1.2) but 4.5.0-Obuntu4.1 is to be installed.
Pls. help

Jose Catre-Vandis
July 13th, 2009, 05:01 PM
Try downloading the latest virtualbox version (3.0) from their website and see how you get on. If it is a deb file it should handle your dependencies OK.

Ibrahim Mohammed Abdu
July 13th, 2009, 05:11 PM
I've downlod virtualbox 3.0 and is still showing the same message.

Jose Catre-Vandis
July 15th, 2009, 12:56 AM
Hmmm, are you running Intrepid (8.10) or Jaunty (9.04), as Intrepid has the 4.4 version of libqtcore whilst Jaunty has 4.5. If you are on Jaunty then you will need the Jaunty deb file for VBox.

You could try uninstalling everything to do with libqtcore and then force the 4.4 version if it is available?

Jose Catre-Vandis
July 15th, 2009, 12:56 AM