PDA

View Full Version : [ubuntu] error 21 woes



bs953
July 13th, 2009, 07:09 AM
Hi all new to ubuntu, have been a windows fan since day one. My linux nerd (soon to be ex buddy) talked me into doing an unbuntu 9.04 install.

This is on an Asus P5B deluxe all pentium 4 gigs of ram, sata DVD drive 250 Maxtor IDE drive. thats it that simple right? NOT

I did do this: http://ubuntuforums.org/showthread.php?t=285638

NO go, my Linux nerd (soon to be ex nerd) couldn't log into the machine because I was running the live cd after much frustration of port forwarding etc.

The drive is brand new, tried three drives different sizes etc still no go I get the error 21, installed from the GUI, farted with partitions, file formats etc etc etc.

So does anybody have any brilliant ideas? I am 6 hours into this misery and just for grins and nucs nucs. I installed W7 build 7264 and I was surfing the web in 8 minutes with no errors including updates! total time from power on disk in. So i am still waiting for (my soon to be ex buddy) to justify Linux to me.

I am totally game to give it a whirl and frankly I kinda like it, but not if I have to go through this kind of hell. Thanx all

Bigtime_Scrub
July 13th, 2009, 07:23 AM
To help you a little more information is needed. What exactly are you trying to do. Were you trying to dual boot Linux with XP? Where you doing a fresh install with only Ubuntu? Error 21 basically means can't find disk from what I understand....

Anyway if you are using Windows 7 and you installed it all you need to do to get Ubuntu is boot into the live CD and follow the installer with partitioning set for "boot ubuntu side by side with windows."

As far as your friend goes this might be helpful to him, as he knows your situation better then anyone here. (or at least he should)

https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows

bs953
July 13th, 2009, 03:56 PM
No no dual booting, one drive one OS like I said real simple real clean. I want this machine to be a single OS box period. My goal was to keep it real simple. Alas to no avail. I will chaeck that link.

Intersting whenI did the grub thing I came up with (hd0,0), I also did the command line to install grub there and it reported success, but then the big 21 again.
I think it is something in my bios, that is the only place left to look unless I am one out of 90 million unbuntu users that just can't install it.
There is no way for my 'buddy' to log into the machine using the live cd is there? he was able to get into my router and got to the login screen for 9.04 but that was it.