PDA

View Full Version : [ubuntu] Firefox goes into full screen



bsmith52
July 13th, 2009, 04:44 AM
I must have changed a setting without realizing it. Whenever I get into Firefox, it goes into full screen mode. In order to access the top gnome(?) panel (with Applications, System, etc.), I need to click on Edit-Preferences (nothing happens), then Edit-Preferences (again!) - Preferences screen appears - the top panel appears. I close it. I can access my applications. Then as soon as I access Firefox again, I go back into full screen mode again.

I have tried just about every combination of Firefox Preferences. None seem to have an impact.

Thanks for your help for this novice user.

Bill

mevets
July 13th, 2009, 04:52 AM
Are you sure its fullscreen mode. Because everyone once in a while I will run into a bug where firefox loses it window borders and so it is streched over gnome-panel. This look different than firefoxs fullscreen mode. To fix the problem I always back my .mozilla folder and rename it so firefox gives me a new profile. You will lose all your settings if you do this though.

earthpigg
July 13th, 2009, 05:04 AM
press f11?

xyphur
July 13th, 2009, 05:34 AM
2nd, F11

bsmith52
July 13th, 2009, 05:35 AM
Pressing f11 gets me the top screen with Applications, Places, etc. But it replaces the toolbar with my Refresh icon, etc with a message "[ubunto] Firefox goes into full screen - Ubuntu Forums - Mozilla Firefox"

This gives me the top toolbar (Applications, etc), and my boxes with the open applications; as well as my sanity. Thanks.

Will I need to clear out my .mozilla folder in order to get back to "normal"

Thanks for your help,
Bill

xyphur
July 13th, 2009, 05:57 AM
...shouldn't need to, as from what I gather Firefox remembers it's last window state, so it should now remember to remain windowed instead of full screen on the next restart of the browser process.

...which is what I imagine was happening before. You simply managed to get around it by opening the preferences dialog, which apparently cannot co-exist with the browser while it's in full screen mode, so perhaps it forces a fall-back to windowed mode to allow display of that dialog.

Anyone else care to 2nd my hunch?

lovinglinux
July 13th, 2009, 06:23 AM
See Solution [FOT002] from the Troubleshooting section of the Firefox optimization and troubleshooting thread (http://ubuntuforums.org/showthread.php?t=1193567&highlight=FOT002).