View Full Version : [SOLVED] Touchscreen BA 72 Wincor Nixdorf

July 10th, 2009, 05:33 PM
HI All I tried to use the xorg input packages for touch screens provided through APT, but none of them worked. I also tried some tutorials on the net like seeing where it is plugged in with cat /dev/ttyS0 and so on.

The screen is working fine as display, but I can't use it for touch in Ubuntu yet, as long as I tried every driver I'm not sure whether I have to config sth. manually after installing Xorg input drivers.

What can I do to get at minimum a seeable reaction that the PC is aware of the screen ?

February 21st, 2010, 06:51 AM
I haven't tried them yet, but you might try this driver page from Wincor (http://www.wincor-nixdorf.com/internet/site_EN/EN/Support/Downloads/POSLotterySystems/Driver/Display/Display_node.html)

February 22nd, 2010, 05:24 PM
HI, I've successfully installed the Touchscreen drivers but guess the main porblem still exists, possibly the screen isn't detected as it's attached through internal com ports.

I've tried to install the snx_golden module, but wasn't able to compile it.

February 22nd, 2010, 05:38 PM
If there's still someone out who may help me, heres the log while "make install"

WN PCI COM board Linux driver - release 1.08
from http://www.wincor-nixdorf.com/internet/site_EN/sid_177132DF7A0BEB9474234A66DDA53EA2.live1/EN/Support/Downloads/POSLotterySystems/Driver/MultiIO/MultiIO_node.html

cd snxmknod;\
Build Golden tty file node (ttySNX0 ~ ttySNX31)
cd snxdump;\
make install
make[1]: Betrete Verzeichnis '/home/kasse/Desktop/WNPCICOMLinux_driver/golden/snxdump'
gcc -O2 -pipe -o snxdump snxdump.c
cp -p snxdump /usr/bin
make[1]: Verlasse Verzeichnis '/home/kasse/Desktop/WNPCICOMLinux_driver/golden/snxdump'
cd snxterm;\
make install
make[1]: Betrete Verzeichnis '/home/kasse/Desktop/WNPCICOMLinux_driver/golden/snxterm'
gcc -c -o snxterm.o snxterm.c
make[1]: Verlasse Verzeichnis '/home/kasse/Desktop/WNPCICOMLinux_driver/golden/snxterm'

sry for the german log but it looks like the makefile was created in german too, if you need a translation of something don't worry to ask.

March 12th, 2010, 10:08 AM
use egalax touchscreen driver for your BA72 wincor-nixdorf :

i use them and it work perfectly on : ubuntu and archlinux

March 12th, 2010, 06:28 PM
Sorry for the late reply, but I found out that it isnt a ttyS1 Problem,

problem was related to a wrong Xorg configuration.

I've posted a short how to on my blog how the touchscreen works with 9.04 and it's default mutouch drivers.