PDA

View Full Version : [ubuntu] resoloution problem with Nvidia GeForce 5200 FX



TAYLOR!
July 10th, 2009, 07:42 AM
i installed the lastest drivers from nvidia's site and i cant go any higher than 800x600. ive done a few fixes to my xorg.conf but hanv't worked.

this is what my xorg looks like


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Thu Jun 25 19:52:48 PDT 2009

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "UseEDID" "False"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Default Device"
SubSection "Display"
Modes "1024768_60"
EndSubSection
EndSection

tommcd
July 10th, 2009, 07:51 AM
You could have just used the nvidia driver from the Ubuntu repos. I used a 5200 for a year or two with earlier versions of Ubuntu and I never had a problem with the driver from the Ubuntu repos.

To fix the resolution problem, try using:

sudo nvidia-settings
if you have not tried that already. The nvidia settings window may give you the option for the correct resolution.
If that does not work, try using xrandr as in this tutorial:
https://wiki.ubuntu.com/X/Config/Resolution

And welcome to the Ubuntu forums!

amitabhishek
July 10th, 2009, 07:53 AM
^^^ He is right just use the repos.

tommcd
July 10th, 2009, 08:01 AM
If you do decide to use the nvidia driver from the Ubuntu repos, be sure to completely remove the driver from nvidia.com before installing the driver from the Ubuntu repos.

TAYLOR!
July 10th, 2009, 12:53 PM
right... i went back to the restricted drivers (which i presume are the same in the respo) and i did the xrandr thing but still nothing. i get this after doing everything.


taylor@taylor-desktop:~$ xrandr --output default --mode 1024x768_70.00
xrandr: Configure crtc 0 failed

on one of the steps (getting the mode line one i think) i did both cvt and gtf.

the quote is what i got after using gtf.

themattbeballin
July 10th, 2009, 07:16 PM
I am not sure this will help you much, but when I had my nVidia GeForce FX 5200, you should install the 90 drivers and not anything newer.

Also, if you use a KVM, that could also be the culprit. It was for me at a time.

I hope this helps.

Matt

tommcd
July 11th, 2009, 08:16 AM
right... i went back to the restricted drivers (which i presume are the same in the respo) and i did the xrandr thing but still nothing. i get this after doing everything.

Did you try using the --newmode option in xrandr as it says in the tutorial? I think you need that to get modes that are not automatically detected.

Create a new modeline in the terminal with gtf or cvt. Then replace the modeline you currently have in your xorg.conf with the modeline you get with cvt or gtf. For example:


bash-3.1$ gtf 1024 768 70

# 1024x768 @ 70.00 Hz (GTF) hsync: 56.00 kHz; pclk: 76.16 MHz
Modeline "1024x768_70.00" 76.16 1024 1080 1192 1360 768 769 772 800 -HSync +Vsync

What monitor are you using? Do you have more that one monitor hooked up?