View Full Version : [ubuntu] Acer Aspire 4520 Ethernet Problem.

July 8th, 2009, 05:10 PM

I own a Acer Aspire 4520, which i bought in Bangalore, India. It is running on Windown XP Professional. I have a very weird problem with the Ethernet port. I was able to use wired LAN, through the Ethernet port successfully, for over a year ago, in India, and for about a year in Edinburgh, Scotland. I am currently in Germany, and there seems to be some kind of a problem with the compatibility of the network port [on the wall] and my Ethernet driver, here. I am staying in a student hostel where in, each room is provided with wired internet access through a wall mounter network port. When i connect my laptop to the same, the tiny LED on my laptop's Ethernet port does not glow. So i tried to uninstall the LAN driver and reinstall it. The minute i uninstalled the LAN driver, the LED started glowing, and it stopped when i reinstalled the driver. So that tells that the problem [Or incompatibility] is between the driver and probably the way the wall mounter port is wired. I could find 3 different LAN drivers for my laptop, for Windows XP, i tried them all with no success. The weird thing is that my laptop [With the same LAN driver] works fine when connected to the LAN port in the room next door, and other laptops work fine when connected to my room's LAN port. Its just my laptop that doesn't working in my room [I know, tough luck].

Also, earlier today, i installed the latest version of Ubuntu on my laptop, thinking that this should solve the problem once for all [I previously had Ubuntu, back when i was in India, and have successfully accessed internet over it]. But the same problem persists, that is, i do not get the Ethernet LED blinking, although it works perfectly fine when connected in another room, over Ubuntu. I really wonder what the problem is, and what the possible solution could be [Other than relocating to another room]. Anybody? Thanks in advance.