PDA

View Full Version : [ubuntu] Brightness too high in ubuntu, cant change w/ apple keyboard as in os x or windows xp



eacls86
July 4th, 2009, 03:55 PM
I am running ubuntu 9.04 on my intel mac via bootcamp and i can't change the brightness with the f1 and f2 keys and it is far too bright for my liking

thanks

Bucky Ball
July 4th, 2009, 03:58 PM
Try right clicking on the top toolbar, 'add to panel' and you should be able to add a brightness applet which will allow you to adjust screen brightness.

derekeverett
July 4th, 2009, 04:01 PM
I'm using a mac keyboard on an HP machine just cause I like the keyboard. I got real used to them over the years using a mac.

I've never bothered with bootcamp so I'm not sure if this will help or not but on my HP box if I hold down the fn key (beside home key) and press function keys I get some of the normal mac intended functionality.

eacls86
July 4th, 2009, 04:03 PM
Try right clicking on the top toolbar, 'add to panel' and you should be able to add a brightness applet which will allow you to adjust screen brightness.

Has no effect - there is a red circle with a red line thru it over the icon, plus its setting as at the bottom so if it did work it would only make it brighter

thanks all the same

eacls86
July 4th, 2009, 04:08 PM
I'm using a mac keyboard on an HP machine just cause I like the keyboard. I got real used to them over the years using a mac.

I've never bothered with bootcamp so I'm not sure if this will help or not but on my HP box if I hold down the fn key (beside home key) and press function keys I get some of the normal mac intended functionality.

-------

tried that all already :)

the volume f keys still work (f10 - 12) as does the eject key (without holding fn)

but thanks all the same

too future posters - i don't care whether or not the solution involves using the keyboard - i just want to be able to change the brightness of my monitor (as opposed to the brightness in linux) with a pc monitor this would be as simple as pressing a button on the monitor itself as you all know

and sorry if my sentences don't make sense because its hard to concentrate with these sore eyes lol

derekeverett
July 4th, 2009, 04:12 PM
Did you see this?

http://ubuntuforums.org/archive/index.php/t-1010532.html

eacls86
July 4th, 2009, 04:38 PM
sudo modprobe mbp_nvidia_bl
returns
FATAL: Error inserting mbp_nvidia_bl (/lib/modules/2.6.28-13-generic/kernel/drivers/video/backlight/mbp_nvidia_bl.ko): No such device

echo 150 | sudo tee /sys/devices/platform/applesmc.768/leds/smc::kbd_backlight/brightness
returns
tee: /sys/devices/platform/applesmc.768/leds/smc::kbd_backlight/brightness: No such file or directory
150

thanks

456
August 3rd, 2009, 04:21 PM
Hi eacls86,

To quote you:
"too future posters - i don't care whether or not the solution involves using the keyboard - i just want to be able to change the brightness of my monitor (as opposed to the brightness in linux) with a pc monitor this would be as simple as pressing a button on the monitor itself as you all know"

The monitior you refer to is obviously a laptop monitor. "as opposed to the brightness in linux" - I not sure what this means.

This is the advice I've given to similar posts (today).

Have you tried setting the brightness options in the power management program?

Accessed via: System - Preferences - Powermanagement.

I've just fixed my laptop after getting annoyed that the screen kept adjusting to 50% brightness on battery power.

I came to your thread eacls86, seeking an answer but eventually found it by searching for "adjust brightness" in the built-in ubuntu help (accessed via: system - help and support). Please don't read that as being condescending - I searched there weeks ago but used the wrong search words.

Hope I've helped,

456

sargenme
April 9th, 2010, 07:36 AM
I have the same problem. Using a MacBook with dual boot. None of the suggestions so far work for me.

linuxopjemac
April 9th, 2010, 07:42 AM
Start here:
https://wiki.ubuntu.com/MactelSupportTeam/CommunityHelpPages

Probably pommed will do what you want:

sudo apt-get install pommed