View Full Version : Wine problems (sorry if in wrong section)

July 4th, 2009, 02:41 PM
I recently installed the latest version of wine and added the correct information to the repositories to upgrade this version whenever needed (I just followed the winehq directions so what I just said may be mis-worded). The first ubuntu update manager broke my wine install, libc6 GLIBC cant be found, i even completely removed and re-installed but still not running a thing not even wine configuration.
Any help with this problem would be greatly appreciated, if you need more more information I will post as advised. Thanks in advance.

July 4th, 2009, 04:21 PM
Have you tried installing/reinstalling those packages through Synaptic? I would give that a try...

July 4th, 2009, 05:26 PM
I read removing libc6 will stop ubuntu from working so I didn't, I did reinstall though.

The error I get when I type winedbg is:

wine: failed to initialize: /lib32/libc.so.6: version `GLIBC_2.9' not found (required by /usr/lib32/wine/ntdll.dll.so)

July 4th, 2009, 07:18 PM
FYI this is the correct area for this type of question.

July 6th, 2009, 10:07 PM
Try "sudo apt-get install glibc-doc" and that might install what you are missing.

December 9th, 2009, 04:25 PM

I'm pretty new at working with linux. But I have the same problem:

wine: failed to initialize: /lib32/libc.so.6: version `GLIBC_2.9' not found (required by /usr/lib32/wine/ntdll.dll.so)

I've tried the solutions offered here and other threads regarding wine failing to initialize.

I hope someone can help me.

Thanks in advance,