PDA

View Full Version : [ubuntu] Help configuring my xorg.conf with dual monitor (TwinView)



BassKozz
July 2nd, 2009, 04:29 AM
I have a dual monitor setup (Twinview), both monitors are connected to my 1xNvidia MSI NX8600GT card...
I've been using a 21.6inch HannsG HG216D (herein referred to as HG216D) monitor as my LEFT monitor, and a Dell 1905fp (herein referred to as 1905fp) as my RIGHT monitor. I recently got rid of the 19inch 1905fp Dell monitor and moved my HG216D to the RIGHT and now I have a new 23inch DELL S2309W (herein referred to as S2309W) on the left. The new S2309W is connected to my computer via DVI cable and is configured Perfectly at it's native 1920x1080 resolution. However I can't for the life of me get my HG216D back to it's native 1680x1050. The HG216D is connected via VGA cable that is also routed thru a KVM, I realize this means that this monitor can't/won't be auto-configured. However I should be allowed to set it manually right?...

gksudo nvidia-settings
won't let me select 1680x1050 for the HG216D resolution, it will only let me select 1440x900 MAX, there is no option for 1680x1050, (See attached: screenshot) WTF ](*,)

I've tried to manually edit my /etc/X11/xorg.conf, but after hours on end messing with it, I give UP...
Here is my current xorg.conf:

cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Sun Feb 1 20:25:37 UTC 2009

# commented out by update-manager, HAL is now used
#Section "InputDevice"
#
# # generated from default
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/psaux"
# Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
#
# # generated from default
# Identifier "Keyboard0"
# Driver "kbd"
#EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "BlankTime" "1" # Blank the screen in 10 minutes (Fake)
Option "StandbyTime" "2" # Turn off
Option "SuspendTime" "3" # Full hibernation
Option "OffTime" "4" # Turn off (DPMS)
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 64.0
VertRefresh 43.0 - 60.0
Option "DPMS" "TwinView"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 64.0
VertRefresh 43.0 - 60.0
Option "DPMS" "TwinView"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GT"
Option "NoLogo" "True"
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GT"
Option "DPMS"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: 1280x1024 +1680+0, DFP: 1680x1050 +0+0"
# Removed Option "metamodes" "CRT: 1280x1024 +1920+0, DFP: 1920x1080 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: 1440x900 +1920+0, DFP: 1920x1080 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: 1280x1024 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


Now if I disconnect the VGA/KVM and use the DVI>HDMI cable on the HG216D then everything is recognized properly, and I can set the correct resolution for the HG216D, and that causes my xorg.conf to look like this:


cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Sun Feb 1 20:25:37 UTC 2009

# commented out by update-manager, HAL is now used
#Section "InputDevice"
#
# # generated from default
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/psaux"
# Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
#EndSection
# commented out by update-manager, HAL is now used
#Section "InputDevice"
#
# # generated from default
# Identifier "Keyboard0"
# Driver "kbd"
#EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "BlankTime" "1" # Blank the screen in 10 minutes (Fake)
Option "StandbyTime" "2" # Turn off
Option "SuspendTime" "3" # Full hibernation
Option "OffTime" "4" # Turn off (DPMS)
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL S2309W"
HorizSync 30.0 - 83.0
VertRefresh 50.0 - 76.0
Option "DPMS" "TwinView"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 64.0
VertRefresh 43.0 - 60.0
Option "DPMS" "TwinView"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GT"
Option "NoLogo" "True"
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GT"
Option "DPMS"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: 1280x1024 +1680+0, DFP: 1680x1050 +0+0"
# Removed Option "metamodes" "CRT: 1280x1024 +1920+0, DFP: 1920x1080 +0+0"
# Removed Option "metamodes" "CRT: 1440x900 +1920+0, DFP: 1920x1080 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1920x1080 +0+0, DFP-1: 1680x1050 +1920+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: 1280x1024 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

However if I use that version of the xorg.conf with my VGA/KVM it simply won't display anything on the HG216D... How can I use the second xorg.conf to work with my VGA/KVM?

Here is the "diff" between the two:

68,70c68,70
< ModelName "CRT-1"
< HorizSync 28.0 - 64.0
< VertRefresh 43.0 - 60.0
---
> ModelName "DELL S2309W"
> HorizSync 30.0 - 83.0
> VertRefresh 50.0 - 76.0
112a113
> # Removed Option "metamodes" "CRT: 1440x900 +1920+0, DFP: 1920x1080 +0+0"
119c120
< Option "metamodes" "CRT: 1440x900 +1920+0, DFP: 1920x1080 +0+0"
---
> Option "metamodes" "DFP-0: 1920x1080 +0+0, DFP-1: 1680x1050 +1920+0"

I am just not sure what I need to change and how to get the second xorg.conf to play nice via a VGA connection?

PLEASE HELP
-BassKozz