View Full Version : [SOLVED] WEP issues with D-Link WDL-G122 & Ubuntu 8.04.2

July 1st, 2009, 10:54 AM
I'm using a D-Link WDL-G122 USB Wireless adapter on "ubuntu-8.04.2-desktop-amd64" with the 'hack' described here (http://www.hotubuntunews.com/blog_2.shtml) (http://www.hotubuntunews.com/blog_2.shtml) to try and connect to a WEP protected wireless network.

I have the pre-provided passkey, it's a 10 digit number (no dashes or punctuation of any sort) so I'm not sure if it's supposed to be Open or Shared, and ASCII, Hex, or alphanumeric, but I've tried all 6 combinations and none of them will connect. I'm not in control of the router, so changing any settings on that end (WSK, WPA1/2, specifying/learning key type) aren't possible.

I've connected to the network with 3 different wireless adapters (including the D-Link in question) from 2 other computers, using Win XP Pro 32-bit and Win 7 beta (build 7048 64-bit and build 7100 32-bit). I'm confident the error is not in hardware, nor in my typing of the key, but rather a software configuration issue.

I also cannot connect the computer wirelessly to any other network with internet access, nor can I connect it to any wired network.