View Full Version : *.exe files can't locate needed libraries

June 30th, 2009, 08:19 PM
I have some code that has been built into its executables on a Windows machine. The corresponding libraries (ie, those not made by Windows) were also built and are in the same directory as the executables.

When I open wine cmd and run the executable as foo.exe I get a ton of errors where it can't find the libraries it needs. However, they are definitly in the same directory.

What am I missing to make this work?

June 30th, 2009, 10:00 PM
Not all programs/libraries work perfectly under wine (yet) so maybe they are just not supported yet? also, you might be missing some required dlls from the system32 dir of your windows machine.

Also, it would help a lot if your posted the command output...

Hope this helps,

June 30th, 2009, 10:13 PM
Yeah, still not sure how much of all this works in Wine, but I did get my dll problem fixed just like you said.

But some of the dlls that it said were missing (yet I KNEW were there) turned out to rely on dlls from the Windows machine that I had to copy over.

Thay cleaned up that mess. But I'm still getting errors.

So..this problem has been solved.

June 30th, 2009, 10:15 PM
I would check the app database for wine before installing anything via wine.