View Full Version : [ubuntu] error 22

June 29th, 2009, 01:29 PM

I had NBR installed in a dual boot with windows on an eee pc. I want to install eeeNBR so i deleted the regular NBR.

The problem is that when I boot my computer I get the error 22 and can not enter windows (which I need to do before installing eee). It is not the boot.ini which have changed... I looked at it through the live cd which I am using now...

I can not boot windows and have error 22 when booting

I need to get rid of Ubuntu as a first...


June 29th, 2009, 01:51 PM
here is info on fixing grub


on second thought, if you have the windows install cd, boot it, go to recovery and fix the mbr

June 29th, 2009, 02:59 PM

- as i run

sudo grub

- and then

find /boot/grub/stage1

- i get error 15: file not found..

I tried doing

sudo mkdir /mnt/root

but also get an error, it says cannot create since file exists...

I am not familiar with the terminal...

I do not have the windows cd

thanks for the effort


June 29th, 2009, 03:04 PM
wait, you already deleted the partition where grub was installed (along with NBR)?

if so, you will need either a. the windows install cd (which you say you don't have) or b. supergrub so you can repair the mbr,