View Full Version : [ubuntu] How do I install Older Google Earth 4.2

June 29th, 2009, 02:05 AM
No matter what guide I use I seem to be unable to run GE 4.3 successfully, my system always crashes on GE startup.
How can I install an older version ( 4.2 ) I never had any problem with it.
I have also tried to empty clean all GE files but I am not sure that I have removed them all, how do I check for and completely remove them?
I miss having GE and getting a successful install is now a challenge.

June 29th, 2009, 08:06 AM
Yea it's fixed, it was a simple fixed once I pressed the correct buttons.
It was a driver issue.
I had to open up hardware drivers then I found out 3D was not selected. I checked to enable 3d, installed the driver, rebooted per instructions, presto GE now works.