PDA

View Full Version : [ubuntu] New monitor is not displaying optimum resolution



mipetruniak
June 28th, 2009, 08:01 PM
I recently purchased a Dell S2209W 22 inch Wide Flat Panel Monitor for use with my Lenovo Z60m laptop. I don't dock it- I fake it by closing the lid. It's native resolution is 1920 x 1080.

Windows will display it just fine, but with Jaunty all I can get is 1024 x 768 (I'm using VGA).

I've been browsing the Ubuntu forums all weekend to try and resolve this- but to no avail. Reconfiguring xorg.conf gave me no options to specify which resolution I'd like to use.


sudo dpkg-reconfigure xserver-xorg

If anyone can help I would greatly appreciate it. I provided the pertinent information below.

Thanks in advance,
Mike

xrandr:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1920 x 1200
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
1920x1080 60.0 +
1280x1024 75.0 60.0
1152x864 75.0
1024x768 75.0 60.0*
800x600 75.0 60.3
640x480 75.0 59.9
720x400 70.1
DVI-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1360x768 59.8
1152x864 60.0
1024x768 60.0*
800x600 60.3
640x480 59.9
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
1680x1050 60.1 + 50.1
1400x1050 60.0
1280x1024 59.9
1440x900 59.9
1280x960 59.9
1280x854 59.9
1280x800 59.8
1280x720 59.9
1152x768 59.8
1024x768 59.9*
800x600 59.9
640x480 59.4
S-video disconnected (normal left inverted right x axis y axis)

xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

sudo lspci | grep -i vga
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]

mipetruniak
June 29th, 2009, 01:53 AM
Additionally, I'd like to add I have a live disc of Hardy Heron and when I loaded that- it displayed at 1920 * 1080 just fine (the top & bottom panels did not stretch the length of the screen, though).

Also, my power management settings are:
When laptop lid is closed: Blank screen


Mike

mipetruniak
June 29th, 2009, 03:55 PM
Bump.

mipetruniak
June 29th, 2009, 11:48 PM
OK- I'm much better off. I'm working at 1920 x 1080 @ 60Hz- but I do not see this option available in System > Preferences > Display.

First, I used the gtf utility to calculate my desired mode.

gtf 1920 1080 60

This is the output:

# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync

I copy and pasted the modeline to xrandr and added a new mode:

xrandr --newmode "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync

With this new mode, I added it to VGA-0 and DVI-0:

xrandr --addmode VGA-0 "1920x1080_60.00"
xrandr --addmode DVI-0 "1920x1080_60.00"

Finally I switched over to it:

xrandr --output VGA-0 --mode 1920x1080_60.00

Now I'm in business. I would love to know how to add this to Display options.


Mike

aouie
July 10th, 2009, 02:50 AM
With a X1950GT card and the Open Source ATI drivers, the below xorg.conf helped me setup 1920x1080 using the display. You can ignore the "virtual" line if you are not using dual monitors. By the way the other monitor is currently set to 1280x1024.

---
Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Depth 24
Modes "1920x1080" "1440x900" "1024x768"
Virtual 3200 1080
EndSubSection
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection
---
I had to add the Depth and Modes lines.
Sincerely,
Aouie