View Full Version : [ubuntu] text consoles are gone in Jaunty

June 23rd, 2009, 03:13 PM

I installed Ubuntu 9.04 on my Dell Inspiron using the NVIDIA drivers supplied with Ubuntu. The system works fine in X, however when I press Ctrl-Alt-F1(2..6) to get a text console I only see a blinking cursor. 'ps' shows getty is running properly on tty1 to 6. When I run an strace on getty for tty1 while going to the first console, I see it actually does something but I don't see anything on the screen except for the blinking cursor.

Any ideas what might be wrong?

Thanks in advance,


June 26th, 2009, 07:34 PM
bump, snif.

June 26th, 2009, 07:40 PM
This isn't any help but, ctrl+alt+f1 ....f6 consoles are working here.

June 26th, 2009, 07:47 PM
Hmm, I tried logging in, blind, on one of the text consoles and ran 'ls -lR'. 'ps' from a console in X shows the ls is indeed running. So apparently the keyboard is responsive, I can logon at the text console, I just don't see anything at all except for the blinking cursor.

Also when I turn powerdown the pc I get white bars on my screen but no readable text. Seems like the NVIDIA drivers are messing with the text console

Verry weird

June 26th, 2009, 07:55 PM
That is odd! I can't say for sure but, it could very well be a Nvidia problem. Are you using the latest and greatest drivers?

Anyone else have any ideas?

June 26th, 2009, 08:31 PM
I'm using the latest proprietary drivers supplied by a regular Ubuntu upgrade. I did not install the NVIDIA drivers myself as I really like the way Ubuntu makes sure everything still works when a kernel update is applied. I don't know how well Ubuntu tracks the NVIDIA drivers.

Hmm, at closer inspection the installed version appears to be 180.44 while the latest version on the NVIDIA website is 185.18.14, sigh.


June 26th, 2009, 08:38 PM
Hmm, found this link: http://lcardinaals.wordpress.com/2009/05/11/ubuntu-9-04-x-updates-voor-ati-intel-en-nvidia/ (in Dutch unfortunately). According to the article adding the following line to /etc/apt/sources.list enables installation of the latest NVIDIA drivers.

deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main

Trying it now...

June 26th, 2009, 08:46 PM
Well, I'm definitely running NVIDIA's latest driver now

root@erwin:~# cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86 Kernel Module 185.18.14 Wed May 27 02:23:13 PDT 2009
GCC version: gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4)

However I still don't see a text console and now even the blinking cursor has dissapeared :)

June 26th, 2009, 09:15 PM
uh-oh .... looks like a known bug


June 26th, 2009, 09:19 PM
Doh, yep that's what I'm having too. Sigh. Thanks for the link.

July 28th, 2009, 02:27 PM

same here. no console will have a look.