PDA

View Full Version : [gnome] Keyboard Shortcuts won't use the Super key properly.



jr2
June 19th, 2009, 09:15 PM
Hey,

I have an HP dv4 series laptop.. I can't customize the keyboard shortcuts to use Super (aka "Windoze") + L .. when I hold down the Super key, it immediately defaults to "SuperL" (IDK why the "L", maybe "left"?, but I only have one on this laptop) and won't let me add the actual "L" key. Now, the show desktop function works fine, it is shown as "Mod4+D" in the list. If the Super key is "Mod4", why is it showing as "SuperL" and acting like I pressed and released it? IDK how to fix this, any help appreciated.


I believe you have to enable the "Super" (aka Windows) key before you can use it as a modifier.

Menu: System -> Preferences -> Keyboard

This brings up a "Keyboard Preferences" box with numerous tabs, one of which is "Layouts." Go to that tab, and click on "Layout Options," and you'll see an item called "Alt/Win key behavior." Under that, you can set "Super is mapped to Win key." That will let you use the Super key as a modifier. Or it should anyway.

thefluxster
June 19th, 2009, 09:36 PM
I just installed 8.10 last night and am having the exact same behavior. Pressing either of the two Super/Mod4/Windows keys results in the behavior you would expect if you had just quickly pressed and then released the key.

Any known solutions to this problem?

mcubed
June 19th, 2009, 10:05 PM
I believe you have to enable the "Super" (aka Windows) key before you can use it as a modifier.

Menu: System -> Preferences -> Keyboard

This brings up a "Keyboard Preferences" box with numerous tabs, one of which is "Layouts." Go to that tab, and click on "Layout Options," and you'll see an item called "Alt/Win key behavior." Under that, you can set "Super is mapped to Win key." That will let you use the Super key as a modifier. Or it should anyway.

jr2
June 23rd, 2009, 10:47 PM
That fixed it, thanks, mcubed! :D

Alex8080
June 24th, 2009, 09:59 AM
Just to be sure, some other thread:
http://ubuntuforums.org/showthread.php?t=1192427