PDA

View Full Version : [ubuntu] cd/dvd drive not working!



C4BL3
June 17th, 2009, 12:23 AM
Legit ubuntu beginner here.

I've just installed Jaunty on my Dell E1405 and have gotten everything to work, except for my cd/dvd drive.

As far as I know the drive is in good shape and i've inserted a variety of disks but no luck.

Any help is much appreciated!

swisstone198
June 17th, 2009, 12:32 AM
run

$ cat /proc/scsi/scsi

do you see your cd/dvd drive?

run

$ dvd+rw-mediainfo /dev/dvd

does this see the drive?

wpshooter
June 17th, 2009, 12:32 AM
How did you install Ubuntu ?

zeroseven0183
June 17th, 2009, 01:19 AM
On a freshly installed Ubuntu, if I can still recall it correctly, any CD inserted on the drive will automatically add an icon to the desktop.

And yeah, how did you install Ubuntu? If it's from the CD then it's working. The only issue I think is how the CDs is recognized. How about opening Nautilus (or Places) to see the drive?

C4BL3
June 17th, 2009, 01:25 AM
Hey swiss - i tried both commands and they worked. i can see the drive, and the configuration says "no media mounted"

and I installed ubuntu via my flashdrive

C4BL3
June 17th, 2009, 01:37 AM
oh, and hey i can see the drive in in the file browser!

...but it keeps saying "unable to mount location: no media in the drive'

alket
June 17th, 2009, 01:41 AM
im not expert but did you try another cd ?

C4BL3
June 17th, 2009, 01:46 AM
yeah... i tried a bunch, and i'm beginning to wonder about the drive, but it was working fine before i installed Ubuntu

wpshooter
June 17th, 2009, 02:01 AM
Is CD drive being recongize in BIOS and at very initial boot up ?

mc4man
June 17th, 2009, 04:02 AM
If you installed from a usb flash drive then ck. your fstab and make sure it's not set as a cdrom drive. (in other words the usb drive may have gotten the /media/cdrom0 mount point.


cat /etc/fstab

C4BL3
June 17th, 2009, 06:25 AM
Thanks Mac - here's what I got checkin the fstab:


cable@Gift:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=7baa7574-2a51-478f-b7a8-9129e2da32da / ext4 relatime,errors=remount-ro 0 1
# /home was on /dev/sda4 during installation
UUID=4b7082ec-96a1-4b01-9a4d-a9cd0924fa69 /home ext4 relatime 0 2
# /usr was on /dev/sda3 during installation
UUID=4cb98935-984c-46b7-97e1-23eb37ab5637 /usr ext4 relatime 0 2
# swap was on /dev/sda2 during installation
UUID=49aa0ada-6aaa-4faa-85dd-912f6d11fe13 none swap sw 0 0

swisstone198
June 17th, 2009, 12:24 PM
What command are you using to mount (or is it doing it auto)?

try command (if you have not already)

$ mount -t iso9660 -o ro /dev/cdrom /mnt

or

$ mount -t iso9660 -o ro /dev/dvd /mnt


If you still get error what does /var/log/messages say?

C4BL3
June 18th, 2009, 04:32 AM
Well, i've tried both commands, and I keep getting the message "no medium found on /dev/sr0"
Does that mean it's just not reading the disc?

mc4man
June 18th, 2009, 05:32 AM
I don't have jaunty so just an observation.

That is the oddest fstab I've ever seen and there is no dvd/cdrom drive(s) listed. (/dev/scd0, /dev/scd1
Maybe jaunty does things differently but you need someone with jaunty to advise

I don't get this at all

# / was on /dev/sda1 during installation, ect. ect.

My fstab in 8.04 (don't copy, just example of layout, cdrom drives in blue


# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sdb3 :
UUID=622a0b49-e4a4-41bb-b871-1d1291b46905 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda5 :
UUID=0fb7ecba-03cb-4381-89ca-eaeccc362fb8 none swap sw 0 0
/dev/sdb8 /media/music vfat iocharset=utf8,umask=000 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sda2 /media/TO\040SEE ntfs-3g defaults,locale=en_US.UTF-8 0 0

C4BL3
June 22nd, 2009, 04:40 AM
Well, I'm afraid I've tried all I can think and the drive still doesn't mount due to a "no media in the drive" error. Perhaps it's just the hardware/cd sensor?