PDA

View Full Version : [ubuntu] workspaces switching via scroll wheel?



blur xc
June 14th, 2009, 10:34 PM
I've got the whole desktop cube thing going on, and I find at random times, if I'm scrolling w/ the scroll wheel of my mouse, it'll sometimes switch workspaces, like a ctrl-alt-(left or right arrow). Mostly I'm scrolling down which makes it switch to the right.

any clues? It's mildly annoying...

BM

Hamchan
June 14th, 2009, 10:36 PM
Mine does that, but only when the pointer is over the desktop instead of an open window. When the pointer is in the window, the scroll wheel just scrolls. Not sure how to disable it though since I sort of like the feature.

blur xc
June 14th, 2009, 10:55 PM
oooOOOOhhhhh.... Ok- I can reproduce that. It was bugging me, because I was scrolling in a box and if I guess if I got the pointer in that space between to scrolling text boxes, it'd flip screens. At least now I know what's doing it, and can control it...

And since we are on the subject of switching workstations, is it possible to program individual mouse buttons in Ubuntu like the logitech software does on Windblows computer? What I would love is to program one of hte thumb buttons to be the ctrl-alt key combo, so I can do the whole cube deal w/o using two hands.

thanks,
BM

Locutus_of_Borg
June 14th, 2009, 11:34 PM
ccsm > Viewport Switcher > Desktop-Based Viewport Switching

I think button 4 and 5 are scroll up/down just disable those


Try this: http://www.ollisalonen.com/btnx/
for re-mapping extra mouse buttons.

john.nicholls
June 15th, 2009, 10:40 AM
This is the default behavior of the Viewport Switcher in Compiz.

Spectre5
October 17th, 2009, 02:40 AM
Can you disable this feature? I find it very annoying and prefer to use ctrl+alt+left/right or simply clicking the workspace on the panel.

Thanks!

netcyrax
October 30th, 2009, 02:17 AM
just use the CompizConfig Settings Manager (you will have to install it via the Ubuntu Software Centre)..

Then run it (System -> Preferences), go to ViewPort Switcher (under Desktop) and in the "Desktop-Based Viewport Switching" tab disable everything you don't need.

Spectre5
October 31st, 2009, 12:04 AM
just use the CompizConfig Settings Manager (you will have to install it via the Ubuntu Software Centre)..

Then run it (System -> Preferences), go to ViewPort Switcher (under Desktop) and in the "Desktop-Based Viewport Switching" tab disable everything you don't need.

Perfect, that is exactly what I was looking for, thanks!