View Full Version : [ubuntu] Keyboard Doesn't Respond, HP Pavillion dv6000

June 14th, 2009, 06:10 AM
I'm very new to new to Ubuntu (and Linux in general) and was very excited today when my Ubuntu 9.04 disc came in the mail. My HP Pavillion dv6000 on the main partition, and came with a secondary recovery partition. I deleted the recovery partition, then shrunk the C:/ drive within Vista. I had about 130gb with Vista (which, after all was said and done, works 100% like it did before), and about 50 gigs free. With the advice of a friend, I made about 47 gigs for Ubuntu, and about 3 gigs for a "Swap Area" partition.

Anyway, like I said, Vista works fine. However, after choosing Ubuntu in the grubb bootloader, I get to the login screen where I'm supposed to choose a username. At this point, my keyboard and mouse (not a USB keyboard or mouse, the ones built into my laptop) don't respond at all. The capslock key doesn't turn the light on or off either. The enable/disable touchpad does make the little light turn from blue to red and back, although that doesn't do anything.

The mouse still works fine when booting Vista, and worked/works fine when booting from the disc. What do I do?

June 14th, 2009, 04:27 PM
Bump...anybody know what's wrong?

July 1st, 2009, 07:31 AM
Problem Summary:I Upgraded from Linux Mint 5 to 6 (Hardy to Intrepid). Upon reaching the login screen, my keyboard is no longer recognized. Prior to the login screen I can navigate w/ keyboard to recovery mode and get to a root prompt, but I don't know much about what to do in there.

During the upgrade, I received an error message about broken packages and I'm not sure if the upgrade app automtically fixed it or not. First thing I tried to do in Recovery Mode was fix broken packages

Similar Cases: Besides the starter of this thread, I found another guy who had the exact same problem here (http://ubuntuforums.org/showthread.php?t=1017366&highlight=upgrade+intrepid+login+keyboard) but he doesn't really know how he solved it, so his directions are vague. Didn't want to post in a thread marked [SOLVED].

Action: Started in Recovery Mode, attempted to fix broken packages.

Result: Problem persists. Repositories couldn't be reached. It may be that my wireless isn't connected to the Internet (it usually takes a minute after logging in to obtain an IP address)

Any further help would be greatly appreciated. It may be that I just need to connect to the repositories and fix broken packages, or looking at other cases, it might be something with x. I could probably just try a fresh disk installation but I figure it's better to report problems to the community.