PDA

View Full Version : [ubuntu] Bad nVidia!!!



Katman000
June 14th, 2009, 01:33 AM
I was havinmng trouble playing starcraft and I read that it could be the graphics drivers. I followed the ubuntu guide instructions on this and now I can't get into ubuntu. I boot up, grub works, get the ubuntu loading screen and then eternal blackness. I'm typing this on my handy iPod touch. Please help, I need my computer back!

utnubuuser
June 14th, 2009, 05:26 AM
at boot, if you've got silent grub, (which means no grub list), press esc to access recovery mode, then run xfix.

If you have grub selection menu, select recovery mode, then choose "try to fix x"

From the command-line, the name of the hardware-driver manager is jockey. jockey-gtk is the graphical version (I think).

kdi
June 14th, 2009, 09:06 AM
I was havinmng trouble playing starcraft and I read that it could be the graphics drivers. I followed the ubuntu guide instructions on this and now I can't get into ubuntu. I boot up, grub works, get the ubuntu loading screen and then eternal blackness. I'm typing this on my handy iPod touch. Please help, I need my computer back!

I was having the same prob before. it's ur xorg.conf that has to be correctly configured. switch on your computer and press esc. select recovery. choose root and enter ur password. this leads u to console.

1. type sudo nano /etc/X11/xorg.conf

2. analyze ur xorg.conf. i put my xorg.conf as an example of working xorg.conf for your reference.
__________________________________________________ ____________________________
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder63) Mon Mar 2 12:46:46 PST 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 2 12:45:55 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
# commented out by update-manager, HAL is now used
# InputDevice "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used
# InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
#
# # generated from default
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/psaux"
# Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
#
# # generated from default
# Identifier "Keyboard0"
# Driver "kbd"
#EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "COMPAQ S510"
HorizSync 30.0 - 61.0
VertRefresh 50.0 - 120.0
Option "DPMS"
EndSection

Section "Device"
Identifier "GeForce FX 5500"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5500"
Option "NvAGP" "1"
Option "RenderAccel" "True"
option "NoLogo" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "GeForce FX 5500"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1024x768_75 +0+0; 1024x768 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
__________________________________________________ ____________________________
note: don't copy exactly my xorg.conf. you must know ur desktop's "HorizSync" n "VertRefresh" value.

look at "Device" section n see what's written there.

i'll try to help if u could give me ur comp spec. u can refer here (http://paktamcyber.blogspot.com/2009/06/its-nearly-week-for-me-to-configure-my.html) for more.

gud luck!:D

Katman000
June 14th, 2009, 02:56 PM
Thanks for the advice, it seemed to be the right solution, but even after editing the xorg.conf file to the best of my ability, nothing. I am using an old GeForce4 MX 4000 graphics card and a ViewSonic AV1912wb-3 19" widescreen flatpanel display. I cant post my xorg.conf unfortunatley but could someone please type up a draft of what it should be like with my hardware? I know it is bothersome, but I am very new to Ubuntu and have never had to deal with drivers past installing them.

gradinaruvasile
June 14th, 2009, 03:04 PM
Thanks for the advice, it seemed to be the right solution, but even after editing the xorg.conf file to the best of my ability, nothing. I am using an old GeForce4 MX 4000 graphics card and a ViewSonic AV1912wb-3 19" widescreen flatpanel display. I cant post my xorg.conf unfortunatley but could someone please type up a draft of what it should be like with my hardware? I know it is bothersome, but I am very new to Ubuntu and have never had to deal with drivers past installing them.

The newer versions of X are quite good at detecting displays and auto configuting. I havent touched the xorg conf since i installed ubuntu 8.04...
I recommend sticking to the recommended drivers (in your case i think it will be 96 series drivers - or 71). The newer ones usually dont help on older hardware. Uninstall your current drivers and install the ones supplied by ubuntu.

kdi
June 14th, 2009, 05:08 PM
Thanks for the advice, it seemed to be the right solution, but even after editing the xorg.conf file to the best of my ability, nothing. I am using an old GeForce4 MX 4000 graphics card and a ViewSonic AV1912wb-3 19" widescreen flatpanel display. I cant post my xorg.conf unfortunatley but could someone please type up a draft of what it should be like with my hardware? I know it is bothersome, but I am very new to Ubuntu and have never had to deal with drivers past installing them.

you should let the os fix ur x in order for u to get login graphically. to do this make sure you press esc button to go into grub menu. select using arrow button n select xfix. the os will configure your display according to native open nvidia driver provided by the kernel.

when u login to ur account, u cannot enable 3d effect though. then, remove ur previous installed driver n reinstall it.

after you reinstall the driver, don't reboot it right away. enter the terminal n type:

1. sudo nano /etc/default/linux-restricted-modules-common.

it should look like mine:
__________________________________________________ ________________________
# This file is sourced from the linux-restricted-modules-common init
# script and is used to disable the link-on-boot feature, one module
# at a time. This can be useful if you want to use hand-compiled
# versions of one or more modules, but keep linux-restricted-modules
# installed on your system, or just to disable modules you don't use
# and speed up your boot process by a second or two.
#
# Use a space-separated list of modules you wish to not have linked
# on boot. The following example shows a (condensed) list of all
# modules shipped in the linux-restricted-modules packages:
#
# DISABLED_MODULES="madwifi ltm wl"
#
# Note that disabling "madwifi" disables all madwifi drivers, "ltm"
# disables ltmodem and ltserial. You can also name each module
# individually, if you prefer a subset.

DISABLED_MODULES="nv nvidia"
__________________________________________________ ________________________
note the bold value. copy exactly in yours, exit n save.

2. sudo nano /etc/modprobe.d/blacklist.conf

add two value which i've bolded for you:
__________________________________________________ ________________________
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp
blacklist agpgart
blacklist intel_agp
__________________________________________________ ________________________

lastly, type sudo gedit /etc/X11/xorg.conf n add the value i have bolded below in yours n save. make sure that the "Device" Identifier is referring to ur card model,not mine.:D. one more thing, the value in red must be the same. if it possible, post ur xorg.conf to this thread before u reboot ur machine so that i could see what it looks like.
__________________________________________________ ________________________
Section "Device"
Identifier "GeForce FX 5500"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5500"
Option "NvAGP" "1"
Option "RenderAccel" "True"
option "NoLogo" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "GeForce FX 5500"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1024x768_75 +0+0; 1024x768 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
__________________________________________________ ________________________

Gud luck...:D

Configuring Nvidia Graphic Driver on Ubuntu Studio (http://paktamcyber.blogspot.com/2009/06/its-nearly-week-for-me-to-configure-my.html)

zachthejones
June 22nd, 2009, 02:27 AM
I had a similar problem. The reason you lose stuff on your display after the ubuntu splash screen is (probably) that the resolution is out of the range of the monitor.

So you can get your screen back (albeit without the nvidia drivers): hit "esc" when booting up (with a blank grub screen - only one OS), or choose the "recovery Mode". Then, on the different recovery options, go down to the bottom. One of the last ones will be about fixing a bad graphical configuration or something. All this will do is reset your xorg.conf file back to it's most basic configuration (deactivating your drivers in the process).

I think the driver you need is the 173 one, but you can check an nVidia list (http://www.nvidia.com/object/IO_18897.html) to make sure you're using the right driver. There should be a link from that page to the latest version of the driver if you want to try it.

Also, I'm not sure what type of monitor you have, but I found my primary problem with my setup was that I was connecting to my LCD monitor via a VGA monitor and it was incorrectly detecting the monitor as a CRT. When I bought a DVI cable it detected it correctly and everything was much better.

I did a little blog write-up (http://linux.zachjones.net/?p=175) on what worked for me, if you want to check it out. Good luck!