View Full Version : [ubuntu] no flac option in soundkonverter

June 13th, 2009, 07:47 AM
I am using soundconverter for ripping my CD collection on two different PCs (both Hardy). No problems on one but the other one does not offer the option "flac" when I want to convert lossless, only wav and wv. Looking in the list of plugins FLAC v. 301 is listed as "should be shipped with my distribution".

Any idea?

June 13th, 2009, 07:51 AM
I'm not really sure what could be causing this problem. Have you tried reinstalling the program?

June 13th, 2009, 08:12 AM
Install flac (soundkonverter uses flac, not libflac, faac, not libfaac, ect.

To ck. open sk's setting and look in Environment (note sk. usually needs to be restarted after you install something or make setting's changes

June 13th, 2009, 08:37 AM
Thx. Installing flac solved it. I had in mind that flac would be in the standard distro.

June 13th, 2009, 08:59 AM
while with flac it won't matter if ever using other formats also ck. in the 'backends' to see if there is a 'better' encoder, decoder, ripper available (green vs yellow or red

June 13th, 2009, 09:05 AM
Celebrated too early. Now I can select flac, sk recognizes CD but won't rip. Remains in state "waiting" forever.

June 13th, 2009, 04:27 PM
Never used sk for ripping but this is what seems to happen (in gnome)

I only have cdparanoia installed so that's what must be set in backends and it does work.

What happens though is when you open the settings -> configure soundkonverter for anything, it then reverts the ripper back to kio_audiocd even if you don't open backends.

So every time you open settings you'd need to reset the ripper back to cdparanoia before exiting.

If you open ~/.kde/share/config/soundkonverterrc you can see what's set and how it changes when opening the settings menu (for anything

June 21st, 2009, 04:19 AM
:D Thank you for the hint.
Works fine again.

June 21st, 2009, 04:25 AM
I also noticed that the other possible ripper - cdda2wav, isn't to be found.
Turns out it's included now in the icedax package.

cdparanoia works fine here, just thought I'd mention