PDA

View Full Version : [ubuntu] How to download Audacity 1.2.6



tomreid
June 12th, 2009, 02:05 AM
Hi

The version of Audacity available in the software repositories in Ubuntu is 1.3.7 which the Audacity web site says is a beta build. Is has been crashing and freezing a lot on my system, so i wondered if anyone knows how to download a .deb file of the previous stable release (1.2.6).

For some reason only 1.3.7 is available in the Ubuntu repositories, i have download a tar gz file of the source code of 1.3.7., but compiling software is something I've yet how to learn how to do.

Thanks

shiggydiggy
August 22nd, 2009, 10:07 AM
i'm looking for this aswell! Help!

Copernicus1234
August 22nd, 2009, 10:12 AM
Compiling should be easy if its a standard package. Just unpack, go to the directory, type ./configure and let it configure itself. Then type make, and when its done building, you can install with sudo make install.

If you install it this way however, it may conflict with existing versions so I would remove the old synaptic package first. And if you want to uninstall this later, you need to type locate audicity and manually remove all the files. Packages are easier for a reason. :)

gjoellee
August 22nd, 2009, 10:14 AM
Download the tarball: http://audacity.googlecode.com/files/audacity-src-1.2.6.tar.gz
Extract it, then as it says in the README you install audacity with the following commands:

./configure
make
sudo make install

of course you have to navigate to the audacity folder. That can be done with:


cd /home/$user/path/to/your/audacity/folder

you probable won't have to remove the "/home/$user/" has $user goes to the home folder for the user you are currently using.

shiggydiggy
August 22nd, 2009, 01:21 PM
how do i get all the dependecies needed to compile it?

magicmax0
August 22nd, 2009, 02:09 PM
All you need is "audacity" and "audacity-data". You can also try the newer 1.3.8 version, you can get the .deb files here (http://www.getdeb.net/search.php?keywords=audacity). Just download both packages and double click to install them, they can be deleted after install.

shiggydiggy
August 22nd, 2009, 03:32 PM
All you need is "audacity" and "audacity-data". You can also try the newer 1.3.8 version, you can get the .deb files here (http://www.getdeb.net/search.php?keywords=audacity). Just download both packages and double click to install them, they can be deleted after install.
How do i install them? they both depend on each other to install..

shiggydiggy
August 22nd, 2009, 04:41 PM
how do you install packages that depend on each other?