PDA

View Full Version : [ubuntu] Setting default file manager



Nevon
June 7th, 2009, 08:20 PM
Back when I first installed Ubuntu 9.04, Nautilus would crash on me pretty much constantly - causing me to have no real desktop. In an attempt to at least be able to browse my files normally, I removed Nautilus and installed Thunar instead. After that, I tried to reinstall Nautilus (because I really love nautilus). Too my surprise, it seemed to work just fine. I even got my desktop back. But for some reason Thunar is still set as my default file manager. So whenever I use the Places menu, Thunar pops up. However, if I plug in a USB memory - Nautilus takes care of it.

I've already tried removing Thunar, but then the Places menu just gives me an error when I try to open something.

Is there any way I can set Nautilus to be the default file manager?

benerivo
June 7th, 2009, 08:58 PM
You could check out the bottom of this page (http://www.psychocats.net/ubuntu/nonautilusplease), as well as removing thunar.

Nevon
June 7th, 2009, 10:27 PM
You could check out the bottom of this page (http://www.psychocats.net/ubuntu/nonautilusplease), as well as removing thunar.

Already tried both of those things. The script provided there actually only restores Nautilus if you used one of the scripts provided there to remove Nautilus in the first place.

benerivo
June 7th, 2009, 10:40 PM
It may be a configuration file that causes the problem. I would try creating a new user to see if they have the problem as well. If not, then the problem might be solved by deleting something from your home folder. Don't know what, but hope it helps...

Orfintain
June 8th, 2009, 02:28 AM
I have a similar issue rhythum box has hyjacked some nautalis functions and now none of my bookmarks work or any places for that matter other than computer I have removed ryhum box. the above script does nothing and a guest user dose not have this problem...

Nevon
June 12th, 2009, 11:09 AM
It may be a configuration file that causes the problem. I would try creating a new user to see if they have the problem as well. If not, then the problem might be solved by deleting something from your home folder. Don't know what, but hope it helps...

I tried making a new user, and it worked just fine. But I don't want to lose all my settings and stuff from my old user, so I need to find out what folder it is that's mucking everything up. I tried removing .gnome2, .gnome, .gconf and .nautilus without any luck. Any ideas on what folder to remove?