PDA

View Full Version : [ubuntu] Dualhead: Gnome can't handle separate x sessions



schwim
June 5th, 2009, 03:28 PM
Hi there everyone,

I tried Mint, and dropped it for this reason, thinking there was a deficiency in the distro, but it seems that the problem is more likely with Gnome and not any particular flavor of linux. I'm in great need of some assistance as I'm slowly being driven insane with this bug.

1) Brand new install of Ubuntu. Reboot
2) Install the restricted Nvidia drivers. Reboot
3) Run nvidia-settings as root. Activate dualhead(separate x-sessions). Reboot

Both monitors work. If I choose to open Firefox in the second monitor, it will open. Everything else however opens in the first monitor when selected in the application menu of the second monitor. I can't get anything else to open in the monitor that it was selected in. In monitor 2, I select Applications/Accessories/Terminal and the terminal will open in monitor 1 with no way to move it to the other monitor.

Here's my xorg.conf:



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 1440 0
Screen 1 "Screen1" LeftOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Proview"
HorizSync 30.0 - 80.0
VertRefresh 60.0 - 75.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Proview"
HorizSync 30.0 - 80.0
VertRefresh 60.0 - 75.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6800 GT"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6800 GT"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT-0: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


I don't know what to do. I ran dualhead successfully both in Gnome and KDE when running Fedora on this machine, but 4 installs of Ubuntu flavors later, I've still got a useless dualhead system.

I'd love some help if someone can provide it.

thanks,
json

tomski
June 5th, 2009, 04:50 PM
do you just want dual monitors with 1 desktop
or
dual monitors with 2 desktops

i ask because i have dual monitors (1600x1200 + 1440x1050) and 1 desktop 3000x1200

the way you have yours layed out in the xorg.conf you supplied suggests a dual monitor & dual desktop (1 for each monitor)

tomski
June 5th, 2009, 04:55 PM
If I choose to open Firefox in the second monitor, it will open. Everything else however opens in the first monitor when selected in the application menu of the second monitor. I can't get anything else to open in the monitor that it was selected in. In monitor 2, I select Applications/Accessories/Terminal and the terminal will open in monitor 1 with no way to move it to the other monitor.


take a look here:
http://ubuntuforums.org/showthread.php?t=1137206

schwim
June 5th, 2009, 04:57 PM
Hi there Tom and thanks very much for the reply.

I want two separate desktops. I use one side for development and the other for browsing, mail, music, etc. I've previously run this style without issue until now.

Do you run your system so you can have really wide applications, or do you partition the applications on either side of the desktop?

thanks,
json

tomski
June 5th, 2009, 05:00 PM
i just use one big desktop spread accroos 2 monitors which is the default for dual head in linux

i think the problem you are having is a gnome bug & there is already a few peep's who have this same issue
check the link i posted just a moment ago & in that thread there are a few responses to this issue& a further link to a bug report

plenty to read but im sure it is the same problem you have

schwim
June 5th, 2009, 05:03 PM
Thank you very much for that link. That is indeed my problem and I'm sorry that it's a bug and not something I did wrong :(

I guess I'll try Kubuntu and if that doesn't work, I'll wait a bit and try, try again a little bit later.