View Full Version : [xubuntu] can't select/change to higher resolution than 800x600 under X - Part 2

May 28th, 2009, 09:55 PM
The main problem I have is almost exactly the same as the first post in this thread:


but none of it's posts helped me solve my situation, and since the thread got closed, and I have no clue how to reopen it, that's why I started this new thread..

In my case: I DL-ed and tried both hardy, ibex, and gaunty, all with Xubuntu edition.

and no matter wich i try:

x.org.conf seems to be "almost" empty, and since it can't detect/profile my hw correctly, it does not allow the selection of any resolution be set higher than 800x600. no matter wich "display configurator" tool i choose from any menu/via command line.

what I'd like to achieve is HW acceleration via GLX driver under X with 1024x768 resolution

(under Xfce i tried all menu elements under settings/system wich seemed to be in any connection with the: "display", "desktop", "resolution", "window manager" keywords, and have spent many hours both in synaptic, and gnome-app-installer to check if there are other tools that might can solve my situation)

my hw is an: 1600xp athlon, 512ddr333, with a geforce2ti, and an almost 10-13yo 14" noname (Amaga) monitor

that monitor is capable of 1024x768 @ 60hz, but only that, and no higher res/refresh, only lowers.

nor any windows or linux detects/lists or support it.

the second problem source seems to be the gpu itself wich is only supported till NVIDIA GLX 71.89, and from that point it's dropped..

and since the advanced monitor and resolution tools written by them are only packed under the 90++ versions of the GLX-s I can't use them either because having 2 different version of GLX causes version conflict..

my partial successes:
-HW acc via GLX under 800x600 but not at 1024x768
-consolse resolution got changed to 1024x768 via custom xrandr config editing

still... without 1024 it's really pain in the... to use the gui :(

May 28th, 2009, 10:14 PM
if I run:

sudo dpkg-reconfigure -phigh xserver-xorg

i get the error:

xserver-xorg postinst warning: overwriting possibly-customised configuration
file; backup in /etc/X11/xorg.conf.20090528225719

but even if i empty the X11 folders root content (or not) both situations produce an almost empty xorg.conf with the usual comment lines, and having the device/driver section be as empty as this:

Section "Device"
Identifier "Configured Video Device"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

only nvidia-xconfig was able to produce a somewhat more detailed config file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Sat Jan 24 20:04:4$

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "Module"
Load "dbe"
Load "extmod"
# Load "type1"
# Load "freetype"

Load "glx"

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "unknown"
ModelName "unknown"
HorizSync 60.0
VertRefresh 60.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

but even that config file only contained a range of horizontal and vertical refresh rate, and i had to manually modify that to 60..

still with that config file it only blinks a few times after starting the regular services it offers me the safe-mode launch of X because of X launching failure..

dermotti also suggested in the other thread that:

When you run sudo dpkg-reconfigure xserver-xorg there is a point in which is asks you what resolutions you want.

Just uncheck all resolutions except the one that you DO want, and that should pretty much gurantee it will default you to that resolution."

but for me, not a single offering or ask is made, even if i run the command with normal (working) xorg.conf or with empty folder

both only makes a little hdd usage, and gives me back the prompty without any error lines or anything at all...