View Full Version : [ubuntu] New user, new install.

May 28th, 2009, 04:19 AM
Hello. I'm new here, so forgive me if I've posted this in the wrong section.

First of, I am new to Ubuntu. This is my first time installing it.

Now, my problem.

When I start Ubuntu, and it loads, it gives me "Gave up waiting for root device", etc,
along with ALERT! /dev/mapper/florence-root does not exist. Dropping to a shell, from
then it loads to Initranfs. (florence is the computers hostname).

How can I attempt to fix this, and yes; I have added rootdelay=90 to the kernel, and it
doesnt fix it.

I have tried both 8 and 9, latest files, on the Server portion with nothing but the core installed. This is on a older system, IBM eSever xSeries with 2 processes.

Thanks in advance!

May 28th, 2009, 05:50 AM
Are you using LVM for your partitions?

May 28th, 2009, 12:19 PM
Yes. I selected LVM.

May 28th, 2009, 12:35 PM
reboot wait about 5 seconds, type
exit at the prompt post what happens

May 28th, 2009, 09:45 PM
Ubuntu loads as it should.

May 29th, 2009, 03:26 AM
Which version of Ubuntu are you using? I remember having to load a module in the init script sometimes to get LVM partitions to be seen during boot.

May 29th, 2009, 06:12 AM
I honestly feel like a complete idiot.
I first tried rootdelay=90 on a whole separate line, not with the kernel parameters, so i tried again, except actually added rootdelay=90 at the end of the kernel line, and it boots fine. no more problems! it must just take an extra moment for the hard drives to kick in.

but, thanks again for the attempted help, and i hope somebody can learn from my silly mistake!