View Full Version : [ubuntu] please help! fresh install: " the configuration could not be loaded" no sudo rights

May 27th, 2009, 05:41 PM
this might be a stupid question or a bug:
i just installed ubuntu 9.04 and have no sudo rights.
i tried to go to system-administration-users & groups, i was hoping to get an UNLOCK option.
However, i get the following message:
"the configuration could not be loaded"
followed by: "you are not allowed to access the system configuration".

needless to say, i have no sudo rights.
i have only 1 account set up on the system (that i set up on install) and when i try a sudo command it says i don't have privileges to do so.

any idea?

thanks for the help.

May 27th, 2009, 05:45 PM
How did you install?

Ubu only on the PC?

Dual boot?

Within Widows e.g. wubi etc.?

How did you set up your partitions?

May 27th, 2009, 05:59 PM
i installed on a PS3. following the best practices on the web.
basically, formated the PS3, created a new partition, rebooted of the 9.04 ISO CD for PS3, went through the install process (which was simple and solid) and here i am...

during the install process i was prompted to set up a user/password. these work, and allow me to login to the desktop, but i can't do much when i'm there.

thanks for the help!!

May 27th, 2009, 06:04 PM

May 27th, 2009, 06:41 PM
thanks - looks like a good site. and on the right track.
stupid question - how do i enter recovery mode when using kboot and not grub?

i tried going into sh (which i assume is shell) but i don't know which commands to enter, as the ones mentioned in the link above aren't working (n/ etc/ not found)

thanks agian

May 28th, 2009, 01:43 PM
Just posting to confirm the above problem with a default install of 9.04 on PS3 using the alternate installer disk. I'll also try the above link for a fix when I get home.

May 28th, 2009, 03:09 PM
stupid question - how do i enter recovery mode when using kboot and not grub?

thanks agian

at the kboot prompt type sh to start a shell.

remount the root partition:

umount /mnt/root
mount -t ext3 -w /dev/ps3da1 /mnt/root

chroot into the root partition:

chroot /mnt/root bash

add your user to the admin group:

adduser username admin

backup and edit the sudoers file (if needed):

cp /etc/sudoers /etc/sudoers.backup
EDITOR=nano visudo

the default file looks like this:

# See the man page for details on how to write a sudoers file.

Defaults env_reset

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root ALL=(ALL) ALL

# Uncomment to allow members of group sudo to not need a password
# (Note that later entries override this, so you might need to move
# it further down)

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

When you are done, press: Ctrl+x, y, Enter (save the file and exit)

make sure the file has the correct permissions:

chmod 0440 /etc/sudoers

press Ctrl+d to exit from the chroot or type:


repeat the previous step to exit from the BusyBox shell.

at the kboot prompt boot the system in the normal way.

May 28th, 2009, 07:59 PM
Thanks sisko311!

Up and working.