View Full Version : [ubuntu] Got compiz, but emerald ain't workin'!!!!

May 26th, 2009, 01:17 AM
I really am not sure what is going on. I've actually reinstalled my system hoping a clean start would clean up any screwups I made playing around. Basically, when I switch my window manager over to compiz (using fusion-icon), I lose all my window decorations (that's the emerald issue). But also, if I fire up gnome-do or a terminal, I just get a blank white screen. even AWN does the same thing.

Ironically enough, when I first installed everything it was working great. Here's the order of what went wrong:

I installed 9.04
I did the 45 mb of updates and rebooted
It detected my 5-year-old nvidia card and I used the version 96 of the driver (173 woudln't show anything on boot up)
After another reboot into the new nvidia driver, I set the resolution to where I wanted it and saved the changes to the xorg.conf file
From there I install the compizconfig-settings-manager, fusion-icon, and emerald so I can have my eye-candy. Everything seems to install correctly.
I fire up compiz, and emerald is decorating the windows correctly and I can view gnome-do and a terminal normally
On my next reboot, I've lost my window decorations and now I get the blank window space for gnome-do, terminal
when I switch the window manager back to Metacity I have my window decorations back

I'm just kind of lost at what to do. I've tried the classic:

emerald --replace

It seems to me that the compositing is either turned off or not working correctly - and I really made no changes from the time it worked to the time it didn't, other than booting up off the changed xorg.conf file. Here's what the new xorg.conf file looks like:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Sat Jan 24 20:04:42 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "ServerFlags"
Option "Xinerama" "0"

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "KT@ KT-191W"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 76.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5200"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1440x900 +0+0"
SubSection "Display"
Depth 24

June 7th, 2009, 01:43 AM
okay, for those who care, I fixed the problem. I have an nVidia FX 5200 video card and it needed the 173 driver. I got myself a DVI cable for my LCD and the card correctly detected the monitor and it's optimal resolution (I had been using a VGA cable and it was detecting it as a CRT and setting the resolution too high).

With the right driver, emerald and all the compositing works perfectly!