PDA

View Full Version : [ubuntu] Unable to disable auto-mount for external hdd



fabokzs
May 23rd, 2009, 11:23 PM
Hi,

I'm trying to stop my ubuntu 9.04 system auto-mounting my external hdd if it is attached to my computer.

I tried with different kind of hal configurations like:


<match key="volume.uuid" string="xxxxxxxx-xxxx">
<merge key="volume.policy.should_mount" type="bool">false</merge>
</match>or


<match key="volume.uuid" string="xxxxxxxx-xxxx">
<merge key="storage.automount_enabled_hint" type="bool">false</merge>
</match>The rule


<merge key="volume.ignore" type="bool">true</merge>Is working though, but in this case the hdd does not show up in places.

Does anybody have any idea to disable auto-mount for my device?

Zsolt

asmoore82
May 24th, 2009, 05:10 AM
This option was easily accessible in Ubuntu 8.04 LTS through "System -> Preferences -> Removable Media"

Now you have to Alt+F2 for "Run" and ...

gconf-editor

Then browse down to /desktop/gnome/volume_manager/
and uncheck the keys automount_drives and automount_media

I'm assuming/hoping that Gnome will consider this a regression and have a solution in the next release.
The "Media" Tab in nautilus preferences is a big improvement over the old "Removable Media"
but it seems that automounting preferences just slipped through the cracks.

fabokzs
May 24th, 2009, 10:27 AM
Hi,

This option was easily accessible in Ubuntu 8.04 LTS through "System -> Preferences -> Removable Media"

Now you have to Alt+F2 for "Run" and ...

gconf-editorThen browse down to /desktop/gnome/volume_manager/
and uncheck the keys automount_drives and automount_media

First the entry you mentioned was empty. After that I installed the gnome-volume-manager (I removed it, because I wanted to get rid of the totem), but the hdd is still auto mounted even if the two keys are set to false.

Zsolt

asmoore82
May 26th, 2009, 02:48 AM
Oops ... it moved on me AGAIN!


gconf-editor

and in "/apps/nautilus/preferences/"
the key is media_automount

:lolflag: growth is painful, but necessary.

fabokzs
May 29th, 2009, 08:17 PM
It is working now, thank you very much