View Full Version : [xfce] no sound XFCE$, sound nonX

May 22nd, 2009, 08:49 PM
No sound while in xfce4, can get sound while
not in X windows with current AMD64 release 9.04 cdrom
(clean install). While not in X, can do this command from sox:
play /usr/share/sounds/alsa/*.wav
plays the speaker-text wave files.
From X-term using same play command get the error:
ALSA-LIB: confimisc.c :768 (parse card) cannot find card '0'.
Mplayer spits same error plus pulse error and other (guesses) errors,
while playing a mpeg-ts, vid shows no sound , non-X session
mplayer plays the sound from the mpeg-ts, no vid (no frame-buff).
After install, moved gdm out of /etc/init.d, edit /etc/shadow
for real root user & user with no passwords.
I Do not run [gkx]DM on any of my linux systems,
do run Xwin from root. Will not change shadow or DM.
---Sound changes for problem -----------------
Searched this site and google
Added .asound file in user dir
My other distro on this system Mandriva 2009.1 (sound working in X)
has a lot pulseaudio files installed.
Myth cd only had the libpulse files ?
Got the latest Debian 5.1 amd64 (5dvd sets)
installed pulseaudio, pulseaudio-module-x11, pulseaudio-utils
still no sound in X-windows
Yours Carl Day daycarl@gmail.com </* spammed to max */>