View Full Version : [ubuntu] 9.04 Jaunty Openoffice 3 and Samba via cifs cannot write files.

May 22nd, 2009, 04:03 AM
It seems with the new release I can no longer write to my samba mounts (done via pam_mount) directly from openoffice. I am able to copy files via nautilus or at the console on the mounts, create, edit, delete files with no problems. But there seems to be issues specifically with openoffice and gedit.

Ive looked around and only found a few pieces of advice.
1. Ensure you are mounting with utf8 support
2. Try adding the nobrl option
3. Try disabling openoffice lock files in /etc/openoffice/ooffice.sh
4. On the samba server disable any veto options

I could come up with no combination of the above options that allow me to write to my cifs mounts.

I also find it pretty interesting that I can edit a file on the cifs mount with vim without issue but gedit chokes.

I would very much appreciate some help.

May 22nd, 2009, 02:26 PM
The two errors that I get when trying to save are as follows.

General Error
General input/output error.


Error saving the document
Object not accessible.
The object cannot be accessed due to insufficient user rights.

Again remember I can edit files on this cifs mount with the same user and vim without issue.

Any ideas?

May 23rd, 2009, 01:55 PM
I think I have a similar problem with Openoffice 2.4 and ubuntu 8.10. Maybe it's a lower level issue?

June 2nd, 2009, 03:43 AM
For a solution to this problem, see the troubleshooting section located in the 2nd link in my sig.

June 24th, 2009, 05:52 AM
I have already tried the nobrl option and got no joy. I have also tried the nounix option but still cannot edit files directly with OpenOffice.org on the cifs share..

June 24th, 2009, 07:25 AM
Does mounting the share manually (not with pam_mount) solve the problem?

September 4th, 2009, 12:24 AM
Does mounting the share manually (not with pam_mount) solve the problem?

I tried your suggestion, but no, it does not solve the problem. It's rather annoying because nothing seems to help. I tried the nounix and nobrl options but all to no avail.

What I did discover is that when there is a lockfile present, you then close the file, re-open it's no longer in read-only. but then when you want to save it, it'll give you an authentication error.

February 26th, 2010, 04:00 PM
I've solved it installing gvfs-fuse package. This make openoffice use fuse an automagically 'copy' in /home/user/.gvfs