View Full Version : [ubuntu] Canīt start xorg in ubuntu 8.11 due to fatal error caused by /lib/modules

May 21st, 2009, 12:17 PM
Hello, I really need some urgent help please.

I installed ubuntu 8.10 in an acer aspire one using a wubi install. It was working correctly, but after I installed an update and tried to open a new shell( the update manager adviced that it was necesary to reboot the system), it did not open, so I went to a shell that I had opened before installing the update and tried to open several gnome applications, such like eog and gedit, to see if it could give information about the error. It showed and error saying that gettext symbol was not defined. I thought this was caused by the update and that it would be fixed as soon as I rebooted the system. But after rebooting, it wouldn`t load the graphic environment and showed the following error at startup:

X: warning; process set to priority -1 instead of requested priority 0

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux wicho 2.6.27-14-generic #1 SMP Wed Apr 15 18:59:16 UTC 2009 i686
Build Date: 09 March 2009 10:48:54AM
xorg-server 2:1.5.2-2ubuntu3.1 (buildd@rothera.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed May 20 21:40:27 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
FATAL: Could not load /lib/modules/2.6.27-14-generic/modules.dep: No such file or directory
(EE) [drm] drmOpen failed.
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
(EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
(EE) intel(0): Couldn't allocate video memory

Fatal server error:
AddScreen/ScreenInit failed for driver 0

giving up.
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3): Server error.

I have tried to fix this problem using the recovery mode, but none of the options provided with 2.6.27-14-generic kernel has worked. I can still log in a root shell using recovery mode, and I am hoping I can solve the problem from there with the necessary advice.

Thanks in advance.

May 21st, 2009, 02:59 PM
> modules.dep

generated by depmod: try "depmod -a"

May 22nd, 2009, 03:35 AM
#depmod -a
WARNING: Couldnīt open directory /lib/modules/2.6.27-14-generic: No such file or directory
FATAL: Could not open /lib/modules/2.6.27-14-generic/modules.dep.temp for writing: No such file or directory