PDA

View Full Version : [ubuntu] gnome-terminal left mouse click behaviour in ubuntu 9.04



jbellis113
May 21st, 2009, 06:48 AM
I've just installed Ubuntu 9.04. In gnome-terminal, when I left mouse click to the right of the last character on a line, the rest of the line is highlighted (and used as the clipboard contents).

How do I make it so the rest of the line is not highlighted on a mouse left click?

In ubuntu 8.10, gnome-terminal, upon a left mouse click would not select the remainder of the line.

tcab
June 2nd, 2009, 07:47 AM
Yes - I get this ugly behaviour too. When clicking on a terminal window in order to change window focus and type my next command, I invariably get a "reverse video" selection effect past the end of the line.

I've tried playing with color schemes but to no avail. If the background is white (default) the ugly highlight effect is black. If the background is black (my preferred) the highlight is white.

The only way to avoid it is to either mouse click carefully on some text (which usually highlights a character anyway, not ideal).

Or activate the terminal window with a RIGHT click, but then be careful to slide your mouse off the popup menu otherwise you end up triggering the first item in that menu, which is to open up a brand new terminal window. Alarming! In fact the popup menu is way too trigger happy, just right clicking and releasing the mouse opens a new terminal window - even though you don't feel like youve actively selected anything. The relevant menu item is not even highlighted - yet it gets triggered - I think this is another bug.

Its all really quite annoying.

dbatothestars
June 10th, 2009, 09:08 PM
I am getting this same behaviour running virtualbox on windows XP with ubuntu 904 as a guest. This means that I can snapshot the unix host and revert back to that point in time. Interestingly, the left-click selects whole line only occurs after a length of time. I've tried to isolate the triggering events, but no joy so far.
It's worse than annoying, as the X paste buffer is nuked every time you click on another window.

jbgron
June 15th, 2009, 05:10 AM
I have the same problem. I spend all day on the terminal so this is extremely fu**ing annoying! I hate to say it but I've actually installed Konsole until this bug is fixed.

dbatothestars
June 26th, 2009, 07:33 PM
is this an install of Ubuntu, or through a virtual machine? I'd like to elminate virtual box as a suspect!

I have the same problem. I spend all day on the terminal so this is extremely fu**ing annoying! I hate to say it but I've actually installed Konsole until this bug is fixed.

JorritSchippers
June 27th, 2009, 05:34 PM
I have this problem in VMware, so it might be VM related.

jbellis113
June 29th, 2009, 11:24 PM
I'm running Ubuntu 9.04 as a guest machine using Sun VirtualBox 2.2.4. Windows XP is the Host.

jbgron
June 29th, 2009, 11:56 PM
This is happening natively for me, although I do have VMWare Server and VirtualBox installed. I can't believe this is not fixed already, this makes gnome-terminal unusable for me, I have to use Konsole.

jbellis113
July 2nd, 2009, 05:45 AM
I've just upgraded to VirtualBox 3.0. Problem has gone away!

austindougli
August 28th, 2009, 04:30 PM
The latest VMware Workstation update, 6.5.3 build 185404, seems to fix the problem. I installed the new release and installed the updates vmware tools, rebooted and the issue went away.

Now if only they would fix the issue of Gnome Terminal not remembering its settings.

jbellis113
January 18th, 2010, 03:00 AM
This problem (see OP) has re-appeared for me in Ubuntu 9.10, using VirtualBox 3.1.2. Anyone else experiencing this?

m.afifi
February 5th, 2010, 10:00 PM
Yes same behaviour for me on VBOX 3.1.2

Uname -a

2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 02:39:34 UTC 2010 x86_64 GNU/Linux

provoko
October 9th, 2010, 05:59 PM
I have the latest latest of everything and it still happens....

insulanus
March 27th, 2011, 07:54 PM
I found the bug report for this behaviour:

https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/445084