View Full Version : [ubuntu] 9.04 new install -- can't load after login

May 15th, 2009, 04:21 AM
I just upgraded 8.10 to 9.04; installation was completed successfully. Upon the reboot just after installation, the login screen shows up but after login the desktop just blinks continuously. Mouse, keyboard, sound work okay. I switched to text mode to try to figure out what was going on but I'm not sure what to look for. Any help would be much appreciated.

Hardware details: Asus M50, Intel Core Duo T8300 @ 2.40 GHz with an ATI Radeon HD3470 graphics card, dual booting Windows XP and Ubuntu.

EDIT: No error messages are displayed. The system just seems to freeze and continues to blink (as if trying to reload gnome but unsuccessfully).

EDIT: I have since tried to reboot 2 more times, with the exact same result. The problem is persistent and reproducible. My thoughts are that it could be a problem with X. Additionally, I ran recovery mode, and chose the "dpkg" (Repair broken packages) option which reported installing a "partial upgrade". I then ran the "xfix" (Auto repair of graphic problems) which provided no feedback .. no improvement either.

May 27th, 2009, 09:00 PM
I have a similar problem in that it seems to load ok until the point where the desktop would normally show but instead the screen is black with some static at the top of the screen. I think my problem is due too my graphics drivers as i have a ATI HD4670 which only has proprietary drivers from ati and something has gone wrong on updating to 9.04. I also tried the same fixes to no avail. To be honest i dont feel like I will get this resolved very quickly unless I reinstall from scratch, disapointing to say the least.

Just had a quick gander at the ATI website for HD3470 drivers i see ATI only have proprietary drivers for your card as well and was wondering if you were using them before the upgrade. I must admit i dont have much experience with ubuntu but it would seem that if the driver is not fully supported then it could well be the cause of the problem?

May 28th, 2009, 11:53 PM
Yep, I was using the fglrx proprietary drivers for ATI and that worked great on Hardy and Intrepid. I didn't have any problems before upgrading to 9.04.

I concur, it's quite disappointing.

Given the lack of response (and since I needed to have a working Ubuntu installation) I ended up re-installing Hardy. It's not as bad as it sounds - I copied all the files I needed to the windows partition through ubuntu text-mode (along with some config files) and then just wiped the ubuntu partitions, leaving windows intact.