PDA

View Full Version : [ubuntu] I ruined GDM/X. Help.



tehkane
May 14th, 2009, 09:04 AM
I recently decided to reinstall Ubuntu. Things were going just fine, until today...

I had a ~4 day uptime, so I'm not entirely sure what may have caused this problem. But these come to mind:
- I installed WINE and then Counter Strike Source; Failed to play, though.
- Ubuntu had a few updates available today. So I installed them and then restarted as per it's request. That's when I noticed the problem.

Up until now, I had been running the latest NVIDIA 8 Series Linux x86_64 driver. When I restarted, GDM loaded up and said Ubuntu will have to load in low graphics mode and that 'Type1' module failed to load and couldn't be found.

I tried reinstalling the NVIDIA driver and got the same problem plus more. Started saying NVIDIA modules weren't found and to make sure I had a NVIDIA card installed.

I then ran 'dpkg-reconfigure xserver-xorg' which got GDM back up and running. I, once again, tried reinstalling my NVIDIA driver. Failed. Now I can't even get GDM back up. I don't get any errors, but, when I boot up, it sits at the CLI. When I hit CTRL + F7, it sits there at a blank, black screen.

Any ideas?
I'm running the Ubuntu version prior to the latest. 8.10? The second latest... :P

Just need to figure out how to get **** working again and I wanna know what ruined things in the first place :/

If you need any logs, lemme know.

tehkane
May 14th, 2009, 03:16 PM
A few log files. Hopefully it'll help the diagnosis.

Xorg.0.log - http://slexy.org/view/s2nV7g7tWE
Xorg.0.log.old - http://slexy.org/view/s20Dargbhd
Xorg.20.log - http://slexy.org/view/s20akVEXqC
Xorg.failsafe - http://slexy.org/view/s21Tt5wM4L
Xorg.failsafe.log.old - http://slexy.org/view/s21iNkmmU6

.xsession-errors - http://slexy.org/view/s20XSo4oVn

GDM - http://slexy.org/view/s20Bsg44FG
These logs were given odd names when I transferred them to my Windows box. They lost the neat :0.log :1.log etc... So I just put them into the one file

lspci

01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)

Locutus_of_Borg
May 14th, 2009, 05:57 PM
did a new kernel get installed?

check the grub boot menu, and see if theres a new entry, if so boot from the older one and see if that one works, if it does you probably need the nvidia kernel modules for the new kernel

first remove all existing nvidia packages, then use envy (http://albertomilone.com/nvidia_scripts1.html) to install the driver for your card, or you can try the jaunty package: nvidia-glx-180

tehkane
May 15th, 2009, 05:21 AM
No idea if a new kernel was installed. Also not sure how to tell new kernels apart from old kernels in GRUB. But I'll play around with booting the different available kernels and see what happens. :P

How can I remove all NVIDIA packages? 'sudo apt-get remove nvidia-glx' ? Will that also remove the driver I downloaded from the NVIDIA site?

If I remove these GFX drivers, will I be stuck at CLI until I reinstall the GLX driver (I think that's the Ubuntu NVIDIA driver...) ? Or could I, then, reconfigure Xorg-xserver and get back to a GUI and from there use Envy/nvidia-glx-180 ?

Thanks for reply. I was expecting to come back today and see this thread on page 10 requiring a bump xD

tehkane
May 15th, 2009, 08:46 AM
I tried booting up with an older kernel version, still errors.

I also reinstalled the NVIDIA drivers that I had been using which gets X running but in low graphics mode.



The following error was encountered. You may need to update your configuration to solve this.

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure that there is a supported NVIDIA GPU in the system, and that the NVIDIA device files have been created properly. Please consult the NVIDIA README for details

**ABORTING**
Screen(s) found, but none have a usable configuration


Xorg.conf


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Apr 17 00:40:10 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
# Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

micio
May 15th, 2009, 10:37 AM
Using the last kernel version, try to uninstall nvidia drivers

if you installed debs

sudo apt-get remove --purge nvidia-glx

or if you installed .run file provided by nvidia.com


sudo sh /path/to/Nvidia/package.run --uninstall

then reboot

then reconfigure xorg

try to run X in low graphics mode,

reinstall driver (debs or .run package, as you want)

ensure that nvidia-xconfig in order to configure as better as it can is runned

reboot and hope :)

if it doesn't work, post new logs.