View Full Version : [ubuntu] 9.04 alt install does not detect all RAID5 disks, does not boot after any install

May 10th, 2009, 07:34 AM
Hi guys -

I've got a P5B-E motherboard, 3 SATA 300GB drives in RAID5. It all runs XP just fine but I cannot for the life of me get 9.04 to install to the RAID and boot.

I'm using the alternate and mdadm. When it comes to the detect drives screen it only shows 2 of the drives (should it show 3?).

I've also installed 9.04 to a single 250GB drive also attached to the MB while leaving windows installed on 1 of 3 partitions on the RAID in hopes that 9.04 would boot and then I'd have access to the RAID for storage.

For some reason I can't even boot the single drive (even when I tell the MB it is the first boot device. If I boot to the RAID first I go straight into XP.

Any help would be great.

May 11th, 2009, 12:51 PM
Solved: https://help.ubuntu.com/community/FakeRaidHowto#Step%20by%20step%20(tested%20for%20I ntel%20ICH9R%20array)

Worked like a champ... just a few words on it:

Step 7 looks obvious looking back, but I left free space from my original windows partition, so I didn't know what to look for when choosing my partion in my next step. I tried the process a second time and saw my partitions for Ubutnu and then I knew what number to put at the end of the path.

Everything else worked perfectly.

one other word of advice if you are trying mdadm to create your arrays - NEVER use the "create" command if you plan to keep an old array. I did and it destroyed a lot of work. Noob, yes, I know. .