PDA

View Full Version : [ubuntu] Atheros AR242x woes on my ASUS-X59SL laptop



kgish
May 9th, 2009, 10:47 AM
Why is it that every time I upgrade to a newer version of the linux kernel my wireless connection stops working? :(

The only way to get around this (it seems) is to reinstall my madwifi-hal-0.10.5.6-r3879-20081204 driver and reboot.

I'd think that by now Ubuntu should support this by now, or am I mistaken?

This is my configuration:

Ubuntu: 9.04
Linux: 2.6.28-12-generic
Laptop: ASUS X59SL-AP275C
Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Does anyone out there happen to have any suggestions?

superprash2003
May 9th, 2009, 06:02 PM
you could always stick to the old kernel by choosing the old kernel when you boot

kgish
May 9th, 2009, 06:59 PM
you could always stick to the old kernel by choosing the old kernel when you boot

Not much of an option if I want to keep abreast of the latest and greatest versions.

binbash
May 9th, 2009, 07:11 PM
My card is also using that chipset.First, 2.6.28-12-generic kernel comes with partial upgrade.Default installation of ubuntu DOES support that chipset from my experience.It also works with *.29 kernel out of the box.

You can find the debs here :

http://kernel.ubuntu.com/%7Ekernel-ppa/mainline/v2.6.29.1/