PDA

View Full Version : [ubuntu] 9.04 Network Printing Problems + fixed IP problem



dunbrokin
May 9th, 2009, 02:15 AM
I have upgraded all 3 Dell PC's (P, W, J) to Jaunty. Under Intrepid I could set a fixed IP address and share the printer between P and J. However now, I can see the printer on machine P in localhost and print from it - but none of the other machines can see the printer.

If I use the New Printer Function and click on Network Printer and enter the address of P (10.1.1.5) the find function will not discover the printer.

This problem is all compounded because in the Network Manager I cannot set a static IP. When I enter 10.1.1.1 as the Gateway under Manual, it does not stay, the system loses the gateway and then I cannot access the internet and so I have to go back to Automatic DHCP - which in turn will (when I get the printer working) confuse the other machines as to where the printer is.

Note: share is turned on on machine P

chili555
May 9th, 2009, 02:42 AM
Why not simply remove Network Manager on the machine with the printer and set up /etc/network/interfaces with a static IP? Here is one, as an example:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.108
netmask 255.255.255.0
gateway 192.168.1.254Substitute your details as needed. Also, please select an IP address outside the range of the DHCP server in your router. Mine allocates five addresses from x.100 to x.104.

You might be able to do the same thing with BIND, samba, winbind and a rusty screwdriver, but this is so easy.

dunbrokin
May 9th, 2009, 02:47 AM
Why not simply remove Network Manager on the machine with the printer and set up /etc/network/interfaces with a static IP?

Select an IP address outside the range of the DHCP server in your router. Mine allocates five addresses from x.100 to x.104.



The machine with the printer (P) needs the Network Manager as it needs to connect to the net also.

How do I find out the range of IP addresses set by the DHCP server?

dunbrokin
May 9th, 2009, 03:20 AM
hp-makeuri 10.1.1.4:631


comes back with printer not found - though I can print directly from 10.1.1.4 to the attached printer....I obviously have something set up incorrectly in cups ...I guess.

I cannot ping 10.1.1.4:631 though I can ping 10.1.1.4.

chili555
May 9th, 2009, 03:39 AM
The machine with the printer (P) needs the Network Manager as it needs to connect to the net also.One has little to do with another. I have 5 machines running Ubuntu here and none runs Network Manager. NM is actually useful for machines that are taken to work, university and the cyber-cafe and need to select from many networks. For a desktop machine that stays home all day, it's utterly useless.

This machine I am answering on now has a static IP address and is connected on boot and sees the network printer upstairs, that also has a static IP.
How do I find out the range of IP addresses set by the DHCP server?Look in the setup pages of the router. It should give the range, such as 192.168.1.100 to 192.168.1.149, which is, in my opinion, far too many for a home network. Five maybe or ten is plenty.

dunbrokin
May 9th, 2009, 03:39 AM
~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:21:70:e6:93:d6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Memory:f6ae0000-f6b00000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2837 errors:0 dropped:0 overruns:0 frame:0
TX packets:2837 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:280612 (280.6 KB) TX bytes:280612 (280.6 KB)

pan0 Link encap:Ethernet HWaddr e6:d7:e1:08:44:6c
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 00:21:6a:29:e5:38
inet addr:10.1.1.4 Bcast:10.255.255.255 Mask:255.0.0.0
inet6 addr: fe80::221:6aff:fe29:e538/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:77504 errors:0 dropped:0 overruns:0 frame:0
TX packets:51563 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:97632096 (97.6 MB) TX bytes:7073890 (7.0 MB)

wmaster0 Link encap:UNSPEC HWaddr 00-21-6A-29-E5-38-35-33-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

dunbrokin
May 9th, 2009, 03:44 AM
# Printer configuration file for CUPS v1.3.9
# Written by cupsd on 2009-05-09 12:30
<DefaultPrinter OfficeJet-6100-Series>
Info Hewlett-Packard OfficeJet 6100 Series
Location pj-indulgence
DeviceURI hp:/usb/OfficeJet_6100_Series?serial=MY392H71MM2R
State Idle
StateTime 1241829012
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

dunbrokin
May 9th, 2009, 04:49 AM
SOLVED!

On the client machine make sure you have Server>Configure>Basic Server Settings set to "Show printers shared by other systems"

Ambystoma
May 18th, 2009, 04:01 AM
OMG, thanks so much! That fixed my problem! I spent hours trying to figure out what the heck was going on with my network and printing configs (despite the fact that I'm also running Mint and Suse, and they print just fine to the network). I won't tell you how many times I re-installed the new hplip, and messed around with CUPS. That "allow printing from internet" setting was more obvious in previous versions. I don't know why they made it so darned obscure in 9.04. The setting is intuitive, just not clearly located now. You would think it would be placed in the menu when you right-click the properties of the specific printer. Oh well, go figure. Anyhow, thanks again! :p

Themotorman
May 24th, 2009, 05:18 AM
SOLVED!

On the client machine make sure you have Server>Configure>Basic Server Settings set to "Show printers shared by other systems"

I have an Epson 62 attached to a winXP machine this winxp is connected to a router.
I can access winxp files ok from my obuntu OS machine and could connect and print before the latest upgrade of ubuntu 9.04. Now I cant. I do not find any obvious way to connect or even find the printer from my ubuntu OS computer . The printer selection GUI does not show Samba and cannot find the printer.
This post suggests server settings but how do you do change server settings? I cannot find this in the system admin.
list.
When I had the previous release of Ubuntu setting up a winxp connected network printer was intuitive and very simple... what has changed or am I just more senile ...
Thanks for amy suggestions

dunbrokin
May 24th, 2009, 05:40 AM
Try System > Administration > Printing

That is where all the information is.

Themotorman
May 24th, 2009, 07:54 PM
Try System > Administration > Printing

That is where all the information is.

Yes but with Ubunutu9.04 ( latest rev. ) the admin>printing> doesnot give a way to look at the server. When i enter //192.168.1.103/epson it comes back printer not found..I have checked out the ip and also tried smb://192.168.1.103/epson with and without the "epson"; still not found..
This is very frustrating and I do not have any good ideas of where to go from here. If I do a CUPS by using http://localhost:631 I can find the printer but when I try to print to it nothing happens. The best i get is that it goes to 10% ( that's what is reported ) but nothing happens.
Help please.. my printer is a long way from my work area and I do not need so much exercise. I have been sending the printing via email to the machine connected to the printer and printing from it.. but it worked fine on 8.4 so something has changed.
BTW The winxp host/server has been set up for printer sharing and that's all it's used for !
Thanks for help.

dunbrokin
May 24th, 2009, 10:12 PM
Sorry, but you are outside my scant knowledge now.

FWIW my url shows up as ipp://10.1.1.5:631/printers/OfficeJet-6100-Series