PDA

View Full Version : [ubuntu] Just got Ati HD2900xt drivers 9.4 and Xinerama working



eidoslinux
May 7th, 2009, 07:22 PM
I just got Ati drivers and Xinerama working perfect. i know i and alot of other have had problems with this on 9.04 so i am going to tell you how i did it hopefully it will help.

start from the beging remove all signs of the Ati driver, and delete all directorys and files with in them.

now go to the Ati site and download and install the drivers manually. use there install instructions. go all the way down tell it says you are done.

next step go to System > Prefer > Display and uncheck mirror screens.

then you are going to have to disable RandR 1.2

Edit /etc/ati/amdpcsdb
In the section labeled [AMDPCSROOT/SYSTEM/DDX]
add this:


EnableRandR12=Sfalse

Also, in /etc/X11/xorg.conf in the "Device" section add:


Option "EnableRandR12" "false"

restart X and now it is time to configure your xorg.conf file the rest of the way. Here is what mine looks like. * note for a min turn Xinerama "off" untill you restart x after this step



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
Screen "aticonfig-Screen[1]-0" RightOf "aticonfig-Screen[0]-0"
Option "Clone" "off"
Option "Xinerama" "on"
Option "AIGLX" "on"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "freetype"
Load "extmod"
Load "glx"
Load "dri"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "EnableRandR12" "false"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "on"
Option "UseFastTLS" "2"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[1]-0"
Driver "fglrx"
Option "EnableRandR12" "false"
Option "UseFastTLS" "2"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]-0"
Device "aticonfig-Device[1]-0"
Monitor "aticonfig-Monitor[1]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768"
EndSubSection
EndSection

Section "DRI"
Group "Video"
Mode 0666
EndSection

Section "Extensions"
Option "RENDER" "Enable"
Option "DAMAGE" "Enable"
Option "Composite" "Enable"
EndSection
now after you restart X again go to your Amdcccle config screen and enable big desktop, when that is done you can go back to your xorg.conf file and turn Xinerama "on". and that should be it.

Let me know if this helps anyone or if anyone needs alittle more info

Slaughtyaardvark
May 8th, 2009, 03:10 PM
eidos: You are my god. For the first time since the Jaunty upgrade, I have a working fglrx.

My symptoms before using this fix were: when using fglrx, when I loaded into X the secondary screen would flicker repeatedly, and X would be extremely slow and unresponsive. Also, trying to load up the display applet would produce a display-applet-sized grey box that would then freeze X.

Now, all is working perfectly, as it was with Intrepid.

Thanks again,
Ryder

sepius
May 15th, 2009, 11:26 PM
I have a Asus ATI 2400pro, and your config makes it look so beautiful. Thankyou for this, you have made another person very happy.

majeric
May 16th, 2009, 09:45 PM
Thank you for great post. It help me a lot.
Now I have one more question. What is your FPS with glxgears. I have only about 100 FPS. I think this is to small.
I have used exactly the same xorg.conf than eidoslinux has posted.

My laptop:
Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
Radeon HD 2600
with kubuntu 9.04.

Any suggestions?
thanks

HavocXphere
May 16th, 2009, 09:49 PM
Thanks for posting. Gonna borrow some of your xorg...maybe it'll fix some of my ati issues.

EDIT: I don't think you can have "VideoOverlay" and "OpenGLOverlay" on at the same time. I'm pretty sure they are mutually exclusive.

eidoslinux
May 17th, 2009, 01:00 AM
ya that is way low what i am getting is.

[code]
chris@Alice-Ubuntu:~$ glxgears -fullscreen
Running synchronized to the vertical refresh. The framerate should be
approximately 1/4800851 the monitor refresh rate.
11818 frames in 5.0 seconds = 2363.417 FPS
11874 frames in 5.0 seconds = 2374.759 FPS
11875 frames in 5.0 seconds = 2374.820 FPS
11887 frames in 5.0 seconds = 2377.337 FPS
11873 frames in 5.0 seconds = 2374.545 FPS
11874 frames in 5.0 seconds = 2374.792 FPS
11874 frames in 5.0 seconds = 2374.717 FPS
11874 frames in 5.0 seconds = 2374.775 FPS
11874 frames in 5.0 seconds = 2374.784 FPS
11875 frames in 5.0 seconds = 2374.879 FPS
11875 frames in 5.0 seconds = 2374.823 FPS
11875 frames in 5.0 seconds = 2374.922 FPS
11875 frames in 5.0 seconds = 2374.833 FPS
11874 frames in 5.0 seconds = 2374.776 FPS
11875 frames in 5.0 seconds = 2374.998 FPS
11875 frames in 5.0 seconds = 2374.903 FPS
11878 frames in 5.0 seconds = 2375.424 FPS
11874 frames in 5.0 seconds = 2374.709 FPS
11874 frames in 5.0 seconds = 2374.688 FPS
11874 frames in 5.0 seconds = 2374.677 FPS
11875 frames in 5.0 seconds = 2374.808 FPS
11874 frames in 5.0 seconds = 2374.754 FPS
11874 frames in 5.0 seconds = 2374.741 FPS
11874 frames in 5.0 seconds = 2374.773 FPS
11875 frames in 5.0 seconds = 2374.812 FPS
11875 frames in 5.0 seconds = 2374.830 FPS
11875 frames in 5.0 seconds = 2374.888 FPS
11875 frames in 5.0 seconds = 2374.923 FPS
11874 frames in 5.0 seconds = 2374.713 FPS
11875 frames in 5.0 seconds = 2374.901 FPS
[\code]

but i would use a better benchmark programs then that, i use phoronix-test-suite
personally.

eidoslinux
May 17th, 2009, 01:04 AM
and as far as videooverlay and open gloverlay, x is not saying it is not working right. i was wondering about that too.

yabu
May 23rd, 2009, 08:53 AM
Many thanks for this I have been trying for ages to get the open set up working with dual monitor, one monitor displayed at 1280x1024 but the other one displayed at 1152x864, I had tried following ATI installation instructrions, then found your post with the instructions concearning EnableRandR12, now I can spread my multimedia apps out over the two screens. Thank you Thank you

kouchris
May 27th, 2009, 01:34 PM
hey eidoslinux, i just read your thread and providing i am a total noob i would like to ask a couple of questions before i begin cause every single time i tried to use xinerama it ended up with a re-instalation.. :S
i got a 64 bit version of ubuntu and i have tryied to use xinerama the problems i had are:

1. resolution on screens was different, i kinda made it to get it working on 1280x12024.will it work using a resolution of 1680x1050?
2.when i tried to turn on the effects i got an error saying that the composite extension is missing.

thanks a lot for the help!
this forum is very helpful.i would have gone back to windows without it..

edit: i did try this method.
when i unchecked the mirror screen option it was recomended to me by ubuntu to let fix it on its own.then i was instracted to log off and on ..
when i did that my login screen crashed.i had to re install ubuntu again.
any help?
here is an image of the message
http://g.imagehost.org/view/0288/Screenshot
if you select no then it says
your setting cannot be applied because the virtual resolution is too big to contain your screens.
i made it..i didnt turn off the mirror screen setting but i think it did turn off from the xorg.conf settings..
many thanks for the great help!!

kouchris
May 27th, 2009, 04:48 PM
http://g.imagehost.org/view/0288/Screenshot

eidoslinux
May 28th, 2009, 02:22 AM
ok.. first dont worry about turning on zinerama yet.. follow the list that i gave down to the detail. and even if x crashes if you miss a step you dont need to reinstall Ubuntu all you have to do is rebuild your x screen to do so, @ grub prompt you will see a selection of boot in ubuntu safe mode or something along those lines. once there you just have to return x to the orginal file and then start again.. just remember go in order of what i said and it will all be good. as far as when you turn off mirror in display and the message opens up just say yes. you will be editing everything anyway so it will not be there long. so no worry's.

Let me know if there is anymore info you need. If there is make sure you let me know which video card you have running and system specs. It makes it easyer. I will help with what ever i can so you will not have to see the Evil MS OS again.. lol

Atrixium
June 17th, 2009, 01:53 AM
eidoslinux, I think you may very well be my saviour! I've been searching for 3 days trying to find a solution to nearly this exact problem you've solved here!

My symptoms were the same lag and flicker as Slaughtyaardvark's except that I'm running a single 19" CRT. I'm currently at the office right now and can't test this but I plan to as soon as I get home!

For my system it seems that the relevant operation would be to just disable RandR12 since I've just got the one monitor and the driver I installed was the one chosen by EnvyNG and seems to work flawlessly otherwise. Do you think disabling RandR12 would be my solution and if so, what are the consequences for disabling it?


Here are my system specs, just in case:

AM2 Athlon64 X2 5200+ on an Asus M2N MX-SE Plus
ATI Radeon HD 4830
Linux Mint 7


Thanks!

eidoslinux
June 19th, 2009, 03:11 AM
when you disable Randr12 all you are doing is saying that you want your Ati Drivers to control the view and not The display program that comes with linux. really the Randr12 in my ideas is for the O.S. Drivers and not the Prop drivers. i have yet to find anyone that has had a problem with doing this. so you can try it.. the other thing is the flickering can also be caused from visual effects setting as well. but i would say disable RandR12 and let the drivers work like they should.

Atrixium
June 19th, 2009, 03:33 AM
Wow! That worked awesome! Just disabling randr1.2 solved all my problems and even allowed the catalyst control panel to work! My system is running great now, thanks!

eidoslinux
June 20th, 2009, 02:13 AM
well good to hear that. like i say if anyone needs help i will do my part. i dont get to code much anymore so i help with what i can. Long LIVE Linux, Long Live My Distro UBUNTU.

Failbot
July 15th, 2009, 08:17 AM
Thanks!

Now I can have ProjectM running on the telly and control the music from the other monitor... :D