View Full Version : [kubuntu] updates broken

May 7th, 2009, 03:17 PM
Hi Folks,

I installed 9.04 when prompted by updater, and while it has taken me a few weeks to get used to it I am still not sure that I like it.

My problem is that each time that I try to apply updates/fixes I get this error message,
Software Updates - KDE Control Module.
"An Internal system error has occurred"
"A problem that we were not expecting has occurred.
Please report this bug with the error description."

"The backend took too much time to process the synchronous request - you need to fork!"

I do not know if any updates are being applied or not, the "Updates Available" icon in the panel goes away when the error message is closed.
when I click on "Refresh" all that appears is "1 Blocked Update"
do I assume that updates are being applied?

Any ideas welcome.

Thanks in advance


May 7th, 2009, 03:46 PM
"apt-get autoremove" should do the trick I guess

May 7th, 2009, 08:08 PM
Tried that, and
apt-get upgrade,
apt-get --fix-missing install,
dpkg --configure -a
,apt-get -f install,
apt-get update.
not strictly in that order, but all done, and what is a "Fork"

May 13th, 2009, 04:52 PM
Anyone else with this problem? My upgraded (from Intrepid) is doing the same thing and my husband's newly (yesterday) installed system is doing it.

I would also like to know what a "fork" is (other than the obvious). Is this a message we should be sending to someone on the bugfix team?

May 13th, 2009, 09:11 PM
Pardon me for butting in But I am also having update issues. Might this be for upgrades. Because mine is of different..then some of yous.

May 13th, 2009, 09:21 PM
This is a known bug. Please take a look at this (https://bugs.launchpad.net/ubuntu/+source/packagekit/+bug/272410) and add any additional comments as required.

June 11th, 2009, 03:58 AM
this is how to get blocked updates:

from the terminal type.

sudo apt-get dist-upgrade

then your password.

I read somewhere on these (or kubuntuforums.org) that the reason you get these is they require the removal of other packages.

That might be wrong and or misquoted as it was a while ago but it's never led to problems for me.