View Full Version : [ubuntu] Error 16 when booting

May 6th, 2009, 08:53 PM
Hello All,

On a 80GB SATA laptop HDD, I installed Windows first and then installed Ubuntu 9.04. Everything was ok and I could dual boot. Then my company installed Safeguard Easy (whole disk encryption software) and now at the boot screen when I pick ubuntu I get the following error:

"error 16: inconsistent file system structure"

I used a Live CD and did a file system check:

sudo e2fsck -C0 -p -f -v /dev/hda2

my fdisk -l output is:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x29bcd914

Device Boot Start End Blocks Id System
/dev/sda1 * 2 6375 51199155 7 HPFS/NTFS
/dev/sda2 6376 9729 26941005 5 Extended
/dev/sda5 6376 9486 24989076 83 Linux
/dev/sda6 9487 9729 1951866 82 Linux swap

and my menu.lst looks like this:

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

default 4
timeout 10
# savedefault=false

## ## End Default Options ##

title Ubuntu 9.04, kernel 2.6.28-11-generic
uuid 230eb8b2-2b4b-403e-b4b1-b71825846fa7
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=230eb8b2-2b4b-403e-b4b1-b71825846fa7 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic

title Ubuntu 9.04, kernel 2.6.28-11-generic (recovery mode)
uuid 230eb8b2-2b4b-403e-b4b1-b71825846fa7
kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=230eb8b2-2b4b-403e-b4b1-b71825846fa7 ro single
initrd /boot/initrd.img-2.6.28-11-generic

title Ubuntu 9.04, memtest86+
uuid 230eb8b2-2b4b-403e-b4b1-b71825846fa7
kernel /boot/memtest86+.bin


# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
rootnoverify (hd0,0)
chainloader +1

I do not want to reinstall GRUB in a way that modifies the MBR because of the disk encryption - since that renders the Windows boot inoperable (learnt it the hard way from a previous install). I know that the ext3 partitions are not encrypted because I can mount them when using the live CD.

Any idea on how I solve the "Error 16" problem?

Thanks in advance.

July 26th, 2009, 09:57 AM
Same problem here. No ideas yet??

I already tried the following:

Installed grub on a memory stick, and booted the installed system (Jaunty).



Replaced defaultly used UUID's with 'real' names.

Not working.

Booted from HD, and entered the Grub console. I can set root (hd0,6 in my case)
and kernel (boot/vmlinuz-2.6.28-13-generic), but if I type

initrd /boot/initrd.img-2.6.28-13-generic

(Jaunty) I get

Error 16: Inconsistent filesystem structure

Not working.

Recreated initrd (mkinitramfs with and without -r option)

Not working.

Before Safeguard everything was ok. I'm thankful for any ideas!

July 27th, 2009, 10:46 PM

Sorry to hear that you also are having troubles. I was never able to find any solutions to that and the laptop still does not boot into Ubuntu.

Same thing here: before Safeguard, everything was OK.


July 28th, 2009, 09:55 PM
Sleeplessness and luck saved the day: What's disturbing is that setting the initrd causes the error in grub shell ("initrd /boot/initrd.img-2.6.28-13-generic" directly caused the Error 16). So the idea came up to boot simply without initrd. And that's the lucky part: It works!! I don't really understand the cause for the initrd problem, but the kernel is loaded and the system comes up. Obviously my notebook is "standard" enough and no "essential" driver is needed from initrd. The only thing missing is the framebuffer driver, but that's no problem since it's only needed for text consoles.

The menu.lst entry for Ubuntu now is the following:

title Ubuntu 9.04 (no initrd)
kernel /boot/vmlinuz-2.6.28-13-generic root=/dev/sda7 ro
The original "splash" option is useless without framebuffer device, and if looking at boot messages, then all (not "quiet") ;)

pulseplanet, I hope you have luck with that as well!

July 28th, 2009, 10:18 PM
mtuu, I'm glad you figured out how to restore your boot setup, and thank you for sharing this interesting information.

Edit: Oops, I didn't see you have already tried mkinitramfs...

Would you be willing to do an experiment?

If you run

sudo cp /boot/initrd.image-2.6.28-13-generic /boot/initrd.image-2.6.28-13-generic.bak
sudo update-initramfs -u

the machine should generate a new initrd for you:

update-initramfs: Generating /boot/initrd.img-2.6.28-13-generic

Then see if you can boot with the regenerated initrd:

gksu gedit /boot/grub/menu.lst

Add another boot stanza:

title Ubuntu 9.04 (with new initrd)
kernel /boot/vmlinuz-2.6.28-13-generic root=/dev/sda7 ro
initrd /initrd.img-2.6.28-13-generic

July 28th, 2009, 10:38 PM
Many thanks. I can confirm that removing the initrd line works.

Making a new initrd and booting with it as you suggest does not work for me. Same error: "Error 16: Inconsistent filesystem Structure"

July 29th, 2009, 12:10 AM
Ok, pulseplanet. Thanks for trying the experiment. :)