View Full Version : [ubuntu] GeForce Go 7400 driver (Jaunty)

May 6th, 2009, 08:44 PM
OK, so I know that it has to have been asked 10000000 times by now, but can someone point me in the right direction to get my video chip cooperating with X.org 7 that came with jaunty so that I can enable compiz and AWN, etc.?

The last version of Ubuntu I tried was 8.04, and the restricted hardware dialog made it work easy peasy, but its not in that dialog for 9.04. There are several packages installed when I search synaptic for "nvidia", but none of then seem to do the trick, I get 60-ish FPS in glxgears.

I'm not opposed to using the nvidia drivers, I just want 3D accel.

May 7th, 2009, 04:38 AM
Sorry for the bump, but can someone at least limnk me to a tutorial or howto?

May 7th, 2009, 04:39 PM
If I just download and install the closed-source drivers from nVidia's website, will that help?

May 7th, 2009, 04:43 PM
Hi nexus, take a look here:

Substitute this link for the 32-bit driver:

May 7th, 2009, 04:49 PM
Ah, thanks, exactly what I was looking for. I'll let you know how it goes.

May 7th, 2009, 05:58 PM
Excellent, thanks, its working now. I still have to figure out how to disable vertical refresh, but I'm getting 3D accel, and everything is cool.

May 7th, 2009, 06:34 PM
Have you tried looking at nvidia-settings?

May 7th, 2009, 08:30 PM
Yes, but I don't see one called vsync. I found a few "VBlank"s, and unclicked them...

I'm not this big of a moron, I promise :)

May 7th, 2009, 10:58 PM
Hello again, nexus. You were onto something with VBlank.

Please see the following: http://us.download.nvidia.com/XFree86/Linux-x86/180.51/README/chapter-11.html

May 8th, 2009, 02:12 AM
Thanks for the link and all the help. I do have one other quick question though. Ctrl+alt+backspace doesn't seem to want to cycle the X server like it used to. I'm guessing there is a line I need to uncomment somewhere or a value to change from 0 to 1 or something?

May 8th, 2009, 02:34 AM
I can't remember where I read it, but I seem to remember that it was disabled in Jaunty. But it can be turned back on. Sorry my memory is so bad so you will have to Google for it.

May 8th, 2009, 04:58 AM

You can install a nice little helper app to re-enable Ctrl-Alt-Bksp.

sudo apt-get install dontzap
dontzap -d

Restart X server (log off and log on), and it'll be back.

May 8th, 2009, 03:57 PM
Ah, nice. I googled it, installed don't zap, turned the reboot ability on, and tried it. Haven't rebooted until just now, and it works. Thanks guys. My Jaunty install is pretty much 100% done, and works great. It feels a lot snappier and I like what I've seen so far a lot. We've come a long way since Dapper Drake, huh?

May 8th, 2009, 08:41 PM

I'm glad everything worked out, for you... and now, if you run into others with the same problem, you can help them with your own experience! :)