PDA

View Full Version : [ubuntu] 9.04 on laptop with video issues



hawkeye0203
May 6th, 2009, 01:25 PM
I've been reading a lot on this subject and it seems that others with ATI graphics cards (and even a few with Intel) are having the problem with lock-ups and scrambled lines on the login screen. Here's my situation if anyone might have some foresight:

Laptop:

Toshiba Satellite A215
AMD Athlon X2 1.8GHz
4GB RAM
ATI Radeon X1200
Dual Boot with Vista


Timeline:

Fresh install everything great!
Looked in restricted drivers to install ATI drivers, but not there
installed ATI drivers (9.3) from ATI site. Quit due to some sort of incompatibility.
Restarted and got the scrambled login screen and lock ups
Did a TON of research and found the following commands:


sudo apt-get autoremove --purge fglrx-kernel-source

sudo apt-get autoremove --purge xorg-driver-fglrx

Got into Recovery mode and went to command line then ran commands, rebooted. EVERYTHING GREAT!
Installed ATI 9.4 because I found that it worked for some.
Restarted and everything was great! That was last night.
Restarted this morning and got scrambled screen again!
Recovery mode -> command line -> ran above commands, but this time it says they're not installed! Not sure what to do now!


I originally wanted to install the drivers because my computer was doing a few funny things: couldn't run some screensavers (trivial, but noticed it); Mouse cursor was glitching like it had "scan lines" running through it; overall screen picture would flicker and "jump" with lines through it then they would disappear.

Also I've noticed that it is slower overall than previous versions I've used... Is this common?

OK, so I think I got it all out. Any ideas?

Update: Tried doing the following:


aticonfig --initial



aticonfig --initial -f

Both returned something like "No supported devices found"

Also:


sudo sh /usr/share/fglrx/uninstall.sh

But the directory "fglrx" doesn't even exist... ?

The for giggles tried this:


sudo apt-get install xserver-xorg-video-radeon

But it told me it was already the latest version....

inspired
May 6th, 2009, 02:30 PM
I went through a very similar process... Same result. Although I didn't try installing 9.4 as I had read on the ATI site it had no support for my older ATI chip (Mobility Radeon 9200 on a compaq nx7010 laptop).

My graphics performance actually improved after I installed the 9.3 drivers and then removed them. No idea why.

I have not tested whether playing video is now possible. It was not possible after my upgrade to 9.04.

In my opinion the team behind Ubuntu cocked up big time with regards to this release, and not informing people that older ATI users would screw up their system if they upgraded.

Jonathan

hawkeye0203
May 7th, 2009, 01:41 AM
Fixed it! Wow is it running great now!! I still get a *few* screen glitches now and then, but everyhting is running faster and looking more beautiful!

This is what I did:
https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver#Problem:%20%20Need% 20to%20fully%20remove%20-fglrx%20and%20reinstall%20-ati%20from%20scratch