View Full Version : [ubuntu] Can't expand partition?

May 5th, 2009, 06:25 PM
I have a FOG imaging server set up. I had it set up on an 80gb drive but I quickly filled it with a series of 2-5gb images that I use for all of the computers at work. I got a hold of a 160gb drive and copied it to the 80. The problem is now, I have 80gb of space left over. I want to grow my main ext3 partition to utilize the 80gb of left over space yet - I can't.

I'm booted up to an Ubuntu 9.04 LiveCD right now and I'm looking at GParted from within that LiveCD. I cannot grow the partition whatsoever to suck up the remaining 80gb...

How on earth am I doing anything wrong?

May 5th, 2009, 06:55 PM
Is the 80 gb partition unmounted? Is the remaining space unallocated?

May 5th, 2009, 07:11 PM
Yes, everything is unmounted. I've tried using GParted LiveCD along with the Ubuntu LiveCD.

The additional space is unallocated. I've also tried to format it as ext2, ext3, and I also created a blank partition with no file system on it. Every option didn't work.

I have a feeling it's because of the fact it's an extended partition.

I have a 2nd drive in the computer with the images backed up on, so I'm just going to format it since all I use this computer for is to image computers. It's simple enough to re-format it in this particular instance.

Still peeves me though...

May 5th, 2009, 07:24 PM
One thought. As I understand, an extended partition is only a container for one or more logical partitions. Are trying to expand a logical partition? If so, maybe you need to expand the container (extended) partition first.