PDA

View Full Version : [ubuntu] External Hard Drive input/output error



wuchun05161990
May 5th, 2009, 04:04 PM
Hello, I have Ubuntu 9.04 installed using Wubi under Vista. I have an external hard drive that worked fine. However, today I copied some files from my work desktop (windows XP) to the hard drive, and after that I have the following problems with the external hard drive:

1. Whenever I try to copy anything to /media/name_of_external_hard_drive, the prompt says input/output error.
2. The same thing happens when I want to delete any files under /media/name_of_external_hard_drive.
3. However, when I tried to remove /change a file in a directory under the hard drive, like /media/name_of_hard_dirve/a_dir, there was no problem.
4. If I run vista and try to open the hard drive, the prompt says it's corrupted and non readable. So I can't even open the drive under Vista. I did a chkdisk under vista but that didn't work.

Note the files I copied from work are in the /media/name_of_hard_dirve. They should be large files, but I checked the properties of two of them, the size appears to be zero. I guess they are corrupted.

So what should I do? I can copy all the files from this drive to somewhere to backup since I can still access them under Ubuntu, but they are like 300 GB altogether. Is there anything I can do before I need to format the drive?

Any help is appreciated!

Penguin-Guru
September 10th, 2009, 11:24 PM
Same problem, it's a problem.