View Full Version : [ubuntu] USB storage device issue

May 5th, 2009, 03:51 PM
After upgrading from Intrepid to Jaunty, my USB memory sticks still work just fine. However, my phone no longer works as a USB device. My phone acts as a microSD card reader. It connects to the computer as a "mass storage device". Intrepid recognized it just like any other USB storage device I might plug in. Jaunty doesn't. What changed?

Same issue on home and work computers, both recently upgraded from Intrepid to Jaunty.

When I tell the phone to "disconnect" as "mass storage", the computer immediately recognizes the phone as a cellular modem (not a feature I use, but this worked before, and still works).

Any other common issues with SD card readers or similar devices since the upgrade?

May 6th, 2009, 12:38 PM
try to load the usb-storage module:

sudo modprobe usb-storage

and then plug your card.

if it works, you may want to add usb-storage to the file /etc/modules.

May 6th, 2009, 03:03 PM
I tried this with no luck. Other USB sticks still work, but still not the microSD-reading phone.