PDA

View Full Version : HowTo: Encode Video for iPod Video



Pages : 1 2 [3]

Metallinut
June 2nd, 2007, 12:21 AM
I used essentially the same script you have in the intro, but this is what I used:



ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_file_name}.mov"

endersshadow
June 2nd, 2007, 04:12 AM
Change that line to this:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1000k -b 700k -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_file_name}.mov"

Those k's should make all the difference.

bennyj
June 2nd, 2007, 05:35 AM
I have a question.I noticed that in the tutorial posted that it says you can convert from .vob file straight from dvd::rip.When I rip the dvd with dvd::rip it breaks the dvd up into multilple files each about 1gb in size.How would i go about ripping it into one big file and then converting it?Or could the ipodvidenc do them all at the same time and put them together into one big file?If so how would I go about this using the ipodvidenc?

thanks

endersshadow
June 2nd, 2007, 06:59 AM
I have a question.I noticed that in the tutorial posted that it says you can convert from .vob file straight from dvd::rip.When I rip the dvd with dvd::rip it breaks the dvd up into multilple files each about 1gb in size.How would i go about ripping it into one big file and then converting it?Or could the ipodvidenc do them all at the same time and put them together into one big file?If so how would I go about this using the ipodvidenc?

thanks

To the best of my knowledge, dvd::rip will always split those. My suggestion is to use vobcopy (available via apt-get), and use this command:


vobcopy -l -n # -o /path/to/output/directory/

Here, the -l tells it to rip to 1 large file. The # is the title number.

Sorry :-|

bennyj
June 2nd, 2007, 02:36 PM
To the best of my knowledge, dvd::rip will always split those. My suggestion is to use vobcopy (available via apt-get), and use this command:


vobcopy -l -n # -o /path/to/output/directory/

Here, the -l tells it to rip to 1 large file. The # is the title number.

Sorry :-|

Thanks endershadow you have been a great help!

endersshadow
June 2nd, 2007, 03:25 PM
Thanks endershadow you have been a great help!

Glad you got it working. I do what I can...happy encoding :-D

bennyj
June 3rd, 2007, 07:24 PM
This might be a bone head question but im a little confused. I have been using the ipodvidenc script with vobcopy and following this turorial and everything works fine.I can rip,encode and then upload to my ipod no problem.So I thought I would give the GUI version a try.Did the configure thing,make and make install.loaded the preference.Everything comes up as it should.

Now my question.Am I supposed to be able to rip from the dvd to vob using Vive gui?And then encode to ipod formatt all with the one click of the encode button?Or do I still need to rip to vob seperately using vobcopy and then encode using vive?

thanks

FXFman1209
June 3rd, 2007, 11:17 PM
Alright. I've followed the instructions exactly and there were no problems. So, to try this for the first time, I start up Vive. I select my File to be a 40-minute episode of Psyche (avi), and set the output to "/home/fxfitz/test" (should there be an extension??) I set the preset to iPod/PSP Video and click encode, and then Vive just exits. I've never done anything like this before and it would be much appreciated if you could lend a hand and let me know what I'm doing wrong. Thanks!!

endersshadow
June 4th, 2007, 03:14 AM
This might be a bone head question but im a little confused. I have been using the ipodvidenc script with vobcopy and following this turorial and everything works fine.I can rip,encode and then upload to my ipod no problem.So I thought I would give the GUI version a try.Did the configure thing,make and make install.loaded the preference.Everything comes up as it should.

Now my question.Am I supposed to be able to rip from the dvd to vob using Vive gui?And then encode to ipod formatt all with the one click of the encode button?Or do I still need to rip to vob seperately using vobcopy and then encode using vive?

thanks

It does it all for you. You can choose to keep the VOB but otherwise it will delete it for you.


Alright. I've followed the instructions exactly and there were no problems. So, to try this for the first time, I start up Vive. I select my File to be a 40-minute episode of Psyche (avi), and set the output to "/home/fxfitz/test" (should there be an extension??) I set the preset to iPod/PSP Video and click encode, and then Vive just exits. I've never done anything like this before and it would be much appreciated if you could lend a hand and let me know what I'm doing wrong. Thanks!!

Yes, there should be an extension. This was an issue with the Beta, but I believe it was fixed in the SVN version...I'll give it a whirl, though :)

bennyj
June 4th, 2007, 03:45 AM
The reason i asked is becuase i keep getting"segmetation fault(core dumped). I used the presets under preference and made sure that every drop down box has a value and output points to my home directory but no luck.Any suggestions.I wish I could provide you with more but thats all the error code i get in the console.
Thanks

endersshadow
June 4th, 2007, 03:49 AM
The reason i asked is becuase i keep getting"segmetation fault(core dumped). I used the presets under preference and made sure that every drop down box has a value and output points to my home directory but no luck.Any suggestions.I wish I could provide you with more but thats all the error code i get in the console.
Thanks

Oh that lovely error.

Which version are you using, 2.0.0-beta1 or the SVN? Also, what was the path to the input and output files?

Thanks!

bennyj
June 4th, 2007, 03:59 AM
Oh that lovely error.

Which version are you using, 2.0.0-beta1 or the SVN? Also, what was the path to the input and output files?

Thanks!

version 2.0.0-beta1 input path- /dev/hdd - output path = /home/benny/ipod movies

endersshadow
June 4th, 2007, 04:06 AM
version 2.0.0-beta1 input path- /dev/hdd - output path = /home/benny/ipod movies

The beta doesn't have full directory support. Also, /dev/hdd isn't a directory, per se. Make the input and outputs specific movie files. You'll need extensions, as well (ffmpeg won't encode without extensions).

bennyj
June 4th, 2007, 04:07 AM
would this help?
benny@benny-desktop:~$ whereis vobcopy
vobcopy: /usr/bin/vobcopy /usr/X11R6/bin/vobcopy /usr/bin/X11/vobcopy /usr/share/man/man1/vobcopy.1.gz
benny@benny-desktop:~$ whereis vive
vive: /usr/local/bin/vive
benny@benny-desktop:~$


just wondering if vive can reach vobcopy?

endersshadow
June 4th, 2007, 04:12 AM
would this help?
benny@benny-desktop:~$ whereis vobcopy
vobcopy: /usr/bin/vobcopy /usr/X11R6/bin/vobcopy /usr/bin/X11/vobcopy /usr/share/man/man1/vobcopy.1.gz
benny@benny-desktop:~$ whereis vive
vive: /usr/local/bin/vive
benny@benny-desktop:~$


just wondering if vive can reach vobcopy?

Shouldn't have a problem :)

FXFman1209
June 4th, 2007, 06:02 AM
Hang on, I'm also having the Segmentation Fault error... whats the problem? I'm sorry. :(

endersshadow
June 4th, 2007, 11:43 AM
Hang on, I'm also having the Segmentation Fault error... whats the problem? I'm sorry. :(

If you're using the beta version, you need to make sure all drop down boxes are selected and that the input and outputs are file names, not directories.

bennyj
June 4th, 2007, 12:53 PM
Well finaly got it to work.My problem was that i was hittihg the load button after inserting the dvd and it would drop down a box with numbered tiles and in parantheses(sp?) next to it-it would have the duration of the movie.I would select that thinking that was all i had to do.But for some reason vive does'nt like that.If i seleceted the button below that and browse for the title directly of the dvd and just put mymovie.mp4 in the output then all went well.

thanks for the help

ps.also i noticed that when i went to upload the movei to my 30 gig 5th gen ipod it would tell me(through windows.I would transfer the movie to my laptop into itunes)that the bit rate of my ipod did not support the current bit rate of the movie.So I changed to ipodvidenc from 192 audio bit rate to 128 and all went well.

FXFman1209
June 4th, 2007, 03:06 PM
Alright, it looks like I was missing one drop down box. Now I'm getting this error...

fxfitz@lappyman:~$ ffmpeg -i "/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi" -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -bufsize 4096 -pass 1 -aspect 4:3 -s 320x240 -acodec mp3 -ab 192 -ar 44100 -title "Psych" -author "Psych" -copyright "2007" -comment "Encoded by Vive" "/home/fxfitz/name" ; exit
FFmpeg version SVN-r9192, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-x264 --enable-xvid --enable-shared --disable-debug
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on Jun 3 2007 18:04:19, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)

Seems stream 0 codec frame rate differs from container frame rate: 23.98 (65535/2733) -> 23.98 (23976024/1000000)
Input #0, avi, from '/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi':
Duration: 00:42:30.0, start: 0.000000, bitrate: 1147 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 512x384, 23.98 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 128 kb/s
Output #0, mp4, to '/home/fxfitz/name':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=2-31, pass 1, 0 kb/s, 23.98 fps(c)
Stream #0.1: Audio: mp3, 44100 Hz, stereo, 0 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0xb7e1c188]removing common factors from framerate
[mpeg4 @ 0xb7e1c188]timebase not supported by mpeg 4 standard
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height
exit


What audio codec should I use? And what should the new file's extension be??

Thanks

Metallinut
June 4th, 2007, 03:59 PM
Change that line to this:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1000k -b 700k -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_file_name}.mov"

Those k's should make all the difference.

Made that change, now when trying to convert I get the following:

FFmpeg version SVN-r9165, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enab
le-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --en
able-lipmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-x
264 --enable-xvid --enable-shared --disable-debug
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on May 31 2007 17:48:46, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)

Seems stream 0 codec frame rate differs from container frame rate: 29.98 (65535/
2186) -> 29.97 (2997/100)
Input #0, avi, from 'GI Joe The MASS Device.avi':
Duration: 01:37:45.5, start 0.000000, bitrate: 1285 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 528x400, 29.97 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 192 kb/s
Output #0, mp4 to '/home/jp/converted/GI Joe The Mass Device.mov':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=3-5, 700 kb/s, 29.97 fps(c)
Stream #0.1: Audio: aac, 48000 Hz, stereo, 0 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0xb7d6a488]VBV buffer too small for bitrate
Error while opening codec for output stream #0.0 - maybe incorrect parameters su
ch as bit_rate, rate, width or height


Grr...

endersshadow
June 5th, 2007, 02:13 AM
FXFMan: Make bitrate and maxrate both 0.

Metallinut: Take out the -bufsize 4096 argument.

FXFman1209
June 5th, 2007, 02:31 AM
Nope:(

fxfitz@lappyman:~$ ffmpeg -i "/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi" -f mp4 -vcodec mpeg4 -bufsize 4096 -pass 1 -aspect 4:3 -s 320x240 -acodec ac3 -ab 192 -ar 44100 -comment "Encoded by Vive" "/home/fxfitz/test.mp4" ; exit
FFmpeg version SVN-r9192, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-x264 --enable-xvid --enable-shared --disable-debug
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on Jun 3 2007 18:04:19, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)

Seems stream 0 codec frame rate differs from container frame rate: 23.98 (65535/2733) -> 23.98 (23976024/1000000)
Input #0, avi, from '/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi':
Duration: 00:42:30.0, start: 0.000000, bitrate: 1147 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 512x384, 23.98 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 128 kb/s
Output #0, mp4, to '/home/fxfitz/test.mp4':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=2-31, pass 1, 200 kb/s, 23.98 fps(c)
Stream #0.1: Audio: ac3, 44100 Hz, stereo, 0 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0xb7e33188]VBV buffer too small for bitrate
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height

endersshadow
June 5th, 2007, 02:48 AM
Try switching Buffer Size to 0 and Audio Bitrate to 128.

FXFman1209
June 5th, 2007, 02:54 AM
Alright...

output: /home/fxfitz/test.mp4
preset: iPod/PSP Video
Keep raw VOB

VIDEO
Container Format: mp4
Video Codec: mpeg4
MaxBitrate: 1000
Bitrate 700
Buffer Size:0
Number of Passes: 1
(never changed the right column)

AUDIO
Audio Codec: ac3
Audio Bitrate: 128
Sampling Frequency: 44100

OUTPUT:

fxfitz@lappyman:~$ ffmpeg -i "/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi" -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -pass 1 -aspect 4:3 -s 320x240 -acodec ac3 -ab 128 -ar 44100 -comment "Encoded by Vive" "/home/fxfitz/test.mp4" ; exit
FFmpeg version SVN-r9192, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-x264 --enable-xvid --enable-shared --disable-debug
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on Jun 3 2007 18:04:19, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)

Seems stream 0 codec frame rate differs from container frame rate: 23.98 (65535/2733) -> 23.98 (23976024/1000000)
Input #0, avi, from '/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi':
Duration: 00:42:30.0, start: 0.000000, bitrate: 1147 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 512x384, 23.98 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 128 kb/s
File '/home/fxfitz/test.mp4' already exists. Overwrite ? [y/N] y
Output #0, mp4, to '/home/fxfitz/test.mp4':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=2-31, pass 1, 0 kb/s, 23.98 fps(c)
Stream #0.1: Audio: ac3, 44100 Hz, stereo, 0 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0xb7d6d188]a vbv buffer size is needed, for encoding with a maximum bitrate
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height
exit


Same thing. :(:(

endersshadow
June 5th, 2007, 02:59 AM
You didn't set maxrate and bitrate to 0, as well :)

Here's what the issue is: That version of Vive was made w/ the older ffmpeg which dealt with rates as kb/s. Now, it deals with them as b/s, so it is now giving you underflow errors.

FXFman1209
June 5th, 2007, 03:06 AM
Woops. I'm sorry, I set those to 0 on another test. Here is the output when ALL of them have been set to 0.

fxfitz@lappyman:~$ ffmpeg -i "/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi" -f mp4 -vcodec mpeg4 -pass 1 -aspect 4:3 -s 320x240 -acodec ac3 -ab 128 -ar 44100 -comment "Encoded by Vive" "/home/fxfitz/test.mp4" ; exit
FFmpeg version SVN-r9192, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-x264 --enable-xvid --enable-shared --disable-debug
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on Jun 3 2007 18:04:19, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)

Seems stream 0 codec frame rate differs from container frame rate: 23.98 (65535/2733) -> 23.98 (23976024/1000000)
Input #0, avi, from '/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi':
Duration: 00:42:30.0, start: 0.000000, bitrate: 1147 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 512x384, 23.98 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 128 kb/s
File '/home/fxfitz/test.mp4' already exists. Overwrite ? [y/N] y
Output #0, mp4, to '/home/fxfitz/test.mp4':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=2-31, pass 1, 200 kb/s, 23.98 fps(c)
Stream #0.1: Audio: ac3, 44100 Hz, stereo, 0 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0xb7dde188]removing common factors from framerate
[mpeg4 @ 0xb7dde188]timebase not supported by mpeg 4 standard
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height
exit

endersshadow
June 5th, 2007, 03:22 AM
Now that's and new one!

It appears that it's a bit of a problem w/ a yuv as an input. Cut and paste this command into your terminal:


ffmpeg -i "/home/fxfitz/multimedia/videos/psych/Psych.S01E15.DSR.XviD-ORENJi.avi" -f mp4 -vcodec mpeg4 -b 700k -aspect 4:3 -r 23.98 -s 320x240 -acodec aac -ar 48000 -comment "Encoded by Vive" "/home/fxfitz/test.mp4"

FXFman1209
June 5th, 2007, 03:26 AM
Unknown codec: aac. :(

endersshadow
June 5th, 2007, 03:28 AM
Unknown codec: aac. :(

My fault...habit made me type aac instead of ac3...sorry!

P.S.-This for an iPod? If so, use mp3, not ac3.

FXFman1209
June 5th, 2007, 03:31 AM
Awesome! It's encoding!

Alright, so, how would I get this to work all the time with Vive? Or do I have to command line it all the time?

PS. And what exactly was the problem?? yuv??

endersshadow
June 5th, 2007, 03:39 AM
Awesome! It's encoding!

Alright, so, how would I get this to work all the time with Vive? Or do I have to command line it all the time?

PS. And what exactly was the problem?? yuv??

The problem is the framerate of the original movie and the way yuv handles it. You have to explicitly set the framerate with ffmpeg for some reason, which isn't an option in Vive. My suggestion would be to use the command line, since it appears yuv, mpeg4, and ffmpeg do not play well together. That way, it's easier to change options.

FXFman1209
June 5th, 2007, 03:40 AM
Alright. Thanks a bunch!!

endersshadow
June 5th, 2007, 03:54 AM
It's what I'm here for :)

FXFman1209
June 5th, 2007, 05:47 AM
Alright. I have another question for you. So far I've got everything working fine from the command line, and I just ripped a DVD using dvdrip. I had to rip two titles, however, and it produces 3 .vob files per title. Is there anyway to combine all of these .vob files into one easy .mp4 file for the ipod??

endersshadow
June 5th, 2007, 12:44 PM
Alright. I have another question for you. So far I've got everything working fine from the command line, and I just ripped a DVD using dvdrip. I had to rip two titles, however, and it produces 3 .vob files per title. Is there anyway to combine all of these .vob files into one easy .mp4 file for the ipod??

If you use transcode, yes. I don't have the documentation in front of me nor do I know it off the top of my head, but I gotta run. If you look a few posts up, you use this command:


vobcopy -l -n # /path/to/output/dir/

Where # is the title number, it will rip one large file, which then you can run through Vive/ffmpeg. Although, Vive does have the DVD ripping functionality built in, as well.

Metallinut
June 7th, 2007, 04:41 PM
Metallinut: Take out the -bufsize 4096 argument.

Did that and now get this:


FFmpeg version SVN-r9165, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-x264 --enable-xvid --enable-shared --disable-debug
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on May 31 2007 17:48:46, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)

Seems stream 0 codec frame rate differs from container frame rate: 29.98 (65535/2186) -> 29.97 (2997/100)
Input #0, avi, from 'GI Joe The MASS Device.avi':
Duration: 01:37:45.5, start: 0.000000, bitrate: 1285 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 528x400, 29.97 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 192 kb/s
Output #0, mp4, to '/home/jp/converted/GI Joe - The MASS Device.mov':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=3-5, 700 kb/s, 29.97 fps(c)
Stream #0.1: Audio: aac, 48000 Hz, stereo, 0 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0xb7d67488]a vbv buffer size is needed, for encoding with a maximum bitrate
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height

endersshadow
June 7th, 2007, 07:47 PM
Try this:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -b 700k -qmin 3 -qmax 5 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_file_name}.mov"

Metallinut
June 8th, 2007, 02:34 PM
Try this:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -b 700k -qmin 3 -qmax 5 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_file_name}.mov"

Looks like it's running now...we'll see how it looks on my iPod.

Thanks!

penguinchrissy
June 20th, 2007, 12:06 AM
No matter what I do I get this output when trying to encode

ffmpeg: error while loading shared libraries: libavformat.so.50: cannot open shared object file: No such file or directory

I know I have the proper lib installed it the same version as ffmpeg.

Any fixes?

endersshadow
June 20th, 2007, 01:09 AM
Yup. It's a simple command, but to get it right I need the output from this command:


ls /usr/lib | grep libav

penguinchrissy
June 20th, 2007, 02:19 AM
here is the output for that command

libavahi-client.so.3
libavahi-client.so.3.2.2
libavahi-common.so.3
libavahi-common.so.3.4.3
libavahi-core.so.5
libavahi-core.so.5.0.0
libavahi-glib.so.1
libavahi-glib.so.1.0.1
libavahi-qt3.so.1
libavahi-qt3.so.1.0.1
libavc1394.so.0
libavc1394.so.0.3.0
libavcodec.so.0d
libavcodec.so.0d.51.11.0
libavformat.so.0d
libavformat.so.0d.50.5.0
libaviplay-0.7.so.0
libaviplay-0.7.so.0.0.44
libaviplayavcodec-0.7.so.0
libaviplayavcodec-0.7.so.0.0.44
libaviplayavformat-0.7.so.0
libaviplayavformat-0.7.so.0.0.44
libaviplayavutil-0.7.so.0
libaviplayavutil-0.7.so.0.0.44
libaviplaydha-0.7.so.0
libaviplaydha-0.7.so.0.0.44
libaviplayvidix-0.7.so.0
libaviplayvidix-0.7.so.0.0.44
libavutil.so.0d
libavutil.so.0d.49.0.0


Thanks for your help!!:p

endersshadow
June 20th, 2007, 04:21 AM
Sorry, the season finale of Deadliest Catch was on...and that takes pretty much any and all precedence in my life (it's a sad one, I know). Anyway, here's that command:


sudo ln -s /usr/lib/lbavformat.so.0d.50.5.0 /usr/lib/libavformat.so.50

That should do it. Cheers!

penguinchrissy
June 20th, 2007, 05:05 AM
That was a great last episode and After the catch was cool to. Again I thank you for you help but I tried what you said and this is what happened. I tired it a couple of times. Once then I closed the terminal and ran ipodvidence and the other ffmpeg code neither worked. I tired your code again then ran ipodvidence again then your code again to show you the results.

ipodvidenc The.Departed.avi
What would you like to name the output file (sans extension)?
test
test will be located in /home/dj. Is this acceptable? [y/n]
y
ffmpeg: error while loading shared libraries: libavformat.so.50: cannot open shared object file: No such file or directory
dj@dj-laptop:~$ sudo ln -s /usr/lib/lbavformat.so.0d.50.5.0 /usr/lib/libavformat.so.50
ln: creating symbolic link `/usr/lib/libavformat.so.50' to `/usr/lib/lbavformat.so.0d.50.5.0': File exists

endersshadow
June 20th, 2007, 11:28 AM
Well that's bizarre. I definitly put that in right. Try flip flopping the file names..

penguinchrissy
June 20th, 2007, 05:35 PM
This is an error I'm getting now

sudo ln -s /usr/lib/lbavformat.so.0d.50.5.0 /usr/lib/libavformat.so.50
ln: accessing `/usr/lib/libavformat.so.50': Too many levels of symbolic links

It worked last night!?

endersshadow
June 21st, 2007, 12:32 AM
This is an error I'm getting now

sudo ln -s /usr/lib/lbavformat.so.0d.50.5.0 /usr/lib/libavformat.so.50
ln: accessing `/usr/lib/libavformat.so.50': Too many levels of symbolic links

It worked last night!?

Well that's interesting, what's this put out:


ls -l | grep libavformat

penguinchrissy
June 22nd, 2007, 04:52 AM
nothing comes out

dj@dj-laptop:~$ ls -l | grep libavformat
dj@dj-laptop:~$

thats all that happens :(

endersshadow
June 22nd, 2007, 01:34 PM
sorry, ls -l /usr/lib | grep libavformat

My fault!

penguinchrissy
June 23rd, 2007, 06:36 PM
ls -l /usr/lib | grep libavformat
lrwxrwxrwx 1 root root 26 2007-06-20 12:29 lbavformat.so.0d.50.5.0 -> /usr/lib/libavformat.so.50
lrwxrwxrwx 1 root root 24 2007-06-19 18:48 libavformat.so.0d -> libavformat.so.0d.50.5.0
-rw-r--r-- 1 root root 543600 2007-03-21 10:14 libavformat.so.0d.50.5.0

endersshadow
June 24th, 2007, 03:49 PM
I'm an idiot. I mistyped the name!

Do this:


sudo rm /usr/lib/lbavformat.so.0d.50.5.0
sudo ln -s /usr/lib/libavformat.so.0d.50.5.0 /usr/lib/libavformat.so.50

That should work :)

penguinchrissy
June 25th, 2007, 03:38 AM
no go again

dj@dj-laptop:~$ sudo rm /usr/lib/lbavformat.so.0d.50.5.0
Password:
dj@dj-laptop:~$ sudo ln -s /usr/lib/libavformat.so.0d.50.5.0 /usr/lib/libavformat.so.50
dj@dj-laptop:~$ cd /home/dj/AzureusDownloads/The.Departed
bash: cd: /home/dj/AzureusDownloads/The.Departed: No such file or directory
dj@dj-laptop:~$ cd /home/dj/AzureusDownloads/Films/The.Departed
dj@dj-laptop:~/AzureusDownloads/Films/The.Departed$ ipodvidenc The.Departed.avi
What would you like to name the output file (sans extension)?
test
test will be located in /home/dj/AzureusDownloads/Films/The.Departed. Is this acceptable? [y/n]
y
ffmpeg: error while loading shared libraries: libavcodec.so.51: cannot open shared object file: No such file or directory
dj@dj-laptop:~/AzureusDownloads/Films/The.Departed$ sudo rm /usr/lib/lbavformat.so.0d.50.5.0
rm: cannot remove `/usr/lib/lbavformat.so.0d.50.5.0': No such file or directory
dj@dj-laptop:~/AzureusDownloads/Films/The.Departed$ sudo ln -s /usr/lib/libavformat.so.0d.50.5.0 /usr/lib/libavformat.so.50
ln: creating symbolic link `/usr/lib/libavformat.so.50' to `/usr/lib/libavformat.so.0d.50.5.0': File exists
dj@dj-laptop:~/AzureusDownloads/Films/The.Departed$ ipodvidenc The.Departed.aviWhat would you like to name the output file (sans extension)?
test
test will be located in /home/dj/AzureusDownloads/Films/The.Departed. Is this acceptable? [y/n]
y
ffmpeg: error while loading shared libraries: libavcodec.so.51: cannot open shared object file: No such file or directory
dj@dj-laptop:~/AzureusDownloads/Films/The.Departed$


:(

PinkBullets9
June 25th, 2007, 02:32 PM
umang@umang-desktop:~$ sudo apt-get install libdvdcss2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package libdvdcss2-dev

any ideas? am i missing something from the sources?

penguinchrissy
June 26th, 2007, 01:05 AM
you probaly don't have a repository that you need.

fanfan
June 27th, 2007, 08:30 AM
I was wondering if anyone could modify the ipodvidenc script to convert a folder of videos instead of a single file? I've got about 45 files that I want to convert... Anyways, help is greatly needed and appreciated.
-Brian

Metallinut
June 28th, 2007, 08:49 PM
This is the script I'm using:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -b 700k -qmin 3 -qmax 5 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "/home/jp/converted/${output_file_name}.mov"

However, when I move the file over to Windows (still using it for iTunes), iTunes and Quicktime both say the file is not a video....

Has anyone got this working, and can import their converted videos into iTunes, and play them on a video iPod?

Thanks

bennyj
June 28th, 2007, 10:29 PM
This is the script I'm using:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -b 700k -qmin 3 -qmax 5 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "/home/jp/converted/${output_file_name}.mov"

However, when I move the file over to Windows (still using it for iTunes), iTunes and Quicktime both say the file is not a video....

Has anyone got this working, and can import their converted videos into iTunes, and play them on a video iPod?

Thanks

You need to rename it from "movie.mov" to "movie.mp4" then import it into itunes and it will work fine! I just went into the script and changed {outputfile}.mov to {outputfile}.mp4. That way you dont have to mess with it after encoding.

endersshadow
July 3rd, 2007, 05:09 AM
Sorry folks! Was on vacation at the Jersey Shore. Twas rather nice.

Anyway, to your questions:

penguinchrissy: You may just be better off uninstalling ffmpeg, libavcodec, and libavformat and reinstalling them. It's rather odd that it's giving you all of that.

PinkBullets: You're going to want to add the Medibuntu (http://medibuntu.sos-sts.com/) repository to your sources.list file.

fanfan: Yes, yes it is possible by adding a for each loop. However, the latest SVN of Vive (https://sourceforge.net/projects/vive) has this feature.

lonegeek
July 8th, 2007, 07:49 PM
Unable to find a source package for ffmpeg


Is what I get when I type in apt-get source ffmpeg

FakeOutdoorsman
July 8th, 2007, 08:03 PM
Do you have Universe Packages and Source code enabled in your /etc/apt/sources.list file? You can do this graphically with System -> Administration -> Software Sources. Check "Community-maintained Open Source software (universe)" and "Source code". Then in a terminal type "sudo apt-get update" and finally retry "sudo apt-get source ffmpeg".

claypole
July 9th, 2007, 11:57 AM
This may be buried in the post somewhere, but I had to change enable-x264 and enable-xvid flags to enable-libx264 and enable-libxvid. This may be because the flags have changed on the latest ffmeg from svn, it would be great if this could be updated in the main text of the HOWTO for others. And thanks for a great HOWTO!! :KS

endersshadow
July 10th, 2007, 02:01 AM
This may be buried in the post somewhere, but I had to change enable-x264 and enable-xvid flags to enable-libx264 and enable-libxvid. This may be because the flags have changed on the latest ffmeg from svn, it would be great if this could be updated in the main text of the HOWTO for others. And thanks for a great HOWTO!! :KS

Changed, and thanks :)

vishnu
July 10th, 2007, 04:29 AM
Excellent but when I run I get this?

ffmpeg: error while loading shared libraries: libavformat.so.50: cannot open shared object file: No such file or directory

mortuk
July 11th, 2007, 09:57 AM
I get this error also, any ideas?

endersshadow
July 11th, 2007, 04:51 PM
For the libavformat.so.50 error: http://www.twelvestone.com/forum_thread/view/33460

endersshadow
July 12th, 2007, 06:09 AM
Vive 2.0.0-beta2 is now available! New features include multiple file and folder support, a simplified and streamlined interface, and a lot of behind the scenes stuff that makes me sleep better at night but you won't notice unless you look at the code. So download it today (https://sourceforge.net/project/showfiles.php?group_id=158461)!

eyemou
July 13th, 2007, 12:02 AM
Hello... I was wondering (pardon my ignorance, btw), how to uninstall ffmpeg. You see, I installed the newest SVN version, which has problems encoding with the aac codec it seems (I am getting the "unknown codec 'aac'" error upon encoding), and want to install an older version.

I had built this one from source, and figured that an apt-get remove ffmpeg would do the trick. It acted as if it removed something (I wish I hadn't of closed the terminal window, so I can recall exactly what happened), but apparently ffmpeg is still installed...

"FFmpeg version SVN-r9569, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-libogg --enable-liba52 --enable-dc1394 --enable-libgsm --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-libxvid --enable-libx264"

Also, does someone know which version is known to work with aac (which I do have installed, and did enable when compiling the SVN version r9569, but with no luck), and where to get it?

Does the 20060823 version work? Or is it the 200703[something] version? I think there was also a recent one, from earlier this month (July 2007).

Any hep appreciated. I've come so close to getting things to work, that I can't turn back now.

BTW, this thread, and the wiki post have been extremely helpful.

Thanks!!

eyemou
July 13th, 2007, 12:08 AM
Duh. Nevermind my question about the uninstall ("make uninstall"... I just had to manually clean out and then remove the /usr/local/vhook folder, as the uninstall attempted to remove it with files still included).

My question still stands about what is & where to obtain the proper ffmpeg version for Ipod video encoding (on Kubuntu Feisty 7.04, btw).

Thanks!

eyemou
July 13th, 2007, 04:34 AM
Aha!

svn checkout -r 8560 svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg

That version (r8560) + your instructions seems to work. I got nervous during the 'make', as a lot of warnings ("deprecated" this, "null pointer" that) were flying by, but it compiled, and works now.

Now to try ripping some dvds to mp4...

endersshadow
July 13th, 2007, 04:43 PM
Glad to hear you solved your problems before I could get here :-D

jmusso
July 14th, 2007, 09:06 AM
For the libavformat.so.50 error: http://www.twelvestone.com/forum_thread/view/33460

I checked this out and tried to do as the guide told me. I'm running into a problem wtih permission to edit this file. Its saying I don't have the permission to do it... I don't understand why. Help please? also, when I try to sudo apt-get libdvdcss2-dev it says something like e: libdvdcss2-dev does not exist. Thanks.

huzz
July 14th, 2007, 12:52 PM
huzz@iNFECTED:~/downloads/vive-2.0.0-beta2$ make
make all-recursive
make[1]: Entering directory `/home/huzz/downloads/vive-2.0.0-beta2'
Making all in src
make[2]: Entering directory `/home/huzz/downloads/vive-2.0.0-beta2/src'
gcc -g -O2 -D PREFIX=\"/usr/local\" -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -pthread -DORBIT2=1 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -o vive error.o interface.o options.o preferences.o presets.o combo_menus.o encode.o dvd.o tooltips.o vive.o -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lX11 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -pthread -lgnomevfs-2 -lgconf-2 -lgmodule-2.0 -ldl -lORBit-2 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0 -lvte
combo_menus.o: In function `populate_ffmpeg':
/home/huzz/downloads/vive-2.0.0-beta2/src/combo_menus.c:38: undefined reference to `av_register_all'
/home/huzz/downloads/vive-2.0.0-beta2/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/huzz/downloads/vive-2.0.0-beta2/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/huzz/downloads/vive-2.0.0-beta2/src/combo_menus.c:50: undefined reference to `first_avcodec'
/home/huzz/downloads/vive-2.0.0-beta2/src/combo_menus.c:94: undefined reference to `first_avcodec'
collect2: ld returned 1 exit status
make[2]: *** [vive] Error 1
make[2]: Leaving directory `/home/huzz/downloads/vive-2.0.0-beta2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/huzz/downloads/vive-2.0.0-beta2'
make: *** [all] Error 2
huzz@iNFECTED:~/downloads/vive-2.0.0-beta2$

Could someone please tell me where am i going wrong....

endersshadow
July 16th, 2007, 04:11 AM
jmusso: 1. Try using sudo in front of the command that's telling you that you don't have permission
2. What's your /etc/apt/sources.list look like?

huzz: You need to compile ffmpeg with the --enable-shared flag in order to install libavformat.

jmusso
July 16th, 2007, 06:31 AM
joe@joe:~$ /etc/apt/sources.list
bash: /etc/apt/sources.list: No such file or directory
joe@joe:~$ gedit /etc/apt/sources.list
joe@joe:~$
joe@joe:~$


that's what it said. i wasn't sure if i was supposed to do a gedit or not, so the first time i didn't, then when i ran "gedit /blah blah blah/" it came up with an empty script. does this help? thanks for the help!

jmusso
July 16th, 2007, 08:41 AM
When I tried to install Vive, this is what I got...

joe@joe:~$ pkg-config
Must specify package names on the command line
joe@joe:~$ cd /home/joe/vive-2.0.0-beta2
joe@joe:~/vive-2.0.0-beta2$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for ffmpeg... yes
checking for vobcopy... yes
checking for mplayer... yes
checking for prefix by checking for ffmpeg... /usr/local/bin/ffmpeg
checking whether DVD is enabled... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... yes (version 2.10.11)
checking pkg-config is at least version 0.9.0... yes
checking for libgnomevfs... configure: error: Package requirements (gnome-vfs-2.0 >= 2.0) were not met:

No package 'gnome-vfs-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libgnomevfs_CFLAGS
and libgnomevfs_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

joe@joe:~/vive-2.0.0-beta2$
joe@joe:~/vive-2.0.0-beta2$



help?

endersshadow
July 16th, 2007, 02:05 PM
Okay, do this:


sudo su
echo "deb http://medibuntu.sos-sts.com/repo/ feisty free non-free" >> /etc/apt/sources.list
exit
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libdvdcss2-dev libdvdread-dev libdvdnav-dev libgnomevfs2-dev

Then try the configure again.

Not necessary that you read this last part, but I thought I'd at least explain the commands:

The "sudo su" command gives you root access. You need this to edit /etc/apt/sources.list, which is the file that tells Ubuntu where to look for packages. The command "echo "deb http://medibuntu.sos-sts.com/repo/ feisty free non-free" >> /etc/apt/sources.list" simply appends that line to your sources.list file, so that Ubuntu knows to look in the Medibuntu repository. Next, you apt-get update which gets all of the information for the repositories cached on your system, and then you apt-get upgrade which installs any of the updated packages that Medibuntu has. Then, you install libdvdcss2-dev, libdvdread-dev, libdvdnav-dev, and libgnomevfs2-dev, all the development packages you'll need for Vive.

Have fun :)

jmusso
July 16th, 2007, 05:15 PM
joe@joe:~$ sudo su
root@joe:/home/joe# echo "deb http://medibuntu.sos-sts.com/repo/ feisty free non-free" >> /etc/apt/sources.list
root@joe:/home/joe# exit
exit
joe@joe:~$ sudo apt-get update
Get:1 http://archive.ubuntu.com feisty Release.gpg [191B]
Ign http://archive.ubuntu.com feisty/main Translation-en_US
Ign http://archive.ubuntu.com feisty/universe Translation-en_US
Hit http://archive.ubuntu.com feisty Release
Get:2 http://medibuntu.sos-sts.com feisty Release.gpg [189B]
Ign http://medibuntu.sos-sts.com feisty/free Translation-en_US
Hit http://archive.ubuntu.com feisty/main Packages
Ign http://medibuntu.sos-sts.com feisty/non-free Translation-en_US
Ign http://medibuntu.sos-sts.com feisty/free Translation-en_US
Ign http://medibuntu.sos-sts.com feisty/non-free Translation-en_US
Hit http://archive.ubuntu.com feisty/universe Packages
Hit http://medibuntu.sos-sts.com feisty Release
Err http://medibuntu.sos-sts.com feisty Release

Get:3 http://medibuntu.sos-sts.com feisty Release [2195B]
Ign http://medibuntu.sos-sts.com feisty Release
Ign http://medibuntu.sos-sts.com feisty/free Packages
Ign http://medibuntu.sos-sts.com feisty/non-free Packages
Ign http://medibuntu.sos-sts.com feisty/free Packages
Ign http://medibuntu.sos-sts.com feisty/non-free Packages
Hit http://medibuntu.sos-sts.com feisty/free Packages
Hit http://medibuntu.sos-sts.com feisty/non-free Packages
Hit http://medibuntu.sos-sts.com feisty/free Packages
Hit http://medibuntu.sos-sts.com feisty/non-free Packages
Fetched 2385B in 1s (1432B/s)
Reading package lists... Done
W: GPG error: http://medibuntu.sos-sts.com feisty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
W: You may want to run apt-get update to correct these problems
joe@joe:~$



i'm guessing this is a problem... i'm going to carry out the other commands you listed in hopes i don't screw everything up. thanks for the help, and the explanation is valuable. i always like to know what i'm doing and why i'm doing it.

jmusso
July 16th, 2007, 05:21 PM
Okay so I went ahead and ran all of the other commands you gave me after I got that line of code above...

I "cd" ed where my vive was, ./configured it, then did a "make", and when i did "make install" here's what happened....


joe@joe:~/vive-2.0.0-beta2$ make install
Making install in src
make[1]: Entering directory `/home/joe/vive-2.0.0-beta2/src'
make[2]: Entering directory `/home/joe/vive-2.0.0-beta2/src'
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/bin" || /bin/mkdir -p "/usr/local/bin"
/usr/bin/install -c 'vive' '/usr/local/bin/vive'
/usr/bin/install: cannot create regular file `/usr/local/bin/vive': Permission denied
make[2]: *** [install-viveprgPROGRAMS] Error 1
make[2]: Leaving directory `/home/joe/vive-2.0.0-beta2/src'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/joe/vive-2.0.0-beta2/src'
make: *** [install-recursive] Error 1
joe@joe:~/vive-2.0.0-beta2$

endersshadow
July 17th, 2007, 05:19 AM
make install needs to be super user to commense:


sudo make install

That'll do it :)

jmusso
July 17th, 2007, 07:26 AM
Okay, I think I've done everything right up until now... Here's what I get when I try to encode a video.

joe@joe:~$ ipodvidenc /home/joe/300.avi
What would you like to name the output file (sans extension)?
threehundred
threehundred will be located in /home/joe. Is this acceptable? [y/n]
y
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-pthreads --enable-shared
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Jul 17 2007 02:08:20, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
/home/joe/300.avi: I/O error occured
Usually that means that input file is truncated and/or corrupted.

endersshadow
July 17th, 2007, 12:47 PM
Well, ipodvidenc is a bit different from Vive. ipodvidenc is a script, while Vive is a GUI application. There's a bit of a hangup with ipodvidenc and the newer versions of ffmpeg, but here's how to fix it.


sudo gedit /usr/bin/ipodvidenc

Then, find this line:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1000k -b 700k -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_dir}/${output_file_name}.mov"

Change it to this:


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1000k -b 700k -qmin 3 -qmax 5 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_dir}/${output_file_name}.mov"

Save and then you should be all set. Or simply use Vive with this:


vive

Select /home/joe/300.avi with the File button, then select where you want it output to, select the iPod preset, then press Encode.

jmusso
July 17th, 2007, 05:28 PM
Okay, I did all that... and this is what is happening.

I couldn't copy the text from vive, but here's a screenshot and what it said...

http://img.photobucket.com/albums/v508/jmusso/Screenshot.png

Thanks for all the help, by the way. I really appreciate it.

endersshadow
July 17th, 2007, 08:53 PM
You need to put a file extension on the output file.

jmusso
July 17th, 2007, 09:19 PM
oh okay... and if i was converting these for my ipod video, what file extension should i use? .mp4 or something? i really don't know as much as i should about this... thanks again.

endersshadow
July 18th, 2007, 02:43 AM
.mov is accepted on iPods :)

Edit: You learn by asking that which you don't know, so don't feel bad for asking.

jmusso
July 18th, 2007, 04:55 AM
Got it working! Thanks for all the help. The only weird thing is, the sound seems to be "off", so it looks like a Godzilla movie or something. The sound doesn't match up with the video, its just a tad different so that the people say what they're saying before I can hear it... I watched the original .avi file to see if it was like that there, and it was perfectly normal. So I'm guessing this happened during the encoding process. Any ideas how I can fix this? If you've seen 300 you'll know the effect is lost when Lionidus says "this is sparta" and it looks like he's lip synching...

endersshadow
July 18th, 2007, 05:11 AM
Unfortunately, this sometimes happens with ffmpeg. You'll have to reencode it via the command line. But, I'll make it simple for you :)

Here's the command:


ffmpeg -y -f mp4 -vcodec mpeg4 -b 700k -s 320x240 -acodec aac -ac 2 -ab 192k -title "threehundred" -async 1 -i "/home/joe/300.AVI" "/home/joe/threehundred.mov"

That should do it. On a side note, 300 is an awesome movie. They just opened up a new theater in my town and were using these first few days to do charity showings ($1 admission, 100% goes to charity) while playing not-so-recent movies. Saw 300 again on the big screen for $1 today, and I enjoyed it as thoroughly as I did the first time :-D

weirdalduke
July 18th, 2007, 05:24 AM
I'm getting this message after answering the prompts:

/usr/bin/ipodvidenc: line 24: ffmpeg: command not found

Any Suggestions, Thanks for your help.

endersshadow
July 18th, 2007, 06:10 AM
I'm getting this message after answering the prompts:

/usr/bin/ipodvidenc: line 24: ffmpeg: command not found

Any Suggestions, Thanks for your help.

You don't have ffmpeg installed. Go to the first post and follow instructions on getting it installed and then you'll be all set :)

jmusso
July 18th, 2007, 06:43 AM
Something else weird just happened... I use Banshee to sync my iPod usually, and I did a drag and drop of some songs in my library to my iPod, then clicked Sync and clicked Save Manual Changes, like I always do... except then it started to convert a .mov file, which turned out to be 300! the crappy version with the lip synching of course, but now it won't play on my iPod! I'm afraid that Banshee will try to do this to all my movies... should I just use gtkpod instead, even though its such a hassle compared to Banshee? I moved the vid file on there with gtkpod, and it played well. Then when I moved some mp3s onto it using Banshee, it "converted" the movie file without asking me...

endersshadow
July 18th, 2007, 07:06 AM
To be honest, I know nothing of how Banshee handles iPods and/or media. My iPod's in my car, so I can't try it out right at the moment. My immediate advice would be to just go w/ gtkpod, but if you want to look around to tr to find more info about Banshee, that's your perogative :)

endersshadow
July 20th, 2007, 05:29 PM
Huge news! Vive 2.0.0 has finally been released! Download it here (https://sourceforge.net/project/showfiles.php?group_id=158461)!

Also, an Ubuntu Feisty package has been added. I suggest that you use the Medibuntu (http://medibuntu.org) repository to meet the dependencies, as the Ubuntu package is compiled to allow DVD usage. Enjoy!

shanest
July 25th, 2007, 04:58 AM
Thanks! This worked brilliantly for me.

There was one glitch where the encoded video of my Garden State DVD was complete garbage, but it's been great besides that. DVD ripping is also very slow for me, but I think it's largely (although not completely) due to my drive which is in the docking station for my X60 tablet.

For other DVDs, it worked great, albeit slow.
And for other video files, it works brilliantly!

Once again, thanks for the great work. For awhile, I was worried I might have to transfer videos in *gasp* Windows

92bek
July 26th, 2007, 03:52 AM
Hey, I'm really looking forward to using Vive 2.0 but I cannot seem to get it up and running. I'm running the ubuntu 64bit version and not sure if there's issues introduced by that. But when I attempt to build from source, I get the following error:


chief@Beefy:~$ tar -zxvf vive-2.0.0.tar.gz
gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error exit delayed from previous errors

Or by the .deb pkg:


chief@Beefy:~$ sudo dpkg -i vive_2.0.0-0ubuntu1_i386.deb
dpkg-deb: unexpected end of file in version number in vive_2.0.0-0ubuntu1_i386.deb
dpkg: error processing vive_2.0.0-0ubuntu1_i386.deb (--install):
subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
vive_2.0.0-0ubuntu1_i386.deb


I'm sure there's a simple fix, and it might be more OS related than a VIVE issue; but I'm n00b. Any advice would be greatly appreciated!!!

endersshadow
July 26th, 2007, 04:04 AM
92bek: These errors happen when the download wasn't completed correctly. Try redownloading the files and making sure that their sums are okay.

Here's the MD5 sum of the tar.gz and the .deb, respectively:


44ac203364f00e0a8c68e2fc9194442c vive-2.0.0.tar.gz
830213d2fce8a1b69b4d82a36cc2df2e vive_2.0.0-0ubuntu1_i386.deb

You can check them by doing this:


md5sum /path/to/file

92bek
July 26th, 2007, 08:04 PM
Great! Thanks for the advice. I've was able to download the file w/ integrity and successfully unzip the source file to get to the ./configure prompt. Now another n00b question about compiling the source.

I've collected most of the dependencies which worked for a while but have now been stumped on obtaining the "libgnomeui" package. Code:


chief@Beefy:~$ ./configure
bash: ./configure: No such file or directory
chief@Beefy:~$ ls
Desktop Examples vive-2.0.0 vive-2.0.0.tar.gz
chief@Beefy:~$ cd vive-2.0.0/
chief@Beefy:~/vive-2.0.0$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for ffmpeg... yes
checking for vobcopy... yes
checking for mplayer... yes
checking for prefix by checking for ffmpeg... /usr/bin/ffmpeg
checking whether DVD is enabled... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... yes (version 2.10.11)
checking pkg-config is at least version 0.9.0... yes
checking for libgnome... yes
checking for libgnomeui... configure: error: Package requirements ( libgnomeui-2.0 >= 2.0) were not met:

No package 'libgnomeui-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libgnomeui_CFLAGS
and libgnomeui_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I've researched the forums and there seems to be no similar issue w/ a missing libgnomeui package. I've used the apt-get to install almost all packages labeled "libgnomeui*". Any thoughts on how to install or get the installer to recognize these packages?

Thanks again for the previous help.

endersshadow
July 26th, 2007, 08:11 PM
You'll need to install libgnomeui-dev to compile from source. If you were just using the Debian package, you'd need libgnomeui-0 and libgnomeui-common.

Sokarul
July 28th, 2007, 03:59 AM
I'm having trouble getting the ffmpeg installed first.
The problem is first at

sudo apt-get install libdvdcss2-dev libdvdnav-dev libdvdr
Specifically the libdvdcss2-dev because it can't be found. I also tried the other way listed but it didn't work either.
I am using the 64 bit ubuntu so it may bot matter since Vive seems to only be for i386 which is 32 bit? Correct?

endersshadow
July 28th, 2007, 04:57 AM
I built it on an i386, and Sourceforge's compile farm is now dead and buried so I can't compile it on x64. Assumedly, the code works if built by a 64-bit gcc. Medibuntu definitely has the x64 version of libdvdcss2. Do you have Medibuntu in your /etc/apt/sources.list file?

Sokarul
July 28th, 2007, 06:34 AM
I think I set it up right now, and then I was able to get libdvdcss2 to install.

ibelwich
July 28th, 2007, 12:25 PM
Hey All,

Firstly big thanks for the howto especially useful for a linux newbie like myself.

I installed vive 2.0 (Great App) and ran into a couple of hiccups got those all sorted and can rip and encode dvd's no problem.

However when i transfer them to my ipod using gtkpod , they never play i simply get a black screen fro 30 seconds and then it returns to the menu. I tried installing gpac and remuxxed the video but now gtkpod does not recognise it.

Any ideas on how to resolve this? is something extra I need to download to update gtkpod?

Many thanks

endersshadow
July 28th, 2007, 02:35 PM
Just a couple questions, ibelwich:

1. What version of gtkpod are you using?
2. What options did you use to encode the video?
3. What's the filename of the video?

ibelwich
July 28th, 2007, 09:28 PM
Thanks for the reply Endersshadow,

To answer ytour questions:
1. Gtkpod version 0.99.8
2.I used the default options in vive here's the output from the terminal:
ffmpeg -y -f mp4 -vcodec mpeg4 -b 700k -aspect 4:3 -s 320x320 -acodec aac -ac 2 -ab 192k -i "/home/scott/dvd/vive_dvd_temp1-1.vob "home/scott/dvd/trueromance.mp4"

3. as you can see this is the filename created by vive when I originally inserted the dvd vive_dvd_temp1-1.vob

and then I am encoding this to trueromance.mp4

Thanks

endersshadow
July 29th, 2007, 04:30 AM
Rename it trueromance.mov and try again. It seems silly, but that's the way it is.

ibelwich
July 29th, 2007, 04:17 PM
Thanks endersshadow,

that solved it partially. gtkpod recognises the .mov file and I can copy it to the ipod, but the behaviour is the same blank screen for 30 seconds and then returns back to the menu.

I am going to play around with it a bit see if I can nail it. If you have any other idea's let me know I give them a go.


one thing I have noticed and I am not sure if this is normal or not but in the vive terminal I see the following line

ffmpeg version SVN -rUNKNOWN

Not sure if this is a red-herring or an indication that I did not quite follow your instructions on building ffmpeg correctly


cheers

endersshadow
July 29th, 2007, 05:13 PM
It's not unusual w/ ffmpeg to have that version.

As for the video, does it play correctly on your computer?

ibelwich
July 29th, 2007, 07:40 PM
Yup plays perfectly on the pc...

joe_bling
July 29th, 2007, 08:02 PM
Enders this is a fantastic program! I got everything working fine but have one issue.

Neither the video nor audio plays when I try on my iPod.

I encoded 1min 56 secs of a DVD just fine. Plays fine on my Feisty laptop, plays fine *from* the iPod under Feisty or iTunes/WinXP w/ Quicktime. But nothing plays on the iPod, it's just a blank screen and no sound for 1min 56 secs.

80GB video iPod f/w 1.2.1 using Vive 2.0.0 and gtkPod 0.99.8. The file name is blahblahblah.mov, I used Vive iPod/PSP presets.

Any ideas?

ibelwich
July 29th, 2007, 08:08 PM
Hey Joe,

Thats interesting I am getting the same kinda behaviour on my ipod... 60 gb firmware 1.2.1....maybe there is an issue with version of firmware on the ipod. Enders may know

joe_bling
July 30th, 2007, 12:16 AM
ibelwich that is an odd coincidence.

I should also mention that when I try to import my .mov into the iPod via iTunes, it will not import, iTunes reports "iPod cannot play this format".

endersshadow
July 30th, 2007, 04:05 AM
Try bumping the Audio Bitrate down to 128kbps. I see in the tech specs that it's only allowed to play up to 160kbps, so that may be the problem. The video codecs and bitrates all look good.

ibelwich
July 30th, 2007, 10:18 PM
Thanks Enders,

Will give this a try and let you know how it turns out.

Cheers

ibelwich
August 1st, 2007, 09:12 PM
Hey Enders,

Tried a couple of various options and bitrates both 160 and 128, but unfortunately no joy. I'll keep at it and see if I crack it.

Cheers

Ubundragon
August 2nd, 2007, 04:26 AM
hello guys,

first of all,i want to say im new to ubuntu and so far i managed to make my new operating system work flawlessly..but being new there are still so many things i dont understand..

i tried to install ffmpeg to encode videos for my ipod following the instructions from endersshadow but it aborts the installation all the times..

do i need to install ffmpeg first from repositories and then run the commands?
also what is a SVN version of ffmpeg and how do i get it?from what i understand this is the only version that allows me to encode videos for ipod.

sorry about the nOOb questions but i really wanna make this thing work..

thanks:)

byeeee

joe_bling
August 10th, 2007, 03:45 PM
I've been experimenting with different bitrates etc and I cannot get anything to work on the iPod. Not sure where to go from here, unfortunately I may have to use our Windows machine.

endersshadow
August 10th, 2007, 08:54 PM
Hey everybody, I'm actually out of town for the moment, but I'm heading back Monday and I'll get to everybody's questions upon return :)

joe_bling
August 14th, 2007, 12:30 AM
Just an fyi, I used Handbrake to encode a DVD then transferred it to my iPod, worked perfectly. So I've established the iPod, cable, and gtkpod are all ok.

endersshadow
August 15th, 2007, 05:03 PM
First of all, apologies on the tardiness. I actually just got a job (woot!) and will be moving half way across the country very shortly, so things are a bit crazy. If I don't immediately respond, that's why. Now, no more distractions about my personal life :)

Ubundragon: What error did you get when you tried to install ffmpeg? Once I have this, I can help you out further.

As for your question, the SVN version is just the latest version of ffmpeg, but note that any version of ffmpeg may be used to encode videos correctly, so long as they are compiled correctly. An easy way to do it is just to install the Medibuntu (http://medibuntu.org) repository and then apt-get install ffmpeg. Life will be grand from there.

joe_bling: Can you possibly send me a sample video encoded with Handbrake? If you need a spot to upload it, I can throw up a quick FTP, but email me at endersshadow AT users DOT sourceforge DOT net and I'll dissect it from there and see what I can do with it. I have a feeling it's going to be something that is so simple that it ticks me off I didn't think of it before.

Old Pink
August 16th, 2007, 03:22 AM
Vive always choosing the wrong audio channel, and I get directors commentary or german, usually. Only once seen English.

The preview shows the right audio, the right audio is usually the first and therefore most attractive option in the list, but no, Vive goes elsewhere, and there's no option of changing channels?!

endersshadow
August 16th, 2007, 04:28 AM
Vive always choosing the wrong audio channel, and I get directors commentary or german, usually. Only once seen English.

The preview shows the right audio, the right audio is usually the first and therefore most attractive option in the list, but no, Vive goes elsewhere, and there's no option of changing channels?!

What's the ffmpeg output (i.e.-the terminal output)?

MrGreen
August 19th, 2007, 05:41 PM
trying to get mp4 video on my ipod, gtkpod complains about not being complied with mp4v2 lib.

Not sure how to fix it?

MrG

http://mr-green.net/images/Screenshot-Warning.png

endersshadow
August 19th, 2007, 08:08 PM
MrGreen, simply run this command:


sudo apt-get install gtkpod-aac

And all should be well in your world :)

MrGreen
August 19th, 2007, 08:19 PM
I know what I did wrong I typed acc instead of aac lol

Thanks good to go ....

Metallinut
August 21st, 2007, 03:58 PM
Can you help with an audio sync problem? Here's the command line I'm using to convert to m4v for iTunes/iPod use:


ffmpeg -i "${input_file}" -f mp4 -vcodec xvid -maxrate 1000k -b 700k -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x180 -padtop 30 -padbottom 30 "${input_file}.m4v"

When the video starts, audio playback is sync'd up no problem, but it gets progressively more "off" as the video goes on. By the end of a 50 minute video, the sound is near 2 seconds off the video...

Any ideas why this might be happening?

Thanks,

endersshadow
August 21st, 2007, 05:49 PM
Metallinut try using the async flag. You can get more info here (http://ffmpeg.mplayerhq.hu/ffmpeg-doc.html).

Metallinut
August 21st, 2007, 06:10 PM
Thanks. I just actually saw a difference in some of my videos. The ones with the sync problem were actually encoded with the flag -vcodec mpeg4. I just noticed some other videos (that I haven't watched yet) that did not exhibit the same audio sync problems. These files were encoded with -vcodec xvid.

I think I'll just stick with xvid, as both iTunes and the iPod both seem to play these...

MrGreen
August 23rd, 2007, 07:12 PM
Followed guide in first post of this thread now ffmpeg spits this out


ffmpeg: error while loading shared libraries: libavformat.so.50: cannot open shared object file: No such file or directory


loaded libavformat-dev but sis not help any ideas ?

endersshadow
August 24th, 2007, 06:15 AM
Mr. Green: You'll need to edit the /etc/ld.so.conf file (using sudo), and add this line:


/usr/local/lib

Save and exit and then run this command:


ldconfig -v

All should then be well.

MrGreen
August 24th, 2007, 06:35 AM
Man lol, worked a treat thanks... what is all that about? it is a problem with ubuntu package or svn version of ffmpeg?

MrG

endersshadow
August 24th, 2007, 02:50 PM
I believe it's the SVN version of ffmpeg and it sometimes installs libavformat to /usr/local/lib instead of /usr/lib. Simple enough fix, though :)

MrGreen
August 25th, 2007, 03:34 PM
The only thing now is I can convert avi to mov but flv to mov


ffmpeg -i video.flv -ab 56 -ar 22050 -b 500 -s 320x240 video.mpg


I get .....


PIX_FMT_YUV420P will be used as an intermediate format for rescaling
Output #0, mov, to 'video.mov':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=2-31, 500 kb/s, 25.00 fps(c)
Stream #0.1: Audio: aac, 22050 Hz, stereo, 56 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Unsupported codec (id=0) for input stream #0.0


again vive works fine with avi.... not a problem

strange?

Fisslefink
August 26th, 2007, 09:45 PM
I used the first post on this thread to compile ffmpeg with h.264 support, but I had the worst time trying to get ffmpeg to cooperate with nuvexport and the libfaad packages in the repository!

Finally I have things working. If anyone else has this problem, here are the versions that worked for me:

Disabling the "debian-multimedia.org" repository from /etc/apt/sources.list was essential!

I then removed ffmpeg using:
sudo apt-get remove ffmpeg

I then installed the 8/04/2007 version of Nuvexport (installed from source):
Version 0.4 0.20070804.svn

I then installed ffmpeg r8998 from the SVN repository, as detailed in this webpage:
http://po-ru.com/diary/bleeding-edge-ffmpeg-on-ubuntu-feisty/

Running ffmpeg -version now gives me:

FFmpeg version SVN-r8998, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-libvorbis --enable-libogg --enable-liba52 --enable-libdts --enable-dc1394 --enable-libgsm --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-xvid --enable-pthreads --enable-x264
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on Aug 26 2007 12:57:38, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
ffmpeg SVN-r8998
libavutil 3212288
libavcodec 3352580
libavformat 3345409

and ffmpeg -formats gives me:

FFmpeg version SVN-r8998, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-libvorbis --enable-libogg --enable-liba52 --enable-libdts --enable-dc1394 --enable-libgsm --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-xvid --enable-pthreads --enable-x264
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on Aug 26 2007 12:57:38, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
File formats:
E 3g2 3gp2 format
E 3gp 3gp format
D 4xm 4X Technologies format
D MTV MTV format
DE RoQ Id RoQ format
D aac ADTS AAC
DE ac3 raw ac3
E adts ADTS AAC
DE aiff Audio IFF
DE alaw pcm A law format
DE amr 3gpp amr file format
D apc CRYO APC format
DE asf asf format
E asf_stream asf format
DE au SUN AU Format
DE audio_device audio grab and output
DE avi avi format
D avs avs format
D bethsoftvid Bethesda Softworks 'Daggerfall' VID format
D c93 Interplay C93
E crc crc testing format
D daud D-Cinema audio format
D dc1394 dc1394 A/V grab
D dsicin Delphine Software International CIN format
D dts raw dts
DE dv DV video format
D dv1394 dv1394 A/V grab
E dvd MPEG2 PS format (DVD VOB)
D dxa dxa
D ea Electronic Arts Multimedia Format
DE ffm ffm format
D film_cpk Sega FILM/CPK format
DE flac raw flac
D flic FLI/FLC/FLX animation format
DE flv flv format
E framecrc framecrc testing format
DE gif GIF Animation
DE gxf GXF format
DE h261 raw h261
DE h263 raw h263
DE h264 raw H264 video format
D idcin Id CIN format
DE image2 image2 sequence
DE image2pipe piped image2 sequence
D ingenient Ingenient MJPEG
D ipmovie Interplay MVE format
DE m4v raw MPEG4 video format
D matroska Matroska file format
DE mjpeg MJPEG video
D mm American Laser Games MM format
DE mmf mmf format
E mov mov format
D mov,mp4,m4a,3gp,3g2,mj2 QuickTime/MPEG4/Motion JPEG 2000 format
E mp2 MPEG audio layer 2
DE mp3 MPEG audio layer 3
E mp4 mp4 format
D mpc musepack
DE mpeg MPEG1 System format
E mpeg1video MPEG video
E mpeg2video MPEG2 video
DE mpegts MPEG2 transport stream format
D mpegvideo MPEG video
E mpjpeg Mime multipart JPEG format
DE mulaw pcm mu law format
D mxf MXF format
D nsv NullSoft Video format
E null null video format
D nut nut format
D nuv NuppelVideo format
DE ogg Ogg format
E psp psp mp4 format
D psxstr Sony Playstation STR format
DE rawvideo raw video format
D redir Redirector format
DE rm rm format
E rtp RTP output format
D rtsp RTSP input format
DE s16be pcm signed 16 bit big endian format
DE s16le pcm signed 16 bit little endian format
DE s8 pcm signed 8 bit format
D sdp SDP
D shn raw shorten
D smk Smacker Video
D sol Sierra SOL Format
E svcd MPEG2 PS format (VOB)
DE swf Flash format
D thp THP
D tiertexseq Tiertex Limited SEQ format
D tta true-audio
D txd txd format
DE u16be pcm unsigned 16 bit big endian format
DE u16le pcm unsigned 16 bit little endian format
DE u8 pcm unsigned 8 bit format
D vc1 raw vc1
E vcd MPEG1 System format (VCD)
D video4linux video grab
D video4linux2 video grab
D vmd Sierra VMD format
E vob MPEG2 PS format (VOB)
DE voc Creative Voice File format
DE wav wav format
D wc3movie Wing Commander III movie format
D wsaud Westwood Studios audio format
D wsvqa Westwood Studios VQA format
D wv WavPack
DE yuv4mpegpipe YUV4MPEG pipe format

Codecs:
D V 4xm
D V D 8bps
D V VMware video
DEA aac
D V D aasc
DEA ac3
DEA adpcm_4xm
DEA adpcm_adx
DEA adpcm_ct
DEA adpcm_ea
DEA adpcm_ima_dk3
DEA adpcm_ima_dk4
DEA adpcm_ima_qt
DEA adpcm_ima_smjpeg
DEA adpcm_ima_wav
DEA adpcm_ima_ws
DEA adpcm_ms
DEA adpcm_sbpro_2
DEA adpcm_sbpro_3
DEA adpcm_sbpro_4
DEA adpcm_swf
D A adpcm_thp
DEA adpcm_xa
DEA adpcm_yamaha
D A alac
DEV D asv1
DEV D asv2
D A atrac 3
D V D avs
D V bethsoftvid
DEV bmp
D V D c93
D V D camstudio
D V D camtasia
D V D cavs
D V D cinepak
D V D cljr
D A cook
D V D cyuv
D A dca
D V D dnxhd
D A dsicinaudio
D V D dsicinvideo
DES dvbsub
DES dvdsub
DEV D dvvideo
D V dxa
DEV D ffv1
DEVSD ffvhuff
DEA flac
DEV D flashsv
D V D flic
DEVSD flv
D V D fraps
DEA g726
DEV gif
DEA gsm
D A gsm_ms
DEV D h261
DEVSDT h263
D VSD h263i
EV h263p
DEV DT h264
DEVSD huffyuv
D V D idcinvideo
D A imc
D V D indeo2
D V indeo3
D A interplay_dpcm
D V D interplayvideo
EV jpegls
D V kmvc
D A libdts
EV ljpeg
D V D loco
D A mace3
D A mace6
D V D mdec
DEV D mjpeg
D V D mjpegb
D V D mmvideo
DEA mp2
DEA mp3
D A mp3adu
D A mp3on4
D A mpc sv7
DEVSDT mpeg1video
DEVSDT mpeg2video
DEVSDT mpeg4
D A mpeg4aac
D VSDT mpegvideo
DEVSD msmpeg4
DEVSD msmpeg4v1
DEVSD msmpeg4v2
D V D msrle
D V D msvideo1
D V D mszh
D V D nuv
DEV pam
DEV pbm
DEA pcm_alaw
DEA pcm_mulaw
DEA pcm_s16be
DEA pcm_s16le
DEA pcm_s24be
DEA pcm_s24daud
DEA pcm_s24le
DEA pcm_s32be
DEA pcm_s32le
DEA pcm_s8
DEA pcm_u16be
DEA pcm_u16le
DEA pcm_u24be
DEA pcm_u24le
DEA pcm_u32be
DEA pcm_u32le
DEA pcm_u8
DEV pgm
DEV pgmyuv
DEV png
DEV ppm
D V ptx
D A qdm2
D V D qdraw
D V D qpeg
D V D qtrle
DEV rawvideo
D A real_144
D A real_288
DEA roq_dpcm
D V D roqvideo
D V D rpza
DEV D rv10
DEV D rv20
DEV sgi
D A shorten
D A smackaud
D V smackvid
D V D smc
DEV snow
D A sol_dpcm
DEA sonic
EA sonicls
D V D sp5x
DEV D svq1
D VSD svq3
DEV targa
D V theora
D V D thp
D V D tiertexseqvideo
DEV tiff
D V D truemotion1
D V D truemotion2
D A truespeech
D A tta
D V txd
D V D ultimotion
D V vc1
D V D vcr1
D A vmdaudio
D V D vmdvideo
DEA vorbis
D V vp3
D V D vp5
D V D vp6
D V D vp6f
D V D vqavideo
D A wavpack
DEA wmav1
DEA wmav2
DEVSD wmv1
DEVSD wmv2
D V wmv3
D V D wnv1
D A ws_snd1
D A xan_dpcm
D V D xan_wc3
D V D xl
EV xvid
DEV D zlib
DEV zmbv

Supported file protocols:
file: http: pipe: rtp: tcp: udp:
Frame size, frame rate abbreviations:
ntsc pal qntsc qpal sntsc spal film ntsc-film sqcif qcif cif 4cif
Motion estimation methods:
zero(fastest) full(slowest) log phods epzs(default) x1 hex umh iter

Note, the names of encoders and decoders dont always match, so there are
several cases where the above table shows encoder only or decoder only entries
even though both encoding and decoding are supported for example, the h263
decoder corresponds to the h263 and h263p encoders, for file formats its even
worse

Finally nuvexport works properly with the "mode=ipod" in nuvexportrc!

Note that the command sudo apt-get install libfaad2-dev still gives me the following error, but ffmpeg was able to build just fine with faad support ...perhaps the r8998 version uses a different library for faad support?:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
libfaad2-dev: Depends: libfaad2-0 (= 2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3) but it is not going to be installed
E: Broken packages

For what it's worth, I did do a lot of other things while trying to get this to work, so I may have left out a critical step on this post, or perhaps included one too many. The point is, it can be done! Your mileage may vary.

Hope this helps someone.

mthaddon
August 30th, 2007, 04:52 AM
Hoping someone can help out here.

I compiled from svn as follows:


./configure --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-shared --disable-debug

Here's my ffmpeg -version output:


FFmpeg version SVN-r10257, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-shared --disable-debug
libavutil version: 49.5.0
libavcodec version: 51.42.0
libavformat version: 51.12.2
built on Aug 28 2007 14:22:53, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
ffmpeg SVN-r10257
libavutil 3212544
libavcodec 3353088
libavformat 3345410


Here's my ffmpeg -formats output:


FFmpeg version SVN-r10257, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-shared --disable-debug
libavutil version: 49.5.0
libavcodec version: 51.42.0
libavformat version: 51.12.2
built on Aug 28 2007 14:22:53, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
File formats:
E 3g2 3gp2 format
E 3gp 3gp format
D 4xm 4X Technologies format
D MTV MTV format
DE RoQ Id RoQ format
D aac ADTS AAC
DE ac3 raw ac3
E adts ADTS AAC
DE aiff Audio IFF
DE alaw pcm A law format
DE amr 3gpp amr file format
D apc CRYO APC format
DE asf asf format
E asf_stream asf format
DE au SUN AU Format
DE audio_device audio grab and output
DE avi avi format
D avs avs format
D bethsoftvid Bethesda Softworks 'Daggerfall' VID format
D c93 Interplay C93
E crc crc testing format
D daud D-Cinema audio format
D dc1394 dc1394 A/V grab
D dsicin Delphine Software International CIN format
D dts raw dts
DE dv DV video format
D dv1394 dv1394 A/V grab
E dvd MPEG2 PS format (DVD VOB)
D dxa dxa
D ea Electronic Arts Multimedia Format
DE ffm ffm format
D film_cpk Sega FILM/CPK format
DE flac raw flac
D flic FLI/FLC/FLX animation format
DE flv flv format
E framecrc framecrc testing format
DE gif GIF Animation
DE gxf GXF format
DE h261 raw h261
DE h263 raw h263
DE h264 raw H264 video format
D idcin Id CIN format
DE image2 image2 sequence
DE image2pipe piped image2 sequence
D ingenient Ingenient MJPEG
D ipmovie Interplay MVE format
DE m4v raw MPEG4 video format
D matroska Matroska file format
DE mjpeg MJPEG video
D mm American Laser Games MM format
DE mmf mmf format
E mov mov format
D mov,mp4,m4a,3gp,3g2,mj2 QuickTime/MPEG4/Motion JPEG 2000 format
E mp2 MPEG audio layer 2
DE mp3 MPEG audio layer 3
E mp4 mp4 format
D mpc musepack
DE mpeg MPEG1 System format
E mpeg1video MPEG video
E mpeg2video MPEG2 video
DE mpegts MPEG2 transport stream format
D mpegtsraw MPEG2 raw transport stream format
D mpegvideo MPEG video
E mpjpeg Mime multipart JPEG format
DE mulaw pcm mu law format
D mxf MXF format
D nsv NullSoft Video format
E null null video format
DE nut nut format
D nuv NuppelVideo format
DE ogg Ogg format
E psp psp mp4 format
D psxstr Sony Playstation STR format
DE rawvideo raw video format
D redir Redirector format
DE rm rm format
E rtp RTP output format
D rtsp RTSP input format
DE s16be pcm signed 16 bit big endian format
DE s16le pcm signed 16 bit little endian format
DE s8 pcm signed 8 bit format
D sdp SDP
D shn raw shorten
D smk Smacker Video
D sol Sierra SOL Format
E svcd MPEG2 PS format (VOB)
DE swf Flash format
D thp THP
D tiertexseq Tiertex Limited SEQ format
D tta true-audio
D txd txd format
DE u16be pcm unsigned 16 bit big endian format
DE u16le pcm unsigned 16 bit little endian format
DE u8 pcm unsigned 8 bit format
D vc1 raw vc1
E vcd MPEG1 System format (VCD)
D video4linux video grab
D video4linux2 video grab
D vmd Sierra VMD format
E vob MPEG2 PS format (VOB)
DE voc Creative Voice File format
DE wav wav format
D wc3movie Wing Commander III movie format
D wsaud Westwood Studios audio format
D wsvqa Westwood Studios VQA format
D wv WavPack
DE yuv4mpegpipe YUV4MPEG pipe format

Codecs:
D V 4xm
D V D 8bps
D V VMware video
D V D aasc
EA ac3
DEA adpcm_4xm
DEA adpcm_adx
DEA adpcm_ct
DEA adpcm_ea
DEA adpcm_ima_dk3
DEA adpcm_ima_dk4
DEA adpcm_ima_qt
DEA adpcm_ima_smjpeg
DEA adpcm_ima_wav
DEA adpcm_ima_ws
DEA adpcm_ms
DEA adpcm_sbpro_2
DEA adpcm_sbpro_3
DEA adpcm_sbpro_4
DEA adpcm_swf
D A adpcm_thp
DEA adpcm_xa
DEA adpcm_yamaha
D A alac
DEV D asv1
DEV D asv2
D A atrac 3
D V D avs
D V bethsoftvid
DEV bmp
D V D c93
D V D camstudio
D V D camtasia
D V D cavs
D V D cinepak
D V D cljr
D A cook
D V D cyuv
D A dca
D V D dnxhd
D A dsicinaudio
D V D dsicinvideo
DES dvbsub
DES dvdsub
DEV D dvvideo
D V dxa
DEV D ffv1
DEVSD ffvhuff
DEA flac
DEV D flashsv
D V D flic
DEVSD flv
D V D fraps
DEA g726
DEV gif
DEV D h261
DEVSDT h263
D VSD h263i
EV h263p
D V DT h264
DEVSD huffyuv
D V D idcinvideo
D A imc
D V D indeo2
D V indeo3
D A interplay_dpcm
D V D interplayvideo
DEV D jpegls
D V kmvc
D A liba52
EA libfaac
D A libfaad
DEA libgsm
DEA libgsm_ms
EA libmp3lame
EV libtheora
EV libx264
EV libxvid
EV ljpeg
D V D loco
D A mace3
D A mace6
D V D mdec
DEV D mjpeg
D V D mjpegb
D V D mmvideo
DEA mp2
D A mp3
D A mp3adu
D A mp3on4
D A mpc sv7
DEVSDT mpeg1video
DEVSDT mpeg2video
DEVSDT mpeg4
D A mpeg4aac
D VSDT mpegvideo
DEVSD msmpeg4
DEVSD msmpeg4v1
DEVSD msmpeg4v2
D V D msrle
D V D msvideo1
D V D mszh
D V D nuv
DEV pam
DEV pbm
DEA pcm_alaw
DEA pcm_mulaw
DEA pcm_s16be
DEA pcm_s16le
DEA pcm_s24be
DEA pcm_s24daud
DEA pcm_s24le
DEA pcm_s32be
DEA pcm_s32le
DEA pcm_s8
DEA pcm_u16be
DEA pcm_u16le
DEA pcm_u24be
DEA pcm_u24le
DEA pcm_u32be
DEA pcm_u32le
DEA pcm_u8
DEA pcm_zork
DEV pgm
DEV pgmyuv
DEV png
DEV ppm
D V ptx
D A qdm2
D V D qdraw
D V D qpeg
DEV D qtrle
DEV rawvideo
D A real_144
D A real_288
DEA roq_dpcm
DEV D roqvideo
D V D rpza
DEV D rv10
DEV D rv20
DEV sgi
D A shorten
D A smackaud
D V smackvid
D V D smc
DEV snow
D A sol_dpcm
DEA sonic
EA sonicls
D V D sp5x
DEV D svq1
D VSD svq3
DEV targa
D V theora
D V D thp
D V D tiertexseqvideo
DEV tiff
D V D truemotion1
D V D truemotion2
D A truespeech
D A tta
D V txd
D V D ultimotion
D V vc1
D V D vcr1
D A vmdaudio
D V D vmdvideo
DEA vorbis
D V vp3
D V D vp5
D V D vp6
D V D vp6f
D V D vqavideo
D A wavpack
DEA wmav1
DEA wmav2
DEVSD wmv1
DEVSD wmv2
D V wmv3
D V D wnv1
D A ws_snd1
D A xan_dpcm
D V D xan_wc3
D V D xl
D S xsub
DEV D zlib
DEV zmbv

Supported file protocols:
file: http: pipe: rtp: tcp: udp:
Frame size, frame rate abbreviations:
ntsc pal qntsc qpal sntsc spal film ntsc-film sqcif qcif cif 4cif

Note, the names of encoders and decoders do not always match, so there are
several cases where the above table shows encoder only or decoder only entries
even though both encoding and decoding are supported. For example, the h263
decoder corresponds to the h263 and h263p encoders, for file formats it is even
worse.

When I pass the following script an avi file:


#!/bin/bash

base=`echo $1 | gawk -F. '{print $1}' `

echo "$1 $base"

/usr/bin/ffmpeg -i $1 -f mp4 -vcodec mpeg4 -maxrate 1000k -b 700k -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${base}.mov"

I get:


FFmpeg version SVN-r10257, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-shared --disable-debug
libavutil version: 49.5.0
libavcodec version: 51.42.0
libavformat version: 51.12.2
built on Aug 28 2007 14:22:53, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
Input #0, avi, from 'winston_f1553159.avi':
Duration: 00:00:23.3, start: 0.000000, bitrate: 4465 kb/s
Stream #0.0: Video: mjpeg, yuvj422p, 320x240, 30.00 fps(r)
Stream #0.1: Audio: pcm_u8, 11024 Hz, mono, 88 kb/s
Unknown encoder 'aac'

I can't see what I've missed to get the aac encoder. Any ideas?

Thanks, Tom

endersshadow
August 30th, 2007, 06:10 AM
Hey Tom, do you have libfaac0 installed?

mthaddon
August 30th, 2007, 06:24 AM
yep.


$ aptitude search libfaac
i libfaac-dev - an AAC audio encoder - development files
i libfaac0 - an AAC audio encoder - library files

endersshadow
August 30th, 2007, 06:46 AM
Well then, that's just rather odd. Can I suggest the Medibuntu (http://medibuntu.org) repo and installing ffmpeg from there?

monitorman
September 3rd, 2007, 10:38 PM
I've installed Vive 2.0.0 after installing the Mediabuntu repository.
There weren't any presets available from the drop-down menu after installation.
I tried manually configuring some of the settings, and trying a few tests. The error I receive in the terminal is always "unable to find an output format for (location of test file)"
Any help would be greatly appreciated.

CoriolisSTORM
September 7th, 2007, 09:43 PM
having problems installing here; I downloaded the .deb file to install it and it says that I have an unsatisfiable dependency; libatk1.0-0. I have checked and it is installed. What do I do now?

HeelsFan
September 11th, 2007, 02:46 AM
I was able to install ffmpeg and Vive from the instructions. However, I do not have presets in the Vive drop-down menu either.

Can someone help me load them?

Thanks in advance.

HeelsFan
September 11th, 2007, 10:33 PM
I figured out how to solve my preset issue:
1) Download the tar file from Sourceforge;
2) Untar;
3) Copy the preferences file from the examples directory to your home/.vive directory (make sure you show hidden files); and
4) Restart Vive

Note this will copy over any presets that you may have manually entered.

monitorman
September 12th, 2007, 06:59 PM
I figured out how to solve my preset issue:
1) Download the tar file from Sourceforge;
2) Untar;
3) Copy the preferences file from the examples directory to your home/.vive directory (make sure you show hidden files); and
4) Restart Vive

Note this will copy over any presets that you may have manually entered.

Hey! That worked for me.
Thanks!

Unfortunately, I'm still getting the "unable to find output format" error.

endersshadow
September 14th, 2007, 03:42 AM
Hey folks, I'm really sorry about not getting right back to you. I happen to have just moved half way across the country and just started a new job. As one can imagine, it really interferes with my cyberlife.

As for the preferences, HeelsFan is right. I'm upset that didn't copy over in the deb file, and I'll look into it. It most definitely should!

monitorman: Can you tell me what settings you used? Did you make sure the output file had an extension on it? ffmpeg will only encode if both files have extensions (such as filename.wmv instead of just filename).

monitorman
September 14th, 2007, 10:03 PM
monitorman: Can you tell me what settings you used? Did you make sure the output file had an extension on it? ffmpeg will only encode if both files have extensions (such as filename.wmv instead of just filename).

Hey! Glad you're back!
I'm using the preset ipod/psp settings.
No, i wasn't including an extension on the output file.
Trying that now brings up the error: ""ffmpeg: error while loading shared libraries: libavformat.so.50: cannot open shared object file.no such file or directory"

So, I'm missing some part of ffmpeg?

Thanks.

endersshadow
September 14th, 2007, 11:12 PM
Here's the answer:

http://ubuntuforums.org/showpost.php?p=3243712&postcount=627

Edit the /etc/ld.so.conf file (using sudo), and add this line:


/usr/local/lib

Save and exit and then run this command:


ldconfig -v

All should then be well.

monitorman
September 15th, 2007, 03:44 AM
Sorry for looking like a dumbass, but the exact commands should be...?
I've only been using Ubuntu about a month.
Thanks.

endersshadow
September 15th, 2007, 06:45 AM
It's all right.

The commands should be:


sudo gedit /etc/ld.so.conf

Scroll to the end and type or paste in this line at the very bottom:


/usr/local/lib

Save and close GEdit. Then run this command:


ldconfig -v

Voila :)

monitorman
September 17th, 2007, 09:17 PM
OK. That was what I had been trying.
I get another error:
"ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Permission denied"

Thanks.

endersshadow
September 18th, 2007, 02:39 AM
My fault, it needs to be:


sudo ldconfig -v

monitorman
September 18th, 2007, 07:15 PM
That's got it!
Thanks for walking me through this.

Cheers!

katelewis
September 20th, 2007, 01:36 AM
Does anyone know about video downloads to go on to website? I'm looking to put videos on my website and have come across
various ones but its hard deciding as this is new to me. One sticks out in my mind called smackbiz.biz has anyone used them before?

johnboyholms
September 23rd, 2007, 08:22 AM
Hi,

Can anyone tell me, has h264 encoding been disabled in the latest SVN/release of ffmpeg?

Looking at:

http://ffmpeg.mplayerhq.hu/general.html#TOC6

It only says it is a h.264 decoder.

and when I build with:



jl@id2p:~/ffmpeg$ ./configure --enable-gpl --enable-pp --disable-debug --enable-pthreads --enable-shared --enable-liba52 --enable-dc1394 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid

and run % ffmpeg -formats I get:


jl@id2p:~/ffmpeg$ ffmpeg -formats
FFmpeg version SVN-r10550, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --disable-debug --enable-pthreads --enable-shared --enable-liba52 --enable-libdc1394 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid
libavutil version: 49.5.0
libavcodec version: 51.44.0
libavformat version: 51.13.4
built on Sep 23 2007 16:44:49, gcc: 4.1.3 20070831 (prerelease) (Ubuntu 4.1.2-16ubuntu1)
File formats:
E 3g2 3gp2 format
E 3gp 3gp format
D 4xm 4X Technologies format
D MTV MTV format
DE RoQ Id RoQ format
D aac ADTS AAC
DE ac3 raw ac3
E adts ADTS AAC
DE aiff Audio IFF
DE alaw pcm A law format
DE amr 3gpp amr file format
D apc CRYO APC format
D ape Monkey's Audio
DE asf asf format
E asf_stream asf format
DE au SUN AU Format
DE avi avi format
D avs avs format
D bethsoftvid Bethesda Softworks 'Daggerfall' VID format
D c93 Interplay C93
E crc crc testing format
D daud D-Cinema audio format
D dsicin Delphine Software International CIN format
D dts raw dts
DE dv DV video format
D dv1394 dv1394 A/V grab
E dvd MPEG2 PS format (DVD VOB)
D dxa dxa
D ea Electronic Arts Multimedia Format
DE ffm ffm format
D film_cpk Sega FILM/CPK format
DE flac raw flac
D flic FLI/FLC/FLX animation format
DE flv flv format
E framecrc framecrc testing format
DE gif GIF Animation
DE gxf GXF format
DE h261 raw h261
DE h263 raw h263
DE h264 raw H264 video format
D idcin Id CIN format
DE image2 image2 sequence
DE image2pipe piped image2 sequence
D ingenient Ingenient MJPEG
D ipmovie Interplay MVE format
D libdc1394 dc1394 A/V grab
DE m4v raw MPEG4 video format
DE matroska Matroska File Format
DE mjpeg MJPEG video
D mm American Laser Games MM format
DE mmf mmf format
E mov mov format
D mov,mp4,m4a,3gp,3g2,mj2 QuickTime/MPEG4/Motion JPEG 2000 format
E mp2 MPEG audio layer 2
DE mp3 MPEG audio layer 3
E mp4 mp4 format
D mpc musepack
DE mpeg MPEG1 System format
E mpeg1video MPEG video
E mpeg2video MPEG2 video
DE mpegts MPEG2 transport stream format
D mpegtsraw MPEG2 raw transport stream format
D mpegvideo MPEG video
E mpjpeg Mime multipart JPEG format
DE mulaw pcm mu law format
D mxf MXF format
D nsv NullSoft Video format
E null null video format
DE nut nut format
D nuv NuppelVideo format
DE ogg Ogg format
DE oss audio grab and output
E psp psp mp4 format
D psxstr Sony Playstation STR format
DE rawvideo raw video format
D redir Redirector format
DE rm rm format
E rtp RTP output format
D rtsp RTSP input format
DE s16be pcm signed 16 bit big endian format
DE s16le pcm signed 16 bit little endian format
DE s8 pcm signed 8 bit format
D sdp SDP
D shn raw shorten
D smk Smacker Video
D sol Sierra SOL Format
E svcd MPEG2 PS format (VOB)
DE swf Flash format
D thp THP
D tiertexseq Tiertex Limited SEQ format
D tta true-audio
D txd txd format
DE u16be pcm unsigned 16 bit big endian format
DE u16le pcm unsigned 16 bit little endian format
DE u8 pcm unsigned 8 bit format
D vc1 raw vc1
E vcd MPEG1 System format (VCD)
D video4linux video grab
D video4linux2 video grab
D vmd Sierra VMD format
E vob MPEG2 PS format (VOB)
DE voc Creative Voice File format
DE wav wav format
D wc3movie Wing Commander III movie format
D wsaud Westwood Studios audio format
D wsvqa Westwood Studios VQA format
D wv WavPack
DE yuv4mpegpipe YUV4MPEG pipe format

Codecs:
D V 4xm
D V D 8bps
D V VMware video
D V D aasc
EA ac3
DEA adpcm_4xm
DEA adpcm_adx
DEA adpcm_ct
DEA adpcm_ea
DEA adpcm_ima_dk3
DEA adpcm_ima_dk4
DEA adpcm_ima_qt
DEA adpcm_ima_smjpeg
DEA adpcm_ima_wav
DEA adpcm_ima_ws
DEA adpcm_ms
DEA adpcm_sbpro_2
DEA adpcm_sbpro_3
DEA adpcm_sbpro_4
DEA adpcm_swf
D A adpcm_thp
DEA adpcm_xa
DEA adpcm_yamaha
D A alac
D A ape
DEV D asv1
DEV D asv2
D A atrac 3
D V D avs
D V bethsoftvid
DEV bmp
D V D c93
D V D camstudio
D V D camtasia
D V D cavs
D V D cinepak
D V D cljr
D A cook
D V D cyuv
D A dca
D V D dnxhd
D A dsicinaudio
D V D dsicinvideo
DES dvbsub
DES dvdsub
DEV D dvvideo
D V dxa
DEV D ffv1
DEVSD ffvhuff
DEA flac
DEV D flashsv
D V D flic
DEVSD flv
D V D fraps
DEA g726
DEV gif
DEV D h261
DEVSDT h263
D VSD h263i
EV h263p
D V DT h264
DEVSD huffyuv
D V D idcinvideo
D A imc
D V D indeo2
D V indeo3
D A interplay_dpcm
D V D interplayvideo
DEV D jpegls
D V kmvc
D A liba52
EA libfaac
D A libfaad
DEA libgsm
DEA libgsm_ms
EA libmp3lame
EV libtheora
EV libx264
EV libxvid
EV ljpeg
D V D loco
D A mace3
D A mace6
D V D mdec
DEV D mjpeg
D V D mjpegb
D V D mmvideo
DEA mp2
D A mp3
D A mp3adu
D A mp3on4
D A mpc sv7
DEVSDT mpeg1video
DEVSDT mpeg2video
DEVSDT mpeg4
D A mpeg4aac
D VSDT mpegvideo
DEVSD msmpeg4
DEVSD msmpeg4v1
DEVSD msmpeg4v2
D V D msrle
D V D msvideo1
D V D mszh
D V D nuv
DEV pam
DEV pbm
DEA pcm_alaw
DEA pcm_mulaw
DEA pcm_s16be
DEA pcm_s16le
DEA pcm_s24be
DEA pcm_s24daud
DEA pcm_s24le
DEA pcm_s32be
DEA pcm_s32le
DEA pcm_s8
DEA pcm_u16be
DEA pcm_u16le
DEA pcm_u24be
DEA pcm_u24le
DEA pcm_u32be
DEA pcm_u32le
DEA pcm_u8
DEA pcm_zork
DEV pgm
DEV pgmyuv
DEV png
DEV ppm
D V ptx
D A qdm2
D V D qdraw
D V D qpeg
DEV D qtrle
DEV rawvideo
D A real_144
D A real_288
DEA roq_dpcm
DEV D roqvideo
D V D rpza
DEV D rv10
DEV D rv20
DEV sgi
D A shorten
D A smackaud
D V smackvid
D V D smc
DEV snow
D A sol_dpcm
DEA sonic
EA sonicls
D V D sp5x
DEV D svq1
D VSD svq3
DEV targa
D V theora
D V D thp
D V D tiertexseqvideo
DEV tiff
D V D truemotion1
D V D truemotion2
D A truespeech
D A tta
D V txd
D V D ultimotion
D V vc1
D V D vcr1
D A vmdaudio
D V D vmdvideo
DEA vorbis
D V vp3
D V D vp5
D V D vp6
D V D vp6f
D V D vqavideo
D A wavpack
DEA wmav1
DEA wmav2
DEVSD wmv1
DEVSD wmv2
D V wmv3
D V D wnv1
D A ws_snd1
D A xan_dpcm
D V D xan_wc3
D V D xl
D S xsub
DEV D zlib
DEV zmbv

Supported file protocols:
file: http: pipe: rtp: tcp: udp:
Frame size, frame rate abbreviations:
ntsc pal qntsc qpal sntsc spal film ntsc-film sqcif qcif cif 4cif

Note, the names of encoders and decoders do not always match, so there are
several cases where the above table shows encoder only or decoder only entries
even though both encoding and decoding are supported. For example, the h263
decoder corresponds to the h263 and h263p encoders, for file formats it is even
worse.


If encoding has been disabled does anyone know why? and another way to encode video for an ipod on linux?

Or any other advice would be greatly appreciated.

BTW I am using gutsy.

Thanks in advance

John

endersshadow
September 23rd, 2007, 07:54 PM
I don't know, I haven't installed/tested Gutsy. However, you can encode it with the mov format, mpeg4 video and mp3 audio for the codecs.

johnboyholms
September 24th, 2007, 12:04 AM
I don't know, I haven't installed/tested Gutsy. However, you can encode it with the mov format, mpeg4 video and mp3 audio for the codecs.

Hi ,

I got it working with the gutsy ffmpeg source

apt-get source ffmpeg

However as I mentioned earlier the latest SVN of ffmpeg seems to me to not include h264 as an encoder.

Yes, I could encode mov format, mpeg4 video and mp3 audio for the codecs.

I do hope they haven't dropped H264 encoding from ffmpeg.

TutoWRM
September 25th, 2007, 08:20 AM
ohhhhh I finally got it to work!!!!!!!
after a day of compiling over and over the svn for ffmpeg and read this and many other webs, the error of the encoder aac, was because now it's libfaac (i know pretty stupid not to noticed before), so i've change that in the command line of ipodvidenc and another problem came up, the wrong timebase for mpeg4...... so.... after a few hours, i've finnaly got this command line to work:

ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -b 700k -aspect 4:3 -r 23.98 -s 320x240 -acodec libfaac -ar 48000

so i hope that works for you, because i spent all of my day trying to get it right :/

Sammi
October 3rd, 2007, 05:37 PM
Hmm... i tried MelodyCan converter. Few mouse clicks and I can enjoy my lovely video. Number of conversions at a time is 8-12 files. It`s very good, quickly and comfortable to use.
This smells like a malware advertisement. That's a Windows app and this is a Linux forum.

spockrock
October 7th, 2007, 06:35 PM
I am wondering if anyone here has solved this problem but I am using fesity but all the videos I encode with vive have no sound on both my iphone and ipod video. Any one here found a fix, is this an ffmpeg issue?

atlfalcons866
October 11th, 2007, 11:04 PM
i get this using gutsy

Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.
Use of uninitialized value in pattern match (m//) at /usr/bin/vive line 368.

Metallinut
October 24th, 2007, 10:55 PM
I just upgraded from Fiesty to 7.10 Gutsy.

ffmpeg ceased working in creating iPod videos, I assume because ffmpeg got updated, and my custom built one got overwritten. So I uninstalled ffmpeg, and followed the steps on the first page of this thread to reinstall it.

When I try to encode a video I get the following:
Unknown encoder 'xvid'

Now I made sure to --enable-libxvid (it's listed at the beginning when ffmpeg is run)

I've also verified that libxvidcore4-dev is installed, and is the most current version...

Any idea why ffmpeg doesn't recognize my xvid codec?

3rdalbum
October 25th, 2007, 03:49 PM
I am trying this program for use with my Sony MP3/Video Walkman... if it works, I'll be forever grateful!

woodsdog
October 25th, 2007, 11:16 PM
Guys,

I don't know if these will help anyone, but I've been tinkering around with my iPhone and created some bash scripts that will help encode video to the iPhone and the PSP. They aren't anything super fancy, but some friends of mine and me find them useful.

They do depend on a working version of ffmpeg compiled with x264, libfaac, and xvid. They also rely upon AtomicParsley to tag the meta data correctly.

These scripts do a 2-pass encode on them.

I have started a Google Code project, and have placed them there. You can find it here:

http://code.google.com/p/vs4p/

I'd be interested to see if anyone finds them useful or has suggestions for improvements. If this isnt a good place to discuss, I can start a new thread.

Thanks

Woody

j0ehill
October 28th, 2007, 03:32 AM
I just upgraded from Fiesty to 7.10 Gutsy.

ffmpeg ceased working in creating iPod videos, I assume because ffmpeg got updated, and my custom built one got overwritten. So I uninstalled ffmpeg, and followed the steps on the first page of this thread to reinstall it.

When I try to encode a video I get the following:
Unknown encoder 'xvid'

Now I made sure to --enable-libxvid (it's listed at the beginning when ffmpeg is run)

I've also verified that libxvidcore4-dev is installed, and is the most current version...

Any idea why ffmpeg doesn't recognize my xvid codec?

Try with 'libxvid' instead of 'xvid'. A lot of the syntax has changed in recent ffmpeg versions, for example for -acodec you now need to do 'libfaac', not 'aac'.

ie. ffmpeg -i inputfile -vcodec libxvid -acodec libfaac

j0ehill
October 28th, 2007, 03:45 AM
Not sure if this has already come up, but the script needs to be corrected for recent revisions of ffmpeg. For -acodec, it should now be 'libfaac', and for the various bitrates you now need to add 'kb'.

I've modified it a bit for my own personal use, but here is how it looks for me:



ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -b 1200kb -qmin 3 -qmax 5 -g 300 -acodec libfaac -ab 192kb -s 320x180 -aspect 16:9 "${output_dir}/${output_file_name}.mp4"


I put together a batch encoding version which is not interactive, goes like this:



for i in *.avi; do ffmpeg -i $i -f mp4 -vcodec mpeg4 -b 1200kb -qmin 3 -qmax 5 -g 300 -acodec libfaac -ab 192kb -s 320x180 -aspect 16:9 `basename $i .avi`.encoded.mp4; done;


I've taken out the maxrate part, which does not seem to be necessary, and mine is customized for 16:9 videos, so major YMMV here. There is a version of the command for ipod video on the ffmpeg FAQ which produces higher quality output without a really huge increase in the file size here (http://ffmpeg.mplayerhq.hu/faq.html#SEC18).

Hope this helps somebody!

mukiex
October 31st, 2007, 12:59 AM
I'm getting the "Unknown Codec" error even when I swap to libfaac. I got it when I installed ffmpeg under Ubuntu (Gutsy) and I even got it after I upgraded ffmpeg with the Medibuntu repository. It just says,

Unknown codec 'libfaac'

dm1024
November 8th, 2007, 07:39 AM
I've built a package using checkinstall.
You can try it: http://dmitry.shaposhnik.name/misc/ffmpeg_20071107-1_i386.deb

This is trunk, checked out yesterday. Hope it will be useful.
Btw, you need to install libfaac0 package from ubuntu's repository.

I've converted video for my iPod using this command:

ffmpeg -i "$file" -f mp4 -vcodec mpeg4 -b 700k -aspect 4:3 -r 23.98 -s 320x240 -acodec libfaac -ar 48000 "$file.mp4"

And than transfered to iPod using iTunes. All files except one was transfered successfully, just one was failed with words "iPod will not be able to play this video, so it was not transfered". This video was converted than with iTunes and after that uploaded well.

fululian
November 11th, 2007, 03:31 AM
ffmpeg -i "$file" -f mp4 -vcodec mpeg4 -b 700k -aspect 4:3 -r 23.98 -s 320x240 -acodec libfaac -ar 48000 "$file.mp4"



i used this command or the regular script by endersshadow (or the gui), and am able to convert small files and put them onto the ipod. however, whenever i try this out with a larger file (movie, series), i get this message each time:


FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-libmp3lame --enable-libfaadbin --enable-libfaad --enable-libfaac --enable-xvid --enable-x264 --enable-amr_nb --enable-amr_wb --enable-shared --prefix=/usr
libavutil version: 1d.49.3.0
libavcodec version: 1d.51.38.0
libavformat version: 1d.51.10.0
built on Oct 1 2007 21:28:55, gcc: 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
Casino: I/O error occured
Usually that means that input file is truncated and/or corrupted.


regardless of the specific file. does anyone have a hint? thanks :(

d00by
November 11th, 2007, 06:58 AM
I am running AMD 64 bit ubuntu gutsy. Are the instructions same for installing on that platform??

fululian
November 11th, 2007, 09:10 PM
it seems vive or its ffmpeg doesn't support


AC-3 Audio, because the output reads


Unsupported codec(id=86020) for input stream #0.1

for an AC-3 audio encoded file.

is there any possibility to change this?

thanks a lot

fululian
November 11th, 2007, 09:14 PM
I just upgraded from Fiesty to 7.10 Gutsy.

ffmpeg ceased working in creating iPod videos, I assume because ffmpeg got updated, and my custom built one got overwritten. So I uninstalled ffmpeg, and followed the steps on the first page of this thread to reinstall it.

When I try to encode a video I get the following:
Unknown encoder 'xvid'

Now I made sure to --enable-libxvid (it's listed at the beginning when ffmpeg is run)

I've also verified that libxvidcore4-dev is installed, and is the most current version...

Any idea why ffmpeg doesn't recognize my xvid codec?

i had this issue too, until i found out that there is now a "risky"-dubbed package in the repositories, where you can get a fully-fledged-medibuntu-powered ffmpeg. did you try this one on? the feisty-how-tos featurin ffmpeg didn't work on my gutsy.

bye

d00by
November 12th, 2007, 11:00 AM
I am getting the following error. what am I missing here? I have amd 64 gutsy.


:~/ffmpeg$ ./configure --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac \
> --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis \
> --enable-libx264 --enable-libxvid --enable-shared --disable-debug
Unknown option "--enable-dc1394".
See ./configure --help for available options.

fululian
November 13th, 2007, 12:03 AM
(the opinion leader on this topic obviously being endersshadow, but here we try to go:)

why, you should just leave the "unknown function" out of the ./configure! since you're a gutsy user, why don't you just retrieve the "risky" package from the repositories (medibuntu/universe)?

greets

d00by
November 13th, 2007, 03:35 AM
How do I 'retrieve' risky package? I went in synaptic. there was no such package.

Unable to use option,--enable-dc1394 ,--enable-libogg, liba52 with ./configure.

When I install ffmpeg without using this option and then try to install vive I get the following error when I give sudo make install command in vive directory



:~/vive-2.0.0$ ./configure --prefix=/usr
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for ffmpeg... yes
checking for vobcopy... yes
checking for mplayer... yes
checking whether DVD is enabled... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... yes (version 2.12.0)
checking pkg-config is at least version 0.9.0... yes
checking for libgnome... configure: error: Package requirements (libgnome-2.0 >= 2.0) were not met:

No package 'libgnome-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libgnome_CFLAGS
and libgnome_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

fululian
November 13th, 2007, 03:44 AM
well, simply look into the repositories, "search" for ffmpeg and you'll get this one - ffmpeg - 3:0.cvs20070307-5ubuntu4+medibuntu1 - description:


multimedia player, server and encoder
This package contains the ffplay multimedia player, the ffserver streaming
server and the ffmpeg audio and video encoder. They support most existing
file formats (AVI, MPEG, OGG, Matroska, ASF...) and encoding formats (MPEG,
DivX, MPEG4, AC3, DV...).

This package is built with the "risky" option, to enable mp3/mp4/h264/amr
support. Therefore, it is in Medibuntu as it might violate patents.

This package isn't supported by Ubuntu: DON'T REPORT BUGS TO UBUNTU!

Please report any bug to our bug tracker instead:
https://bugs.launchpad.net/medibuntu/+bugs

do you get the same when browsing your repos?

bye

randomphrase
November 19th, 2007, 11:53 PM
I'm getting the "Unknown Codec" error even when I swap to libfaac. I got it when I installed ffmpeg under Ubuntu (Gutsy) and I even got it after I upgraded ffmpeg with the Medibuntu repository. It just says,

Unknown codec 'libfaac'

Same here, having a hell of a time finding a solution. Searching doesn't seem to be turning up anything useful:

Installed ffmpeg from medibuntu? Yes
aac appears in ffmpeg -formats? Yes
Using the -acodec libfaac command line option? Yes
libavcodec1d installed from medibuntu? Yes


FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-libmp3lame --enable-libfaadbin --enable-libfaad --enable-libfaac --enable-xvid --enable-x264 --enable-amr_nb --enable-amr_wb --enable-shared --prefix=/usr
libavutil version: 1d.49.3.0
libavcodec version: 1d.51.38.0
libavformat version: 1d.51.10.0
built on Nov 17 2007 21:14:42, gcc: 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)

Any ideas appreciated.

kryrinn
November 24th, 2007, 10:57 PM
Newbie here... I have libraw1394-dev installed (as it seemed to appear in an earlier post in this thread was necessary)

This is what I get:

ffmpeg: error while loading shared libraries: libraw1394.so.5: cannot open shared object file: No such file or directory

mukiex
November 25th, 2007, 12:41 PM
randomphrase :
Your post just fixed it for me, and this is gonna **** you off beyond recognition :
I installed libavcodec1d and it installed a bunch of stuff. However, "-acodec libfaac" still didn't work. Guess what?

Change libfaac back to aac. It's in /usr/local/thinliquidfilm/main.py if you're using TLF. Now it effin' works just fine. ERGG.

randomphrase
November 27th, 2007, 12:59 AM
randomphrase :
Your post just fixed it for me, and this is gonna **** you off beyond recognition :
I installed libavcodec1d and it installed a bunch of stuff. However, "-acodec libfaac" still didn't work. Guess what?

Change libfaac back to aac. It's in /usr/local/thinliquidfilm/main.py if you're using TLF. Now it effin' works just fine. ERGG.

Ah. Thanks, that works for me.

Also -vcodec h264 is required instead of -vcodec libx264 in my case.

I ended up compiling ffmpeg myself to get around the problem. In the latest svn sources it looks like they reverted the change so that in the next upgrade to ffmpeg we'll be back to using -acodec libfaac again... :(

buildid
December 7th, 2007, 12:24 AM
http://h264enc.sourceforge.net/

This script works verry well for the ipod nano, i already have done some files well dvd tp ipod nano format

kahuuna
December 30th, 2007, 02:11 PM
http://h264enc.sourceforge.net/

This script works verry well for the ipod nano, i already have done some files well dvd tp ipod nano format

Thank this is the very thing I was looking for to transcode my large videos off my Canon camera into something more compressed. Now if I could only figure out how to batchencode them from a certain directory by fetching the avis recursively from folders inside...

samk
January 3rd, 2008, 02:28 PM
Hi,
I built vive from the svn, and it seems that it does not change the resolution of the output to what is specified in the preferences. ipodvidenc does in fact when i run it against the same vob file. Vive does encode the video, I can import the file into itunes but i cant sync the file to my ipod. I believe it may be because the .mp4 file is at at 720x480.
BTW it's an ipod classic i'm working with. Thanks for any info.

Great Program

sam

reclusivemonkey
January 5th, 2008, 02:55 PM
Followed instructions on the front page. When trying make from source (for Vive), not the betas, I get;


monkey@mother:~/vive-2.0.0$ make
make all-recursive
make[1]: Entering directory `/home/monkey/vive-2.0.0'
Making all in src
make[2]: Entering directory `/home/monkey/vive-2.0.0/src'
gcc -g -O2 -D PREFIX=\"/usr\" -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -DORBIT2=1 -pthread -I/usr/include/libgnome-2.0 -I/usr/include/orbit-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/gail-1.0 -I/usr/include/atk-1.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/libpng12 -pthread -DORBIT2=1 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -o vive error.o interface.o options.o preferences.o presets.o combo_menus.o encode.o dvd.o tooltips.o vive.o -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lpango-1.0 -lcairo -lX11 -lXfixes -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -pthread -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lgmodule-2.0 -ldl -lORBit-2 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0 -pthread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lpango-1.0 -lcairo -lX11 -lXfixes -lgconf-2 -lgmodule-2.0 -ldl -lORBit-2 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0 -pthread -lgnomevfs-2 -lgconf-2 -lgmodule-2.0 -ldl -lORBit-2 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0 -lvte
combo_menus.o: In function `populate_ffmpeg':
/home/monkey/vive-2.0.0/src/combo_menus.c:38: undefined reference to `av_register_all'
/home/monkey/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/monkey/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/monkey/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_avcodec'
/home/monkey/vive-2.0.0/src/combo_menus.c:94: undefined reference to `first_avcodec'
collect2: ld returned 1 exit status
make[2]: *** [vive] Error 1
make[2]: Leaving directory `/home/monkey/vive-2.0.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/monkey/vive-2.0.0'
make: *** [all] Error 2

Any advice? Currently I find it a hell of a lot easier to boot into Windows to manage my iPod as gtkpod won't let me import any album art (asked on the thread and no replies) and without this working I can't get any videos on. I'm seriously thinking of saving for a Mac Mini now as Gutsy just isn't cutting it for me any more.

orgyn
January 5th, 2008, 07:02 PM
thx very much for this, it worked great!

Bokonon
January 8th, 2008, 04:17 AM
This has really worked well for me. I use the script, but installed the necessary programs separately.

My videos look & sound very good on my Nano 3G with your default settings, plus the size is acceptable. 230-430 MB per DVD.

I tried the other script linked here, which gives you a lot more power, but the files end up larger and for me it is a bit of an overload of options. For power users, that might be a better option, but for me, I like this script and the KISS principle applies.

m4cks
January 13th, 2008, 02:45 AM
/home/maxx/vive-2.0.0/src/combo_menus.c:38: undefined reference to `av_register_all'
/home/maxx/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/maxx/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/maxx/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_avcodec'
/home/maxx/vive-2.0.0/src/combo_menus.c:94: undefined reference to `first_avcodec'


I have libavformat (and libavformt-dev) and libavcodec (and libavcodec-dev) install AND as was recommended previously, I compiled ffmpeg from latest svn using --enabled-shared.

it's just not linking on gutsy. any info is appreciated.

jak-_-
January 13th, 2008, 07:20 AM
mpeg4ip never seems to compile on any version, need it for libmp4v2 which is needed for gtkpod to be able to sync .mp4 videos... Any ideas?


./../include/grayc.hpp:106: error: extra qualification 'CU8Image::' on member 'upsampleForSpatialScalability'
./../include/grayc.hpp:115: error: extra qualification 'CU8Image::' on member 'upsampleSegForSpatialScalability'
./../include/vopses.hpp:813: error: extra qualification 'CVideoObject::' on member 'filterCodedPictureForRRV'
make[6]: *** [sys_block.lo] Error 1
make[6]: Leaving directory `/home/meez/sources/mpeg4ip-1.4.1/common/video/iso-mpeg4/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/meez/sources/mpeg4ip-1.4.1/common/video/iso-mpeg4'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/meez/sources/mpeg4ip-1.4.1/common/video/iso-mpeg4'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/meez/sources/mpeg4ip-1.4.1/common/video'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/meez/sources/mpeg4ip-1.4.1/common'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/meez/sources/mpeg4ip-1.4.1'
make: *** [all] Error 2

Sweetrelease
January 13th, 2008, 09:17 PM
ok, i got it working, but is there a way to add the
MP4Box -add videofile.mov videofile.mov
to the ipodvidenc script so its all done in one sweep

rshel
January 23rd, 2008, 05:54 AM
The audio codec options do not show aac or mp3 as choices. Am I doing something wrong?
Thanks!

rshel
January 23rd, 2008, 04:09 PM
Temporarily lost all sound on Ubuntu until removing Vive and ffmpeg folder created in home folder. What?

money2themax
January 28th, 2008, 07:17 AM
i want to convert .Divx to .mp4 for an ipod 5.5G 30GB White Firmware 1.2.1

i also have the newest Rockbox for this iPod

money2themax
January 28th, 2008, 09:30 AM
bump

mocha
January 29th, 2008, 11:01 PM
I find that by far the easiest way to convert anything to Ipod compatible formats is with an ffmpeg frontend called WinFF. Search for it. The author BiggMatt has made a number of presets for Ipod, and there are some members of the WinFF forum that have posted numerous presets as well. You can create your own very easily. WinFF also allows you to enter overrides for things like bitrate, aspect ratio, sampling frequency, etc. The latest version supports drag and drop and even adds the "-threads 2" for dual core processors in the preferences. The frontend is good for any general conversion with ffmpeg, it has presets for everything, DVD, wmv, xvid, audio, etc. This is the only stable frontend I have found for ffmpeg. If I need to use mencoder I use ThinLiquidFilm or h264enc (for single files). Everything else I tried crashes too easily or isn't intuitive enough to produce the correct options for a particular format.

money2themax
January 30th, 2008, 01:15 AM
ferpict lol:KS

bttb
February 2nd, 2008, 03:28 PM
For the task of converting videos for your iPod there's also avi2mp4.sh.

Requirements:

- coreutils
- bc calculator
- findutils
- faac audio encoder
- mplayer (with support for your input files)
- mencoder (with x264 support)
- aacgain (to ReplayGain the audio; you should at least have v1.7.0)
- MP4Box (part of the gpac suite; v0.4.4 or later required)

It's a batch encoder. The user simply sets the configuration and then runs the script on as many videos as he/she likes. All one needs to know is in the script's comments.

Hope you give it a shot: Link (http://www.vdr-portal.de/board/thread.php?threadid=73188)

Regards
bttb

kaiesh
February 3rd, 2008, 10:31 PM
Hi,

I followed this tutorial to obtain the SVN version of ffmpeg and tried to encode files for my gf's ipod touch - I found that it didn't work right out of the box...

Once I tweaked it a little bit, I found that I could encode video successfully, but there was no audio playback on her ipod - irrespective of whether or not it was properly imported by itunes.

After some head bashing ](*,), I figured out that the file I was encoding from had an audio track of 5.1 dolby, and the ipod only supports stereo :-P

So, incase this helps anyone else out there, I modded the ./configure command for the SVN version of ffmpeg to read as follows (all other surrounding commands are the same):

./configure --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-libdc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-shared --disable-debug --enable-encoder=aac --enable-encoder=x264 --enable-encoder=msmpeg4v2 --enable-encoder=msmpeg4v3 --enable-encoder=libfaac


and I also modded the ipodvidenc file to address the complaints ffmpeg was giving me about bitrates being in bits and not Kbits, the wrong libraries being used, and also to support conversion that forced audio into stereo, as well as maintained aspect ratios (i.e. adds black padding bars so people don't look stretched tall). As a consequence there is one more flag in the ffmpeg command, and it asks a couple more questions. The ipodvidenc file I use, now reads as follows:


#!/bin/bash
## ipodvidenc - The iPod Video Encoder for Linux.
## Created by Eric Hewitt, January 9, 2006.
## Modified by Kaiesh Vohra, February 3, 2008.
## Released under the GPL. Go nuts.

input_file=$1

echo "What would you like to name the output file (sans extension)?"

read output_file_name

echo "$output_file_name will be located in $PWD. Is this acceptable? [y/n]"

read output_file_loc_permis

if [ $output_file_loc_permis = 'n' ] || [ $output_file_loc_permis = 'N' ]
then
echo "Where would you like to store $output_file_name.mov?"
read output_dir
else
output_dir=$PWD
fi

echo "What height do you want the video to be? Remember that you need to determine this by calculating 240/(orig width/orig height)..."
read new_height

echo "How much padding do you want on the top? Best would be (240 - new height)/2..."
read padding_top

echo "How much padding do you want on the bottom? Best would be (240 - new height)/2..."
read padding_btm

ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1024000 -b 716800 -qmin 3 -qmax 5 -bufsize 4194304 -g 300 -acodec libfaac -ab 196608 -ac 2 -s "320x${new_height}" -padtop "${padding_top}" -padbottom "${padding_btm}" -aspect 4:3 "${output_dir}/${output_file_name}.mp4"


Special thanks to the guys that put this thread together, it was HUGELY useful!

But, like I said - hope my little mod helps someone!
:popcorn:

bdw
March 13th, 2008, 10:12 AM
I get the following error when I try to encode an MP4 from a VOB file, apparently it's missing a codec but I'm not sure which one:


ffmpeg -y -vcodec mpeg4 -b 700k -aspect 16:9 -s 320x180 -acodec aac -ac 2 -ab 192k -comment "Encoded by Vive" -i "/home/bdw/vive_dvd_temp1-1.vob" "/home/bdw/test.mp4"

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --enable-gpl --enable-pp --enable-swscaler --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libogg --enable-libgsm --enable-dc1394 --disable-debug --enable-libmp3lame --enable-libfaadbin --enable-libfaad --enable-libfaac --enable-xvid --enable-x264 --enable-liba52 --enable-amr_nb --enable-amr_wb --enable-shared --prefix=/usr
libavutil version: 1d.49.3.0
libavcodec version: 1d.51.38.0
libavformat version: 1d.51.10.0
built on Dec 20 2007 21:25:50, gcc: 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)

Seems stream 0 codec frame rate differs from container frame rate: 29.97 (30000/1001) -> 59.94 (60000/1001)
Input #0, mpeg, from '/home/bdw/vive_dvd_temp1-1.vob':
Duration: 00:03:00.1, start: 0.045500, bitrate: 180763 kb/s
Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480, 7500 kb/s, 59.94 fps(r)
Stream #0.1[0x80]: Audio: ac3, 48000 Hz, 5:1, 384 kb/s
Stream #0.2[0x81]: Audio: ac3, 48000 Hz, mono, 192 kb/s
Stream #0.3[0x83]: Audio: ac3
Output #0, mp4, to '/home/bdw/logansrun.mp4':
Stream #0.0: Video: mpeg4, yuv420p, 720x480, q=2-31, 700 kb/s, 59.94 fps(c)
Stream #0.1: Audio: aac, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Error while opening codec for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height


Needless to say, this is driving me bonkers as I can't figure out what's missing on my system. :-(

mocha
March 13th, 2008, 08:45 PM
I think you need to do -acodec libfaac instead of -acodec aac

bdw
March 15th, 2008, 09:01 AM
I think you need to do -acodec libfaac instead of -acodec aac

I gave that a shot but I got the "unknown codec" error. libfaac is enabled in the ffmpeg build so it appears that I'll need to take a different approach.

itsdaveperdue
March 18th, 2008, 09:29 PM
Sorry, maybe I'm late to the party. Have you tried handbrake? It's pretty straightforward.

HandBrake CLI Guide: http://trac.handbrake.fr/wiki/CLIGuide

HandBrake Download Page (including Linux download): http://handbrake.fr/?article=download

There is a handbrake gui called HandBrake GTK, but it apparently isn't an official part of HandBrake and is based on old code. It looks like they're working on a QT gui, but he CLI is super easy to use.

WrathofthePenguin
March 22nd, 2008, 02:04 PM
Ok, I've been having all kinds of fun trying to get Vive installed. When I run the ./configure, I had to use the disable-dvd flag because of the new version of libdvdcss being out. Now, when I run the command:

./configure --prefix=/usr --disable-dvd

The last few lines look like this, so I don't think there's a problem with this:

config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating doc/Makefile
config.status: creating doc/C/Makefile
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands


However, when I run make, I get:

combo_menus.o: In function `populate_ffmpeg':
/home/glenn/Desktop/vive-2.0.0/src/combo_menus.c:38: undefined reference to `av_register_all'
/home/glenn/Desktop/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/glenn/Desktop/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_oformat'
/home/glenn/Desktop/vive-2.0.0/src/combo_menus.c:50: undefined reference to `first_avcodec'
/home/glenn/Desktop/vive-2.0.0/src/combo_menus.c:94: undefined reference to `first_avcodec'
collect2: ld returned 1 exit status
make[2]: *** [vive] Error 1
make[2]: Leaving directory `/home/glenn/Desktop/vive-2.0.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/glenn/Desktop/vive-2.0.0'
make: *** [all] Error 2


What am I missing here?

Thanks!

RJ Hythloday
April 5th, 2008, 11:00 PM
I haven't read all 51 pages yet, but I"m hoping someone can help me get started.

We got my daughter a 6th gen nano and she wants youtube vid's on it.

I've dl some from here http://www.tubeleecher.com/

and renamed them as they dl to the desktop

installed gtkpod the ipod is mounted, I can access the folders etc,

tried to add some vids through gtkpod and got this
The following track could not be processed (filetype unknown): '/home/bob/Amy_youtube_downloads/Best_of_Gir' same thing for allDo I have to reencode them? I'm not sure I've got everything set up right, but she's really anxious to get it working, and I don't want to resort to itunes and a dual boot. help please!

esc1
April 9th, 2008, 04:58 AM
I finally got ffmpeg installed after hours, but now I can't start converting anything b/c I can't even play vids now from the winff frontend.. the error msg I get is

failed to play /usr/bin/ffplay : 127

anyone know what the problem is?

Hotz
April 15th, 2008, 07:35 PM
Thanks For good program

DakoCwerf
June 5th, 2008, 11:43 PM
well, here is how i've done that for ubuntu hardy 8.04

dl ffmpeg

sudo apt-get build-dep ffmpeg
sudo apt-get source ffmpeg
cd ffmpeg-*

now my configure line (yes, you need to do it with sudo)

sudo ./configure --enable-gpl --enable-pp --enable-libvorbis --enable-libogg --enable-liba52 --enable-libdts --enable-dc1394 --enable-libgsm --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-xvid --enable-pthreads --enable-shared
if you are missing some of the libs - just sudo apt-get them (dev versions also)

then

sudo make && sudo make install

then just create a script like it was said in 1st post I will just quote it now


ipodvidenc Script

And last, but certainly not least, you can create a script for converting your videos to iPod Video format.


gedit

This should pop up a blank document. Now, just copy and paste this code into it:


#!/bin/bash
## ipodvidenc - The iPod Video Encoder for Linux.
## Created by Eric Hewitt, January 9, 2006.
## Released under the GPL. Go nuts.

input_file=$1

echo "What would you like to name the output file (sans extension)?"

read output_file_name

echo "$output_file_name will be located in $PWD. Is this acceptable? [y/n]"

read output_file_loc_permis

if [ $output_file_loc_permis = 'n' ] || [ $output_file_loc_permis = 'N' ]
then
echo "Where would you like to store $output_file_name.mov?"
read output_dir
else
output_dir=$PWD
fi

ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1000k -b 700k -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 "${output_dir}/${output_file_name}.mov"

Save as ipodvidenc in your present working directory (it will be moved, anyway). Back in the terminal, run:


chmod 755 ipodvidenc
sudo mv ipodvidenc /usr/bin

Now, when you want to encode a video to iPod format, run this command:


ipodvidenc video.avi

It will run you through a few prompts and then encode the video. You can now use gtkpod to upload the video onto your iPod just like you load mp3's onto it.

after that you can transfer it and watch. don't be scared if you run it on your ubuntu - it will have color problems (mine had all the video a little to the blue). on the ipod it was ok.

hope this helps you.

dmrx24
June 16th, 2008, 10:57 PM
Are there any other decent alternatives to ffmpeg? I am using Hardy 64bit.

bobandiara
June 19th, 2008, 05:16 AM
Hello, guys!
There is a much simpler way, though it takes a lot longer.
If you have a video file in avi, or mpeg formats, you can use Avidemux (sudo apt-get install avidemux) to convert it to the format the iPod understands. It helps a lot if you have the proper codecs (w32codecs and all...) to do that.

First of all, open Avidemux. It is found in your Sound And Video (or whatever is the name in english - I'm a brazilian Ubuntu user :p) menu entry. Then, open the desired file. It may ask you a few questions, like "Rebuild time frame?" and/or "create index?" and many others. Just click "yes", it will help in the final quality of the (re)encoded media.

After that, click on the "Auto" menu, select "IPOD (mpeg4)". A dialog box will popup. If you want, you can change some settings or just leave them be. Click ok.

On the left panel, set video to "MPEG-4 ASP (Xvid4)" and audio to "AAC (FAAC)". If it is your wish, you may change the audio and video settings by clicking the configure button on the respective options, but it is not necessary. Change the format option to "MP4".

After all this, click the save button, define your target directory, the target file name. I recommend the .mp4 extension, to avoid confusion.

Sit down, grab a cup of coffee, tea, beer or whatever you like, and wait for the little brat to do the dirty job ;).

Then, finally, if you haven't done it yet, "sudo apt-get install gtkpod-aac easytag-aac".

"Easytag?", one might ask. Yes, the "easytag-aac" package has support for editing mp4/m4a/aac tags! Edit your tags, if you like, put the files into the iPod the usual way with gtkpod, and enjoy!!!

I recommend Ubuntu 8.04 for the newer iPod owners, for there is no need to patch anything to get things working.

I hope this little text helps.

Sorry about the poor english, and see ya!

mroc
August 1st, 2008, 11:01 PM
Hi all. This may be very obvious to most but I had to look it up, so for the benefit of newer users, I thought I'd make a note:

Just today I tried to run the ./configure command with the options listed in the original post and got one error.

Unknown option "--enable-pp".
See ./configure --help for available options.

A quick google search turned up this link (http://lists.mplayerhq.hu/pipermail/ffmpeg-user/2008-April/015109.html), which states that "--enable-pp recently changed to --enable-postproc"

So if anyone else got this error it's a simple change to make.

Also, thank you to endersshadow for creating and maintaining this thread.

janne_oksanen
October 10th, 2008, 11:38 AM
Something's happened to --enable-liba52 too. I keep getting unknown option on that one and a few google searches came up with nothing.

mocha
October 10th, 2008, 05:15 PM
Something's happened to --enable-liba52 too. I keep getting unknown option on that one and a few google searches came up with nothing.

Search these forums for a thread on how to compile x264 and ffmpeg. Apparently ffmpeg now has its own internal aac and doesn't need the --enable-liba52 anymore.

money2themax
October 13th, 2008, 10:31 PM
those are all windows programs how do they help us linux folk?

fewjr
December 16th, 2008, 03:21 AM
Hello all and endersshadow,
I've been going over everything I can find in google and the forum with getting my ipod to work in Ubuntu. I am using 8.10 now and see that your tutorial was started back in January 2006. I see people are still posting in there as of October 2008. I haven't had time to read through all 70 some pages of the thread. I am working on it, but I was wondering if you could help me out with this. I want to be able to manage my music as well as rip/convert movies to ipod video and put them on my ipod. I have been ripping all my cds to the hard drive using Rhythmbox because my itunes backup of 5000 songs is corrupt...go figure. I ripped a couple DVDs with dvd::rip and converted to H264 with winff. I have gtkpod-aac 0.99.12-1ubuntu-1 installed in synaptic from the multiverse. I cannot get video on my ipod though. There is no video section on the left pane under ipod in gtkpod. I have a thread started here http://ubuntuforums.org/showthread.p...73#post6376673 where I was trying to get help. It shows the files installed for gtkpod. At this link https://help.ubuntu.com/community/iP...20iPod%20Video there is a screenshot showing video in the left pane under ipod. I don't have that. I am using a 5th Generation 30GiG Ipod. If you could help I would appreciate it. I really want to stay out of Windows if at all possible. I have been using Ubuntu since 8.04 and have run into alot of issues. I have been doing my best, but I need help on this one.

Best Regards,
fewjr

Thank You
fewjr

fewjr
December 16th, 2008, 03:39 AM
Okay....reading this thread through and got to the part where you announce that its on the wiki, I see that the screenshot I pointed to is the same screenshot I was looking at. Then I looked under the screenshot and there in nice little letters it says:
Notice I made a playlist just for Video. You don't have to, but it helps organize things. Just click on the Add Files button, select the .mov that you want to transfer to the iPod, and then you're all set.

Is that all I was doing wrong....jeeesh!:oops: What a burnout. Work and 5 daughters...I need a vacation! Well when I get home from work I'll give that a try. I have been reading so many things for so many different issues I'm having with Ubuntu that I guess I just wasn't thinking of something so easy. I'll post if it is working. I tried to use iTunes to put the video I ripped/converted on my Ipod, but it would not let me. I hope gtkpod does.

fewjr

mechoulas
April 25th, 2009, 02:53 AM
the easiest way so far!thanks bobandiara,works perfect on me,I am running ubuntu jaunty and my ipod is 30GB capacity,fifth generation

clanmackay
November 16th, 2009, 03:03 AM
This may have shown up in the 50+ pages of comments, but I don't really feel like reading all of them, so... :-)

ffmpeg -i "${input_file}" -f mp4 -vttc mpeg4 -maxrate 1000k -b 700k -qmin 3 -qmax 5 -bufsize 4096 -g 300 -attc aac -ab 192 -s 320x240 -aspect 4:3 "${output_dir}/${output_file_name}.mov"

This distorts a video if it's not 4:3 to begin with. I found a fix for this, modified some values to get them to work on my system, increased the bitrate and took the size up to VGA (which is supported on newer iPods), and put it on my website, an.omalo.us (link) (http://an.omalo.us/2009/11/13/ffmpeg-and-ipod-in-linux/comment-page-1/#comment-63504). I'm not pasting it here, because I want to retain the ability to modify it if I find a bug. If you find a bug, please post there and I'll fix it.

HTH.