PDA

View Full Version : HowTo: Encode Video for iPod Video



Pages : 1 [2] 3

ubernoob
May 21st, 2006, 10:18 AM
After you have used MP4Box, you should rename your files to mp4 instead of mov. Or else you won't be able to search/skip in the movie.

Does anyone know how to move some of the videos to "Music Videos"?

Sir_Yaro
May 21st, 2006, 05:05 PM
Thanks. I hadn't done that. Where did you find that instruction? It wasn't on the first page here.
It is in a viva configure file

[...]
print "Checking for MP4Box...";
$check{'mp4box'} = `MP4Box -h`;
if ($check{'mp4box'} =~ /not found/i || $check{'mp4box'} !~ /crypt/)
{
print "Not found or incorrect version\n";
die "Please install MP4Box by running:
./install mp4box
Or, run the following commands by yourself:
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac-0.4.0-rc2.tar.gz
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac_extra_libs-0.4.0.tar.gz
tar -zxf gpac-0.4.0-rc2.tar.gz
tar -zxf gpac_extra_libs-0.4.0.tar.gz
cd gpac_extra_libs
cp -r * ../gpac/extra_lib
cd ../gpac
chmod +x configure
./configure
make lib
make apps
make install
sudo cp bin/gcc/libgpac.so /usr/lib\n";
}
else
{
print "Found\n";
}

`perl Makefile.PL`;
[...]

Hikaru79
May 26th, 2006, 03:27 PM
Hi. Just got an iPod video, and this thread was perfect, but I'm getting an error that I cannot understand. It comes when I try to convert AVI files.


[wmv3 @ 0x8335bc8]This decoder is not supposed to produce picture. Dont report this as a bug!
[wmv3 @ 0x8335bc8]Profile value 2 is forbidden


I've tried a few different encode scripts, and I keep getting this.

Any ideas?

Iandefor
May 27th, 2006, 07:25 AM
Hi. Just got an iPod video, and this thread was perfect, but I'm getting an error that I cannot understand. It comes when I try to convert AVI files.


[wmv3 @ 0x8335bc8]This decoder is not supposed to produce picture. Dont report this as a bug!
[wmv3 @ 0x8335bc8]Profile value 2 is forbidden

I've tried a few different encode scripts, and I keep getting this.

Any ideas? That output is from the decoder- which is for wmv. Try encoding in formats other than wmv.

Hikaru79
May 27th, 2006, 04:44 PM
That output is from the decoder- which is for wmv. Try encoding in formats other than wmv.
That doesn't really solve the problem, as the files are in AVI (wmv?) format to begin with. Is there a fix?

--edit--
Doesn't seem to like the matroska wrapper either.


hikaru@navi:/multimedia/animanga/anime/Ghost in the Shell - Standalone Complex$ ipod-encoder -tfv /multimedia/animanga/anime/Ghost\ in\ the\ Shell\ -\ Standalone\ Complex/\[a4e\]Ghost_in_Shell_TV_02\[divx5.2.0\].mkv
Encoding: /multimedia/animanga/anime/Ghost in the Shell - Standalone Complex/[a4e]Ghost_in_Shell_TV_02[divx5.2.0].mkv
--> iPod video, 2891148206x1305088130:
/multimedia/animanga/anime/Ghost in the Shell - Standalone Complex/[a4e]Ghost_in_Shell_TV_02[divx5.2.0].mkv
Converting to iPod: 480x208
ffmpeg -i "/multimedia/animanga/anime/Ghost in the Shell - Standalone Complex/[a4e]Ghost_in_Shell_TV_02[divx5.2.0].mkv" -r 20 -t 00:00:10 -y -vcodec xvid -vtag mp4v -b 1024 -acodec aac -ac 2 -ab 128 -f mp4 -s 480x208 "/multimedia/animanga/anime/Ghost in the Shell - Standalone Complex/[a4e]Ghost_in_Shell_TV_02[divx5.2.0].mkv"
ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-zlib --enable-vorbis --enable-libogg --enable-theora --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid
built on May 26 2006 10:17:36, gcc: 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)
[matroska @ 0x82c7660]Ignoring seekhead entry for ID=0x1549a966
[matroska @ 0x82c7660]Ignoring seekhead entry for ID=0x1654ae6b
[matroska @ 0x82c7660]Ignoring seekhead entry for ID=0x114d9b74
[matroska @ 0x82c7660]Ignoring seekhead entry for ID=0x1043a770
[matroska @ 0x82c7660]Unknown entry 0x7ba9 in info header
[matroska @ 0x82c7660]Unknown entry 0x73a4 in info header
[matroska @ 0x82c7660]Unknown track header entry 0x23314f - ignoring
[matroska @ 0x82c7660]Unknown track header entry 0x23314f - ignoring
[matroska @ 0x82c7660]Unknown audio track header entry 0x78b5 - ignoring
[matroska @ 0x82c7660]Unknown track header entry 0x23314f - ignoring
[matroska @ 0x82c7660]Unknown audio track header entry 0x78b5 - ignoring
[matroska @ 0x82c7660]Unknown track header entry 0x23314f - ignoring
[matroska @ 0x82c7660]Unknown track header entry 0x23314f - ignoring
[matroska @ 0x82c7660]Unknown track header entry 0x6d80 - ignoring
[matroska @ 0x82c7660]Unknown track header entry 0x23314f - ignoring
[matroska @ 0x82c7660]Unknown track header entry 0x6d80 - ignoring
[matroska @ 0x82c7660]Unknown matroska file header ID 0x1043a770
[matroska @ 0x82c7660]Unknown/unsupported CodecID A_AAC/MPEG4/LC/SBR.
[matroska @ 0x82c7660]Unknown/unsupported CodecID A_AAC/MPEG4/LC/SBR.

Seems that stream 0 comes from film source: 1000.00 (1000/1) -> 24.00 (24/1)
Input #0, matroska, from '/multimedia/animanga/anime/Ghost in the Shell - Standalone Complex/[a4e]Ghost_in_Shell_TV_02[divx5.2.0].mkv':
Duration: N/A, bitrate: N/A
Stream #0.0: Video: mpeg4, yuv420p, 640x352, 1000.00 fps
Stream #0.1: Audio: 0x0000, 22050 Hz, 5:1
Stream #0.2: Audio: 0x0000, 22050 Hz, 5:1
Resampling with input channels greater than 2 unsupported.Can't resample. Aborting.
Abort at ffmpeg.c:1704

drobvice
June 3rd, 2006, 05:34 AM
I have been using Vive to convert some avi videos I...uh...obtained and it fails if there is a space in the title. I did not have this issue with the ipodvidenc script or the 1.5 gui. So if it was called, say, "24 Season 2 Episode 3", Vive would not convert it but if I replace all spaces with an _ underscore, it would work fine. Is there a way around this? I don't mind renaming files but if I have many episodes to do (something like 24 of them) it gets cumbersome. And like I said, it wasn't a problem with ipodvidenc. Failing that, is there an easy way to replace spaces with underscores in a folder full of files?

endersshadow
June 3rd, 2006, 05:20 PM
I have been using Vive to convert some avi videos I...uh...obtained and it fails if there is a space in the title. I did not have this issue with the ipodvidenc script or the 1.5 gui. So if it was called, say, "24 Season 2 Episode 3", Vive would not convert it but if I replace all spaces with an _ underscore, it would work fine. Is there a way around this? I don't mind renaming files but if I have many episodes to do (something like 24 of them) it gets cumbersome. And like I said, it wasn't a problem with ipodvidenc. Failing that, is there an easy way to replace spaces with underscores in a folder full of files?

This is a bug fix that's coming within the week in the next Vive, I'm just packaging it up right now, but if you can't wait that long, do this:


sudo gedit /usr/bin/vive

And then right after line 72, which is this:


$ffmpeginfo{'infile'} = $file_input->get_text();

Insert this:


$ffmpeginfo{'infile'} =~ s/\ /\\\ /g;

And then after the next line (the output line), just do this:


$ffmpeginfo{'output'} =~ s/\ /\\\ /g;

So that the entire block of code should look like (starting at line 72):


$ffmpeginfo{'infile'} = $file_input->get_text();
$ffmpeginfo{'infile'} =~ s/\ /\\\ /g;
$ffmpeginfo{'output'} = $output_entry->get_text();
$ffmpeginfo{'output'} =~ s/\ /\\\ /g;

And that be that.

drobvice
June 3rd, 2006, 06:50 PM
I haven't tried inserting the code yet but thanks!! Looking forward to the next release.

endersshadow
June 5th, 2006, 02:49 AM
News:

Vive 0.3 Beta 2 released today! Grab it at vive.sourceforge.net (http://vive.sourceforge.net)!

drobvice
June 5th, 2006, 05:44 PM
I get the following on ./configure:

desktop:~/Download/vive-0.3$ ./configure
syntax error at ./configure line 119, near "/."
Execution of ./configure aborted due to compilation errors.

INMCM
June 5th, 2006, 10:45 PM
Ditto on the Line 119 error. Tried to fiddle with the code to make it work, but no go.

endersshadow
June 5th, 2006, 10:56 PM
I've reuploaded the file to Sourceforge and attached it here.

You can simply right click and save as in the Vive-0.3 directory, then do this:


mv configure.txt configure
chmod 755 configure

Then proceed w/ the ./configure etc...sorry about that!

Edit: Fixed it...seriously.

drobvice
June 6th, 2006, 07:26 AM
I followed above instructions and got this:

desktop:~/Download/vive-0.3$ ./configure
Bareword found where operator expected at ./configure line 119, near "/vive/preferences"
(Missing operator before preferences?)
syntax error at ./configure line 119, near "/vive/preferences"
Execution of ./configure aborted due to compilation errors.

I tried downloading the current 0.3 beta 2 and starting over and got the same message as before:

desktop:~/Download/vive-0.3$ ./configure
syntax error at ./configure line 119, near "/."
Execution of ./configure aborted due to compilation errors.

endersshadow
June 6th, 2006, 10:59 PM
You know those days you have when you do something quick because you think you've diagnosed the problem and then you realize that you, in fact, have only made said problem worse when it was a simple problem to begin with? That was yesterday.

It's seriously fixed this time. I tested it...something I failed to do after adding that part twice...lesson: learned.

drobvice
June 7th, 2006, 05:31 AM
Trust me. You will get no complaints from me. Looking forward to trying it out (at work right now). Out of curiosity, what was wrong? I looked at the code and tried to "fix" it but the missing operator I had no clue on...I know nothing about writing code at all.

endersshadow
June 7th, 2006, 11:45 AM
Trust me. You will get no complaints from me. Looking forward to trying it out (at work right now). Out of curiosity, what was wrong? I looked at the code and tried to "fix" it but the missing operator I had no clue on...I know nothing about writing code at all.

I forgot to put the path name in quotes :oops:

ubernoob
June 8th, 2006, 04:37 PM
last time i tried to convert a dvd in widescreen to the ipod, it stretches the image, instead of making a black border on the top and bottom. Do you know how to keep the original aspect ratio?

endersshadow
June 9th, 2006, 03:04 AM
last time i tried to convert a dvd in widescreen to the ipod, it stretches the image, instead of making a black border on the top and bottom. Do you know how to keep the original aspect ratio?

Either specify the Aspect Ratio in Vive or leave it blank and it will take it from the video.

drobvice
June 9th, 2006, 04:35 PM
I created a profile for iPod Widescreen on my copy. Change aspect to 16:9 and make it 180x320. Don't forget to save a .mp4 for scrolling on the pod!

*Edit*

enders, would you like bug/feature requests submitted to this thread or sourceforge?

endersshadow
June 9th, 2006, 10:44 PM
I created a profile for iPod Widescreen on my copy. Change aspect to 16:9 and make it 180x320. Don't forget to save a .mp4 for scrolling on the pod!

*Edit*

enders, would you like bug/feature requests submitted to this thread or sourceforge?

This thread, a PM, or my email box at endersshadow at users dot sourceforge dot net would probably be best, since those are the things I check most often :)

drobvice
June 9th, 2006, 11:37 PM
When I choose an avi file to convert, the preview button chokes. If I run from terminal, I get no messages and have to force quit the app. Also, the version number still shows 0.1 alpha 2 in help-->about. Let me know if this is an error with my setup or if it's working for you.

endersshadow
June 9th, 2006, 11:41 PM
When I choose an avi file to convert, the preview button chokes. If I run from terminal, I get no messages and have to force quit the app. Also, the version number still shows 0.1 alpha 2 in help-->about. Let me know if this is an error with my setup or if it's working for you.

The Help->About thing is definitely not something wrong with your setup...solamente my laziness. As per the AVI file, I'm not at my computer right now and I'm on a Windows 2000 box, so testing it is not in the works for me tonight. If you could run the file through ffmpeg via the command line just to get what its video and audio input codecs are and post that output here, that'd be a helpful, as AVI is just a container format.

Thanks!

ubernoob
June 10th, 2006, 06:42 PM
im trying to copy a dvd from a iso image.

I mount the iso with: mount -o loop -t iso9660 file.iso /media/virtualdisc

So in vive, i have set both the device and mount point to be /media/virtualdisc in its own profile. (Btw... why do all the profile have to have the same device? If i change one, they all changes)


I only get this error message:



Use of uninitialized value in substitution (s///) at /usr/bin/cpdvd line 76.
Vobcopy 0.5.14 - GPL Copyright (c) 2001 - 2004 robos@muon.de
[Hint] All lines starting with "libdvdread:" are not from vobcopy but from the libdvdread-library

path to dvd: /dev/loop0
libdvdread: Using libdvdcss version 1.2.5 for DVD access
libdvdread: Could not open /dev/loop0 with libdvdcss.
libdvdread: Can't open /dev/loop0 for reading

[Error] Path thingy didn't work '(null)'
[Error] Try someting like -i /cdrom, /dvd or /mnt/dvd
ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-zlib --enable-vorbis --enable-libogg --enable-theora --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid
built on May 20 2006 21:01:41, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
/data/vive_dvd_temp*.vob: I/O error occured
Usually that means that input file is truncated and/or corrupted.

drobvice
June 11th, 2006, 04:25 AM
If you could run the file through ffmpeg via the command line just to get what its video and audio input codecs are and post that output here, that'd be a helpful, as AVI is just a container format.

Thanks!

The video converts with no problems. It's just that the preview doesn't work. I think it just opens totem to play but that isn't happening. Previously, I would get a message regarding not being able to find the file due to the spaces present but now it doesn't.

endersshadow
June 12th, 2006, 01:23 AM
im trying to copy a dvd from a iso image.

I mount the iso with: mount -o loop -t iso9660 file.iso /media/virtualdisc

So in vive, i have set both the device and mount point to be /media/virtualdisc in its own profile. (Btw... why do all the profile have to have the same device? If i change one, they all changes)


I only get this error message:



Use of uninitialized value in substitution (s///) at /usr/bin/cpdvd line 76.
Vobcopy 0.5.14 - GPL Copyright (c) 2001 - 2004 robos@muon.de
[Hint] All lines starting with "libdvdread:" are not from vobcopy but from the libdvdread-library

path to dvd: /dev/loop0
libdvdread: Using libdvdcss version 1.2.5 for DVD access
libdvdread: Could not open /dev/loop0 with libdvdcss.
libdvdread: Can't open /dev/loop0 for reading

[Error] Path thingy didn't work '(null)'
[Error] Try someting like -i /cdrom, /dvd or /mnt/dvd
ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-zlib --enable-vorbis --enable-libogg --enable-theora --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid
built on May 20 2006 21:01:41, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
/data/vive_dvd_temp*.vob: I/O error occured
Usually that means that input file is truncated and/or corrupted.


Quite frankly, I never foresaw this occurance. The setting is global for all presets, since it just sets the node and path to your DVD for cpdvd, though in Dapper, the node will become obsolete, I've left it in for those running legacy software. I'll look at including it in the next release


The video converts with no problems. It's just that the preview doesn't work. I think it just opens totem to play but that isn't happening. Previously, I would get a message regarding not being able to find the file due to the spaces present but now it doesn't.

If you'd like to fix this, you can edit it yourself (and thanks for the bug find, btw):

After line 1600, which is this:


my $file_play = $file_input->get_text();

Simply add this line:


$file_play =~ s/\ /\\\ /g;

And all will be fixed :-D

ubernoob
June 14th, 2006, 02:22 AM
More to debug: :D


Use of uninitialized value in substitution (s///) at /usr/bin/cpdvd line 76.
WARNING **: invalid source position for horizontal gradient
Vobcopy 0.5.14 - GPL Copyright (c) 2001 - 2004 robos@muon.de
[Hint] All lines starting with "libdvdread:" are not from vobcopy but from the libdvdread-library

path to dvd: /dev/hdc
libdvdread: Using libdvdcss version 1.2.5 for DVD access
There are 12 titles on this DVD.
[Error] Invalid title 0.
ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-zlib --enable-vorbis --enable-libogg --enable-theora --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid
built on May 20 2006 21:01:41, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
/home/vive_dvd_temp*.vob: I/O error occured
Usually that means that input file is truncated and/or corrupted.



Btw if you find a way that i can copy directly from iso, that would be greate!

hanzomon4
July 17th, 2006, 10:45 PM
This is really neat.
I have an error on an some avi files can't make an any sense of it.

.avi':
Duration: 01:14:06.4, start: 0.000000, bitrate: 1154 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 704x464, 30000.00 fps
Stream #0.1: Audio: mp3, 44100 Hz, stereo, 128 kb/s
File '/home/hanzomon4/test.mov' already exists. Overwrite ? [y/N] y
Output #0, mp4, to '/home/hanzomon4/test.mov':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, 29.97 fps, q=3-5, 700 kb/s
Stream #0.1: Audio: aac, 44100 Hz, stereo, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0x83346a8]timebase not supported by mpeg 4 standard
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height

endersshadow
July 18th, 2006, 03:21 AM
This is really neat.
I have an error on an some avi files can't make an any sense of it.

.avi':
Duration: 01:14:06.4, start: 0.000000, bitrate: 1154 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 704x464, 30000.00 fps
Stream #0.1: Audio: mp3, 44100 Hz, stereo, 128 kb/s
File '/home/hanzomon4/test.mov' already exists. Overwrite ? [y/N] y
Output #0, mp4, to '/home/hanzomon4/test.mov':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, 29.97 fps, q=3-5, 700 kb/s
Stream #0.1: Audio: aac, 44100 Hz, stereo, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0x83346a8]timebase not supported by mpeg 4 standard
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height

What parameters did you use when trying to encode this?

hanzomon4
July 18th, 2006, 08:50 AM
None. I had no idea you could set parameters.
I'll try that video again see if I can get it work.

OrganicPanda
July 18th, 2006, 11:00 AM
hey this sounds really good but following the guide i'm having install problems, par example:

the configure stage works well up untill:



...snip...
gcc -O3 -Wall -Wno-switch -DHAVE_AV_CONFIG_H -I.. -I'/home/panda/ffmpeg-0.cvs20050918'/libavutil -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o faad.o faad.c
faad.c:29:18: error: faad.h: No such file or directory
faad.c:57: error: syntax error before ‘faacDecHandle’
faad.c:57: warning: no semicolon at end of struct or union
faad.c:58: error: syntax error before ‘*’ token
faad.c:58: error: syntax error before ‘hDecoder’
faad.c:58: warning: type defaults to ‘int’ in declaration of ‘faacDecConfigurationPtr’
faad.c:58: error: ‘faacDecConfigurationPtr’ declared as function returning a function
faad.c:58: warning: data definition has no type or storage class
faad.c:60: error: syntax error before ‘hDecoder’
faad.c:62: error: syntax error before ‘hDecoder’
faad.c:66: error: syntax error before ‘hDecoder’
faad.c:69: error: syntax error before ‘hDecoder’
faad.c:92: error: syntax error before ‘hDecoder’
faad.c:95: warning: type defaults to ‘int’ in declaration of ‘FAACContext’
faad.c:95: warning: data definition has no type or storage class
faad.c: In function ‘faac_init_mp4’:
faad.c:105: error: ‘s’ undeclared (first use in this function)
faad.c:105: error: (Each undeclared identifier is reported only once
faad.c:105: error: for each function it appears in.)
faad.c:105: error: syntax error before ‘)’ token
faad.c: In function ‘faac_decode_frame’:
faad.c:133: error: ‘s’ undeclared (first use in this function)
faad.c:133: error: syntax error before ‘)’ token
faad.c:136: warning: unused variable ‘sample_buffer’
faad.c: In function ‘faac_decode_end’:
faad.c:179: error: ‘s’ undeclared (first use in this function)
faad.c:179: error: syntax error before ‘)’ token
faad.c: In function ‘faac_decode_init’:
faad.c:190: error: ‘s’ undeclared (first use in this function)
faad.c:190: error: syntax error before ‘)’ token
faad.c:212: error: ‘faacDecOpen’ undeclared (first use in this function)
faad.c:213: error: ‘faacDecGetCurrentConfiguration’ undeclared (first use in this function)
faad.c:260: error: ‘faac_cfg’ undeclared (first use in this function)
faad.c:287: error: ‘LC’ undeclared (first use in this function)
make[1]: *** [faad.o] Error 1
make[1]: Leaving directory `/home/panda/ffmpeg-0.cvs20050918/libavcodec'
make: *** [lib] Error 2



what can i do to remedy this?
cheers,


EDIT: i got vive working from the sbx packages but when trying to use it the encode button doesnt work lol, it looks like an excellent program aswell](*,)

hanzomon4
July 19th, 2006, 12:21 AM
What parameters did you use when trying to encode this?

I am using the parameters in the ipodvidence script
-f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 test.mo

Could it have some thing to do with the bitrate being to high, for this perticular video the bitrate is
bitrate: 1154 kb/s

Also in all of the videos seeking does not work

EDIT: The seek problem is with gtkpod
# Mark Duncan Says:
December 24th, 2005 at 8:40 pm

Getting movies to ffw and rew with gtkpod:

Drag your movie over to your iPod with gtkpod
Right-click on the movie and click on “Edit details”
Go to the “General” tab and set the play time.
Click Apply and OK.
Sync

The problems comes from gtkpod setting a 0:00 play time for all movies. Manually setting it has worked for every movie I put on so far. I will see about making a patch so gtkpod does this automatically tomorrow.

EDIT Again:I fixed all of my problems even the seek problem by changing the the command at the end of the ipodvidenc to this
ffmpeg -vcodec xvid -b 300 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 96 -i "${input_file}" -s 320x240 -aspect 4:3 "${output_dir}/${output_file_name}.mp4"

I found the command at this website (http://atomized.org/2005/11/converting-video-to-play-on-your-ipod-with-ffmpeg/)
I'm not sure what all of the parameters mean but it has a higher buffer size(so that fixed my first problem)and all of the videos had the correct play time(fixing the seek issue with out editing the play time in gtkpod).

If anybody with a better understanding of ffmpeg could explain what the options mean and why it fixed my problems I would greatly appreciate it.

Okay I think thats all.

jms830
July 19th, 2006, 03:52 PM
whenever I try to install vive 0.3 from source, it tells me I need mp4box. so then i follow the instructions to install gpac. however, it always fails when I "make install", I think due to some errors from the other make commands. Any help? Or maybe someone could post a .deb for the new vive? Here is my output


sudo make install
install -d "/usr/local/bin"
install -c -s -m 755 bin/gcc/MP4Box "/usr/local/bin"
install -c -s -m 755 bin/gcc/MP42Avi "/usr/local/bin"
make -C applications install
make[1]: Entering directory `/home/jordan/Desktop/vive-0.3/gpac/applications'
for i in mp4client osmozilla ; do make -C $i install; done
make[2]: Entering directory `/home/jordan/Desktop/vive-0.3/gpac/applications/mp4client'
rm -f main.o ../../bin/gcc/MP4Client
make -override BUILD_INSTALL=yes all
make[3]: Entering directory `/home/jordan/Desktop/vive-0.3/gpac/applications/mp4client'
gcc -O3 -fno-strict-aliasing -Wall -I/home/jordan/Desktop/vive-0.3/gpac/include -DGPAC_MODULES_PATH=\"/usr/local/lib/gpac\" -c -o main.o main.c
gcc -Wl,--warn-common -o ../../bin/gcc/MP4Client main.o -L../../bin/gcc -lgpac
make[3]: Leaving directory `/home/jordan/Desktop/vive-0.3/gpac/applications/mp4client'
install -c -s -m 755 ../../bin/gcc/MP4Client "/usr/local/bin"
make[2]: Leaving directory `/home/jordan/Desktop/vive-0.3/gpac/applications/mp4client'
make[2]: Entering directory `/home/jordan/Desktop/vive-0.3/gpac/applications/osmozilla'
g++ -O3 -fno-strict-aliasing -Wall -I/home/jordan/Desktop/vive-0.3/gpac/include -I/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk -I/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/plugin/include -I/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/nspr/include -I/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/java/include -I/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/xpcom/include -DXP_UNIX -DMOZ_X11 -DNPBASIC_EXPORTS -DMOZILLA_STRICT_API -DXPCOM_GLUE -c -o osmozilla.o osmozilla.cpp
In file included from osmozilla.cpp:44:
osmozilla.h:50:27: error: X11/Intrinsic.h: No such file or directory
/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/xpcom/include/nsISupportsBase.h:80: warning: ‘class nsISupports’ has virtual functions but non-virtual destructor
/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/xpcom/include/nsIServiceManager.h:40: warning: ‘class nsIServiceManager’ has virtual functions but non-virtual destructor
/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/xpcom/include/nsIMemory.h:54: warning: ‘class nsIMemory’ has virtual functions but non-virtual destructor
/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/xpcom/include/nsIProgrammingLanguage.h:32: warning: ‘class nsIProgrammingLanguage’ has virtual functions but non-virtual destructor
/home/jordan/Desktop/vive-0.3/gpac/extra_lib/include/gecko-sdk/xpcom/include/nsIClassInfo.h:33: warning: ‘class nsIClassInfo’ has virtual functions but non-virtual destructor
nsIOsmozilla.h:25: warning: ‘class nsIOsmozilla’ has virtual functions but non-virtual destructor
osmozilla.h:68: warning: ‘class nsPluginInstanceBase’ has virtual functions but non-virtual destructor
osmozilla.h:178: error: ‘Widget’ does not name a type
osmozilla.h:201: warning: ‘class nsClassInfoMixin’ has virtual functions but non-virtual destructor
osmozilla.cpp: In constructor ‘nsOsmozillaInstance::nsOsmozillaInstance(nsPlugin CreateData*)’:
osmozilla.cpp:171: error: ‘mXtwidget’ was not declared in this scope
make[2]: *** [osmozilla.o] Error 1
make[2]: Leaving directory `/home/jordan/Desktop/vive-0.3/gpac/applications/osmozilla'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/home/jordan/Desktop/vive-0.3/gpac/applications'
make: *** [install] Error 2

ringjp
July 20th, 2006, 02:24 AM
I just went through this tutorial step-by-step and everything seemed to go okay. However, now I'm trying to install Vive and I'm hitting the following error while trying to configure Vive:


The program ffmpeg has been installed, but it does not have the optimal configuration for Vive. Run:
./install ffmpeg

This will activate the Vive install script to install ffmpeg. If you prefer to compile it yourself, the optimal configuration for Vive is:
./configure --enable-gpl --enable-pp --enable-zlib \
--enable-vorbis --enable-libogg --enable-theora \
--enable-a52 --enable-dts --enable-dc1394 --enable-libgsm\
--disable-debug --enable-mp3lame --enable-faad\
--enable-faac --enable-xvid --enable-ogm
You may continue on with installing Vive and install an updated ffmpeg later, if you so choose, as well.
Checking for vobcopy...Can't exec "vobcopy": No such file or directory at ./configure line 41.
Use of uninitialized value in pattern match (m//) at ./configure line 42.
Found
Checking for cpdvd...Use of uninitialized value in pattern match (m//) at ./configure line 54.
Checking for MP4Box...Can't exec "MP4Box": No such file or directory at ./configure line 61.
Use of uninitialized value in pattern match (m//) at ./configure line 62.
Use of uninitialized value in pattern match (m//) at ./configure line 62.
Not found or incorrect version
Please install MP4Box by running:
./install mp4box
Or, run the following commands by yourself:
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac-0.4.0-rc2.tar.gz
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac_extra_libs-0.4.0.tar.gz
tar -zxf gpac-0.4.0-rc2.tar.gz
tar -zxf gpac_extra_libs-0.4.0.tar.gz
cd gpac_extra_libs
cp -r * ../gpac/extra_lib
cd ../gpac
chmod +x configure
./configure
make lib
make apps
make install
sudo

cp bin/gcc/libgpac.so /usr/lib


It seemed like ffmpeg installed just fine. Any ideas? BTW, I'm kind of a newbie...

Edit: Never mind, I fixed it.

endersshadow
July 22nd, 2006, 03:54 AM
Hey guys, I apologize profusely, but I've had (and have) some unfortunate family matters to attend to, so I won't be able to get back to y'all until August. I really apologize, but sometimes, family trumps all.

I'll do this as quick as I can, but I apologize if it's not enough:

@hanzo: ffmpeg commands and their functions can be found here (http://ffmpeg.mplayerhq.hu/ffmpeg-doc.html).

@jms: If you are not using the 1.1 version of the iPod Video 60GB firmware, you will not need MP4Box. Simply comment out (or delete) those lines from the configure script and all will run smoothly. The newest version of the iPod Video 60GB (1.2) does, in fact, fix this problem. It was an heinous oversight on my part and I absolutely apologize for it. Sometimes, developers deserve slaps on the wrist, and this is one of those times. When Vive goes final release, the installation process is something I am definitely going to focus on. I'm letting people test it and seeing what bugs come in now. For the most part, it's been with MP4Box, so I will do my best to update that and make that seamless. Unfortunately, video encoding is a messy process and sometimes us developers don't make it as easy as it should be :)

@ring: Glad you fixed it :)

ringjp
July 22nd, 2006, 01:09 PM
Endershadow,

You've done some great work and we really appreciate it. I hope the family matters work out for you (family definitely comes first).

dyssident
July 26th, 2006, 10:29 AM
your origional settings are confirmed working with the Samsung t809 phone..

for reference (pasted from my script):

AB = 192 # audio bitrate kbit/s (default=64)
B = 700 # video bitrate kbit/s (default=200kbs)
MAXRATE = 1000 # max video bitrate in kbit/s; max 2500 for mpeg4
ACODEC = aac # audio codec
ASPECT = 4:3 # aspect ratio
BUFSIZE = 4096 # rate control buffer size
F = mp4 # container file type
G = 300 # GOP size
S = 320x240 # video dimension
QMAX = 5 # maximum video quantiser scale
QMIN = 3 # minimum video quantiser scale
VCODEC = mpeg4 # video codec; should only ever be mpeg4 or xvid

coreyt
August 3rd, 2006, 04:37 AM
For the love of god..


Please get this added to Automatix :)



Tried and half these packages will not install on Default install. I assume you need other repositories.

endersshadow
August 3rd, 2006, 05:20 AM
For the love of god..


Please get this added to Automatix :)



Tried and half these packages will not install on Default install. I assume you need other repositories.

Iandefor has been kind enough to supply it in BUMPS for Dapper. Since I kind of upset the Automatix people by calling them temporary fools (i.e.-fools for a temporary time, they certainly aren't characteristically foolish) a little while ago, I doubt that Vive is anywhere near their radar, but hey, whatever. My own doing. Anyway, here's the BUMPS thread (http://ubuntuforums.org/showthread.php?t=181251).

Edit: I apologize for this stuff being a bit convoluted. Because of the codecs and legalities, and how very, very messy video encoding is at the moment, this stuff can just get a lot a bit wacky. Once you throw in firmware bugs and manufacturing guffaws, it just gets messier (hence the reason for MP4Box). Once I get around to it, I'm really going to focus on the installation process, as that is what seems to be the biggest problem. Basically, the program is feature complete and functional, people just have a tough time getting it up and running. And for that, I'm going to do everything I can to fix that once I finally get some time on my hands. Again, in the words of the late Kurt Cobain, "all apologies."

coreyt
August 4th, 2006, 11:40 PM
I'm having hell of a time with this program.

First you have to redo ffmpeg (Why is it this way in the repo's in the first place. Recompiled version just enables more options)

Second tried HandBrake, but have no idea where to get jam from.

There used to be a package for Vive which looks great, but I cant get it to compile. Asks for other stuff to be compiled from source. I'd rather have a package to deal with.

I used to build rpm's for Suse/Fedora for gaim on the 64 bit platforms for awhile. I'm just learning on how dpkg handles things. I could host the packages I believe. I currently have 300g of transfer a month and I can stretch that with torrents possibly. I hardly use more than 100m of that bandwidth nowdays.

I have an iPod Video I would love to be able to rip dvd's to it on this machine since it's a dual core AMD X2 and I'd like to see it doing me some good. Takes hours for handbrake to do that on my g4 mac mini.

coreyt
August 4th, 2006, 11:42 PM
Oh hey about the BUMPS.


Vive is not in there at all and it always fails on downloading packages.

I'd love to see what packages need enhancements so I can see about how we can get them put into the dapper main branches. Better for those who dont want to use multiverse or outside sources.

mrpeanut
August 8th, 2006, 02:25 AM
After trying several times to get this to work, and searching for related errors, it's time for me to just ask. Every time I put in the code 'make' I get this is as the output, and the process fails. Does anybody have any ideas?


tmr7@tidbit-laptop:~/mpeg4ip-1.4.1$ make
make all-recursive
make[1]: Entering directory `/home/tmr7/mpeg4ip-1.4.1'
Making all in include
make[2]: Entering directory `/home/tmr7/mpeg4ip-1.4.1/include'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/tmr7/mpeg4ip-1.4.1/include'
Making all in lib
make[2]: Entering directory `/home/tmr7/mpeg4ip-1.4.1/lib'
Making all in utils
make[3]: Entering directory `/home/tmr7/mpeg4ip-1.4.1/lib/utils'
source='config_opts.cpp' object='config_opts.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/sh ../../depcomp \
/bin/sh ../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -fexceptions -Wall -DMPEG4IP -I/usr/include/SDL -D_REENTRANT -c -o config_opts.lo config_opts.cpp
libtool: ignoring unknown tag CXX
g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -fexceptions -Wall -DMPEG4IP -I/usr/include/SDL -D_REENTRANT -c config_opts.cpp -fPIC -DPIC -o .libs/config_opts.o
../../libtool: line 1223: g++: command not found
make[3]: *** [config_opts.lo] Error 1
make[3]: Leaving directory `/home/tmr7/mpeg4ip-1.4.1/lib/utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/tmr7/mpeg4ip-1.4.1/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tmr7/mpeg4ip-1.4.1'
make: *** [all] Error 2

endersshadow
August 8th, 2006, 03:09 AM
mrpeanut, what's your ./configure command and output look like?

mrpeanut
August 8th, 2006, 04:49 AM
Thanks for the quick response endersshadow. It seems that at a certain point the terminal stops displaying some of the information that it feeds out. The ./config output was cut short by it. I'll display what I have. If there is a way for it to store more, or maybe log so I can go back and copy the whole ouput over just let me know. As for the output, here is what I have.


checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
appending configuration tag "F77" to libtool
checking whether make sets $(MAKE)... (cached) yes
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ANSI C... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for inline... inline
checking for an ANSI C-conforming const... yes
checking whether we are using the GNU C++ compiler... (cached) no
checking whether g++ accepts -g... (cached) no
checking dependency style of g++... (cached) none
checking for a BSD-compatible install... /usr/bin/install -c
checking for working alloca.h... yes
checking for alloca... yes
checking for dlopen... yes
checking for dlopen in -lc... no
checking for dlopen in -ldl... yes
checking for OSS audio support... yes
checking for ALSA CFLAGS...
checking for ALSA LDFLAGS... -lasound -lm -ldl -lpthread
checking for libasound headers version >= 0.9.0... found.
checking for snd_ctl_open in -lasound... yes
-- /usr/lib/libasound.so.* -> libasound.so.2
checking for dlvsym... yes
checking for artsc-config... /usr/bin/artsc-config
checking for aRts development environment... yes
-- /usr/lib/libartsc.so.* -> libartsc.so.0
checking for esd-config... /usr/bin/esd-config
checking for ESD - version >= 0.2.8... yes
-- /usr/lib/libesd.so.* -> libesd.so.0
checking for NAS audio support... no
checking for Linux 2.4 unified input interface... yes
checking for pthreads... yes
checking for recursive mutexes... yes
checking for pthread semaphores... yes
checking for broken glibc 2.0 pthreads... no
checking whether semun is defined in /usr/include/sys/sem.h... no
checking sigaction... yes
checking for GCC Altivec instruction support... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating include/Makefile
config.status: creating src/Makefile
config.status: creating src/audio/Makefile
config.status: creating src/audio/alsa/Makefile
config.status: creating src/audio/arts/Makefile
config.status: creating src/audio/baudio/Makefile
config.status: creating src/audio/dc/Makefile
config.status: creating src/audio/disk/Makefile
config.status: creating src/audio/dma/Makefile
config.status: creating src/audio/dmedia/Makefile
config.status: creating src/audio/dsp/Makefile
config.status: creating src/audio/esd/Makefile
config.status: creating src/audio/macrom/Makefile
config.status: creating src/audio/mint/Makefile
config.status: creating src/audio/mme/Makefile
config.status: creating src/audio/nas/Makefile
config.status: creating src/audio/nto/Makefile
config.status: creating src/audio/openbsd/Makefile
config.status: creating src/audio/paudio/Makefile
config.status: creating src/audio/riscos/Makefile
config.status: creating src/audio/sun/Makefile
config.status: creating src/audio/ums/Makefile
config.status: creating src/audio/windib/Makefile
config.status: creating src/audio/windx5/Makefile
config.status: executing depfiles commands
configure: configuring in lib/rtp
configure: running /bin/sh './configure' --prefix=/usr/local --cache-file=/dev/null --srcdir=.
checking build system type... i686-pc-linux
checking host system type... i686-pc-linux
checking target system type... i686-pc-linux
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for a sed that does not truncate output... /bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
appending configuration tag "F77" to libtool
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking whether time.h and sys/time.h may both be included... yes
checking for an ANSI C-conforming const... yes
checking for size_t... yes
checking stropts.h usability... yes
checking stropts.h presence... yes
checking for stropts.h... yes
checking sys/filio.h usability... no
checking sys/filio.h presence... no
checking for sys/filio.h... no
checking for stdint.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for int8_t... yes
checking for int16_t... yes
checking for int32_t... yes
checking for int64_t... yes
checking for uint8_t in <stdint.h>... yes
checking for uint16_t in <stdint.h>... yes
checking for uint32_t in <stdint.h>... yes
checking whether byte ordering is bigendian... no
checking whether char is unsigned... no
checking for /dev/urandom... yes
checking for vsnprintf... yes
checking for inet_pton... yes
checking for inet_ntop... yes
checking for inet_aton... yes
checking for socklen_t... yes
checking for library containing socket... none required
checking for library containing inet_addr... none required
checking for getipnodebyname in <netdb.h>... no
checking netinet6/in6.h usability... no
checking netinet6/in6.h presence... no
checking for netinet6/in6.h... no
checking netinet/ip6.h usability... yes
checking netinet/ip6.h presence... yes
checking for netinet/ip6.h... yes
checking for struct addrinfo in <netdb.h>... yes
checking for sin6_len in struct sockaddr_in6... no
checking for gtkdoc-scan... no
configure: compiler warnings will not be errs
checking whether c compiler accepts -Wmissing-prototypes... yes
checking whether c compiler accepts -Wmissing-declarations... yes
checking whether c compiler accepts -Wbad-function-cast... yes
checking whether c compiler accepts -Wwrite-strings... yes
checking whether c compiler accepts -Wformat=2... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating win32/Makefile
config.status: creating uclconf.h
config.status: uclconf.h is unchanged
config.status: executing depfiles commands
configure: configuring in common/video/iso-mpeg4
configure: running /bin/sh './configure' --prefix=/usr/local --cache-file=/dev/null --srcdir=.
checking build system type... i686-pc-linux
checking host system type... i686-pc-linux
checking target system type... i686-pc-linux
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking for shl_load... no
checking for shl_load in -ldld... no
checking for dlopen... no
checking for dlopen in -ldl... yes
checking whether a program can dlopen itself... yes
checking whether a statically linked program can dlopen itself... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
appending configuration tag "F77" to libtool
checking libtool tag=C for nasm... yes
checking whether make sets $(MAKE)... (cached) yes
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ANSI C... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking whether we are using the GNU C++ compiler... (cached) no
checking whether g++ accepts -g... (cached) no
checking dependency style of g++... (cached) none
checking for inline... inline
checking for an ANSI C-conforming const... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for X... libraries /usr/X11R6/lib, headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking whether byte ordering is bigendian... no
checking for ANSI C header files... (cached) yes
checking whether time.h and sys/time.h may both be included... yes
checking for long... yes
checking size of long... 4
checking for bool... no
checking size of bool... 0
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking for unistd.h... (cached) yes
checking for stdint.h... (cached) yes
checking for inttypes.h... (cached) yes
checking getopt.h usability... yes
checking getopt.h presence... yes
checking for getopt.h... yes
checking byteswap.h usability... yes
checking byteswap.h presence... yes
checking for byteswap.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for strerror... yes
checking for strcasestr... yes
checking for poll... yes
checking for getopt... yes
checking for getopt_long... yes
checking for getopt_long_only... yes
checking for getrusage... yes
checking for socketpair... yes
checking for strsep... yes
checking for inet_ntoa... yes
configure: compiler warnings will not be errs
checking whether c compiler accepts -malign-loops... no
checking whether c compiler accepts -falign-loops... yes
checking whether c compiler accepts -malign-functions... no
checking whether c compiler accepts -falign-functions... yes
checking whether c compiler accepts -malign-jumps... no
checking whether c compiler accepts -falign-jumps... yes
checking whether c compiler accepts -Wmissing-prototypes... yes
checking whether c compiler accepts -Wmissing-declarations... yes
checking whether c compiler accepts -Wno-char-subscripts... yes
checking whether c compiler accepts -Wno-unknown-pragmas... yes
checking whether c compiler accepts -Wformat=2... yes
checking whether c++ compiler accepts -Wmissing-prototypes... no
checking whether c++ compiler accepts -Wno-char-subscripts... no
checking whether c++ compiler accepts -Woverloaded-virtual... no
checking whether c++ compiler accepts -Wno-unknown-pragmas... no
checking whether c++ compiler accepts -Wno-deprecated... no
checking whether c++ compiler accepts -Wformat=2... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating mpeg4-2000.h
config.status: mpeg4-2000.h is unchanged
config.status: executing depfiles commands

Thanks for any insight or help you can provide! -Greg-

mrpeanut
August 14th, 2006, 04:33 AM
Does anyone have any idea of what I should do?

jimmygoon
August 14th, 2006, 05:11 AM
"sudo apt-get install build-essential g++"

then ./configure
and then make

coreyt
August 15th, 2006, 01:05 AM
Checking your system in order to install Vive...
Checking for ffmpeg...Found
The program ffmpeg has been installed, but it does not have the optimal configuration for Vive. Run:
./install ffmpeg

This will activate the Vive install script to install ffmpeg. If you prefer to compile it yourself, the optimal configuration for Vive is:
./configure --enable-gpl --enable-pp --enable-zlib \
--enable-vorbis --enable-libogg --enable-theora \
--enable-a52 --enable-dts --enable-dc1394 --enable-libgsm\
--disable-debug --enable-mp3lame --enable-faad\
--enable-faac --enable-xvid --enable-ogm
You may continue on with installing Vive and install an updated ffmpeg later, if you so choose, as well.
Checking for vobcopy...Found
Checking for cpdvd...Use of uninitialized value in pattern match (m//) at ./configure line 54.
Checking for MP4Box...Can't exec "MP4Box": No such file or directory at ./configure line 61.
Use of uninitialized value in pattern match (m//) at ./configure line 62.
Use of uninitialized value in pattern match (m//) at ./configure line 62.
Not found or incorrect version
Please install MP4Box by running:
./install mp4box
Or, run the following commands by yourself:
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac-0.4.0-rc2.tar.gz
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac_extra_libs-0.4.0.tar.gz
tar -zxf gpac-0.4.0-rc2.tar.gz
tar -zxf gpac_extra_libs-0.4.0.tar.gz
cd gpac_extra_libs
cp -r * ../gpac/extra_lib
cd ../gpac
chmod +x configure
./configure
make lib
make apps
make install
sudo cp bin/gcc/libgpac.so /usr/lib




Okay where is the install script this error mentions. And ffmpeg should already be configured correctly.

MotK
August 25th, 2006, 01:21 PM
endersshadow,

quick suggestion:

vive is a great prog! could you maybe add batch encoding at some point? that way, i can just select a crapload of files and encode them overnight without having to watch them?

plus, do you know a way to add mp4 files to gtkpod without having to encode them yourself? bc any mp4 file for ipod that i download off ipodnova.net or elsewhere, gtkpod doesnt recognize it? do you know of a fix?

hardkaare
August 30th, 2006, 06:42 PM
I would be nice with a new packages for the newest vive.
Thx for a very nice guide.

gandalf2041
August 31st, 2006, 07:55 PM
endersshadow,

Very Nice Work! Thank You! :D

I d/l and installed the latest Vive from sourceforge (BTW: SBX .debs work great but the Vive is a bit outdated). At any rate, I didn't have any of the presets or scripts mentioned in the README but, thankfully, I didn't need them. I was able to create my own preset based upon your script parameters for ffmpeg. During my first encode, my home directory ran out of space :oops: I guess that's what caused the computer to hang (although you might consider a 'disable screensaver' option). At any rate, I ended up with a 7.6 GB file with a .mov.vob extension. I assume this is because Vive didn't get to finish. Will the interim .vob be the same size as the original? and if so, what is the normal average compression? (I'm wondering how much space I need to add to my /home).

Thanks again for all your hard work!

KageKeeper
September 4th, 2006, 05:44 AM
Checking your system in order to install Vive...
Checking for ffmpeg...Found
The program ffmpeg has been installed, but it does not have the optimal configuration for Vive. Run:
./install ffmpeg

This will activate the Vive install script to install ffmpeg. If you prefer to compile it yourself, the optimal configuration for Vive is:
./configure --enable-gpl --enable-pp --enable-zlib \
--enable-vorbis --enable-libogg --enable-theora \
--enable-a52 --enable-dts --enable-dc1394 --enable-libgsm\
--disable-debug --enable-mp3lame --enable-faad\
--enable-faac --enable-xvid --enable-ogm
You may continue on with installing Vive and install an updated ffmpeg later, if you so choose, as well.
Checking for vobcopy...Found
Checking for cpdvd...Use of uninitialized value in pattern match (m//) at ./configure line 54.
Checking for MP4Box...Can't exec "MP4Box": No such file or directory at ./configure line 61.
Use of uninitialized value in pattern match (m//) at ./configure line 62.
Use of uninitialized value in pattern match (m//) at ./configure line 62.
Not found or incorrect version
Please install MP4Box by running:
./install mp4box
Or, run the following commands by yourself:
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac-0.4.0-rc2.tar.gz
wget http://internap.dl.sourceforge.net/sourceforge/gpac/gpac_extra_libs-0.4.0.tar.gz
tar -zxf gpac-0.4.0-rc2.tar.gz
tar -zxf gpac_extra_libs-0.4.0.tar.gz
cd gpac_extra_libs
cp -r * ../gpac/extra_lib
cd ../gpac
chmod +x configure
./configure
make lib
make apps
make install
sudo cp bin/gcc/libgpac.so /usr/lib




Okay where is the install script this error mentions. And ffmpeg should already be configured correctly.

Getting the same exact issues.

Any suggestions?

endersshadow
September 4th, 2006, 06:43 PM
endersshadow,

quick suggestion:

vive is a great prog! could you maybe add batch encoding at some point? that way, i can just select a crapload of files and encode them overnight without having to watch them?

plus, do you know a way to add mp4 files to gtkpod without having to encode them yourself? bc any mp4 file for ipod that i download off ipodnova.net or elsewhere, gtkpod doesnt recognize it? do you know of a fix?

Rename the files from .mp4 to .mov.

As for those having MP4Box configure issues, I'm going to edit the configure script and post a new one for you. It should be up in the next hour or so. I apologize for my absence as of late, I do. I shall get back to you in a bit :)

endersshadow
September 4th, 2006, 08:09 PM
Hey there you crazy kids, I've fixed the configure script, and you can download the new Vive 0.3 package here (http://prdownloads.sourceforge.net/vive/vive-0.3.tar.gz?download). I will be starting work on Vive 1.0 shortly, and will finally get out a full release that works :)

gandalf2041
September 5th, 2006, 10:05 PM
Hi endersshadow,

Welcome back! Vive seems to be turning out nicely but, alas...I can't seem to get it to work for me :-k v3 beta 2 compiled and installed fine. I can read the DVD and select the pre-sets. When I push encode, it says it's encoding but a second later it's done and there's no file.

I have compiled ffmpeg and it encodes a vob which I extracted (using dvdbackup - vobcopy would've worked too I guess) beautifully. I'm sure it's something simple, is there an error log I can review?

endersshadow
September 6th, 2006, 12:48 AM
Hi endersshadow,

Welcome back! Vive seems to be turning out nicely but, alas...I can't seem to get it to work for me :-k v3 beta 2 compiled and installed fine. I can read the DVD and select the pre-sets. When I push encode, it says it's encoding but a second later it's done and there's no file.

I have compiled ffmpeg and it encodes a vob which I extracted (using dvdbackup - vobcopy would've worked too I guess) beautifully. I'm sure it's something simple, is there an error log I can review?

In my infinite wisdom, I do not have an error log that you can review...I apologize.

However, try starting it from the terminal, which will show all output in the terminal for you to review :)

gandalf2041
September 9th, 2006, 02:45 AM
Sorry it took so long... here's the terminal output:


[21:33:25]-rand:~(0)>> vive
Use of uninitialized value in substitution (s///) at /usr/bin/cpdvd line 76.
Vobcopy 0.5.14 - GPL Copyright (c) 2001 - 2004 robos@muon.de
[Hint] All lines starting with "libdvdread:" are not from vobcopy but from the libdvdread-library

path to dvd: /dev/hdd
libdvdread: Using libdvdcss version 1.2.9 for DVD access
There are 4 titles on this DVD.
There are 37 chapters on the dvd.
Most chapters has title 1 with 29 chapters.

There are 4 angles on this dvd.
Using Title: 2
Title has 2 chapters and 1 angles
Using Chapter: 1
Using Angle: 1

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000013a
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000002ed
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0001c7f9
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x003d1b5b
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x003d1b5f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x003d5236
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x003d523a
libdvdread: Elapsed time 0
libdvdread: Found 3 VTS's
libdvdread: Elapsed time 0

DVD-name: vive_dvd_temp

your-name for the dvd: vive_dvd_temp

Outputting to /home/vive_dvd_temp2-1.vob

[Error] error opening file /home/vive_dvd_temp2-1.vob.partial
FFmpeg version SVN-r6155, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid
libavutil version: 49.0.0
libavcodec version: 51.12.0
libavformat version: 50.5.0
built on Sep 3 2006 11:38:04, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
/home/vive_dvd_temp*.vob: I/O error occured
Usually that means that input file is truncated and/or corrupted.


Not sure why it's complaining about the input file. vobcopy seems to run OK from the command line and I've successfully encoded the .vob via ffmpeg (the one I took from dvdbackup):-k

endersshadow
September 9th, 2006, 02:17 PM
I'll tell you what's happening: It's jumping to ffmpeg before vobcopy is done creating the vob.

I'll tell you what I don't know: Why it's happening. But that's a pure, honest-to-goodness bug that I'll definitely look into. I apologize for that. You know how us damned developers and bug-free software go together like peanut butter and pepperoni pizza. Sorry :-|

gandalf2041
September 9th, 2006, 03:01 PM
I apologize for that. You know how us damned developers and bug-free software go together like peanut butter and pepperoni pizza. Sorry

No need to apologize! :-D That's what makes OSS so fantastic! People like you who put time and effort into something simply because they enjoy it! My hat is off to you! Thanks for all you hard work! :KS

PriceChild
September 16th, 2006, 02:52 PM
Trying out the 0.3 beta 2.... It just deleted 2 Gbs of videos when i selected my destination folder and clicked encode...

endersshadow
September 18th, 2006, 07:07 AM
I've released Vive 1.0.0, the full release! No more Beta!

The VOB bug should be fixed, as well as the deletion in multiple file things....(sorry about that...that's rather embarassing and unfortunate, PriceChild)...

Check it out at http://vive.sourceforge.net!

darksider415
September 24th, 2006, 09:31 PM
I've been noticing the shell script in the beginning of the HOWTO was lacking a couple of things, so I'm posting the modifications that a friend of mine and I have done, over the past week or so. I have tested this with my 5G iPod, and things do work with it.

*Alex and I did the version numbering scheme for our modifications, with Eric's original script being version 1.0, which may differ from how he did it. - CSC - 9/25/06*


#!/bin/bash
## ipodvidenc - The iPod Video Encoder for Linux.
## Created by Eric Hewitt, January 9, 2006. Modified by Caleb Cupples, 17 September 2006. Further modified by Alex Lowe, 17 September 2006. Cinematic Widescreen functionality added by C. Cupples on 24 September 2006
## Released under the GPL. Go nuts.

## Version 1.2

# Make the first argument the input file
input_file=$1

echo "What would you like to name the output file (sans extension)?"

read output_file_name

widescreen='N'
system:/media
echo "Is this video widescreen? (Fullscreen (4:3) assumed otherwise) [y/N]"

read widescreen

case "$widescreen" in
n*|N*|*)
aspect_ratio="4:3"
resolution="320x240"
;;esac

#The cinematic widescreen format is the standard, according to several sources. Please email me at cscupples [at] gmail.com if I was incorrect on this. - C. Cupples

case "$widescreen" in
y*|Y*)
echo "Is this cinematic widescreen (1.85:1) or not? (16:9 assumed otherwise.) [y/N]"

read cinematic

case "$cinematic" in
n*|N*|*)
aspect_ratio="16:9"
resolution="320x180"
;;esac

case "$cinematic" in
y*|Y*)
aspect_ratio="370:200"
resolution="320x172"
;;esac
;;esac


output_file_loc_permis='Y'

echo "$output_file_name will be located in $PWD. Is this acceptable? [Y/n]"

read output_file_loc_permis

case "$output_file_loc_permis" in
n*|N*)
echo "Where would you like to store $output_file_name.mov?"
read output_dir
;;esac

case "$output_file_loc_permis" in
y*|Y*|*)
output_dir=$PWD
;;esac


ffmpeg -i "${input_file}" -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s $resolution -aspect $aspect_ratio "${output_dir}/${output_file_name}.mov"

C. Cupples

hardkaare
September 26th, 2006, 08:35 PM
Could someone make a new deb for vive's new version?

darksider415
September 27th, 2006, 10:51 PM
I've created a .deb of the current version of Vive, available at http://cscupples.strangled.net/

It should work, but if not, drop me an email and I'll see what I can do, if it's an issue with my particular setup.

C. Cupples

--Update--
The deb wasn't working for me at first, so I had to redo it, but it now works. I built it on Kubuntu Edgy Knot 3, but it should run on Dapper, I think.

CSC

siiib
September 27th, 2006, 11:00 PM
i've been following this thread with interest..

slightly OT i know but what do you guys reckon is the optimum rate for encoding for ipod?? i've been sort of doing it at 300 megs an hour .. simply based on the fact that an average film is two hours and fits on one cd without much loss of quality in mp4.. i reckon i may be overdoing it and could cut this down a bit.. main reason being i'd like to post my optimised ipod vids cos they can be difficult to get hold of.. errm assuming anyone is interested in my collection of war films or bbc documentaries.. heh. save someone else the hassle..
any tips, links etc much appreciated

regards Simon

p.s. looks like itunes has had it now.. not much left on the xp partition left to replace!

darksider415
September 27th, 2006, 11:05 PM
I'm getting pretty nice quality in the 200-220 MB/hr range for video, using ffmpeg for encoding. Most of this depends on the quality of the source file, though.

CC

siiib
September 28th, 2006, 05:34 PM
cheers mate.. the source is the original dvd!.. oops i asked a question in the wrong bit.. sorry:p

endersshadow
October 2nd, 2006, 10:34 PM
There was an issue w/ the 1.0.1 release with DVD-to-video encoding, which is now fixed in 1.0.2, available at Sourceforge (http://sourceforge.net/project/showfiles.php?group_id=158461).

KingFuzz
October 4th, 2006, 03:27 PM
I'm having a problem wih vive. When pushing the encode button and black window pops up twice and nothing happens. I've compiled it from the latest source..
Thank you in advance..

-Chris

Kryten107
October 8th, 2006, 09:26 AM
After getting the "unknown codec 'acc'" error, I tried to recompile ffmpeg to make sure I had AAC support. I had to add the Edgy repos to satisfy the liblame-dev stuff, and even after recompiling it still didn't work. ffmpeg -formats doesn't list aac as an option, and --enable-faac isn't listed in the parameters under ffmpeg.

When compiling ffmpeg, make gets an error that I couldn't figure out:

devin@Nayru:~/CVS/ffmpeg-0.cvs20050918$ make
make -C libavutil all
make[1]: Entering directory `/home/devin/CVS/ffmpeg-0.cvs20050918/libavutil'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/devin/CVS/ffmpeg-0.cvs20050918/libavutil'
make -C libavcodec all
make[1]: Entering directory `/home/devin/CVS/ffmpeg-0.cvs20050918/libavcodec'
gcc -O3 -Wall -Wno-switch -DHAVE_AV_CONFIG_H -I.. -I'/home/devin/CVS/ffmpeg-0.cvs20050918'/libavutil -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o dtsdec.o dtsdec.c
dtsdec.c:27:17: error: dts.h: No such file or directory
dtsdec.c:59: error: syntax error before ���*��� token
dtsdec.c: In function ���convert2s16_2���:
dtsdec.c:62: error: ���_f��� undeclared (first use in this function)
dtsdec.c:62: error: (Each undeclared identifier is reported only once
dtsdec.c:62: error: for each function it appears in.)
dtsdec.c:66: error: ���s16��� undeclared (first use in this function)
dtsdec.c: At top level:
dtsdec.c:72: error: syntax error before ���*��� token
dtsdec.c: In function ���convert2s16_4���:
dtsdec.c:75: error: ���_f��� undeclared (first use in this function)
dtsdec.c:79: error: ���s16��� undeclared (first use in this function)
dtsdec.c: At top level:
dtsdec.c:87: error: syntax error before ���*��� token
dtsdec.c: In function ���convert2s16_5���:
dtsdec.c:90: error: ���_f��� undeclared (first use in this function)
dtsdec.c:94: error: ���s16��� undeclared (first use in this function)
dtsdec.c: At top level:
dtsdec.c:103: error: syntax error before ���*��� token
dtsdec.c: In function ���convert2s16_multi���:
dtsdec.c:106: error: ���_f��� undeclared (first use in this function)
dtsdec.c:108: error: ���flags��� undeclared (first use in this function)
dtsdec.c:110: error: ���DTS_MONO��� undeclared (first use in this function)
dtsdec.c:113: error: ���s16��� undeclared (first use in this function)
dtsdec.c:117: error: ���DTS_CHANNEL��� undeclared (first use in this function)
dtsdec.c:118: error: ���DTS_STEREO��� undeclared (first use in this function)
dtsdec.c:119: error: ���DTS_DOLBY��� undeclared (first use in this function)
dtsdec.c:122: error: ���DTS_3F��� undeclared (first use in this function)
dtsdec.c:131: error: ���DTS_2F2R��� undeclared (first use in this function)
dtsdec.c:134: error: ���DTS_3F2R��� undeclared (first use in this function)
dtsdec.c:137: error: ���DTS_LFE��� undeclared (first use in this function)
dtsdec.c: In function ���channels_multi���:
dtsdec.c:194: error: ���DTS_LFE��� undeclared (first use in this function)
dtsdec.c:198: error: ���DTS_CHANNEL_MASK��� undeclared (first use in this function)
dtsdec.c:198: error: ���DTS_2F2R��� undeclared (first use in this function)
dtsdec.c: In function ���dts_decode_frame���:
dtsdec.c:219: error: ���dts_state_t��� undeclared (first use in this function)
dtsdec.c:219: error: ���state��� undeclared (first use in this function)
dtsdec.c:241: warning: implicit declaration of function ���dts_syncinfo���
dtsdec.c:255: error: ���level_t��� undeclared (first use in this function)
dtsdec.c:255: error: syntax error before ���level���
dtsdec.c:256: error: ���sample_t��� undeclared (first use in this function)
dtsdec.c:260: error: ���level��� undeclared (first use in this function)
dtsdec.c:261: error: ���bias��� undeclared (first use in this function)
dtsdec.c:263: error: ���DTS_ADJUST_LEVEL��� undeclared (first use in this function)
dtsdec.c:264: warning: implicit declaration of function ���dts_frame���
dtsdec.c:269: warning: implicit declaration of function ���dts_blocks_num���
dtsdec.c:271: warning: implicit declaration of function ���dts_block���
dtsdec.c:276: warning: implicit declaration of function ���dts_samples���
dtsdec.c:277: error: ���DTS_CHANNEL_MASK��� undeclared (first use in this function)
dtsdec.c:277: error: ���DTS_LFE��� undeclared (first use in this function)
dtsdec.c: In function ���dts_decode_init���:
dtsdec.c:298: warning: implicit declaration of function ���dts_init���
dtsdec.c:298: warning: assignment makes pointer from integer without a cast
dtsdec.c: At top level:
dtsdec.c:315: error: ���dts_state_t��� undeclared here (not in a function)
dtsdec.c:315: error: syntax error before ���)��� token
make[1]: *** [dtsdec.o] Error 1
make[1]: Leaving directory `/home/devin/CVS/ffmpeg-0.cvs20050918/libavcodec'
make: *** [lib] Error 2

I'm assuming the make error would have something to do with the lack of aac support. Any ideas?

Update: Also, it seems Banshee can't play AAC files anymore, so although I reinstalled all the packages that I had uninstalled (including packages like mplayer that were uninstalled with the AAC stuff) AAC remains broken. I'll look into it more.

Update #2: There were a few packages that needed to be downgraded in order to accomodate the AAC packages (apparently I had never noticed that the build-dep for ffmpeg had failed) but my AAC is back and I'm encoding things fine. :P

starwarsfan982
October 9th, 2006, 10:07 PM
Hi, I was looking for a gui solution for encoding video, and this one seems really nice. Only one problem, it doesn't work. When i run this from the terminal, it pops up. I select to encode in AVI from a vob file i got using vobcopy. I output to a directory naming it whatever.avi When I click encode, a terminal pops up and then closes. When i check the Terminal I ran it from, i get the this error:

mv: invalid option -- r
Try `mv --help' for more information.

Does anyone have any idea how to fix this? I will post in the Desktop forums too, but this also seemed like an appropriate place.

kerme8503
October 11th, 2006, 03:46 AM
I have got upto the "sudo make install blah blah" I do that, it goes for a while, then it says "Install failed" "cleaning up" "Bye" hmm... help please :)

misteral
October 21st, 2006, 02:51 AM
Has anyone gotten this to work on a 64 bit system (AMD 64 in particular in my case)?

Thanks

apoclypse
October 30th, 2006, 12:12 AM
Hi, I was looking for a gui solution for encoding video, and this one seems really nice. Only one problem, it doesn't work. When i run this from the terminal, it pops up. I select to encode in AVI from a vob file i got using vobcopy. I output to a directory naming it whatever.avi When I click encode, a terminal pops up and then closes. When i check the Terminal I ran it from, i get the this error:

mv: invalid option -- r
Try `mv --help' for more information.

Does anyone have any idea how to fix this? I will post in the Desktop forums too, but this also seemed like an appropriate place.

I have this issue too. it just doesn't seem to work for me. Another thing does this support h.264 encoding, cause thats what I'm looking to convert my dvds. What we need is something like ffmpegx which is for the mac. I've tried the ipodenc scripts and that gives me errors. I just don't know what to do anymore. I really don't want to use windows to encode my files. If someone can give the actual commandline steps I don't care how long the steps are. I know it can be done cause I've seen quite a few sites with very sparse info but they sure show a lot of examples. This is frustrating me to no end.

apoclypse
October 30th, 2006, 04:59 AM
Nevermind. I found this great little app called handbrake which does the trick rather well. I think it statically links all the file to it but the dependancies are pretty similar to what you see in the howto here. Right now only the commandline tool seems to compile. There is some code for a gtk frontnd but it doesn't seem to compile. If any one can get this thing working with a gui I think it would be incredible. Vive seems nice but it just doesn't work for me at all, neither does ipodenc. The cli version is super easy to use and there is documentation on how to use it for the most common tasks, in this case that would be encoding a dvd for an ipod. It works great so far and supports the x.264 library which was really the most important thing for me.

Vive just needs to mature a little, I think maybe the authors might want to redo a few things, such as the preferences. Other than that everything is pretty easy to use. I just wish it would actually work when it came to encoding stuff. Ah, well such is the nature of beta software I guess.

KillerFrog_505
November 9th, 2006, 04:20 AM
HELP!!! i get this error message

casey@burnsie:~$ sudo apt-get install libtool libsdl1.2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libtool is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsdl1.2-dev: Depends: libglu1-mesa-dev but it is not going to be installed or
libglu-dev
E: Broken packages

endersshadow
November 9th, 2006, 04:42 AM
HELP!!! i get this error message

casey@burnsie:~$ sudo apt-get install libtool libsdl1.2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libtool is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsdl1.2-dev: Depends: libglu1-mesa-dev but it is not going to be installed or
libglu-dev
E: Broken packages

Could you paste your /etc/apt/sources.list file?

Thanks!

As for everybody else, I'm very sorry for not getting on things right away! College hath grabbed me by the arm and yanked me away from fun things like Vive, but after Thanksgiving, I'll have some time to sit down and really bang out some bugs.

Thanks and sorry again!

KillerFrog_505
November 9th, 2006, 05:45 AM
## Add comments (##) in front of any line to remove it from being checked.
## Use the following sources.list at your own risk.

deb http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu edgy-proposed main restricted universe multiverse

## MAJOR BUG FIX UPDATES produced after the final release
deb http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy-updates main restricted universe multiverse

## UBUNTU SECURITY UPDATES
deb http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

## BACKPORTS REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.)
deb http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse

## PLF REPOSITORY (Unsupported. May contain illegal packages. Use at own risk.)
deb http://packages.freecontrib.org/plf edgy-plf free non-free
deb-src http://packages.freecontrib.org/plf edgy-plf free non-free

## CANONICAL COMMERCIAL REPOSITORY (Hosted on Canonical servers, not Ubuntu
## servers. RealPlayer10, Opera, DesktopSecure and more to come.)
deb http://archive.canonical.com/ubuntu edgy-commercial main

## Listen
#deb http://theli.free.fr/packages/ edgy listen

#Beryl Repositories for Edgy Eft (Ubuntu 6.10)
deb http://xgl.compiz.info/ edgy main-edgy
deb-src http://xgl.compiz.info/ edgy main-edgy

# Treviño's Beryl-SVN Ubuntu Edgy Eft Repository
# GPG key: 81836EBF
deb http://3v1n0.tuxfamily.org edgy beryl-svn

## Automatix repo
deb http://www.getautomatix.com/apt edgy main


#AUTOMATIX REPOS START

deb http://wine.lowvoice.nl/apt dapper main

deb http://dl.google.com/linux/deb/ stable non-free

deb http://archive.canonical.com/ubuntu dapper-commercial main

deb http://archive.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
#AUTOMATIX REPOS END

mike41
November 13th, 2006, 04:51 AM
I'm having a problem while compiling the mpeg4ip

when I say "make" I get the following error:


libtool: ignoring unknown tag CXX
../../libtool: line 1223: g++: command not found
make[3]: *** [config_opts.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
mike@mike-tc:~/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1$ make < ~out.a
make all-recursive
make[1]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1'
Making all in include
make[2]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/include'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/include'
Making all in lib
make[2]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib'
Making all in utils
make[3]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib/utils'
source='config_opts.cpp' object='config_opts.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/bash ../../depcomp \
/bin/bash ../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -fexceptions -Wall -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -c -o config_opts.lo config_opts.cpp
libtool: ignoring unknown tag CXX
g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -fexceptions -Wall -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -c config_opts.cpp -fPIC -DPIC -o .libs/config_opts.o
../../libtool: line 1223: g++: command not found
make[3]: *** [config_opts.lo] Error 1
make[3]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib/utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1'
make: *** [all] Error 2


I tried going into the specified makefiles and removing -Werror, but i still get the error. I've searched the forum, and the web for hours now trying to find other ways to do this stuff, but I haven't had any luck.

PLEASE ANY HELP!!! :)

endersshadow
November 13th, 2006, 09:04 PM
Killer Frog: Try looking for the glu-dev packages suggested. That's what libsdl1.2-dev is complaining about.

mike41: Did it get through the ./bootstrap step and ./configure without errors?

mike41
November 13th, 2006, 10:40 PM
yea I got through everything until the "make", and then I removed the -Werror lines in the makefiles, then I retyped make, and got the same error. I have a copy of Nero, so I installed that and Nero Recode is working nicely (in windows of course). I suppose I'll just stick with that for now.

iggywig
November 14th, 2006, 03:36 PM
I've got a problem with ffmpeg and libfaac.. I've built ffmpeg from the source as page one says. I'm not using the script yet just the ffmpeg command line from the script:

ian@ian-ubuntu:~$ ffmpeg -i test.avi -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 ipodtest

It fails immediately and I get this:
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-faadbin
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Nov 14 2006 14:25:55, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Input #0, mpeg, from 'test.avi':
Duration: 00:00:41.6, start: 0.500000, bitrate: 660 kb/s
Stream #0.0[0x1e0]: Video: mpeg1video, yuv420p, 320x240, 104857 kb/s, 29.97 fps(r)
Stream #0.1[0x1c0]: Audio: mp2, 22050 Hz, mono, 56 kb/s
File 'ipodtest' already exists. Overwrite ? [y/N] y
Output #0, mp4, to 'ipodtest':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, q=3-5, 700 kb/s, 29.97 fps(c)
Stream #0.1: Audio: aac, 22050 Hz, mono, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[aac @ 0x849ef18]libfaac doesn't support this output format!
Error while opening codec for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height

Any ideas?
Cheers

Slace
November 15th, 2006, 06:10 AM
does anyone have a script that will encode for an iPod in H.264 format, using x264?

Choxo
November 29th, 2006, 03:39 PM
Hi,

I tried to 'make' but I've got the error:



make[6]: *** [sys_block.lo] Error 1
make[6]: Leaving directory `/home/spitz/mpeg4ip-1.4.1/common/video/iso-mpeg4/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/spitz/mpeg4ip-1.4.1/common/video/iso-mpeg4'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/spitz/mpeg4ip-1.4.1/common/video/iso-mpeg4'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/spitz/mpeg4ip-1.4.1/common/video'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/spitz/mpeg4ip-1.4.1/common'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/spitz/mpeg4ip-1.4.1'
make: *** [all] Error 2


I deleted -Werrior in the line, but it still doesn't work.
I don't have to delete the entire line, do I?

The ending of my ./configure was like this:

checking whether c++ compiler accepts -Wformat=2... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating mpeg4-2000.h
config.status: mpeg4-2000.h is unchanged
config.status: executing depfiles commands

Thanks,

Choxo

sirmrmatt
November 29th, 2006, 04:16 PM
Hi.

I *HAD* Vive installed and working fine yesterday, but then I installed the .deb package over it and it's not working anymore!! ARRRGGHHH!!! ](*,)

So anyhow, when I start it from the Ubuntu Programs menu, I get nothing. Just does nothing. From the command line, I am getting this message in an endless repeat pattern:


Use of uninitialized value in pattern match (m//) at /usr/local/bin/vive line 376

Any help on this one? I tried deleting the /usr/local/bin/vive and recompiling/installing, but it didn't work. ](*,) BAAHHH! lol

Any help?

- Matt

chaumurky
November 30th, 2006, 11:28 PM
Ok, using the 'ipodvidenc' script I'm getting the "[mpeg4 @ 0x849ee58]timebase not supported by mpeg 4 standard" error for avi's created by my stills camera. "Vive" just spits out a 0k sized file so I assume it's the same problem. It seems the frame rate/timebase of 12fps is the issue. Is it possible to fix the frame rate by an added parameter or something? "Frame-doubling" perhaps?

ooosadface
December 2nd, 2006, 08:16 PM
I'm having a problem while compiling the mpeg4ip

when I say "make" I get the following error:


libtool: ignoring unknown tag CXX
../../libtool: line 1223: g++: command not found
make[3]: *** [config_opts.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
mike@mike-tc:~/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1$ make < ~out.a
make all-recursive
make[1]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1'
Making all in include
make[2]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/include'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/include'
Making all in lib
make[2]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib'
Making all in utils
make[3]: Entering directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib/utils'
source='config_opts.cpp' object='config_opts.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/bash ../../depcomp \
/bin/bash ../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -fexceptions -Wall -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -c -o config_opts.lo config_opts.cpp
libtool: ignoring unknown tag CXX
g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -fexceptions -Wall -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -c config_opts.cpp -fPIC -DPIC -o .libs/config_opts.o
../../libtool: line 1223: g++: command not found
make[3]: *** [config_opts.lo] Error 1
make[3]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib/utils'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mike/Desktop/vive-1.0.2/mpeg4ip-1.5.0.1'
make: *** [all] Error 2


I tried going into the specified makefiles and removing -Werror, but i still get the error. I've searched the forum, and the web for hours now trying to find other ways to do this stuff, but I haven't had any luck.

PLEASE ANY HELP!!! :)

I was having the same problem. I found this to be the problem. I needed to install g++. When I went to Package Manager I installed the latest (g++-4.1.something). Anyway the make is looking for the command g++. My command after installing g++ was 'g++-4.1', g++ didn't exist. So, I went back to package manager and installed the plain jane g++. Now, it works! :D

I found info on doing an alias and something called symlink or something, but once I found alias wasn't a reckognized command I went straight to the install plain g++ idea.

endersshadow
December 4th, 2006, 11:28 PM
Ah, makes a lot of sense now. Thanks sadface!

berteh
December 9th, 2006, 09:44 PM
Hi,

I tried to run vive-1.0.2 on Dapper and got some troubles.

Install seemed to have worked well (I actually installed .debs with an older version and updated the /usr/bin/vive script from the new sources).

After loading a dvd, selecting the adequate title, output file and preset I hit encode and got the following error:

Use of uninitialized value in substitution (s///) at /usr/bin/vive line 162, namely the
s/\.// below:


elsif ($vob_keep || $vob_only_checked)
{
$ffmpeginfo{'vobfile'} =~ s/\.//;
$vobkeepcommand="mv -f $ffmpeginfo{'outfile'}/vive_dvd_temp*.vob $ffmpeginfo{'output'}.vob 2>&1";
}

I got no clue why this happens.. as anyone else seem to be happy with VIVE, so please let me know how to fix this... or if you need any other information in order to to so.

thanks.

PS: is there any other place with "official" support for vive? I didn't see anything on the Sourceforge forum...

endersshadow
December 10th, 2006, 06:53 AM
What was your output file input and/or which box did you check (keep or only for the VOB)?

Also, "official" support is just emailing me at endersshadow AT users DOT sourceforge DOT net. I'm not a huge project by any means, so that's pretty much it.

Thanks!

berteh
December 11th, 2006, 09:41 AM
What was your output file input and/or which box did you check (keep or only for the VOB)?


I tried
- input: /dev/dvdrw and /dvd (alias)
- output: /media/rip/7arrive.avi (where the current user has rwx access to /media/rip directory)
- encoding using your "custom AVI" settings
- "keep VOB" checked (and NOT the only VOB one)

thanks for your help.

endersshadow
December 12th, 2006, 07:35 PM
You can delete 162. My fault for just leaving that line in there.

I'm working on 1.0.3 which should fix a few other bugs. Stay tuned!

FakeOutdoorsman
December 13th, 2006, 12:54 AM
I'm have the same error as sirmrmatt from message #333 (http://ubuntuforums.org/showpost.php?p=1822187&postcount=333).

I followed the install instructions from Vive 1.0.2 README, but I used sudo checkinstall -D make install instead of sudo make install. I wanted it listed in Synaptic. When I try to start the program in terminal I get this message once:


Use of uninitialized value in pattern match (m//) at /usr/local/bin/vive line 376.


and then I get repeats of the same line over and over again except it is at line 441.

I uninstalled Vive from Synaptic and then i recompiled and remade everything from a new folder and I still get this error. I compiled ffmpeg from SVN yesterday and I am using Edgy.

FakeOutdoorsman
December 13th, 2006, 02:49 AM
I noticed a problem with using the ffmpeg SVN instead of a version from the repository. Using the ipodvidenc or the ffmpeg options shown in the wiki article iPodVideoEncoding (https://help.ubuntu.com/community/iPodVideoEncoding) will result in an error:


mpeg4 @ 0x84f6338]rc buffer underflow

The ffmpeg SVN units for options have recently changed from kilobits/sec to bits/sec, so it is trying to encode at a really low bitrate with a very high quality setting (-qmin 3 -qmax 5). I think the unit change applies to maxbitrate and b.

References:
[Ffmpeg-user] buffer underflow errors
(http://lists.mplayerhq.hu/pipermail/ffmpeg-user/2006-October/004902.html)
[Ffmpeg-user] maxrate (http://lists.mplayerhq.hu/pipermail/ffmpeg-user/2006-October/004647.html)

endersshadow
December 13th, 2006, 07:25 AM
Well that's a fun fact.

What rates do you have to use now?

Also, I was going through the code trying to clean it up, and let's just say that I'm rather embarassed that I wrote this stuff. Over my winter break, I'm gonna work on an entire rewrite in C. Should run faster, smoother, and allow for a bit more cleanliness all around. I apologize to everybody for my awful, awful, awful code. I'm in the middle of finals right now, so please be patient!

FakeOutdoorsman
December 13th, 2006, 09:10 AM
What rates do you have to use now?

I tried multiplying the original bitrates for "maxbitrate" and "b" by 1024 to change kilobits to bits but I was still getting the same errors; even after removing qmin and qmax. I just deleted the SVN version of ffmpeg and went with the Ubuntu repository source version. It worked for me after I did that, but now I'm getting the AC EOB marker is absent error with some of my DV source movies.

It's frustrating to find a good ffmpeg code example and find it doesn't work because ffmpeg likes to change the option names and units. It's doubly frustrating when the ipod firmware updates screws things up too.

You shouldn't be embarassed for your code. ffmpeg isn't easy to work with.

endersshadow
December 13th, 2006, 07:14 PM
I tried multiplying the original bitrates for "maxbitrate" and "b" by 1024 to change kilobits to bits but I was still getting the same errors; even after removing qmin and qmax. I just deleted the SVN version of ffmpeg and went with the Ubuntu repository source version. It worked for me after I did that, but now I'm getting the AC EOB marker is absent error with some of my DV source movies.

It's frustrating to find a good ffmpeg code example and find it doesn't work because ffmpeg likes to change the option names and units. It's doubly frustrating when the ipod firmware updates screws things up too.

You shouldn't be embarassed for your code. ffmpeg isn't easy to work with.

If you can read Perl, read through the code...you'll shake your head through most of it. It's not ffmpeg, it's that I had to go through roundabout ways of making things work because I thought to myself, "Well, Perl would be a good choice for a GUI plugin..."

Suffice it to say that I'm an idiot. I'll figure it out and get it working well. I promise :-D

FakeOutdoorsman
December 15th, 2006, 11:05 PM
I was able to resolve my issues from post 341. The uninstall instructions from the README weren't working correctly so I did it myself:



sudo unlink /usr/local/bin/vive
sudo unlink /usr/local/man/man1/vive.1p
sudo unlink /usr/local/lib/perl/5.8.8/auto/Vive/.packlist
sudo rm -f /usr/share/pixmaps/vive.xpm
sudo rm -f /usr/share/applications/vive.desktop
sudo rm -f /usr/local/bin/vive
sudo rm -f /usr/local/man/man1/vive.1p
sudo rm -rf /usr/local/lib/perl/5.8.8/auto/Vive
sudo rm -rf /blib/script/vive


I reinstalled Vive from scratch and tried to start it but it still gave me the same errors, but once I restarted the computer everything worked.

FakeOutdoorsman
December 20th, 2006, 12:09 AM
Mpeg4ip will encounter an error if you try to install it with a svn of x264 after 07-18-2006, revision 536:


video_x264.cpp: In member function `virtual bool CX264VideoEncoder::Init()':
video_x264.cpp:173: error: 'struct x264_param_t::<anonymous>' has no member named 'b_cbr'
make[4]: *** [video_x264.lo] Error 1


The API for x264 changed and mpeg4ip 1.5.0.1 doesn't include those changes. You can either comment out the line or download and complile the current CVS of mpeg4ip:


cvs -z3 -d:ext:developername@mpeg4ip.cvs.sourceforge.net:/cvsroot/mpeg4ip co -P mpeg4ip


If it asks for a password just hit enter. You will need to get CVS from Synaptic.

Smokeymcpawt
December 22nd, 2006, 02:55 AM
jared@jareds:~$ ipodvidenc /home/jared/torrents/borat.avi
What would you like to name the output file (sans extension)?
borat
borat will be located in /home/jared. Is this acceptable? [y/n]
/y
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr
libavutil version: 0d.49.0.0
libavcodec version: 0d.51.11.0
libavformat version: 0d.50.5.0
built on Sep 20 2006 00:26:15, gcc: 4.1.2 20060906 (prerelease) (Ubuntu 4.1.1-13ubuntu2)
Input #0, avi, from '/home/jared/torrents/borat.avi':
Duration: 01:20:20.0, start: 0.000000, bitrate: 1217 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 624x336, 25.00 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 32 kb/s
Unknown codec 'aac'
jared@jareds:~$


I get "Unknown codec 'aac'"

Any way to fix this, i DO have faac codec's installed.

endersshadow
December 22nd, 2006, 08:03 AM
Smokey,

ffmpeg is not configured with the --enable-faac flag.

SirKillalot
December 22nd, 2006, 11:51 AM
Mpeg4ip will encounter an error if you try to install it with a svn of x264 after 07-18-2006, revision 536:


video_x264.cpp: In member function `virtual bool CX264VideoEncoder::Init()':
video_x264.cpp:173: error: 'struct x264_param_t::<anonymous>' has no member named 'b_cbr'
make[4]: *** [video_x264.lo] Error 1


The API for x264 changed and mpeg4ip 1.5.0.1 doesn't include those changes. You can either comment out the line or download and complile the current CVS of mpeg4ip:


cvs -z3 -d:ext:developername@mpeg4ip.cvs.sourceforge.net:/cvsroot/mpeg4ip co -P mpeg4ip


If it asks for a password just hit enter. You will need to get CVS from Synaptic.

Hello, did you solve your problem? I got the same issue...

FakeOutdoorsman
December 22nd, 2006, 11:54 PM
Hello, did you solve your problem? I got the same issue...

The Problem: Newer versions of x264 changed some parameters. mpeg4ip 1.5.0.1 doesn't reflect those changes so an error message shows up during mpeg4ip 1.5.0.1 installation.

The Fix: Either install an older version of x264 (pre revision 536) or get mpeg4ip through CVS. I recommend getting the new mpeg4ip through CVS rather than using an old x264 version.

What I did: I reinstalled mpeg4ip using CVS. Uninstall your current version of mpeg4ip. Get mpeg4ip through CVS (just enter that code from my previous post into a terminal session). Then follow the mpeg4ip install instructions from the first page of this topic.

Install CVS if you don't have it:


sudo apt-get install cvs

or get it from System -> Administration -> Synaptic Package Manager.

If you want to know more about mpeg4ip CVS:
Mpeg4ip CVS information at Sourceforge (http://sourceforge.net/cvs/?group_id=18676)

Smokeymcpawt
December 24th, 2006, 08:23 PM
hmm, i can't figure out how to put them on my ipod with gtkpod, :(

endersshadow
December 24th, 2006, 11:13 PM
Are you using gtkpod from the repos or did you build gtkpod according to the HowTo (first post)?

Smokeymcpawt
December 25th, 2006, 03:31 AM
iv tried both, but iv figured out how to manually put them on my ipod.

BetaMaster
December 25th, 2006, 05:36 AM
I can't get the ffmpeg section working properly.

When I enter

sudo apt-get build-dep ffmpeg

I get

sven@sven-desktop:~/torrents$ sudo apt-get build-dep ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to find a source package for ffmpeg

And when I try

apt-get source ffmpeg

I get

sven@sven-desktop:~/torrents$ apt-get source ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to find a source package for ffmpeg

=\ Help?

endersshadow
December 25th, 2006, 05:40 AM
Need your /etc/apt/sources.list file. You probably don't have your deb-src repos enabled.

BetaMaster
December 25th, 2006, 05:50 AM
My entire sources.list file:


deb http://us.archive.ubuntu.com/ubuntu/ edgy main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ edgy-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://us.archive.ubuntu.com/ubuntu/ edgy universe
deb-src http://us.archive.ubuntu.com/ubuntu/ edgy universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu edgy-security main restricted
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted
# deb http://security.ubuntu.com/ubuntu edgy-security universe
# deb-src http://security.ubuntu.com/ubuntu edgy-security universe
deb http://www.getautomatix.com/apt edgy main

#AUTOMATIX REPOS START

deb http://dl.google.com/linux/deb/ stable non-free

deb http://wine.lowvoice.nl/apt edgy main

deb http://archive.canonical.com/ubuntu dapper-commercial main

deb http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu edgy-updates universe multiverse

deb http://archive.ubuntu.com/ubuntu edgy-security main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu edgy universe multiverse
#AUTOMATIX REPOS END
deb http://kubuntu.org/packages/amarok-144 edgy main
deb http://ubuntu.beryl-project.org/ edgy main
# Treviño's Beryl-SVN Ubuntu Repository
# GPG key: 81836EBF
deb http://3v1n0.tuxfamily.org edgy beryl-svn
deb http://gandalfn.club.fr/ubuntu edgy stable dev
deb http://download.tuxfamily.org/3v1deb edgy beryl-svn
deb-src http://download.tuxfamily.org/3v1deb edgy beryl-svn
deb http://albertomilone.com/drivers/edgy/nonlegacy/32bit binary/

My deb-src http://us.archive.ubuntu.com/ubuntu/ edgy universe was commented out but I uncommented it just now.
Now the error message I get is

sven@sven-desktop:~/Desktop$ sudo apt-get build-dep ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Could not open file /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_edgy_universe_s ource_Sources - open (2 No such file or directory)

BetaMaster
December 25th, 2006, 03:00 PM
Ah, figured it out. Sorry to have seemed stupid.

kylejack
December 26th, 2006, 01:06 PM
Having some dependency problems early in the process.

kyle@ubuntu:~$ sudo apt-get install libsdl1.2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsdl1.2-dev: Depends: libglu1-mesa-dev but it is not going to be installed or
libglu-dev
E: Broken packages
kyle@ubuntu:~$


I have the universe/debian repositories enabled, so I don't understand what could be causing this. Any ideas?

FakeOutdoorsman
December 26th, 2006, 08:00 PM
kylejack: This is probably an issue with your sources. Try commenting out any unofficial sources you have in /etc/apt/sources.list. Enter the following code and then try to reinstall.

sudo cp /etc/apt/sources.list sources.list.bak
gksudo gedit /etc/apt/sources.list
sudo apt-get update

While you're at it you should post your sources.list here.

kylejack
December 26th, 2006, 08:10 PM
Ok, I commented out the other repositories I've added in.

deb-src http://archive.ubuntu.com/ubuntu edgy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu edgy-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu edgy-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb-src http://archive.ubuntu.com/ubuntu edgy universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
## deb http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse
## deb-src http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu edgy-security main restricted
deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted

deb http://security.ubuntu.com/ubuntu edgy-security universe
deb-src http://security.ubuntu.com/ubuntu edgy-security universe

deb http://archive.ubuntu.com/ubuntu/ edgy universe main restricted multiverse

##deb http://wine.sourceforge.net/apt/ binary/

##deb http://deb.opera.com/opera/ etch non-free
## deb http://seveas.ubuntulinux.nl/ edgy-seveas breezy-backports breezy-custom breezy-extras freenx madwifi
## deb-src http://seveas.ubuntulinux.nl/ edgy-seveas breezy-backports breezy-custom breezy-extras freenx madwifi

deb http://archive.ubuntu.com/ubuntu edgy-backports main restricted universe multiverse

## created by arnieplanetremoved

##deb http://debian.space-based.de/debs/ experimental main
##deb-src http://debian.space-based.de/debs/ experimental main

##deb http://repository.debuntu.org/ dapper multiverse
##deb-src http://repository.debuntu.org/ dapper multiverse

##deb http://albertomilone.com/drivers/edgy/nonlegacy/32bit binary/
##deb http://albertomilone.com/drivers/edgy/nonlegacy/64bit binary/

#AUTOMATIX REPOS START

##deb http://www.getautomatix.com/apt edgy main

##deb http://archive.canonical.com/ubuntu dapper-commercial main

##deb http://archive.ubuntu.com/ubuntu edgy-updates universe multiverse

##deb http://archive.ubuntu.com/ubuntu edgy-security main restricted universe multiverse
#AUTOMATIX REPOS END


Still getting the same error.

patsissons
December 26th, 2006, 08:50 PM
just a note, the deb that SBX created is missing the following dependencies:

- libglib-perl
- libgtk2-perl

There may be others missing, but these two were the only packages that i noticed.

patsissons
December 26th, 2006, 10:51 PM
See if you can figure this one out, it has me very stumped at the moment.



ffmpeg -i "test.avi" -f mp4 -vcodec mpeg4 -maxrate 1000 -b 300 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 48 -s 320x240 "test.avi.mp4"
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-libgsm --enable-dc1394 --disable-debug --enable-mp3lame --enable-faadbin --enable-faad --enable-faac --enable-xvid --enable-x264 --enable-shared --prefix=/usr
libavutil version: 0d.49.0.0
libavcodec version: 0d.51.11.0
libavformat version: 0d.50.5.0
built on Dec 26 2006 13:35:47, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Input #0, avi, from 'test.avi':
Duration: 00:41:26.3, start: 0.000000, bitrate: 1186 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 624x352, 23.98 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 128 kb/s
Unknown codec 'aac'

patsissons
December 27th, 2006, 01:09 AM
found the answer, turns out if you compile it with just the faac-dev package installed it builds fine, but when you run ffmpeg it throws up. so MAKE SURE you have the faac package installed as well.

FakeOutdoorsman
December 27th, 2006, 11:51 PM
kylejack:
There are a few other topics that involve libsdl1.2-dev problems that may be able to help:
Re: Dosbox 0.65 is out! (http://ubuntuforums.org/showthread.php?t=158723&page=2)
Can't Install libsdl1.2-dev in dapper (http://ubuntuforums.org/showthread.php?p=1570003)
Re: Wanna 3d a retro game... help?! (http://www.ubuntuforums.org/showthread.php?p=1928157)

If I got this error I would backup my sources.list and try a fresh, new sources list. Source-o-matic (http://www.ubuntu-nl.org/source-o-matic/) might help. If that didn't work I would try to install the unmet dependencies listed in the error message (libglu-dev).

musse1
December 28th, 2006, 08:03 PM
I get lots and lots of warnings when I do the "make" command after doing exactly as said in the first post of how to install ffmpeg. I do have changed the repositories and gotten the codecs. But the x264 codec doesnt work. Don't know why.

./configure --enable-gpl --enable
-pp --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --
enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --ena
ble-xvid --enable-pthreads

Efter doing this command without the x264 codec I get this:

install prefix /usr/local
source path /home/musse1/ffmpeg-0.cvs20060823
C compiler gcc
make make
CPU x86 (generic)
big-endian no
inttypes.h yes
broken inttypes.h no
MMX enabled yes
Vector Builtins yes
3DNow! Builtins yes
gprof enabled no
zlib enabled yes
libgsm enabled yes
mp3lame enabled yes
libogg enabled yes
Vorbis enabled yes
FAAD enabled yes
faadbin enabled no
FAAC enabled yes
XviD enabled yes
x264 enabled no
a52 support yes
a52 dlopened no
DTS support yes
pp support yes
Software Scaler enabled no
debug symbols no
strip symbols yes
optimize yes
static yes
shared no
video hooking yes
SDL support yes
Imlib2 support yes
FreeType support yes
Sun medialib support no
pthreads support yes
AMR-NB float support no
AMR-NB fixed support no
AMR-WB float support no
AMR-WB IF2 support no
network support yes
IPv6 support yes
.align is power-of-two no
License: GPL
Creating config.mak and config.h...

After this I do the "make" command and the server is working for a couple of minutes and are printing lots of warning messages. When I try to run ffmpeg -i video.avi -b 250 -s 320x240 -r 30 -f avi -an newmovie.avi it is just saying that codec isn't found.

What to do about this? HELP ME!

FakeOutdoorsman
December 28th, 2006, 08:14 PM
Do you have checkinstall installed?


sudo apt-get install checkinstall


Do you have x264 installed?


sudo apt-get install x264


What are some of the errors you get when you try to install ffmpeg with --enable-x264?

musse1
December 28th, 2006, 08:16 PM
I managed to install checkinstall now but still the same problem. It keep saying unsupported codec.

This is the message when I try to enable x264:

ERROR: x264 not found
If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
ffmpeg-devel@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.

FakeOutdoorsman
December 28th, 2006, 08:19 PM
I don't think you have x264 installed. Look at my last post (I must have edited it while you were responding).

musse1
December 28th, 2006, 08:20 PM
couldnt find package x264...what to do?

patsissons
December 28th, 2006, 11:11 PM
couldnt find package x264...what to do?

The package you seek is called x264-bin, and you will also need the dev package libx264-dev

also, i don't recommend using checkinstall if you don't have to. You can get the ffmpeg source package by doing

apt-get source ffmpeg

from there, all you need to do is cd into the ffmpeg directory created and then do the following:

fakeroot debian/rules binary

this will create actual *.deb files that you can install with dpkg -i, this is a much better (and cleaner) approach to building your own packages. Note that you will either have to edit the rules file or do a ./configure with all the flags you want before hand (otherwise it will just build the default ubuntu package). Also note that this requires the package fakeroot (apt-get install fakeroot).

rodney16
December 28th, 2006, 11:14 PM
hi im new to linux and i cant figure out what im doin wrong everytime i try to run
ipodvidenc video.avi i get this message
rodney@rodney-desktop:~$ ipodvidenc video.avi
What would you like to name the output file (sans extension)?
ipod vids
ipod vids will be located in /home/rodney. Is this acceptable? [y/n]
y
ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-zlib --enable-vorbis --enable-libogg --enable-theora --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-ogm
built on Apr 29 2006 00:14:12, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
video.avi: I/O error occured
Usually that means that input file is truncated and/or corrupted.

help please

DaveQB
December 29th, 2006, 05:19 PM
Ah, figured it out. Sorry to have seemed stupid.

What was your solution ?

shriphani
December 30th, 2006, 10:15 AM
could someone tell me what the problem is? i encountered it after running make

x264.c:21:18: error: x264.h: No such file or directory
x264.c:25: error: syntax error before ‘x264_param_t’
x264.c:25: warning: no semicolon at end of struct or union
x264.c:26: warning: type defaults to ‘int’ in declaration of ‘enc’
x264.c:26: warning: data definition has no type or storage class
x264.c:27: error: syntax error before ‘pic’
x264.c:27: warning: type defaults to ‘int’ in declaration of ‘pic’
x264.c:27: warning: data definition has no type or storage class
x264.c:29: error: syntax error before ‘}’ token
x264.c:29: warning: type defaults to ‘int’ in declaration of ‘X264Context’
x264.c:29: warning: data definition has no type or storage class
x264.c: In function ‘X264_log’:
x264.c:35: error: ‘X264_LOG_ERROR’ undeclared (first use in this function)
x264.c:35: error: (Each undeclared identifier is reported only once
x264.c:35: error: for each function it appears in.)
x264.c:35: error: array index in initializer not of integer type
x264.c:35: error: (near initialization for ‘level_map’)
x264.c:36: error: ‘X264_LOG_WARNING’ undeclared (first use in this function)
x264.c:36: error: array index in initializer not of integer type
x264.c:36: error: (near initialization for ‘level_map’)
x264.c:37: error: ‘X264_LOG_INFO’ undeclared (first use in this function)
x264.c:37: error: array index in initializer not of integer type
x264.c:37: error: (near initialization for ‘level_map’)
x264.c:38: error: ‘X264_LOG_DEBUG’ undeclared (first use in this function)
x264.c:38: error: array index in initializer not of integer type
x264.c:38: error: (near initialization for ‘level_map’)
x264.c: At top level:
x264.c:49: error: syntax error before ‘x264_nal_t’
x264.c: In function ‘encode_nals’:
x264.c:51: error: ‘buf’ undeclared (first use in this function)
x264.c:54: error: ‘nnal’ undeclared (first use in this function)
x264.c:55: warning: implicit declaration of function ‘x264_nal_encode’
x264.c:55: error: ‘size’ undeclared (first use in this function)
x264.c:55: error: ‘nals’ undeclared (first use in this function)
x264.c: In function ‘X264_frame’:
x264.c:67: error: ‘x4’ undeclared (first use in this function)
x264.c:69: error: ‘x264_nal_t’ undeclared (first use in this function)
x264.c:69: error: ‘nal’ undeclared (first use in this function)
x264.c:71: error: ‘x264_picture_t’ undeclared (first use in this function)
x264.c:71: error: syntax error before ‘pic_out’
x264.c:73: error: ‘X264_CSP_I420’ undeclared (first use in this function)
x264.c:82: error: ‘X264_TYPE_AUTO’ undeclared (first use in this function)
x264.c:84: warning: implicit declaration of function ‘x264_encoder_encode’
x264.c:84: error: ‘pic_out’ undeclared (first use in this function)
x264.c:95: error: ‘X264_TYPE_IDR’ undeclared (first use in this function)
x264.c:96: error: ‘X264_TYPE_I’ undeclared (first use in this function)
x264.c:99: error: ‘X264_TYPE_P’ undeclared (first use in this function)
x264.c:102: error: ‘X264_TYPE_B’ undeclared (first use in this function)
x264.c:103: error: ‘X264_TYPE_BREF’ undeclared (first use in this function)
x264.c: In function ‘X264_close’:
x264.c:117: error: ‘x4’ undeclared (first use in this function)
x264.c:120: warning: implicit declaration of function ‘x264_encoder_close’
x264.c: In function ‘X264_init’:
x264.c:128: error: ‘x4’ undeclared (first use in this function)
x264.c:130: warning: implicit declaration of function ‘x264_param_default’
x264.c:164: warning: implicit declaration of function ‘x264_encoder_open’
make[1]: *** [x264.o] Error 1
make[1]: Leaving directory `/home/shriphani/ffmpeg-0.cvs20050918/libavcodec'
make: *** [lib] Error 2
shriphani@ubuntu-box:~/ffmpeg-0.cvs20050918$

xyz
December 30th, 2006, 10:49 AM
Thanks a lot for the guide. Great job!
When I get to:

tar xzf libgpod-0.3.2.tar.gz
I get:

th@luser:~/mpeg4ip-1.5.0.1$ tar xzf libgpod-0.3.2.tar.gz
tar: libgpod-0.3.2.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

On the SourceForge site, I noticed it's now:

libgpod-0.4.0
but it doesn't work either. What am I doing wrong?

etola
December 30th, 2006, 03:06 PM
Hi,

I'm having the below error while I'm trying to compile mpeg4ip. any idea why this could happen ?


Making all in ffmpeg
make[5]: Entering directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin/audio/ffmpeg'
if /bin/bash ../../../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I../../../../player/src -I../../../../player/lib -I../../../../include -I../../../../lib -I../../../../lib/mp4av -I../../../../lib/mp4v2 -I../../../../lib/sdp -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -Wformat=2 -Wpointer-arith -Wsign-compare -g -O2 -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -MT ffmpeg.lo -MD -MP -MF ".deps/ffmpeg.Tpo" -c -o ffmpeg.lo ffmpeg.cpp; \
then mv -f ".deps/ffmpeg.Tpo" ".deps/ffmpeg.Plo"; else rm -f ".deps/ffmpeg.Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I../../../../player/src -I../../../../player/lib -I../../../../include -I../../../../lib -I../../../../lib/mp4av -I../../../../lib/mp4v2 -I../../../../lib/sdp -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -Wformat=2 -Wpointer-arith -Wsign-compare -g -O2 -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -MT ffmpeg.lo -MD -MP -MF .deps/ffmpeg.Tpo -c ffmpeg.cpp -fPIC -DPIC -o .libs/ffmpeg.o
ffmpeg.cpp: In function 'codec_data_t* ffmpeg_create(const char*, const char*, int, int, format_list_t*, audio_info_t*, const uint8_t*, uint32_t, audio_vft_t*, void*)':
ffmpeg.cpp:169: error: invalid conversion from 'void*' to 'uint8_t*'
make[5]: *** [ffmpeg.lo] Error 1
make[5]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin/audio/ffmpeg'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin/audio'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1'
make: *** [all] Error 2

FakeOutdoorsman
December 30th, 2006, 09:12 PM
shriphani: do you have x264 installed? Try installing it via Synaptic. You could use the x264 SVN (http://developers.videolan.org/x264.html) as well, but you will encounter errors with mpeg4ip. If you want to use x264 SVN then read post #347 (http://ubuntuforums.org/showpost.php?p=1907905&postcount=347).

xyz: you will get those errors if you try to run tar on a file that does not exist in the current directory. Find out where you downloaded libgpod-0.3.2.tar.gz to and run "tar xzf libgpod-0.3.2.tar.gz" in that same directory.

etola
December 30th, 2006, 10:38 PM
ok, forget about that. I hacked the code a little bit and now it compiles...


Hi,

I'm having the below error while I'm trying to compile mpeg4ip. any idea why this could happen ?


Making all in ffmpeg
make[5]: Entering directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin/audio/ffmpeg'
if /bin/bash ../../../../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I../../../../player/src -I../../../../player/lib -I../../../../include -I../../../../lib -I../../../../lib/mp4av -I../../../../lib/mp4v2 -I../../../../lib/sdp -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -Wformat=2 -Wpointer-arith -Wsign-compare -g -O2 -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -MT ffmpeg.lo -MD -MP -MF ".deps/ffmpeg.Tpo" -c -o ffmpeg.lo ffmpeg.cpp; \
then mv -f ".deps/ffmpeg.Tpo" ".deps/ffmpeg.Plo"; else rm -f ".deps/ffmpeg.Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I../../../../player/src -I../../../../player/lib -I../../../../include -I../../../../lib -I../../../../lib/mp4av -I../../../../lib/mp4v2 -I../../../../lib/sdp -D_REENTRANT -DNOCONTROLS -fexceptions -Wall -Wno-char-subscripts -Woverloaded-virtual -Wno-unknown-pragmas -Wno-deprecated -Wformat=2 -Wpointer-arith -Wsign-compare -g -O2 -DMPEG4IP -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -MT ffmpeg.lo -MD -MP -MF .deps/ffmpeg.Tpo -c ffmpeg.cpp -fPIC -DPIC -o .libs/ffmpeg.o
ffmpeg.cpp: In function 'codec_data_t* ffmpeg_create(const char*, const char*, int, int, format_list_t*, audio_info_t*, const uint8_t*, uint32_t, audio_vft_t*, void*)':
ffmpeg.cpp:169: error: invalid conversion from 'void*' to 'uint8_t*'
make[5]: *** [ffmpeg.lo] Error 1
make[5]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin/audio/ffmpeg'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin/audio'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player/plugin'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1/player'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tola/downloads/mpeg4ip-1.5.0.1'
make: *** [all] Error 2

xyz
December 31st, 2006, 11:57 AM
shriphani: do you have x264 installed? Try installing it via Synaptic. You could use the x264 SVN (http://developers.videolan.org/x264.html) as well, but you will encounter errors with mpeg4ip. If you want to use x264 SVN then read post #347 (http://ubuntuforums.org/showpost.php?p=1907905&postcount=347).

xyz: you will get those errors if you try to run tar on a file that does not exist in the current directory. Find out where you downloaded libgpod-0.3.2.tar.gz to and run "tar xzf libgpod-0.3.2.tar.gz" in that same directory.
How stupid of me! The HowTo says:

wget http://umn.dl.sourceforge.net/sourceforge/gtkpod/libgpod-0.4.tar.gz
tar xzf libgpod-0.3.2.tar.gz
cd libgpod-0.3.2/
It should say:

tar xzf libgpod-0.4.0.tar.gz
cd libgpod-0.4.0/
..then tar woks much better!!
Now it's obvious...I can't tar 0.3.2 when I downloaded 0.4.0!!!
Must be the end of the year!!
Thanks for the help.

FernandoMilton
January 5th, 2007, 01:05 AM
For all you guys with trouble compiling ffmpeg, getting the "ERROR: x264 not found" error message.

The problem, as I found here (http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2006-August/013616.html) is that you must to enable pthreads when compiling ffmpeg with x264 support, so, append "--enable-pthreads" to the end of your "./configure" line and it will compile OK :)

TuxGirl
January 7th, 2007, 03:13 AM
I'm hitting the same problem as some of the other people, but I didn't see an answer here.

ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-zlib --enable-vorbis --enable-libogg --enable-theora --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-ogm
built on Apr 29 2006 00:14:12, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
Input #0, mov,mp4,m4a,3gp,3g2, from '300k.mov':
Duration: 00:01:36.2, start: 0.000000, bitrate: 390 kb/s
Stream #0.0: Video: svq1, yuv410p, 320x240, 600.00 fps
Stream #0.1: Audio: QDM2 / 0x324D4451, 22050 Hz, mono
File 'ipod/300k.mov' already exists. Overwrite ? [y/N] y
Output #0, mp4, to 'ipod/300k.mov':
Stream #0.0: Video: mpeg4, yuv420p, 320x240, 600.00 fps, q=3-5, 700 kb/s
Stream #0.1: Audio: aac, 22050 Hz, mono, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[aac @ 0x83346a8]libfaac doesn't support this output format!
Error while opening codec for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height

I'd appreciate any pointers on what could be wrong. My command-line is below:
ffmpeg -i "$1" -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 320x240 -aspect 4:3 ipod/$new_name;

Thanks!
~TuxGirl

jak
January 14th, 2007, 01:38 PM
Please note, when building ffmpeg you also need to install the following packages beforehand:-

libdts-dev libvorbis-dev libx264-dev libgsm1-dev libdc1394-13-dev libraw1394-dev

( Ubuntu Edgy, AMD64 )

stoic
January 19th, 2007, 12:22 AM
TuxGirl:

Looks like your audio settings are causing problems.

You are asking ffmpeg to encode aac at a high bitrate (192kbps) but low frequency and only in mono (these last two are probably because you are using a low quality source file).

Either try a higher quality source, or reduce the bitrate (the -ab option).
It may also help to state the frequency and channels directly, ie -ar 22050 and -ac 1 (for mono).

Stoic

bitterbug
January 19th, 2007, 04:39 AM
If anyone else has run into 'unk208' compile errors with the latest gtkpod/libgpod releases, just edit the relevant files in the /src directory.

Replace 'unk208' with 'mediatype' in:

file.c
file_itunesdb.c

and everything should work fine after that.

thanks to this thread:
http://article.gmane.org/gmane.comp.ipod.gtkpod/1618/match=track+member+named+unk208

musse1
January 22nd, 2007, 05:21 PM
Gave this a try again and followed this tutorial:
http://po-ru.com/diary/fixing-ffmpeg-on-ubuntu-edgy/
But I still can't get it to encode ANYTHING! If I use x264:

ffmpeg -i /var/www/www/stream/tackle.avi -vcodec x264 -acodec mp3 -s 340x280 /var/www/www/stream/test.avi

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-vorbis --enable-libogg --ena
ble-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp
3lame --enable-faad --enable-faac --enable-xvid --enable-pthreads --enable-x264
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Jan 22 2007 17:10:17, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-
13ubuntu5)
Input #0, avi, from '/var/www/www/stream/tackle.avi':
Duration: 00:00:29.1, start: 0.000000, bitrate: 545 kb/s
Stream #0.0: Video: 3IV2 / 0x32564933, 320x256, 25.00 fps(r)
Unknown codec 'x264'


This is how it looks with any of the codecs I try to use. If I use xvid instead I get this result: Unsupported codec (id=0) for input stream #0.0. What to do?!?!?

dumbkiwi
January 23rd, 2007, 01:21 AM
You need to call the codec 'h264', not 'x264'. However, you may want to try http://thinliquidfilm.org which is a nice gui app for encoding and transferring video to your ipod.

musse1
January 23rd, 2007, 02:34 PM
Then it says this instead:

ffmpeg -i /var/www/www/stream/tackle.avi -vcodec h264
-acodec mp3 -s 340x280 /var/www/www/stream/test.avi
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-vorbis --enable-libogg --ena
ble-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp
3lame --enable-faad --enable-faac --enable-xvid --enable-pthreads --enable-x264
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Jan 22 2007 17:10:17, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-
13ubuntu5)
Input #0, avi, from '/var/www/www/stream/tackle.avi':
Duration: 00:00:29.1, start: 0.000000, bitrate: 545 kb/s
Stream #0.0: Video: 3IV2 / 0x32564933, 320x256, 25.00 fps(r)
File '/var/www/www/stream/test.avi' already exists. Overwrite ? [y/N] y
PIX_FMT_YUV420P will be used as an intermediate format for rescaling
Output #0, avi, to '/var/www/www/stream/test.avi':
Stream #0.0: Video: h264, yuv420p, 340x280, q=2-31, 200 kb/s, 25.00 fps(c)
Stream mapping:
Stream #0.0 -> #0.0
[h264 @ 0x85368d8]width or height not divisible by 16 (340x280), compression wil
l suffer.
[h264 @ 0x85368d8]using cpu capabilities MMX MMXEXT SSE 3DNow!
Unsupported codec (id=0) for input stream #0.0

endersshadow
January 23rd, 2007, 04:27 PM
Your problem isn't h264, it's 3IV2. At the moment, this is a read only codec for Linux (http://www.3ivx.com/download/unix.html) and ffmpeg does not support it.

musse1
January 23rd, 2007, 04:55 PM
Managed to encode with php:

exec("/usr/local/bin/ffmpeg -i /var/www/www/stream/video/Yes.wmv -b 300 -maxrate 300 -r 25 -s 384x256 -vcodec h264 -acodec mp3 /var/www/www/stream/video/test.avi");

But the video gets fliped upsidedown when played in the browser but not in the mediaplayer. Whats the problem? Is there a way to flip the files with fmpeg?

djmadkins
January 29th, 2007, 01:54 AM
I've been using the command line to do this and was hoping one of you guys could help me.

Sometimes when transcoding the contents of a DVD for my Ipod I will get the French soundtrack or the director's commentary instead of the english soundtrack which is what I want.


I do a two step process:

1)

mplayer dvd://1 -dumpstream -dumpfile dvdcache.vob

Now this VOB file is the input into a shell script that issues the following:

2)

ffmpeg -y -i "$1" -f mp4 -vcodec xvid -maxrate 1000 -b 400 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 128 -s 320x240 "$2"

On a recent transcode I got the following output which ends up being in french:


Input #0, mpeg, from 'blackhawk_down.vob':
Duration: 02:24:19.7, start: 0.041500, bitrate: 5195 kb/s
Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480, 9800 kb/s, 29.97 fps(r)
Stream #0.1[0x81]: Audio: ac3, 48000 Hz, stereo, 192 kb/s
Stream #0.2[0x80]: Audio: ac3, 48000 Hz, 5:1, 448 kb/s
Output #0, mp4, to 'blackhawk_down.mp4':
Stream #0.0: Video: xvid, yuv420p, 320x240, q=3-5, 400 kb/s, 29.97 fps(c)
Stream #0.1: Audio: aac, 48000 Hz, stereo, 128 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1

I suspect that the audio I really want is the stream 0.2 and this is my question.. What is the format or use of the map switch to do this?

thanks in advance!
Jeff

FakeOutdoorsman
January 29th, 2007, 02:43 AM
I've never done this, but I believe you will want to add "-map 0:0 -map 0:2" to your command so in the end it might look like this:



ffmpeg -y -i "$1" -map 0:0 -map 0:2 -f mp4 -vcodec xvid -maxrate 1000 -b 400 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 128 -s 320x240 "$2"


More info:
ffmpeg audio/video manipulation (http://howto-pages.org/ffmpeg/#map)
Converting Video Formats with FFmpeg (http://www.linuxjournal.com/article/8517)

patsissons
January 30th, 2007, 05:18 PM
I can't remember if I have posted this before, but in any case, I have built a script that works quite well for encoding video for the ipod. You will need ffmpeg with all the compile time options enabled, if you don't have this already, i have another thread that explains how to get it without too much trouble.

http://ubuntuforums.org/showthread.php?t=325963

the script itself is completely configurable, so you can change any of the default settings if you like. The default settings are designed for small file size with no noticeable loss of quality while viewing on the ipod. If you plan on using the video on a larger screen i would recommend bumping up the video (and probably also the audio) quality. Also, this script uses a 2pass h264 encode by default. here is the script:



#!/bin/sh
# ipodvidenc
# Created by Pat Sissons

# general format config
# PASSLOG = where the 1st pass data is stored
# FORMAT = type of video file, for ipod this must be either mov, mp4, or h264
PASSLOG=/tmp/ipodvidenc.pass
FORMAT=h264

# video format config
# VCODEC = video codec, generally h264 or mpeg4
# VBITRATE = video bit rate (300 looks decent)
# VMAXRATE = max video bit rate (400 is good)
# VSIZE = video size [WxH] (320x240 is standard)
# ASPECT = aspect ratio (4:3 is standard)
# FRAMERATE = fps for the video (ntsc is standard, but 15 cuts the filesize down a lot)
VCODEC=h264
VBITRATE=300
VMAXRATE=400
VSIZE=320x240
ASPECT=4:3
FRAMERATE=15

# video advanced settings
# MOTION = motion estimator (epzs, full, etc...)
# QPEL = subpel refinement quality (1 = slow/HQ, 8 = fast/LQ)
# REFS = encode quality? (higher values = higher quality but slower)
# BUFSIZE = rate control buffer size
# GOPSIZE = how many frames between I-Frames
MOTION=epzs
QPEL=8
REFS=1
BUFSIZE=244
GOPSIZE=300

# audio format settings
# ACODEC = audio codec (this shouldn't change from aac)
# AFREQ = audio frequency (48000 is normal)
# ABITRATE = audio bit rate (48 sounds good with standard ipod headphones)
ACODEC=aac
AFREQ=48000
ABITRATE=48

while [ $# -gt 1 ]
do
case "$1" in
--help)
echo "Options :"
echo -e "\t--help (display this help text)\n"
echo -e "\t--passlog s (default is /tmp/ipodvidenc.pass)"
echo -e "\t--format s (default is h264)"
echo -e "\t--vcodec s (default is h264)"
echo -e "\t--vbitrate s (default is 300)"
echo -e "\t--vmaxrate s (default is 400)"
echo -e "\t--vsize s (default is 320x240)"
echo -e "\t--aspect s (default is 4:3)"
echo -e "\t--framerate s (default is 15)"
echo -e "\t--motion s (default is epzs)"
echo -e "\t--qpel s (default is 8)"
echo -e "\t--refs s (default is 1)"
echo -e "\t--bufsize s (default is 244)"
echo -e "\t--gopsize s (default is 300)"
echo -e "\t--acodec s (default is aac)"
echo -e "\t--afreq s (default is 48000)"
echo -e "\t--abitrate s (default is 48)"
exit
;;
--passlog)
PASSLOG=$2
shift 2
;;
--format)
FORMAT=$2
shift 2
;;
--vcodec)
VCODEC=$2
shift 2
;;
--vbitrate)
VBITRATE=$2
shift 2
;;
--vmaxrate)
VMAXRATE=$2
shift 2
;;
--vsize)
VSIZE=$2
shift 2
;;
--aspect)
ASPECT=$2
shift 2
;;
--framerate)
FRAMERATE=$2
shift 2
;;
--motion)
MOTION=$2
shift 2
;;
--qpel)
QPEL=$2
shift 2
;;
--refs)
REFS=$2
shift 2
;;
--bufsize)
BUFSIZE=$2
shift 2
;;
--gopsize)
GOPSIZE=$2
shift 2
;;
--acodec)
ACODEC=$2
shift 2
;;
--afreq)
AFREQ=$2
shift 2
;;
--abitrate)
ABITRATE=$2
shift 2
;;
*)
echo "Unknown Option [$1]"
shift
;;
esac
done

input_file=$1

output_file=`basename "${input_file}"`

ffmpeg -y -pass 1 -passlogfile ${PASSLOG} -i "${input_file}" -vcodec ${VCODEC} -me ${MOTION} -refs ${REFS} -subq ${QPEL} -b ${VBITRATE} -rc_max_rate ${VMAXRATE} -rc_buffer_size ${BUFSIZE} -s ${VSIZE} -r ${FRAMERATE} -max_b_frames 0 -level 13 -g ${GOPSIZE} -f ${FORMAT} /dev/null
ffmpeg -y -pass 2 -passlogfile ${PASSLOG} -i "${input_file}" -vcodec ${VCODEC} -me ${MOTION} -refs ${REFS} -subq ${QPEL} -b ${VBITRATE} -rc_max_rate ${VMAXRATE} -rc_buffer_size ${BUFSIZE} -s ${VSIZE} -r ${FRAMERATE} -max_b_frames 0 -level 13 -g ${GOPSIZE} -acodec ${ACODEC} -ar ${AFREQ} -ab ${ABITRATE} "${output_file}.mp4"


The only problem with it at the moment is that it dumps an h264 log file in your current directory. I haven't figured out how to set the location of this yet, but it is fairly small and low priority. Hope this is useful for some people.

djmadkins
January 31st, 2007, 02:14 AM
-map 0:0 -map 0.2 added to the line did the trick.

thanks :)

c.dric
February 4th, 2007, 07:29 PM
hi,

i've used the ipodvidenc script successfully to encode avi files in the 4:3 aspect ... but most of my movies are way too stretched ... so i've tried a few other aspects like 16:9 or 2.4761 but those movies don't play on my ipod. i get a blackscreen for a second or 20 then it goes back to the menu.

here are the options i'm using (the exact same options with 4:3 aspect worked perfectly) :


ffmpeg -i ${input_file} -f mp4 -vcodec xvid -maxrate 700 -b 2500 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 640x480 -aspect 16:9 ....

for the record ... it's a new 30gb video ipod (i guess that's a 5.5) version is 1.2.1

any ideas what i'm doing wrong ?

FakeOutdoorsman
February 4th, 2007, 10:47 PM
You need to change 640x480 to 640x352 for 16:9 widescreen movies.

c.dric
February 5th, 2007, 06:26 AM
You need to change 640x480 to 640x352 for 16:9 widescreen movies.

Thanks, that did it ...

I do have another question ...
There is one of my movie that's out of sync after the encoding ... only one out of the seven i did so far. the original avi is fine so i don't know what the problem may be.

here is the command i've used :
ffmpeg -i ${input_file} -f mp4 -vcodec xvid -maxrate 700 -b 2500 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 640x352 ....

i've tried with only one pass then i tried with 2 passes but with the same result.
what else could i try ?

endersshadow
February 5th, 2007, 07:51 AM
c.dric, do you have the output for ffmpeg for that?

c.dric
February 5th, 2007, 01:04 PM
c.dric, do you have the output for ffmpeg for that?

output of pass 1 :


cedric@mobile:$ ffmpeg -i movie.avi -f mp4 -vcodec xvid -maxrate 700 -b 2500 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 640x296 -pass 1 /home/cedric/movie.mov
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-x264
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Feb 2 2007 22:39:15, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Input #0, avi, from 'movie.avi':
Duration: 02:24:32.3, start: 0.000000, bitrate: 870 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 588x244, 25.00 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 112 kb/s
Output #0, mp4, to '/home/cedric/movie.mov':
Stream #0.0: Video: xvid, yuv420p, 640x296, q=3-5, pass 1, 2500 kb/s, 25.00 fps(c)
Stream #0.1: Audio: aac, 48000 Hz, stereo, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Press [q] to stop encoding
frame=216808 q=2.0 Lsize= 2309066kB time=8669.8 bitrate=2181.8kbits/s
video:2129302kB audio:174884kB global headers:0kB muxing overhead 0.211812%


output of pass 2 :


cedric@mobile:$ ffmpeg -i movie.avi -f mp4 -vcodec xvid -maxrate 700 -b 2500 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 640x296 -pass 2 /home/cedric/movie.mov
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-x264
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Feb 2 2007 22:39:15, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Input #0, avi, from 'movie.avi':
Duration: 02:24:32.3, start: 0.000000, bitrate: 870 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 588x244, 25.00 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 112 kb/s
Output #0, mp4, to 'movie.mov':
Stream #0.0: Video: xvid, yuv420p, 640x296, q=3-5, pass 2, 2500 kb/s, 25.00 fps(c)
Stream #0.1: Audio: aac, 48000 Hz, stereo, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Press [q] to stop encoding
frame=216808 q=3.0 Lsize= 1577240kB time=8669.8 bitrate=1490.3kbits/s
video:1397476kB audio:174884kB global headers:0kB muxing overhead 0.310396%

endersshadow
February 5th, 2007, 02:22 PM
It's possibly because your new audio bitrate is greater than the previous audio bitrate. Try leaving the -ab 192 tag off and just do one pass to save a bit of time to test it.

c.dric
February 5th, 2007, 07:06 PM
i removed the -ab 192 but that didn't solve it.
here is the output :


cedric@mobile:/$ ffmpeg -i movie.avi -f mp4 -vcodec xvid -maxrate 700 -b 2500 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -s 640x296 /home/cedric/movie.mov
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-libogg --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-x264
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Feb 2 2007 22:39:15, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Input #0, avi, from 'movie.avi':
Duration: 02:24:32.3, start: 0.000000, bitrate: 870 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 588x244, 25.00 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 112 kb/s
Output #0, mp4, to '/home/cedric/movie.mov':
Stream #0.0: Video: xvid, yuv420p, 640x296, q=3-5, 2500 kb/s, 25.00 fps(c)
Stream #0.1: Audio: aac, 48000 Hz, stereo, 64 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
Press [q] to stop encoding
frame=216808 q=3.0 Lsize= 1459927kB time=8669.8 bitrate=1379.5kbits/s
video:1387205kB audio:67842kB global headers:0kB muxing overhead 0.335423%

should i try another codec ?

endersshadow
February 5th, 2007, 08:13 PM
Hrm. You can try playing with the -async flag by adding -async 10 or if you just want to set the first timestamp correctly, -async 1. Let me know.

c.dric
February 5th, 2007, 09:32 PM
i did a test on the first 10000 frames with the -async 1 option and it looks (or sounds) ok now :)

i'm gonna try the full film.

thanks endersshadow :)

c.dric
February 6th, 2007, 02:39 AM
ok, full film was fine with -async 1 option too.

i did notice something strange with gtkpod or the ipod tho :

after my successful encoding i erased the out of sync copy i had on my ipod and copied the good copy from my computer using gtkpod. i try the newly transfered copy on my ipod and it was out of sync.

so i removed the copy on my ipod again, renamed the good copy on my comp and transfered again using gtkpod and then it was fine.

is there some kind of caching system in gtkpod or the ipod ? is it a bug ?

anyway it's nothing critical. my movies are all great now. i'm just curious :)

endersshadow
February 6th, 2007, 05:25 AM
Well, you do have to commit to the iPod with gtkpod, since it caches everything and saves the write until you hit the "Write to iPod" button. That way, it's much faster. That's the only thing I can think of.

Glad to hear you got it working!

c.dric
February 6th, 2007, 05:39 AM
Well, you do have to commit to the iPod with gtkpod, since it caches everything and saves the write until you hit the "Write to iPod" button.

ooh ](*,) that must be it. i didn't save the changes after removing the old version so it must have cancelled the removal when i added a new copy with the same name.

NorthernLights
February 14th, 2007, 04:33 AM
For all you people who are trying to easily encode videos to use on iPod Video : I'm developping a GUI to mplayer, mencoder and mp4creator to do just that. It's currently in alpha version but it's usable. Check http://sive.sourceforge.net ;)

endersshadow
February 14th, 2007, 07:29 AM
For all you people who are trying to easily encode videos to use on iPod Video : I'm developping a GUI to mplayer, mencoder and mp4creator to do just that. It's currently in alpha version but it's usable. Check http://sive.sourceforge.net ;)

Best of luck to you. Looks promising. My suggestion would be not to name it Simple iPod Video Encoder if you want to add other functionality to it later, as a more generic mencoder frontend. Just a thought...at any rate, good luck.

Oh, and Sourceforge's shell is down so I can't upload a web page, but at any rate, I released Vive 2.0.0-beta1 today. All the beta1 means is that I've got a bit of code cleanup to do, especially w/r/t slight memory leaks that really don't effect things too much, but drive me crazy, so I'll fix them. You can download it at the Vive Project Page (https://sourceforge.net/projects/vive). Feel free to give me feedback either here or at endersshadow AT users DOT sourceforge DOT net. Thanks!

NorthernLights
February 14th, 2007, 10:15 AM
Thanks for the comments :)

Did you include subtitles support in your new version ? I tried VIVE before, but could not find this functionality ; that contributed to give me the idea of SIVE.

endersshadow
February 14th, 2007, 02:57 PM
Not in the beta. I'm putting them in for the actual release, though.

InsaneDuz
February 18th, 2007, 02:48 AM
ok, forget about that. I hacked the code a little bit and now it compiles...

etola: I came across the same problem, but I'm not sure what modifications to make to the code to fix it. Can you explain what you did please?

InsaneDuz
February 18th, 2007, 03:53 AM
etola: I came across the same problem, but I'm not sure what modifications to make to the code to fix it. Can you explain what you did please?

Never mind, I figured it out. For anyone else that comes across this issue, to fix it, replace the following lines of code:

in file: player/plugin/audio/ffmpeg/ffmpeg.cpp, line 169:
replace:

ffmpeg->m_c->extradata = (void *)userdata;
with:

ffmpeg->m_c->extradata = (uint8_t *)userdata;

in file: player/plugin/video/ffmpeg/ffmpeg.cpp, line 258:
replace:

ffmpeg->m_c->extradata = (void *)userdata;
with:

ffmpeg->m_c->extradata = (uint8_t *)userdata;

This should resolve this compile error.

c.dric
March 3rd, 2007, 01:16 AM
how should i do to encode the subtitles in the movie with ffmpeg ?

i have a .srt file in the same directory and the same name as the .avi file.

mplayer plays the movie with the subs but ffmpeg doesn't add the subs to the output movie and i couldn't find an option in the man pages.

thanks.

ps : i've downloaded the SIVE program but i'm having problems compiling the mpeg4ip program required.

rabid9797
March 5th, 2007, 01:49 AM
i have a question about Vive! where do i find libvte? i have libvte9 and such installed from apt-get but there is no just "libvte" :confused:

wilbur.harvey
March 5th, 2007, 08:39 PM
When trying to compile mpeg4ip-1.5.0.1 I get the following error. (Feisty as of 2007-03-02)

/data/software/mpeg4ip-1.5.0.1/player/src/video_sdl.cpp:280: undefined reference to `XMoveWindow'
collect2: ld returned 1 exit status

wharvey@LUNFORCE40:/data/software/mpeg4ip-1.5.0.1$ grep -R XMoveWindow *
player/src/video_sdl.cpp: XMoveWindow(info.info.x11.display, info.info.x11.wmwindow,
Binary file player/src/.libs/video_sdl.o matches
Binary file player/src/.libs/libmp4sdlvideo.a matches
Binary file player/src/video_sdl.o matches
wharvey@LUNFORCE40:/data/software/mpeg4ip-1.5.0.1$

Any ideas?

endersshadow
March 7th, 2007, 10:42 AM
Okay, sorry for the late reply...real world stuff has taken me ahold and won't let go, but I'll do this as quick as possible:

c.dric: When I try to get subtitles with ffmpeg, I get nothing. I would advise mencoder, which can be used via AcidRip or gmencoder. Sorry :-|

rabid: sudo apt-get install libvte-dev

wilbur: sudo apt-get install libsdl1.2-dev

Cheers :-D

montgoss
March 8th, 2007, 07:18 PM
Just an FYI.

I had some trouble compiling ffmpeg. There were several libraries missing. I believe the ones I had to install were ogg, vorbis, dts, dc1394, and x264. If there was an apt-get in there that I missed, my bad. Otherwise, it might be good to add that to make sure anyone more noobish than me won't have a problem.

My second problem compiling ffmpeg were some "permission denied" errors when I tried to do ./configure and make. I had to run those two with sudo. I'm not sure why. Perhaps "apt-get source" made the files downloaded owned by root?

But other than that, the guide was great. I got the latest episode of House on my iPod! =D>
The next step is getting MythTV to automatically transcode shows for the iPod. :popcorn:

FakeOutdoorsman
March 9th, 2007, 01:45 AM
I had some trouble compiling ffmpeg. There were several libraries missing. I believe the ones I had to install were ogg, vorbis, dts, dc1394, and x264. If there was an apt-get in there that I missed, my bad. Otherwise, it might be good to add that to make sure anyone more noobish than me won't have a problem.

The latest ffmpeg SVN configure options have changed for some libraries. For example you might have used this:


./configure --enable-gpl --enable-pp --enable-vorbis --enable-ogg --enable-dc1394 --disable-debug --enable-mp3lame --enable-faad --enable-faac --enable-xvid --enable-pthreads --enable-x264

The latest SVN won't work with the above code, but it would work with:

./configure --enable-gpl --enable-pp --enable-libvorbis --enable-libogg --enable-dc1394 --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-xvid --enable-pthreads --enable-x264

Sometimes you need to make sure that the dev versions of some libraries are installed as well. If you have liblame0, then ffmpeg might not install unless you also install liblame-dev.

endersshadow
March 9th, 2007, 04:18 AM
My second problem compiling ffmpeg were some "permission denied" errors when I tried to do ./configure and make. I had to run those two with sudo. I'm not sure why. Perhaps "apt-get source" made the files downloaded owned by root?

This is exactly the problem. apt-get source does not need to be run as sudo. If it is, all files are owned by root.

Glad to hear you got it working, though :-D

invids
March 10th, 2007, 05:54 AM
how exactly do you link link libgpod.so from /usr/local/bin to /usr/lib ?
I dont know the command to type.

Nephiel
March 10th, 2007, 08:58 PM
The command to create a symbolic link is "ln":

ln -s TARGET LINK_NAME

For example, to create a symbolic link to /usr/local/lib/libgpod.so in /usr/lib/ :

ln -s /usr/local/lib/libgpod.so /usr/lib/libgpod.so
You may need to be root to create files in /usr/lib, so use "sudo" before the ln command if you need it.

For more info about the "ln" command:

man ln

montgoss
March 11th, 2007, 09:58 PM
I can't get Vive to build. I can't even get past the ./configure step. It says:
configure: error: libdvdread development files are not install but are required to compile.
But
sudo apt-get install libdvdread-dev libdvdread3
Reading package lists... Done
Building dependency tree
Reading state information... Done
libdvdread-dev is already the newest version.
libdvdread3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

So, I don't understand why it's giving me that error. I saw some option to compile without DVD support. I did that the first time. But now I'd like to rip some DVDs and Acidrip is producing audio sync issue. Maybe Vive will have better luck, if I can get it to build... Any ideas?

endersshadow
March 12th, 2007, 03:55 AM
montgross, what do you get when you try this command:


locate dvdread

montgoss
March 12th, 2007, 05:25 AM
montgross, what do you get when you try this command:


locate dvdread

I get:

locate dvdread
/var/lib/dpkg/info/libdvdread3.shlibs
/var/lib/dpkg/info/libdvdread3.list
/var/lib/dpkg/info/libdvdread3.postinst
/var/lib/dpkg/info/libdvdread3.postrm
/var/lib/dpkg/info/libdvdread3.md5sums
/var/lib/dpkg/info/libdvdread-dev.md5sums
/var/lib/dpkg/info/libdvdread-dev.list
/home/montgoss/myth_svn/mythtv/libs/libmythdvdnav/.svn/text-base/dvdread_internal.h.svn-base
/home/montgoss/myth_svn/mythtv/libs/libmythdvdnav/.svn/prop-base/dvdread_internal.h.svn-base
/home/montgoss/myth_svn/mythtv/libs/libmythdvdnav/.svn/props/dvdread_internal.h.svn-work
/home/montgoss/myth_svn/mythtv/libs/libmythdvdnav/.svn/wcprops/dvdread_internal.h.svn-work
/home/montgoss/myth_svn/mythtv/libs/libmythdvdnav/dvdread_internal.h
/home/montgoss/montgoss-MythTV/mythtv-0.20/libs/libmythdvdnav/dvdread_internal.h
/home/moko/openembedded/packages/libdvdread
/home/moko/openembedded/packages/libdvdread/libdvdread_0.9.6.bb
/usr/include/dvdread
/usr/include/dvdread/dvd_reader.h
/usr/include/dvdread/ifo_types.h
/usr/include/dvdread/ifo_read.h
/usr/include/dvdread/ifo_print.h
/usr/include/dvdread/nav_types.h
/usr/include/dvdread/nav_read.h
/usr/include/dvdread/nav_print.h
/usr/include/dvdread/cmd_print.h
/usr/lib/gstreamer-0.10/libgstdvdread.so
/usr/lib/vlc/access/libdvdread_plugin.so
/usr/lib/libdvdread.so.3.2.0
/usr/lib/libdvdread.so.3
/usr/lib/libdvdread.a
/usr/lib/libdvdread.la
/usr/lib/libdvdread.so
/usr/lib/gstreamer-0.8/libgstdvdreadsrc.so
/usr/share/doc/libdvdread3
/usr/share/doc/libdvdread3/changelog.Debian.gz
/usr/share/doc/libdvdread3/install-css.sh
/usr/share/doc/libdvdread3/changelog.gz
/usr/share/doc/libdvdread3/TODO
/usr/share/doc/libdvdread3/README.Debian
/usr/share/doc/libdvdread3/copyright
/usr/share/doc/libdvdread-dev
/usr/share/doc/libdvdread-dev/changelog.Debian.gz
/usr/share/doc/libdvdread-dev/changelog.gz
/usr/share/doc/libdvdread-dev/copyright

endersshadow
March 12th, 2007, 07:41 PM
Try this:


./configure --PREFIX=/usr

montgoss
March 13th, 2007, 04:06 AM
$ ./configure --prefix=/usr
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for ffmpeg... yes
checking for vobcopy... yes
checking for mplayer... yes
checking whether DVD is enabled... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... yes (version 2.10.6)
checking for vte_terminal_new in -lvte... yes
checking for dvdcss_open in -ldvdcss... yes
checking for DVDOpen in -ldvdread... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking gtk/gtk.h usability... yes
checking gtk/gtk.h presence... yes
checking for gtk/gtk.h... yes
checking vte/vte.h usability... yes
checking vte/vte.h presence... yes
checking for vte/vte.h... yes
checking dvdcss/dvdcss.h usability... yes
checking dvdcss/dvdcss.h presence... yes
checking for dvdcss/dvdcss.h... yes
checking dvdnav/ifo_read.h usability... no
checking dvdnav/ifo_read.h presence... no
checking for dvdnav/ifo_read.h... no
configure: error: libdvdread development files are not install but are required to compile.

endersshadow
March 13th, 2007, 04:53 AM
My fault. Try:


sudo apt-get install libdvdnav-dev libdvdnav4

montgoss
March 13th, 2007, 05:13 AM
Ok, so I got it to build. But it just segfaults when I click encode (after choosing all my settings). It also won't save my preferences. I'm not sure if that could be related.

Ya know, I don't really need a GUI. What's the syntax to get ffmpeg to read straight from a DVD?

endersshadow
March 13th, 2007, 02:17 PM
Well that's interesting.

And ffmpeg can't read from DVD's, so you need to use vobcopy or mencoder.

Let me know what settings you were using and I'll give you the exact commands.

montgoss
March 13th, 2007, 04:10 PM
Can mencoder rip to mpeg-4? I used Acidrip to rip to mpeg-2, but it screws up the audio sync on this particular TV series. If I ripped to an avi, it works. But it takes so much longer and doesn't look as good.

The ffmpeg command I used to get a decent video off DVD is:

ffmpeg -i VTS_05_1.VOB -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -qmin 3 -qmax 5 -bufsize 4096 -g 300 -acodec aac -ab 192 -s 480x270 -aspect 16:9 /home/montgoss/Desktop/iPod_Videos/Carnivale-S2E03-Ingram,_TX_part1.m4v
This command produces a beautiful little video.

The problem is that VTS_05_1.vob isn't the full title off the DVD. Some of the vobs aren't even broken down in logical points. Like, VTS_05_1.vob is the first 26 minutes of an episode. Then VTS_05_2.vob is the last 25 minutes of the episode plus the first 2 minutes of the next episode. Mencoder understands this, but gets the audio sync wrong.

I think I tried vobcopy. But all it seemed to do was rip a vob off the DVD. Will it actually rip a title off? Like the straight mpeg-2? Cause that's what I need.

Inbo
March 17th, 2007, 10:13 AM
I've tried doing what FernandoMilton suggested to get rid of the 'ERROR: x264 not found' but it's still not working:


mik@mik-desktop:~/Desktop/ffmpeg-0.cvs20060823$ ./configure --enable-gpl --enable-pp --enable-vorbis --enable-pthreads \
> --enable-libogg --enable-a52 --enable-dts \
> --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame \
> --enable-faad --enable-faac --enable-xvid --enable-x264
ERROR: x264 not found
If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
ffmpeg-devel@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.
mik@mik-desktop:~/Desktop/ffmpeg-0.cvs20060823$

CarsomyrXIII
March 17th, 2007, 04:03 PM
I've been having the following error in building mpeg4ip and was wondering if anyone here would be able to help.


ffmpeg.cpp: In function 'int ffmpeg_decode(codec_data_t*, frame_timestamp_t*, int, int*, uint8_t*, uint32_t, void*)':
ffmpeg.cpp:229: error: 'avcodec_decode_audio2' was not declared in this scope
make[5]: *** [ffmpeg.lo] Error 1


I tried the other fix that involves ffmpeg.cpp but it doesn't help [slightly different error].

endersshadow
March 17th, 2007, 05:40 PM
What'd your configure look like?

FakeOutdoorsman
March 17th, 2007, 07:21 PM
Inbo,

Did you look though config.err? IT has additional info that may tell you what is wrong, especially at the end of that file. This is going to sound obvious, but do you have x264 installed?

CarsomyrXIII
March 18th, 2007, 03:39 PM
Tail end of ./bootstrap:


Mp4live encoder report:
ffmpeg encoder is installed
xvid encoder is installed
x264 encoder is installed
lame encoder is installed
faac encoder is installed
*** twolame encoder is not installed


Tail end of ./configure:

configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating mpeg4-2000.h
config.status: mpeg4-2000.h is unchanged
config.status: executing depfiles commands

jangeles
March 25th, 2007, 02:36 AM
I've just registered with the ubuntu forums solely to say a BIG thank you to the writer of the main post and also the people that helped out by posting how they fixed various issues they had.

Viva la iPod video on linux! :-)))))))))

CAN-CAN
March 26th, 2007, 05:23 PM
I followed the instructions in the wiki (https://help.ubuntu.com/community/iPodVideo) and I cannot make encoding to work..

I tried both scripts and I get errors in both..
1st Script (pypodconv) ouput..

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Mar 17 2007 23:24:34, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Input #0, avi, from 'Death_Wish.avi':
Duration: 01:29:36.4, start: 0.000000, bitrate: 1091 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 672x384, 25.00 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 112 kb/s
Warning: not compiled with thread support, using thread emulation
Output #0, mp4, to '/dev/null':
Stream #0.0: Video: 0x0000, yuv420p, 320x182, q=2-51, pass 1, 760 kb/s, 25.00 fps(c)
Stream mapping:
Stream #0.0 -> #0.0
Unsupported codec for output stream #0.0
Encode step FAILED: ffmpeg -y -i "Death_Wish.avi" -f mp4 -pass 1 -threads 1 -an -v 1 -vcodec h264 -b 760 -bt 175 -refs 2 -loop 1 -deblockalpha 0 -deblockbeta 0 -parti4x4 1 -partp8x8 1 -partb8x8 1 -subq 6 -brdo 1 -me_range 21 -chroma 1 -max_b_frames 0 -level 30 -g 300 -keyint_min 30 -sc_threshold 40 -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.7 -qmax 51 -max_qdiff 4 -i_quant_factor 0.71428572 -b_quant_factor 0.76923078 -rc_max_rate 1500 -rc_buffer_size 244 -cmp 1 -s 320x182 -map 0.0 /dev/null

2nd Script (ipodvidenc) output:

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on Mar 17 2007 23:24:34, gcc: 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Input #0, avi, from 'Death_Wish.avi':
Duration: 01:29:36.4, start: 0.000000, bitrate: 1091 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 672x384, 25.00 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 112 kb/s
Unknown codec 'aac'

Can anyone help me with at least one of the Scripts.
My distribution is Ubuntu Edgy.

FakeOutdoorsman
March 26th, 2007, 08:14 PM
CAN-CAN,

I'm not sure of what version of ffmpeg you're using since your configuration shows SVN-rUNKNOWN. Looks like you're trying to encode a h264 video with aac audio, but you don't have these libraries enabled in your ffmpeg install: specifically --enable-x264 --enable-faac. Try removing ffmpeg and reinstalling it with the directions on the wiki iPod Video Encoding (https://help.ubuntu.com/community/iPodVideoEncoding) page under the "Fixing ffmpeg on Ubuntu" secion.

CAN-CAN
March 27th, 2007, 07:00 PM
I tried to reinstall ffmpeg through the the wiki ut in the make step I get this output..


/home/can-can/ffmpeg-0.cvs20060823/version.sh "/home/can-can/ffmpeg-0.cvs20060823"
make -C libavutil all
make[1]: Entering directory `/home/can-can/ffmpeg-0.cvs20060823/libavutil'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/can-can/ffmpeg-0.cvs20060823/libavutil'
make -C libavcodec all
make[1]: Entering directory `/home/can-can/ffmpeg-0.cvs20060823/libavcodec'
gcc -DHAVE_AV_CONFIG_H -I.. -I/home/can-can/ffmpeg-0.cvs20060823/libavutil -O3 -pthread -Wdeclaration-after-statement -Wall -Wno-switch -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -c -o x264.o x264.c
x264.c: In function ‘X264_init’:
x264.c:147: error: ‘struct <anonymous>’ has no member named ‘i_rf_constant’
make[1]: *** [x264.o] Error 1
make[1]: Leaving directory `/home/can-can/ffmpeg-0.cvs20060823/libavcodec'
make: *** [lib] Error 2

Anyone can help..?

FakeOutdoorsman
March 27th, 2007, 07:36 PM
x264.c:147: error: ‘struct <anonymous>’ has no member named ‘i_rf_constant’

Did you make sure you ran sudo apt-get install libx264-dev before you tried to install ffmpeg?

Do you have a 64 bit CPU? You can try uname -a in terminal to find out. The output will show x86_64 or something like that. If so, make sure to follow the 64 bit section in the wiki page you mentioned earlier.

CAN-CAN
March 27th, 2007, 07:55 PM
Yes I am sure..
I have an AMD64 CPU but I don't have a 64-bit kernel of Ubuntu.
This the output of uname -a:

Linux Marianta 2.6.17-11-generic #2 SMP Thu Feb 1 19:52:28 UTC 2007 i686 GNU/Linux

CAN-CAN
March 27th, 2007, 07:56 PM
Yes I am sure..
I have an AMD64 CPU but I don't have a 64-bit kernel of Ubuntu.
This the output of uname -a:

Linux M****** 2.6.17-11-generic #2 SMP Thu Feb 1 19:52:28 UTC 2007 i686 GNU/Linux

FakeOutdoorsman
March 27th, 2007, 08:04 PM
Go ahead and try the 64 bit instrucitons anyway and see if that helps.

CAN-CAN
March 27th, 2007, 08:15 PM
I've already tried and it didn't work..

juanhunglow
March 27th, 2007, 09:23 PM
Feisty success.. mostly

Following the wiki (https://help.ubuntu.com/community/iPodVideoEncoding)I was able to get thinliquidfilm to convert a video that works on my 5G ipod. I had to download the SVN of ffmpeg (per the ffmpeg webpage), then followed the remainder of the instructions to get the proper things enabled in ffmpeg.

Neither script 1 nor script 2 worked for me.

Also, I had been using tovid to covert .avi's but now for some reason the sound does not want to encode properly, however the video is fine. Guessing I borked something in ffmpeg to cause that problem.

Well done and please keep up the great work.

FakeOutdoorsman
March 27th, 2007, 10:25 PM
Neither of the scripts are configured to work with the SVN of ffmpeg. The SVN is a tricky beast to work with because the install and encoding options will often change between revisions meaning lots of google searches and reading of the sometimes sparse man ffmpeg. For example, my SVN configuration uses --enable-libmp3lame instead of --enable-mp3lame and the SVN encoding uses bits/s instead of kilobits such as -b 500k vs -b 500.

juanhunglow
March 27th, 2007, 10:40 PM
Neither of the scripts are configured to work with the SVN of ffmpeg. The SVN is a tricky beast to work with because the install and encoding options will often change between revisions meaning lots of google searches and reading of the sometimes sparse man ffmpeg. For example, my SVN configuration uses --enable-libmp3lame instead of --enable-mp3lame and the SVN encoding uses bits/s instead of kilobits such as -b 500k vs -b 500.

Yes, the first thing I noticed what that "lib..." was required for several of the entries. Good thing the Feisty sandbox is just for play right now. I'll wait for the updated wiki after feisty gets released.

CAN-CAN
March 27th, 2007, 11:12 PM
No one has a solution for my problem?:(

nandasunu
March 27th, 2007, 11:54 PM
First off, thanks so much for the guide, it really helped a lot.

I don't know if this was asked before or not (I don't have time to read though the 45 pages of replies on this thread), but the videos that are converted through your (great :) ) script can't be resumed properly on the ipod and you can skip through the video either, which is pretty essential for me on longer vids. I noticed that this seems to happen on all the .mov videos on the ipod, but not on the .mp4 or .m4v files. How can I modify this script to give this format?

endersshadow
March 28th, 2007, 04:43 AM
Can-Can, you may want to report a ffmpeg bug (http://ffmpeg.mplayerhq.hu/bugreports.html). It seems that it is a problem with their code.

nandasunu, you need a little program called MP4Box, which is in the gpac package.


sudo apt-get install gpac
MP4Box -add /path/to/movie.mov /path/to/movie.mov

This will overwrite itself with a working video.

To everybody, I'm sorry that I didn't get right back to you all. My computer died this past week, and it's been quite the traumatic experience :-P

NorthernLights
April 4th, 2007, 01:39 AM
ps : i've downloaded the SIVE program but i'm having problems compiling the mpeg4ip program required.

Hi ! Sorry for answering late, but since several versions SIVE can work with MP4Box instead of mpeg4ip, which, as said just above, is in the Ubuntu repositories in the GPAC package.

See you !

PS : FYI, i'm the author of SIVE. Sorry for I don't come here often. BTW, you can always come talk on the forums of SIVE : http://sive.sourceforge.net.
Also, i'm in need of testers, so if anyone feels like helping, that would be great. There's one tester now, he's doing good job but is quite busy.

endersshadow
April 4th, 2007, 01:50 AM
Hi ! Sorry for answering late, but since several versions SIVE can work with MP4Box instead of mpeg4ip, which, as said just above, is in the Ubuntu repositories in the GPAC package.

See you !

PS : FYI, i'm the author of SIVE. Sorry for I don't come here often. BTW, you can always come talk on the forums of SIVE : http://sive.sourceforge.net.
Also, i'm in need of testers, so if anyone feels like helping, that would be great. There's one tester now, he's doing good job but is quite busy.

mpeg4ip is needed to move files to the ipod using gtkpod, not for encoding video.

Cheers.

NorthernLights
April 6th, 2007, 11:17 AM
I saw someone said he tried sive but could not get mpeg4ip to work, so i answered him that mpeg4ip was not needed anymore. That's the problem of answering late, you guys were already talking about something else when i answered. :)

aiserv
April 16th, 2007, 12:15 AM
Have a trouble with installing VIVE... have any ideas?

checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: GTK is not version >= 2.0.0. Please update GTK.

endersshadow
April 16th, 2007, 01:20 AM
aiserv:


sudo apt-get install libgtk2.0-dev

endersshadow
April 20th, 2007, 06:14 PM
Updated the HOWTO big time. Including much easier ways to install gtkpod, the updated ffmpeg info for Edgy/Feisty, and installation instructions for Vive. Also updated the MP4Box info to make that easier, too.

No more mpeg4ip! Woohoo!

ngardner
April 28th, 2007, 06:15 AM
I tried to reinstall ffmpeg through the the wiki ut in the make step I get this output..


/home/can-can/ffmpeg-0.cvs20060823/version.sh "/home/can-can/ffmpeg-0.cvs20060823"
make -C libavutil all
make[1]: Entering directory `/home/can-can/ffmpeg-0.cvs20060823/libavutil'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/can-can/ffmpeg-0.cvs20060823/libavutil'
make -C libavcodec all
make[1]: Entering directory `/home/can-can/ffmpeg-0.cvs20060823/libavcodec'
gcc -DHAVE_AV_CONFIG_H -I.. -I/home/can-can/ffmpeg-0.cvs20060823/libavutil -O3 -pthread -Wdeclaration-after-statement -Wall -Wno-switch -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -c -o x264.o x264.c
x264.c: In function ‘X264_init’:
x264.c:147: error: ‘struct <anonymous>’ has no member named ‘i_rf_constant’
make[1]: *** [x264.o] Error 1
make[1]: Leaving directory `/home/can-can/ffmpeg-0.cvs20060823/libavcodec'
make: *** [lib] Error 2

Anyone can help..?


After alot of head banging, I resolved the issue.
you need to open /libavcodec/x264.c and goto line 147. Change i_rf_constant to f_rf_constant
Apparently it changed from int to float, and was missed there.

diom
April 28th, 2007, 05:41 PM
aiserv:


sudo apt-get install libgtk2.0-dev

Hi endersshadow.

Listen I have the exact same problem with GTK. I have tried to reinstall it but to no avail...it just says that I already have the most up-to-date version. I have confimed it in Synaptic and by going to the /usr/lib/ directory. I also had trouble when I tried to install "libdvdcss2-dev"...couldn't find that.
Anyways have you any recommendations/suggestions for me. Stuck on this for the last 2 hours.

Thanks.

endersshadow
April 28th, 2007, 09:25 PM
Hey diom,

Can you post your /etc/apt/sources.list as well as the output from ./configure?

Thanks!

diom
April 29th, 2007, 02:37 PM
Hey diom,

Can you post your /etc/apt/sources.list as well as the output from ./configure?

Thanks!

Hi,
Actually now it is saying that I do have GTK...but, well you'll see.

./configure output


praetorian@Empire:~/Desktop/vive-2.0.0-beta1$ ./configure --prefix=/usr
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for ffmpeg... yes
checking for vobcopy... yes
checking for mplayer... yes
checking whether DVD is enabled... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.0.0... yes (version 2.10.11)
checking for vte_terminal_new in -lvte... no
configure: error: libvte is not installed.



/etc/apt/sources.list


# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://ie.archive.ubuntu.com/ubuntu/ feisty main restricted
deb-src http://ie.archive.ubuntu.com/ubuntu/ feisty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ie.archive.ubuntu.com/ubuntu/ feisty-updates main restricted
deb-src http://ie.archive.ubuntu.com/ubuntu/ feisty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://ie.archive.ubuntu.com/ubuntu/ feisty universe
deb-src http://ie.archive.ubuntu.com/ubuntu/ feisty universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ie.archive.ubuntu.com/ubuntu/ feisty multiverse
deb-src http://ie.archive.ubuntu.com/ubuntu/ feisty multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://ie.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
# deb-src http://ie.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu feisty-security main restricted
deb-src http://security.ubuntu.com/ubuntu feisty-security main restricted
deb http://security.ubuntu.com/ubuntu feisty-security universe
deb-src http://security.ubuntu.com/ubuntu feisty-security universe
deb http://security.ubuntu.com/ubuntu feisty-security multiverse
deb-src http://security.ubuntu.com/ubuntu feisty-security multiverse


As I said before I had trouble trying to get libdvdcss2-dev installed (couldn't find it).
Thanks again.
D

endersshadow
April 29th, 2007, 05:31 PM
diom, add the following line to your sources.list:


deb http://medibuntu.sos-sts.com/repo/ feisty free non-free

Then do this:


sudo apt-get update
sudo apt-get install libvte-dev libdvdcss2-dev libdvdnav-dev libdvdread-dev

Then try the configure again.

Sammi
April 29th, 2007, 05:51 PM
I keep getting a core dump:

Segmentation fault (core dumped)
I don't see more info than that in the terminal. How do I troubleshoot?

endersshadow
April 29th, 2007, 06:09 PM
Sammi,

Is this beta1 or an SVN checkout? Also, what are you doing when it segfaults?

Sammi
April 29th, 2007, 06:14 PM
beta1

I'm just pressing the encode button

Don't know if I've been fiddling too much with installing ffmpeg... It may be screwed up or something. Oh and I'm using Feisty.

EDIT: Trying to install svn gives this error while compiling:
encode.c
encode.c: In function ‘encode_vid_new’:
encode.c:599: error: void value not ignored as it ought to be
make[2]: *** [encode.o] Error 1
make[2]: Leaving directory `/home/<user>/programs/vive/2.0.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/<user>/programs/vive/2.0.0'
make: *** [all] Error 2

endersshadow
April 29th, 2007, 06:23 PM
Well, that error was a boneheaded mistake on my part. I had a comparison in there for debug purposes and only deleted half of it...try the checkout again.

Apologies :)

(BTW, you get to see the latest and greatest feature...multiple file input and selecting a folder to recursively select all of the videos and encoded them. Cool, eh?)

Sammi
April 29th, 2007, 06:36 PM
Ok great :D I'm fairly sure I've got the newest svn of both vive and ffmpeg installed now.

Vive does look different. There seem to be more features like you describe.

Sadly it still dumps it core when I press encode, but this time it gives a fair amount more info:

$ vive
*** glibc detected *** vive: malloc(): memory corruption: 0x085da6c0 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb74e8ef3]
/lib/tls/i686/cmov/libc.so.6[0xb74e990c]
/lib/tls/i686/cmov/libc.so.6(__libc_memalign+0xb1)[0xb74ea7c1]
/lib/tls/i686/cmov/libc.so.6(posix_memalign+0x88)[0xb74ea958]
/usr/lib/libglib-2.0.so.0[0xb78aa694]
/usr/lib/libglib-2.0.so.0(g_slice_alloc+0x364)[0xb78ab0c4]
/usr/lib/libvte.so.9[0xb76d9905]
/usr/lib/libvte.so.9[0xb76e865d]
vive[0x8054475]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x49)[0xb791a9d9]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x12b)[0xb790d62b]
/usr/lib/libgobject-2.0.so.0[0xb791e103]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x8c7)[0xb791f627]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb791f7e9]
/usr/lib/libgtk-x11-2.0.so.0(gtk_button_clicked+0x53)[0xb7c9a163]
/usr/lib/libgtk-x11-2.0.so.0[0xb7c9bdae]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x49)[0xb791a9d9]
/usr/lib/libgobject-2.0.so.0[0xb790be49]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x12b)[0xb790d62b]
/usr/lib/libgobject-2.0.so.0[0xb791e59a]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x8c7)[0xb791f627]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb791f7e9]
/usr/lib/libgtk-x11-2.0.so.0(gtk_button_released+0x53)[0xb7c9a1f3]
/usr/lib/libgtk-x11-2.0.so.0[0xb7c9a251]
/usr/lib/libgtk-x11-2.0.so.0(_gtk_marshal_BOOLEAN__BOXED+0x60)[0xb7d6a6b0]
/usr/lib/libgobject-2.0.so.0[0xb790be49]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x12b)[0xb790d62b]
/usr/lib/libgobject-2.0.so.0[0xb791e753]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x68f)[0xb791f3ef]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x29)[0xb791f7e9]
/usr/lib/libgtk-x11-2.0.so.0[0xb7e7ee18]
/usr/lib/libgtk-x11-2.0.so.0(gtk_propagate_event+0x183)[0xb7d639c3]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main_do_event+0x317)[0xb7d64bc7]
/usr/lib/libgdk-x11-2.0.so.0[0xb7be612a]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x182)[0xb7893df2]
/usr/lib/libglib-2.0.so.0[0xb7896dcf]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9)[0xb7897179]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0xb7d65044]
vive[0x8056097]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xdc)[0xb7496ebc]
vive[0x804b211]
======= Memory map: ========
08048000-08058000 r-xp 00000000 08:02 476114 /usr/bin/vive
08058000-08059000 rw-p 0000f000 08:02 476114 /usr/bin/vive
08059000-085ef000 rw-p 08059000 00:00 0 [heap]
b044c000-b044d000 ---p b044c000 00:00 0
b044d000-b0c4d000 rwxp b044d000 00:00 0
b0c4d000-b0cc3000 r--p 00000000 08:02 573989 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
b0cc3000-b0cc4000 ---p b0cc3000 00:00 0
b0cc4000-b14c4000 rwxp b0cc4000 00:00 0
b14c4000-b14c5000 ---p b14c4000 00:00 0
b14c5000-b1cc5000 rwxp b14c5000 00:00 0
b1cc5000-b1d25000 rw-s 00000000 00:08 6062104 /SYSV00000000 (deleted)
b1d25000-b1d4c000 rw-p b1d25000 00:00 0
b1d4c000-b2039000 r--p 00000000 08:02 704540 /usr/share/fonts/truetype/baekmuk/dotum.ttf
b2039000-b206a000 rw-p b2039000 00:00 0
b206a000-b27d4000 r--p 00000000 08:02 704544 /usr/share/fonts/truetype/kochi/kochi-gothic-subst.ttf
b27d4000-b27f6000 r--p 00000000 08:02 639312 /usr/share/fonts/type1/gsfonts/n022003l.pfb
b27f6000-b2832000 r--p 00000000 08:02 2375768 /usr/share/fonts/truetype/msttcorefonts/Courier_New_Italic.ttf
b2832000-b287c000 r--p 00000000 08:02 2375738 /usr/share/fonts/truetype/msttcorefonts/Courier_New.ttf
b287c000-b2896000 r--p 00000000 08:02 2375757 /usr/share/fonts/truetype/msttcorefonts/Andale_Mono.ttf
b28a3000-b28df000 r--p 00000000 08:02 573998 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf
b28df000-b291e000 r--p 00000000 08:02 574001 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf
b291e000-b291f000 ---p b291e000 00:00 0
b291f000-b311f000 rwxp b291f000 00:00 0
b311f000-b3120000 r--p 00000000 08:02 786797 /usr/share/vte/termcap/xterm
b3120000-b3122000 r--p 00000000 08:02 558228 /usr/share/locale-langpack/en_GB/LC_MESSAGES/atk10.mo
b3122000-b334a000 r--p 00000000 08:02 1150900 /usr/share/icons/hicolor/icon-theme.cache
b334a000-b4434000 r--p 00000000 08:02 1097774 /usr/share/icons/crystalsvg/icon-theme.cache
b443400Aborted (core dumped)

endersshadow
April 29th, 2007, 06:47 PM
What options were you using, per chance? I'll try to replicate it here. I have to run to a meeting right now, so I won't be immediately responsive, but I definitely want to get to the root of this.

Sammi
April 29th, 2007, 06:59 PM
Nv I wasn't even able to replicate it myself. Now I'm getting this:

$ ffmpeg -y -f mp4 -vcodec mpeg4 -maxrate 1000 -b 700 -bufsize 4096 -pass 1 -aspect 4:3 -s 320x240 -acodec aac -ab 128 -ar 44100 -comment "Encoded by Vive" -i /home/<user>/Desktop/file.avi /home/<user>/Desktop/file.mp4
FFmpeg version SVN-r8857, Copyright (c) 2000-2007 Fabrice Bellard, et al.
configuration: --prefix=/usr --enable-gpl --enable-pp --enable-pthreads --enable-dc1394 --enable-liba52 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libogg --enable-libtheora --enable-libvorbis --enable-x264 --enable-xvid --enable-shared --disable-debug
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
built on Apr 29 2007 18:25:02, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
Input #0, avi, from '/home/<user>/Desktop/file.avi':
Duration: 00:22:29.1, start: 0.000000, bitrate: 1473 kb/s
Stream #0.0: Video: msmpeg4v2, yuv420p, 480x360, 23.98 fps(r)
Stream #0.1: Audio: mp3, 44100 Hz, stereo, 320 kb/s
Output #0, mp4, to '/home/<user>/Desktop/file.mp4':
Stream #0.0: Video: mpeg4, yuv420p, 480x360, q=2-31, pass 1, 0 kb/s, 23.98 fps(c)
Stream #0.1: Audio: aac, 44100 Hz, stereo, 0 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0xb7e03cc8]removing common factors from framerate
[mpeg4 @ 0xb7e03cc8]timebase not supported by mpeg 4 standard
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or heightI really know almost nothing about ffmpeg and codec parameters, so this doesn't tell me much. Feels like I'm stuck in error hell. Getting flash-backs to Red Hat RPM dependancy hell :D

EDIT: I can see that I must be using the newest ffmpeg svn as the error says "built on Apr 29 2007 18:25:02, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)", which in my time-zone was just about forty minutes ago. The exact time when I compiled it.

endersshadow
April 29th, 2007, 09:02 PM
Well, you're getting that error because ffmpeg changed how it uses bit rates. Instead of being in kb/s (previous way), they changed to bits/s...this just became the case in the Feisty build of ffmpeg. Take away the -maxrate, -b, and -bufsize flags and values and then see what happens. It's a pain in the neck, but I gotta change it. The real question is just determining which one to use for a user's ffmpeg installation (for the time being).

Email me at endersshadow AT users DOT sourceforge DOT net, and I'll roll you a debugging distribution of the code to narrow this problem down if you feel like keeping on trying. If not, I understand :)

kaitwospirit
April 30th, 2007, 04:37 AM
I'm still learning all this tech stuff, so please help me.

When I'm trying to install vive from the SVN, when I run ./configure I get this error:

"checking for libgnomevfs... configure: error: Package requirements (gnome-vfs-2.0 >= 2.0) were not met:

No package 'gnome-vfs-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libgnomevfs_CFLAGS
and libgnomevfs_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details."

What does this mean I need to do?

endersshadow
April 30th, 2007, 04:51 AM
kaitwospirit:

sudo apt-get install libgnomevfs2-dev

FYI, you will also need to do the following for later in the configure:


sudo apt-get install libvte-dev libdvdcss2-dev libdvdread-dev libdvdnav-dev

diom
April 30th, 2007, 07:34 PM
diom, add the following line to your sources.list:


deb http://medibuntu.sos-sts.com/repo/ feisty free non-free

Then do this:


sudo apt-get update
sudo apt-get install libvte-dev libdvdcss2-dev libdvdnav-dev libdvdread-dev

Then try the configure again.

Thanks endersshadow...that seems to have gotten it to work for me. I've only managed to find time to encode one avi to mp4 but if anything else crops up I'll let all y'all know.

Thanks a million once again.
D

offchance
May 5th, 2007, 12:30 AM
this is a really great project and I really like al lthe time and effort being put into it.

I've been working on this throughout the day and have encountered two problems:

1. vive is installed, has the ipod presets, but abruptly quits whenever I hit the encode button.

2. I get the following with ipodvidenc, even after installing faac:


damion@dmachine:/media/sdb1/video/Harvey Birdman 2-4/Harvey Birdman - Season 04$ ipodvidenc Harvey\ Birdman\ -\ S4E01\ -\ Mufti\ Trouble.avi
What would you like to name the output file (sans extension)?
mufti
mufti will be located in /media/sdb1/video/Harvey Birdman 2-4/Harvey Birdman - Season 04. Is this acceptable? [y/n]
y
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --prefix=/usr
libavutil version: 49.0.0
libavcodec version: 51.11.0
libavformat version: 50.5.0
built on May 4 2007 16:33:56, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
Input #0, avi, from 'Harvey Birdman - S4E01 - Mufti Trouble.avi':
Duration: 00:12:05.5, start: 0.000000, bitrate: 1472 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 640x480, 29.98 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 128 kb/s
Unknown codec 'aac'
damion@dmachine:/media/sdb1/video/Harvey Birdman 2-4/Harvey Birdman - Season 04$


I really want this to work. using xp and having videora take up 99% of my processor and displaying annoying ads is not my cup of tea!

endersshadow
May 5th, 2007, 05:04 PM
offchance,

Yoiu don't have ffmpeg compiled w/ AAC support. Are you using the default install of ffmpeg from Ubuntu?

Also, as to the crashing, what version of Vive are you running?

Thanks!

offchance
May 6th, 2007, 03:06 AM
I ran the code verbatim from your tutorial several times. is there something else I should look for?

I am running Vive 2.0.0-beta1, from the link provided in the tutorial.

thanks for you help!

**edit:

I recompiled ffmpeg per the svn instructions and everything looked ok.

I tried one video with ipodvidenc and got the same error msg as before.

On another file I got the following, which may or may not have anything to do with what is set out in the tut:

FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-libgsm --enable-dc1394 --disable-debug --enable-shared --prefix=/usr
libavutil version: 0d.49.0.0
libavcodec version: 0d.51.11.0
libavformat version: 0d.50.5.0
built on Jan 28 2007 22:48:38, gcc: 4.1.2 20070106 (prerelease) (Ubuntu 4.1.1-21ubuntu7)
Harvey Birdman - S4E01: I/O error occured
Usually that means that input file is truncated and/or corrupted.

Pirate742
May 7th, 2007, 03:02 AM
offchance,

Yoiu don't have ffmpeg compiled w/ AAC support. Are you using the default install of ffmpeg from Ubuntu?

Also, as to the crashing, what version of Vive are you running?

Thanks!


May i ask how is it possible to compile ffmpeg w/ aac support?
Thanks

gorilla_king
May 7th, 2007, 04:28 AM
i didnt use any of this. i tried..but after having no success i decided it was easier just to do stuff command line with ffmpeg. anyway thats what i did

but i did have to fix my ffmpeg version
so heres the version i compiled in a deb if anyone wants it. it should fix the whole h264 thingy

its 7.6 megs so i cant upload it to the forums but i uploaded it to a free file host
http://www.sharebigfile.com/file/162559/ffmpeg-3-0-cvs20060823-3-1ubuntu2-1-i386-deb.html

sry if this link goes bad after a while but you have to download at least once a week to keep em alive

offchance
May 7th, 2007, 06:19 PM
alright...ipodvidenc works now with gorilla_king's ffmpeg build. sweet!

I will continue to work on vive. any advice is appreciated!

endersshadow
May 7th, 2007, 07:12 PM
Sorry for being so late on this...it was the little lady's birthday this weekend, so I was stolen away for that. Now that I'm back and geeking it up again...

I remember now a bug that I've fixed in the SVN version of Vive (I gotta get my act together and finish off 2.0.0, but I keep finding little things wrong with it). If all of the drop down menus aren't selected (aka format, video codec, number of passes, aspect ratio, and audio codec), you'll get a seg fault. Make sure all of them are selected to some value and go from there.

Good luck!

FakeOutdoorsman
May 7th, 2007, 11:03 PM
May i ask how is it possible to compile ffmpeg w/ aac support?
Thanks

The options to enable aac support depends on the ffmpeg version you are compiling. The Ubuntu wiki entry iPodVideoEncoding (https://help.ubuntu.com/community/iPodVideoEncoding) has a section under Fixing ffmpeg on Ubuntu (https://help.ubuntu.com/community/iPodVideoEncoding#head-718248d42e047c1bdeda6e7e26665b1103b6b00f) that will tell you how to do this. If you have any questions, ask them here.

salvador24
May 11th, 2007, 03:05 AM
Thanks endersshadow, that adviced fixed problems I was having with seg fault. Now encoding to mp4 as I write this!

endersshadow
May 11th, 2007, 03:15 AM
Woot! Bug I already fixed!

Enjoy and happy encoding! Glad it's working for you!

diom
May 13th, 2007, 11:26 PM
Hello...

I have gotten Vive to work on my PSP for SP mp4 profiles, but I really want to get AVC working. I tried it in Vive and got the following:



praetorian@Empire:~$ ffmpeg -i "/media/EXTERNAL_/TV/Firefly/05_Safe.avi" -f psp -vcodec h264 -maxrate 1000 -b 700 -bufsize 4096 -pass 2 -aspect 4:3 -s 320x240 -qmin 5 -qmax 6 -acodec aac -ab 192 -ar 44100 "/home/praetorian/a.mp4"
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --enable-gpl --enable-pp --enable-pthreads --enable-vorbis --enable-libogg --enable-a52 --enable-dts --enable-libgsm --enable-dc1394 --disable-debug --enable-mp3lame --enable-faadbin --enable-faad --enable-faac --enable-xvid --enable-x264 --enable-amr_nb --enable-amr_wb --enable-shared --prefix=/usr
libavutil version: 0d.49.0.0
libavcodec version: 0d.51.11.0
libavformat version: 0d.50.5.0
built on Mar 21 2007 14:14:05, gcc: 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
Input #0, avi, from '/media/EXTERNAL_/TV/Firefly/05_Safe.avi':
Duration: 00:42:47.1, start: 0.000000, bitrate: 761 kb/s
Stream #0.0: Video: mpeg4, yuv420p, 496x272, 23.98 fps(r)
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 32 kb/s
File '/home/praetorian/a.mp4' already exists. Overwrite ? [y/N] y
Output #0, psp, to '/home/praetorian/a.mp4':
Stream #0.0: Video: h264, yuv420p, 320x240, q=5-6, pass 2, 700 kb/s, 23.98 fps(c)
Stream #0.1: Audio: aac, 44100 Hz, stereo, 192 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[h264 @ 0xb7ed0f08]using SAR=1/1
[h264 @ 0xb7ed0f08]using cpu capabilities MMX MMXEXT SSE SSE2
[h264 @ 0xb7ed0f08]ratecontrol_init: can't open stats file
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height


This is actually the problem recreated in terminal using the same command as in Vive, but I couldn't copy the output so I just re did it manually.
I was wondering if I am missing the referenced "stats file" or if I have incorrect parameters.
Any help is much appreciated.

Thanks! :confused:

endersshadow
May 13th, 2007, 11:42 PM
Ah, this issue. You see, the fine people at ffmpeg changed their bitrate from kb/s to b/s, putting things off by a value of 1024. The problem is the ffmpeg in Ubuntu uses kb/s, and the SVN uses b/s...it's an issue I'm trying to figure out how to tackle. Use 1024000 as your Max Bitrate and 716800 as your Bitrate, and life should be peachy.

endersshadow
May 14th, 2007, 03:29 PM
I was wrong...it's a factor of 1000, not 1024. At any rate, the latest SVN checkout of Vive provides for kb/s, no matter what version of ffmpeg you use. Hooray standardization!

Donnie Darko
May 26th, 2007, 04:24 AM
well, I've only been on ubuntu for about a month now, and while installing ffmpeg I got stuck. I did the code in the beginning
"sudo apt-get install liblame-dev libxvidcore4-dev libx264-dev libfaac-dev libfaad2-dev
sudo apt-get build-dep ffmpeg"

then Without x264:
"apt-get source ffmpeg
cd ffmpeg-*/
./configure --enable-gpl --enable-pp --enable-vorbis \
--enable-libogg --enable-a52 --enable-dts \
--enable-dc1394 --enable-libgsm --disable-debug --enable-mp3lame \
--enable-faad --enable-faac --enable-xvid --enable-pthreads --enable-shared
make
sudo make install"

now in terminal it has this:
"andrew@andrew-desktop:~/ffmpeg-0.cvs20060823$ "
And I can't erase it or anything.
What should I do, I'm running feisty fawn btw

endersshadow
May 26th, 2007, 01:34 PM
Welcome to Linux, Andrew!

This is what's called the command line. I'll break down what that shebangbang is:


andrew@andrew-desktop:~/ffmpeg-0.cvs20060823$

andrew: Your username (assumedly you're named Andrew)
@andrew-desktop: You are logged in at (@) the computer named "andrew-desktop"
:~/ffmpeg-0.cvs20060823: You are looking at (:) the folder ~/ffmpeg-0.cvs20060823 (~ is short for /home/andrew)

You type in commands from there, and the magic happens. At any rate, if ffmpeg installed successfully, you can then install Vive or ipodvidenc or just use the ffmpeg command line. For example, if you wanted to encode a wmv movie to an avi, in the command line, you would type:


ffmpeg -f avi -vcodec mpeg4 -acodec mp3 -i /path/to/movie.wmv /path/to/movie.avi

So that your command prompt would look like, before you hit enter:

andrew@andrew-desktop:~/ffmpeg-0.cvs20060823$ ffmpeg -f avi -vcodec mpeg4 -acodec mp3 -i /path/to/movie.wmv /path/to/movie.avi

Here's a good command line reference guide (http://doc.gwos.org/index.php/CommandLineBeginners). You don't need to memorize all of it, but scanning over it will give you a sense of what the terminal can do.

Donnie Darko
May 28th, 2007, 01:15 AM
Thanks for the speedy reply and help endersshadow, its greatly appreciated. So, does it mean that ffmpeg is installed (or how can I tell)? I can't use my ubuntu machine till tomorrow, as I'm camping and right now I'm on a HP laptop with xp (bleh!) Thanks in advance.

endersshadow
May 28th, 2007, 03:28 AM
Thanks for the speedy reply and help endersshadow, its greatly appreciated. So, does it mean that ffmpeg is installed (or how can I tell)? I can't use my ubuntu machine till tomorrow, as I'm camping and right now I'm on a HP laptop with xp (bleh!) Thanks in advance.

Assuming that you didn't get any error messages, then yes, yes it is installed. It's important to check the last 15 or so lines of output from installs. It generally contains very important information :)

Metallinut
May 31st, 2007, 11:15 PM
Hey thanks for putting this How-To together. It's great! One quick problem (maybe) though, that maybe someone can help with.

I used to have ffmpeg installed, and had a script to do my iPod video converting, and all worked well. The CLI of ffmpeg would have a nice output, showing what time index it was at, etc. that would allow me to figure out how long the conversion would (roughly) take.

I recently had to rebuild my Ubuntu box (totally unrelated), and am trying to get things back the way they were. I couldn't find the original install method I had used, so I used the one you had in the first post (used the SVN method)

I'm encoding my first video file now, and the output is a little strange to me. Instead of the "full-terminal-window" sized CLI interface, that updates on it's own, I'm getting thousands and thousands of scrolling messages that look like this:


[mpeg4 @ 0xb7d91488]rc buffer underflow9kB time=267.9 bitrate= 394.1kbits/s
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow0kB time=268.0 bitrate= 394.0kbits/s
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow
[mpeg4 @ 0xb7d91488]rc buffer underflow2kB time=268.2 bitrate= 393.8kbits/s
[mpeg4 @ 0xb7d91488]rc buffer underflow


And so on. So just about every 1-2 tenths of a second of video encoding, it's throwing up these lines in the terminal window. Nonstop...

Any ideas?

Thanks

endersshadow
June 1st, 2007, 01:13 AM
What ffmpeg command or options did you use?

bennyj
June 1st, 2007, 03:58 AM
Could someone tell me why this is happening ? I have followed the instructions here to a T but when i type ffmepg in the console i get this

ffmpeg: error while loading shared libraries: libraw1394.so.5: cannot open shared object file: No such file or directory

endersshadow
June 1st, 2007, 04:53 AM
bennyj: Try this:


sudo apt-get install libraw1394-dev

bennyj
June 1st, 2007, 04:57 AM
bennyj: Try this:


sudo apt-get install libraw1394-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
libraw1394-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

endersshadow
June 1st, 2007, 05:04 AM
Is libraw1394-8 installed?

bennyj
June 1st, 2007, 05:08 AM
Is libraw1394-8 installed?

I just doubled checked..and yes it is.evrything else went pretty smooth except for this.
thank for your help and this how to

endersshadow
June 1st, 2007, 05:14 AM
Found the problem...it's a backward compatibility bug in 7.04.


sudo ln -s /usr/lib/libraw1394.so.8.1.1 /usr/lib/libraw1394.so.5

For reference, did you use the with x264 instructions or the without x264 instructions?

bennyj
June 1st, 2007, 05:18 AM
Found the problem...it's a backward compatibility bug in 7.04.


sudo ln -s /usr/lib/libraw1394.so.8.1.1 /usr/lib/libraw1394.so.5

For reference, did you use the with x264 instructions or the without x264 instructions?

That did it!thank you so much for the fast reply's.and yes i used it with x264

endersshadow
June 1st, 2007, 05:20 AM
Awesome :)

I'll look into why this happens and perhaps throw in a little bug report if needed for our friends at Launchpad :)

Metallinut
June 1st, 2007, 06:12 PM
What ffmpeg command or options did you use?

Sorry for the late reply.

I followed the instructions on page one of this thread (just the ffmpeg install instructions) using the "With x264" instructions (via SVN)

endersshadow
June 1st, 2007, 08:20 PM
Sorry for the late reply.

I followed the instructions on page one of this thread (just the ffmpeg install instructions) using the "With x264" instructions (via SVN)

It's okay. I meant what options did you use to encode said video that you got the buffer underflow with :)