PDA

View Full Version : [ubuntu] new version, same bug - evolution error on expunge on Ubuntu 9.04 - Jaunty



costamatrix
May 3rd, 2009, 11:10 PM
Hi folks... i have this old bug on my evolution...

i cant expunge any folders (like the junk folder)...when i try, i get the error:

http://www.piadasonline.com.br/_images/Screenshot-Evolution%20Error-1.png

"Error storing '~/.evolution/mail.....'
Summary and folder mismatch, even after a sync.


Any help people?

jeroenvrp
May 3rd, 2009, 11:32 PM
This has nothing to do with a new version, because it's properly related to files in your home folder.

Close Evolution. Check if that file in the .evolution folder is not set to read only or is owned by another user. If that is the case, please correct it, and restart Evolution.

If that is not the case, try to delete the files; Sent.cmeta, Sent.ibex.index and Sent.ibex.index.data. Don't delete the file Sent, because that is your mailbox. Restart Evolution and click on the Sent folder. It should regenerate your index. Properly you have to mark them all as read again.

Good luck.

hictio
May 3rd, 2009, 11:32 PM
Is that using an IMAP account? I have been using Evolution as the default email client since Hardy, and I haven't see that error before.

jeroenvrp
May 3rd, 2009, 11:35 PM
@hictio: I don't think so. It's a file located under local and at the end it reads mbox.

costamatrix
May 4th, 2009, 12:15 AM
hi folks...

answering...i use pop for gmail...

i check the .evolution directory... all files and directorys belongs to my user...so its ok...

i check the internet and several users have reported this same problem on older versions of evolution/ubuntu....

i have a little bit of fear to try this solution of delete some files....

why i have to do this? it is a bg of evolution right?

and another thing...the problem occured when i tried to expurge several folders: trash, junk....

nab
June 27th, 2009, 01:15 PM
Hi,

I have the same problem with drafts.

I shutdown evolution /home/nab/.evolution/mail/local and deleted in /home/nab/.evolution/mail/local all files Drafts*.*.

After restarting evolution the old titles were still shown in evolution and expurge still doesn't work.

Any suggestions?

TIA,
Niko

nab
July 4th, 2009, 09:34 PM
well, I forgot about this tread so I wrote the solution in my own.

Here is the link:
http://ubuntuforums.org/showthread.php?t=1204369

Sorry about that.

Ian Sinclair
November 24th, 2010, 03:55 PM
Got this problem on Ubuntu 10.04. Ultimate solution - change to Thunderbird!:P

claracc
November 24th, 2010, 05:53 PM
You can keep evolution and solve the problem in this way:

Close evolution, go to Places, personal folder, select see hiden files, then go to .evolution/mail/local, there, delete file folders.db, restart evolution and the problem has to be fixed.